Community discussions

MUM Europe 2020
 
zizobaddy
Member Candidate
Member Candidate
Topic Author
Posts: 107
Joined: Mon Sep 13, 2010 10:13 am

Bandwidth Sharing

Thu Mar 20, 2014 12:42 am

Please how do you share bandwidth between 2 users in router 6.x for example

Bandwidth 1mb

User A 512kb
Useb B 512kb

If use A is not using its 512kb the user B can have 1mb
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2950
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: Bandwidth Sharing

Thu Mar 20, 2014 12:55 am

Too much generic.
Users? HotSpot users? 2 pc on the lan? 2 Pc on wifi? Etc.

Make a simple queue on interface with max 1M
make 2 simple queue, one for each pc, linked to main simple queue,
each must have limit = 512k and max-limit=1M

YEs, I know, too much generic answer...
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2950
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: Bandwidth Sharing

Thu Mar 20, 2014 12:59 am

replace inside the script the contents on <!!!> with interface name, ppp name, or ip address
/queue simple
add limit-at=1M/1M max-limit=1M/1M name=source-1M target=<sourceofinternet>
add limit-at=512k/512k max-limit=1M/1M name=user-1-512k parent=source-1M target=<whereareuser1>
add limit-at=512k/512k max-limit=1M/1M name=user-2-512k parent=source-1M target=<whereareuser2>
I'm Italian, not English. Sorry for my imperfect grammar.
 
zizobaddy
Member Candidate
Member Candidate
Topic Author
Posts: 107
Joined: Mon Sep 13, 2010 10:13 am

Re: Bandwidth Sharing

Mon Mar 24, 2014 9:08 pm

Hi

Thanks it works

Please how do i go about havin different packages

1. 1mb shared

2. 512kbps shared

What i did was to have 1.5mbps dedicated then the 2 packages had parent from 1.5mb

But only any package that is higher works
 
francisuk24
newbie
Posts: 28
Joined: Tue Mar 18, 2014 12:10 am
Location: United Kingdom
Contact:

Re: Bandwidth Sharing

Mon Mar 24, 2014 10:58 pm

replace inside the script the contents on <!!!> with interface name, ppp name, or ip address
/queue simple
add limit-at=1M/1M max-limit=1M/1M name=source-1M target=<sourceofinternet>
add limit-at=512k/512k max-limit=1M/1M name=user-1-512k parent=source-1M target=<whereareuser1>
add limit-at=512k/512k max-limit=1M/1M name=user-2-512k parent=source-1M target=<whereareuser2>
so basically

add limit-at=1M/1M max-limit=1M/1M name=WANSPEED target=MY PUBLIC IP
add limit-at=512k/512k max-limit=1M/1M name=user-1-512k parent=WANSPEED target=192.168.30.2/32
add limit-at=512k/512k max-limit=1M/1M name=user-2-512k parent=WANSPEED target=192.168.30.5/32

Also i just wonted to add about limiting to an IP Address in this case im using IP 159.148.147.201 with speed of 768k but keep in mind it wouldn't be good on video content sites YouTube/Vimeo etc unless you know your ISP's CDN servers.

name="SlowToIP" target=192.168.30.1 dst=159.148.147.201/32 limit-at=768k/768k max-limit=768k/768k

192.168.30.1 - My PC Internal IP
159.148.147.201 - To this IP Address i wont to limit the speed to 768k
RouterBoard RB750R2, RouterOS Level 4
ISP: Zen Internet via VDSL 2 > 74.68Mb Down / 17.84Mb Up
 
zizobaddy
Member Candidate
Member Candidate
Topic Author
Posts: 107
Joined: Mon Sep 13, 2010 10:13 am

Re: Bandwidth Sharing

Tue Mar 25, 2014 11:05 am

Thanks for your reply

Basically what i want to achieve is to have different shared pakages as expalined below

Internet source 10M

5M shared (10 clients)

3M shared ( 8 Clients)

1.5m Shared (5 Clients)

512k shared (2 Clients)

What i noticed is that only the rule at the top works others below doesnt

Who is online

Users browsing this forum: Google [Bot], shivansps and 129 guests