Community discussions

MUM Europe 2020
 
wildbill442
Forum Guru
Forum Guru
Topic Author
Posts: 1050
Joined: Wed Dec 08, 2004 7:29 am
Location: Sacramento, CA

Hotspot Trail

Thu May 11, 2006 5:47 pm

Can't seem to figure out what I'm doing wrong... I'm testing the trial login for the hotspot on my home router, but I keep getting redirected to the MT Hotspot login page.. Here's my config:
/ ip hotspot 
add name="hs-guest-ap" interface=guest-ap address-pool=hs-pool-7 profile=hsprof2 idle-timeout=5m \
    keepalive-timeout=none addresses-per-mac=1 disabled=no 
/ ip hotspot service-port 
set ftp ports=21 disabled=no 
/ ip hotspot profile 
set default name="default" hotspot-address=0.0.0.0 dns-name="" html-directory=hotspot rate-limit="" \
    http-proxy=0.0.0.0:0 smtp-server=0.0.0.0 login-by=mac,cookie,http-chap http-cookie-lifetime=3d \
    split-user-domain=no use-radius=yes radius-accounting=yes radius-interim-update=received \
    nas-port-type=wireless-802.11 radius-default-domain="" 
add name="hsprof2" hotspot-address=10.100.2.1 dns-name="bitshotspot.local" html-directory=hotspot \
    rate-limit="" http-proxy=0.0.0.0:0 smtp-server=0.0.0.0 login-by=mac,trial trial-uptime=1d/1s \
    trial-user-profile=default use-radius=no 
/ ip hotspot user profile 
set default name="default" idle-timeout=none keepalive-timeout=2m status-autorefresh=1m shared-users=1 \
    rate-limit="128k/512k" incoming-filter="guest-network" outgoing-filter="guest-network" \
    transparent-proxy=no 
add name="fullaccess" idle-timeout=none keepalive-timeout=2m status-autorefresh=1m shared-users=1 \
    transparent-proxy=no 
Any suggestions?
 
wildbill442
Forum Guru
Forum Guru
Topic Author
Posts: 1050
Joined: Wed Dec 08, 2004 7:29 am
Location: Sacramento, CA

Fri May 12, 2006 6:09 pm

nobody has implemented this feature huh?
 
jarosoup
Long time Member
Long time Member
Posts: 600
Joined: Sun Aug 22, 2004 9:02 am

Sat May 13, 2006 6:18 am

I've been wanting to try this feature for awhile now...I'll be digging into it this weekend so I'll let you know how it goes and if I can help out at all.
 
wildbill442
Forum Guru
Forum Guru
Topic Author
Posts: 1050
Joined: Wed Dec 08, 2004 7:29 am
Location: Sacramento, CA

Sun May 14, 2006 6:13 am

I'll do some more digging myself tomorrow... I've only played with it for about half an hour, then I had to go to work.

It'd be nice if the hotspot feature had a "free use" authentication method. Just so you could setup queues for users that connected, and use the advertise feature... That's what I am hoping to use this Trial feature for...
 
ofasa
Member Candidate
Member Candidate
Posts: 104
Joined: Tue Jul 20, 2004 11:42 pm

Sun May 14, 2006 2:47 pm

Here's the config for one of my hotspot profiles with the trial feature working:

/ ip hotspot profile
set default name="default" hotspot-address=0.0.0.0 dns-name="" \
html-directory=hotspot rate-limit="32k/128k 64k/256k 48k/96k 30/30 8 \
24k/48k" http-proxy=0.0.0.0:0 smtp-server=0.0.0.0 \
login-by=mac,cookie,http-pap,trial http-cookie-lifetime=3d \
split-user-domain=no trial-uptime=5m/1d trial-user-profile=default \
use-radius=yes radius-accounting=yes radius-interim-update=5m \
nas-port-type=ethernet radius-default-domain=""

You could set the trial uptime to '1 day' and the Trial Uptime Reset to '1 day' the modify the hotspot login page so they just click on a link and get logged in.

Hope this helps!
 
jarosoup
Long time Member
Long time Member
Posts: 600
Joined: Sun Aug 22, 2004 9:02 am

Mon May 15, 2006 8:01 pm

Finally got a chance to try this out. With the default html code and ROS 2.9.23, I just turned on the trial option in the login types and it worked great. Note that if you set the trial time below 5 minutes, the counters don't work right. I set it to 1 minute, but the session timeout was 5 minutes. Setting it to 3 minutes gave me a 4 minute timout. 3 Minutes gave me a 1 minute timeout. Hmmm. Anything above 5 minutes seems to work fine though.

Who is online

Users browsing this forum: No registered users and 162 guests