Community discussions

MikroTik App
 
User avatar
rextended
Forum Guru
Forum Guru
Topic Author
Posts: 2954
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: change startup page in mikrotik

Wed Apr 02, 2014 6:33 pm

This is not mikrotik relate problem.

Check your browser configuration or ask the HotSpot admin.
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
patrikg
Member Candidate
Member Candidate
Posts: 155
Joined: Thu Feb 07, 2013 6:38 pm
Location: Stockholm, Sweden

Re: change startup page in mikrotik

Wed Apr 02, 2014 7:12 pm

Maybe could be Group Policy or external program, but this is little bit of topic.
http://support.microsoft.com/kb/274846

Or it could be a external program.
Try to start IE without any addons/plugins
http://www.addictivetips.com/windows-ti ... t-add-ons/
 
User avatar
rextended
Forum Guru
Forum Guru
Topic Author
Posts: 2954
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: change startup page in mikrotik

Wed Apr 02, 2014 8:15 pm

[...] read above
Last edited by rextended on Thu Apr 03, 2014 12:41 am, edited 3 times in total.
I'm Italian, not English. Sorry for my imperfect grammar.
 
jarda
Forum Guru
Forum Guru
Posts: 7603
Joined: Mon Oct 22, 2012 4:46 pm

Re: change startup page in mikrotik

Wed Apr 02, 2014 9:07 pm

 
User avatar
rextended
Forum Guru
Forum Guru
Topic Author
Posts: 2954
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: change startup page in mikrotik

Wed Apr 02, 2014 9:37 pm

[...] read above
Last edited by rextended on Thu Apr 03, 2014 12:42 am, edited 2 times in total.
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
rextended
Forum Guru
Forum Guru
Topic Author
Posts: 2954
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: change startup page in mikrotik

Thu Apr 03, 2014 12:21 am

Your system, Windows 8.1, when detect than is needed login to use internet, automatically try to open "http://go.microsoft.com/fwlink/?LinkID= ... lcid=0x409" (Internet Explorer Home Page) without ask anything, and obviously wants you to see Bing (the Microsoft search engine) caring about the selected page as your homepage inside your default browser.
If you use chrome, firefox, opera or others, Windows launch the "default program for open urls" (not the default browser... on new Microsoft language...) and pass as parameter http://go.microsoft.com/fwlink/?LinkID= ... lcid=0x409
You try to solve this: change default web pages of Internet Explorer with "https://www.google.com".
If you not solve, ask Microsoft, not this forum.

MikroTik HotSpot simply after login redirect you to the page you try to open without login.

The problem you have is not due to RouterOS on any way.
I'm Italian, not English. Sorry for my imperfect grammar.
 
nerdtron
Member Candidate
Member Candidate
Posts: 123
Joined: Sat Nov 30, 2013 7:49 am

Re: change startup page in mikrotik

Thu Apr 03, 2014 4:43 am

On the login html page, if you find this line:
<input type="hidden" name="dst" value="$(link-orig)" />
Change to something like:
<input type="hidden" name="dst" value="http://google.com" />
This will hardcode google.com as the redirect page. After they login successfully, they will be redirected to google.com regardless of what URL they initially typed.

Who is online

Users browsing this forum: gkhun, Google [Bot], shmichael, vilpalu and 65 guests