Community discussions

 
tarekgemayel
just joined
Topic Author
Posts: 5
Joined: Thu Apr 03, 2014 10:42 am

VLAN tagging and forwarding - Help needed!

Thu Apr 03, 2014 11:38 am

Let me explain the scenario:

1) I have a Linksys router that is connected to the ISP.
2) RB750GL/RB750UP is connected via ethernet to the Linksys router.
3) A modem is connected via ethernet to the RB750GL/RB750UP. (SEE ATTACHMENT)

The internet traffic coming from the Linksys router is untagged.
The modem only receives and transmits TAGGED traffic. (Let us say VLAN 100)

Therefore the intermediate device RB750GL/RB750UP must VLAN tagged 100 the Internet traffic from the Linksys and forward the internet traffic through a port to the modem.

However in order to have a complete and functional modem, i do not know if the VLAN tagged 100 traffic going from the modem to the Linksys must be stripped off of its VLAN ID 100.

Please i am beginner at this. I need all the required, yet detailed, steps for me to achieve a working solution.
I don't know whether we must simply do VLAN tagging for the traffic or even apply an IP for the VLAN.

All help is appreciated!
You do not have the required permissions to view the files attached to this post.
 
misa2
just joined
Posts: 5
Joined: Thu Nov 25, 2010 2:39 pm

Re: VLAN tagging and forwarding - Help needed!

Thu Apr 03, 2014 11:57 am

 
tarekgemayel
just joined
Topic Author
Posts: 5
Joined: Thu Apr 03, 2014 10:42 am

Re: VLAN tagging and forwarding - Help needed!

Thu Apr 03, 2014 12:10 pm

Alright what does that mean then?

My network is similar to the last one in the blog but is actually reversed. Meaning that my Internet traffic coming into the RB750 is untagged and leaves the RB750 tagged.

But how do i configure all of this? I cannot get it to work!
 
CelticComms
Forum Guru
Forum Guru
Posts: 1766
Joined: Wed May 02, 2012 5:48 am

Re: VLAN tagging and forwarding - Help needed!

Sat Apr 05, 2014 12:26 am

Are you trying to use the Linksys device as your firewall or the RB750?
Interlynx | Networking and Information Security Consultants & Trainers | Email: routerlynx@gmail.com
BGP | EIGRP | OSPF | MPLS | Firewall | VPN | IPsec | Multicast | QOS | IPv4/6 | STP | VLAN | PON | AE | M2M | and more!

 
jkarras
Member Candidate
Member Candidate
Posts: 224
Joined: Fri Sep 06, 2013 3:07 am
Location: Utah, USA

Re: VLAN tagging and forwarding - Help needed!

Sat Apr 05, 2014 11:00 pm

If your Linksys is not sending tagged traffic you should not send it tagged traffic.

Like the other posters question is the Mikrotik device being used as your firewall/router or is the Linksys. If you are simply using the Mikrotik as a switch to strip the tags you can use the switch chip features to do the adding and stripping very quickly and easily with out involving the CPU.
 
User avatar
NAB
Trainer
Trainer
Posts: 503
Joined: Tue Feb 10, 2009 4:08 pm
Location: UK
Contact:

Re: VLAN tagging and forwarding - Help needed!

Sat Apr 05, 2014 11:15 pm

Plug the Linksys into ether1 and the modem into ether2, then run the following commands:
/interface bridge add l2mtu=1600 name=bridge1
/interface vlan add interface=ether2 l2mtu=2286 name=vlan2_100 vlan-id=100
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=vlan2_100
Which creates a VLAN interface on ether2 and then bridges ether1 with the VLAN interface thereby bridging the two networks and achieving exactly what you have asked for.
Nicholas Barnes BSc(hons)
Certified Mikrotik Consultant
Certified Mikrotik Trainer

Vitell - Asterisk, Linux and network consultants
Unofficial IRC channel: #routerboard on irc.z.je
 
tarekgemayel
just joined
Topic Author
Posts: 5
Joined: Thu Apr 03, 2014 10:42 am

Re: VLAN tagging and forwarding - Help needed!

Sun Apr 06, 2014 9:47 am

I will be using the Linksys as my firewall, because i am also using it as Wi-Fi for the office.
 
tarekgemayel
just joined
Topic Author
Posts: 5
Joined: Thu Apr 03, 2014 10:42 am

Re: VLAN tagging and forwarding - Help needed!

Sun Apr 06, 2014 12:06 pm

What NAB proposed is kind of working!

I can now see that i have internet on the modem, but traffic is not passing!

Any idea why? Maybe the MTU size? Maybe i have to strip off the VLAN ID 10 when traffic is sent back towards the Linksys?

Any help is appreciated!
 
CelticComms
Forum Guru
Forum Guru
Posts: 1766
Joined: Wed May 02, 2012 5:48 am

Re: VLAN tagging and forwarding - Help needed!

Sun Apr 06, 2014 3:55 pm

What NAB suggested would already present untagged traffic on Ether 1. FYI - On the RB750 you could achieve the same thing at wire speed using the switch chip instead of a bridge.
Interlynx | Networking and Information Security Consultants & Trainers | Email: routerlynx@gmail.com
BGP | EIGRP | OSPF | MPLS | Firewall | VPN | IPsec | Multicast | QOS | IPv4/6 | STP | VLAN | PON | AE | M2M | and more!

Who is online

Users browsing this forum: MSN [Bot] and 124 guests