Community discussions

MUM Europe 2020
 
ropebih
Member Candidate
Member Candidate
Topic Author
Posts: 109
Joined: Tue May 22, 2007 5:35 pm

SSH client is not working

Tue Apr 08, 2014 11:23 am

SSH client is not working since the 6.8. or 6.9 version. When can we expect fix of this bug?
[admin@xxxxx] > system ssh address=192.168.5.3 user=root

Welcome back!
 
onnoossendrijver
Member
Member
Posts: 418
Joined: Mon Jul 14, 2008 11:10 am
Location: The Netherlands

Re: SSH client is not working

Tue Apr 08, 2014 11:31 am

What's not working?
On 6.11:
 > system ssh address=10.10.10.10 user=blabla
password:
Welcome to Ubuntu 12.04.4 LTS (GNU/Linux 3.2.0-60-generic x86_64)
Linux/network engineer: ITIL, LPI1, CCNA R+S, CCNP R+S, JNCIA, JNCIS-SEC
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: SSH client is not working

Tue Apr 08, 2014 12:37 pm

as onnoossendrijver kindly pointed out that problem with ssh client are resolved in newer release.
 
ropeba
Member Candidate
Member Candidate
Posts: 220
Joined: Sat Jul 29, 2006 4:13 pm

Re: SSH client is not working

Tue Apr 08, 2014 6:48 pm

How do you explain this?

v6.11
Image

v6.2
Image
 
stavincki1
just joined
Posts: 12
Joined: Thu Jan 09, 2014 1:06 pm

Re: SSH client is not working

Tue Apr 08, 2014 8:11 pm

Definitely something is still not ok with the SSH Client. I can enstablish one connection to a CentOS device and thats it, no more. I have the same issue with several other devices like user ropeba.
 
stavincki1
just joined
Posts: 12
Joined: Thu Jan 09, 2014 1:06 pm

Re: SSH client is not working

Wed Apr 16, 2014 4:44 pm

As i can see the ssh client problem still exists in the 6.12 version. I hope you will fix that very soon.
 
ropeba
Member Candidate
Member Candidate
Posts: 220
Joined: Sat Jul 29, 2006 4:13 pm

Re: SSH client is not working

Wed Apr 16, 2014 5:55 pm

Same here. I urgently need solution for this problem! We use ssh for IPTV service (STB administration). More than 2-3 months we don't have control over users STBs.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: SSH client is not working

Thu Apr 17, 2014 11:59 am

enable debug logging for ssh and attempt a connection saving full conversation (preferably on both ends) and send to support@mikrotik.com Other way this thread is quite useless as there is no information of what RouterOS exactly is used, what ssh server it attempted to connect to etc.
 
DjM
Member Candidate
Member Candidate
Posts: 111
Joined: Sun Dec 27, 2009 2:44 pm

Re: SSH client is not working

Mon May 12, 2014 2:15 pm

I have the same issue - connection to some SSH servers is working, to same not. [Ticket#2014051266000668] has been created.
 
DjM
Member Candidate
Member Candidate
Posts: 111
Joined: Sun Dec 27, 2009 2:44 pm

Re: SSH client is not working

Tue May 13, 2014 1:08 pm

My issue with SSH client was solved in ROS 6.13rc23 via [Ticket#2014051266000668]. In case that there will be still an issue with MK SSH client, send output from "debug ssh" on MK side and from SSH server side to support@mikrotik.com, if requested.
 
fxpester
just joined
Posts: 10
Joined: Wed Nov 23, 2011 1:11 pm

Re: SSH client is not working

Sat Jun 10, 2017 10:52 am

just facing the issue with v6.28
 
olegtsss
just joined
Posts: 2
Joined: Thu Jul 18, 2019 3:38 pm

Re: SSH client is not working

Thu Jul 18, 2019 3:50 pm

Hello! I have a new version of Router OS 6.45.1 and I have such problem too.
############################################
user ssh-keys private print
Flags: R - RSA, D - DSA
# USER BITS KEY-OWNER
0 R root 2048 root@185.20.24.56

ip ssh print
forwarding-enabled: both
always-allow-password-login: no
strong-crypto: no
allow-none-crypto: no
host-key-size: 2048

system ssh user=root address=185.20.24.56
Welcome back! --------> don't work!
##############################################
But it's work on other PC:
ssh root@185.20.24.56
All right!)))

Log from 185.20.24.56:
sshd[8968]: error: Received disconnect from 33.23.45.33 port 5152:14: [preauth]
sshd[8968]: Disconnected from 33.23.45.33 port 5152 [preauth]


And if I use ssh-client and password auth,
system ssh user=root address=185.20.24.56
All right too ((((
 
olegtsss
just joined
Posts: 2
Joined: Thu Jul 18, 2019 3:38 pm

Re: SSH client is not working

Thu Jul 18, 2019 7:41 pm

It's MikroTik's log (ssh debug):
22:34:28 ssh,debug ssh: auth methods: publickey
22:34:28 ssh,debug ssh: unknown auth method: publickey
22:34:28 ssh,debug ssh: code 0x0300000e closing..

Who is online

Users browsing this forum: No registered users and 82 guests