Community discussions

MikroTik App
 
obadaabdullah
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 71
Joined: Wed Jan 08, 2014 7:41 pm

help in cache

Tue Apr 29, 2014 10:46 am

i want to enable RB built in cache and make my hotspot users arrived it in the max speed
till now i made the first step, still the second how to make users connect to cache full speed (i give each of my hotspot users 1M/1M speed in profiles)
 
ronix
Member Candidate
Member Candidate
Posts: 152
Joined: Thu Nov 17, 2011 6:51 pm

Re: help in cache

Tue Apr 29, 2014 12:39 pm

mark the cache hit DSCP traffic in Mangle
then in queue give it unlimited speed
 
obadaabdullah
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 71
Joined: Wed Jan 08, 2014 7:41 pm

Re: help in cache

Tue Apr 29, 2014 10:15 pm

mark the cache hit DSCP traffic in Mangle
then in queue give it unlimited speed
you mean that i should mark the outgoing package from web-cache to the users?
 
User avatar
aacable
Member
Member
Posts: 434
Joined: Wed Sep 17, 2008 11:58 am
Location: ISLAMIC Republic of PAKISTAN
Contact:

Re: help in cache

Wed Apr 30, 2014 11:01 am

maybe something like this ?

First Mark Cached Contents by MANGLE Rule.
/ip firewall mangle
add action=mark-packet chain=output comment="CACHE HIT" disabled=no dscp=4 \
new-packet-mark=cache-hits passthrough=no
Now if you are using mikoritk 5.x , Create an Queue Tree which will send cache-hits packets to users at full LAN speed, ignoring the user’s Static OR Dynamic QUEUES
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=0 name="Unlimited Speed for CACHE" packet-mark=cache-hits \
parent=global-out priority=8 queue=default
examples with snapshots are here.
http://aacable.wordpress.com/2011/12/29 ... rent-mode/
_____________
Regard's

Syed Jahanzaib
Web: http://aacable.wordpress.com
Email: aacable [at] hotmail.com
 
obadaabdullah
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 71
Joined: Wed Jan 08, 2014 7:41 pm

Re: help in cache

Wed Apr 30, 2014 9:09 pm

maybe something like this ?

First Mark Cached Contents by MANGLE Rule.
/ip firewall mangle
add action=mark-packet chain=output comment="CACHE HIT" disabled=no dscp=4 \
new-packet-mark=cache-hits passthrough=no
Now if you are using mikoritk 5.x , Create an Queue Tree which will send cache-hits packets to users at full LAN speed, ignoring the user’s Static OR Dynamic QUEUES
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=0 name="Unlimited Speed for CACHE" packet-mark=cache-hits \
parent=global-out priority=8 queue=default
examples with snapshots are here.
http://aacable.wordpress.com/2011/12/29 ... rent-mode/

thanks a lot for answering
here is my firewall scripts
i use hotspot with (username & password) RB 6.7 (there is no global out and no traffic on dscp=4)
does this scripts right?

"
/ip firewall nat
add action=redirect chain=hs-auth comment="obada cache final" dst-port=80 protocol=tcp to-ports=\
8080
"
first there is a nat redirection sequence dstnt to prehotspot to hotspot (here you can see port 80 redirected to port 64873, should i get my proxy packets from this port?? or i just give my webproxy this port??
when i but this firewall nat as the first rule my users couldent reach my login page
"
/ip firewall mangle
add action=mark-packet chain=output new-packet-mark=cacheout protocol=tcp src-port=8080
add action=mark-packet chain=output comment=Cache new-packet-mark=Cache passthrough=no
"

thanks again

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot], DarkNate, Google [Bot], Google Adsense [Bot], kocouj1 and 82 guests