Community discussions

MikroTik App
 
robertpenz
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 80
Joined: Mon Oct 10, 2011 8:41 am

Hotspot Feature via Layer 3 not working with VRRP

Thu May 01, 2014 12:08 pm

I have following setup in my lab to reproduce the problem:

The Mikrotik has the Internet connection and is running a DHCP Server and Hotspot Server. A layer 3 switch which connects the clients and also provides a DHCP Relay.

e.g.:

Internet -- Hotspot Mikrotik - (10.0.0.0/24)- Layer3 Switch - (10.0.1.0/24) - Clients

If I set shared-users=unlimited it works until I use VRRP on the Layer 3 switch in the transit network (10.0.0.0/24) to the Mikrotik. If I do this, the user can authenticate but the redirecting webpage is redirecting in a loop. What can I do to work around this problem?

ps: I only have trial Users as I just need to show webpage to make sure the user accepts the house rules ... I know that there are ways around, but as it is free anyway I don't care.

pps: This is only the lab setup, in the real world I've a big network (with many Layer3 Switches) which does not allow to make one Layer2 network for the hotspot feature, and it is also not possible to bring a Mikrotik to every Layer2 location as we're using a enterprise network as basis and this is only on application over it.
 
robertpenz
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 80
Joined: Mon Oct 10, 2011 8:41 am

Re: Hotspot Feature via Layer 3 not working with VRRP

Mon May 12, 2014 10:03 pm

Is nobody running a Layer 3 hotspot network?

Who is online

Users browsing this forum: Baidu [Spider], EdPa and 119 guests