Community discussions

 
vortex1
just joined
Topic Author
Posts: 20
Joined: Tue Sep 28, 2010 10:07 am

layer 2 traffic

Thu May 08, 2014 9:04 pm

hello everyone.
i do have 3 sites (office, and 2 appartments) that each one of them has an adsl connection.
the office is the main site and has a mikrotik 750 that holds the pppoe of the adsl connection. the other 2 sites connect through pptp to the office.
the two sites have a linux box on site A and a mikrotik 750 on site B that hols the adsl connection's pppoe.

due to some requirements i would like to have the 2 mikrotiks to have port5 to pass 'pure' layer 2 traffic. the third site that has a linux box (debian 7, with 3 ethernets) it will connect in the near future.

could someone help me how to setup this?
 
Rudios
Forum Veteran
Forum Veteran
Posts: 966
Joined: Mon Mar 11, 2013 12:58 pm
Location: The Netherlands

Re: layer 2 traffic

Fri May 09, 2014 12:55 am

Setup eoip tunnel over your existing pptp and bridge with ether5.
Testing setup with: 2 x RB750UP | 2 x RB750GL | 1 x RB951G-2HnD | 1 x RB2011UiAS-IN
 
vortex1
just joined
Topic Author
Posts: 20
Joined: Tue Sep 28, 2010 10:07 am

Re: layer 2 traffic

Fri May 09, 2014 8:49 am

this is where I've lost it how to do it.
is there a guide?
 
Rudios
Forum Veteran
Forum Veteran
Posts: 966
Joined: Mon Mar 11, 2013 12:58 pm
Location: The Netherlands

Re: layer 2 traffic

Fri May 09, 2014 10:45 am

this is where I've lost it how to do it.
is there a guide?
I do not know how your PPTP is setup but in most cases the PPTP interface is having an IP address.
If that is the case, create an eoip tunnel between the two IP addresses of the pptp tunnel.
Create an eoip interface on both routerboards connecting to the other Routerboard.
Make sure to set the tunnel id equal to both sides.

on both routerboards put these commands

ros code

/interface eoip
add name=eoip-tunnel remote-address=<ip of opposite pptp> tunnel-id=5
/interface bridge
add name=bridge-tunnel
/interface bridge ports
add bridge=bridge-tunnel interface=ether5
add bridge=bridge-tunnel interface=eoip-tunnel
Testing setup with: 2 x RB750UP | 2 x RB750GL | 1 x RB951G-2HnD | 1 x RB2011UiAS-IN
 
lz1dsb
Member Candidate
Member Candidate
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: layer 2 traffic

Fri May 09, 2014 2:58 pm

this is where I've lost it how to do it.
is there a guide?
Here's the guide...

Who is online

Users browsing this forum: No registered users and 101 guests