Community discussions

MikroTik App
 
kazim
newbie
Topic Author
Posts: 27
Joined: Tue Feb 14, 2012 3:39 pm

How to block VOIP Calls

Thu May 15, 2014 10:58 am

Hi,

I have round about 100 home and corporate customers and they are using private IP. for each customer i have created separate IP pool and on my Mikrotik WAN i have public ip. for the last 10 days my public ip is continuously blocking for 30 minutes and when change the ip its starts work. when i contact to the upstream they told me that you are using VOIP and that's why your ip has been blocked and the internet becomes down. In Afghanistan VOIP is illegal.

any body know how can i block VOIP traffic in Mikrotik.
 
User avatar
cdiedrich
Forum Veteran
Forum Veteran
Posts: 947
Joined: Thu Feb 13, 2014 2:03 pm
Location: Basel, Switzerland // Bremen, Germany
Contact:

Re: How to block VOIP Calls

Thu May 15, 2014 12:17 pm

If they're using SIP, you could at least block their initialization with these rules:

ros code

/ip firewall filter
add action=drop chain=forward !connection-bytes !connection-limit \
    !connection-mark !connection-rate !connection-state !connection-type \
    !content disabled=no !dscp !dst-address !dst-address-list \
    !dst-address-type !dst-limit dst-port=5060 !fragment !hotspot \
    !icmp-options !in-bridge-port !in-interface !ingress-priority \
    !ipv4-options !layer7-protocol !limit !nth !out-bridge-port \
    !out-interface !p2p !packet-mark !packet-size !per-connection-classifier \
    !port !priority protocol=tcp !psd !random !routing-mark !routing-table \
    !src-address !src-address-list !src-address-type !src-mac-address \
    !src-port !tcp-flags !tcp-mss !time !ttl
add action=drop chain=forward !connection-bytes !connection-limit \
    !connection-mark !connection-rate !connection-state !connection-type \
    !content disabled=no !dscp !dst-address !dst-address-list \
    !dst-address-type !dst-limit dst-port=5061 !fragment !hotspot \
    !icmp-options !in-bridge-port !in-interface !ingress-priority \
    !ipv4-options !layer7-protocol !limit !nth !out-bridge-port \
    !out-interface !p2p !packet-mark !packet-size !per-connection-classifier \
    !port !priority protocol=tcp !psd !random !routing-mark !routing-table \
    !src-address !src-address-list !src-address-type !src-mac-address \
    !src-port !tcp-flags !tcp-mss !time !ttl
add action=drop chain=forward !connection-bytes !connection-limit \
    !connection-mark !connection-rate !connection-state !connection-type \
    !content disabled=no !dscp !dst-address !dst-address-list \
    !dst-address-type !dst-limit dst-port=5060 !fragment !hotspot \
    !icmp-options !in-bridge-port !in-interface !ingress-priority \
    !ipv4-options !layer7-protocol !limit !nth !out-bridge-port \
    !out-interface !p2p !packet-mark !packet-size !per-connection-classifier \
    !port !priority protocol=udp !psd !random !routing-mark !routing-table \
    !src-address !src-address-list !src-address-type !src-mac-address \
    !src-port !tcp-flags !tcp-mss !time !ttl
add action=drop chain=forward !connection-bytes !connection-limit \
    !connection-mark !connection-rate !connection-state !connection-type \
    !content disabled=no !dscp !dst-address !dst-address-list \
    !dst-address-type !dst-limit dst-port=5061 !fragment !hotspot \
    !icmp-options !in-bridge-port !in-interface !ingress-priority \
    !ipv4-options !layer7-protocol !limit !nth !out-bridge-port \
    !out-interface !p2p !packet-mark !packet-size !per-connection-classifier \
    !port !priority protocol=udp !psd !random !routing-mark !routing-table \
    !src-address !src-address-list !src-address-type !src-mac-address \
    !src-port !tcp-flags !tcp-mss !time !ttl
But normally it's just a matter of time when they find ways around this...
Christopher Diedrich
MTCNA, MTCUME, MTCWE
Basel, Switzerland
Bremen, Germany

There are 10 types of people: Those who understand binary and those who don't.
There are two types of people: Those who can extrapolate from incomplete data
 
kazim
newbie
Topic Author
Posts: 27
Joined: Tue Feb 14, 2012 3:39 pm

Re: How to block VOIP Calls

Sun May 18, 2014 6:53 am

hi,
It will block skype and viber calls are not

Who is online

Users browsing this forum: Baidu [Spider], inteq and 131 guests