Community discussions

 
Ulypka
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Wed Jan 09, 2013 8:26 am

OVPN bridging

Fri May 16, 2014 11:54 am

Ovpn in the bridge is still not working :(
[Ticket#2014051466000539]
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.13 released!

Fri May 16, 2014 12:01 pm

Ovpn in the bridge is still not working :(
[Ticket#2014051466000539]
OVPN and bridge? How?
You can bridge only interfaces with MAC addresses or PPP interfaces with enabled BCP (Bridge Control Protocol).
So i do not see how that's a bug
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
Ulypka
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Wed Jan 09, 2013 8:26 am

Re: v6.13 released!

Fri May 16, 2014 12:05 pm

Ovpn in the bridge is still not working :(
[Ticket#2014051466000539]
OVPN and bridge? How?
You can bridge only interfaces with MAC addresses or PPP interfaces with enabled BCP (Bridge Control Protocol).
So i do not see how that's a bug
interface ovpn-server server set mode=ethernet
ppp profile set 0 bridge=bridge1


ROS in <6.8 works
in ROS 6.8 6.9 6.10 6.11 6.12 6.13 not working
Last edited by Ulypka on Fri May 16, 2014 12:09 pm, edited 1 time in total.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v6.13 released!

Fri May 16, 2014 12:08 pm

Ulypka, you should have bcp enabled on both sides of PPP (OpenVPN) tunnel.
 
npero
Member
Member
Posts: 316
Joined: Tue Mar 01, 2005 1:59 pm
Location: Serbia

Re: v6.13 released!

Fri May 16, 2014 12:10 pm

Ovpn in the bridge is still not working :(
interface ovpn-server server set mode=ethernet
ppp profile set 0 bridge=bridge1

ROS in <6.8 works
in ROS 6.8 6.9 6.10 6.11 6.12 6.13 not working
Not tested in 6.13 but can confirm in older version bug is you can access to every device in network but not on device where is OpenVPN server like device where is server not in bridge.

Ticket#2014032466000827 open 24.3.2014 for now support not response on this ticket.
Open new ticket Ticket#2014051266000801 12.5.2014. for now noting from MT.
 
Ulypka
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Wed Jan 09, 2013 8:26 am

Re: v6.13 released!

Fri May 16, 2014 12:17 pm

Ulypka, you should have bcp enabled on both sides of PPP (OpenVPN) tunnel.
confirm bridge with two sides work on MT

and what to do if I connect from windows?
Last edited by Ulypka on Fri May 16, 2014 12:19 pm, edited 1 time in total.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.13 released!

Fri May 16, 2014 12:19 pm

Ulypka there is no such feature! It is not a bug! Windows doesn't support any tunnel bridging, it is RouterOS-to-RouterOS feature (and RouterOS-to-Cisco)
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
npero
Member
Member
Posts: 316
Joined: Tue Mar 01, 2005 1:59 pm
Location: Serbia

Re: v6.13 released!

Fri May 16, 2014 12:22 pm

Ulypka there is no such feature! It is not a bug! Windows doesn't support any tunnel bridging, it is RouterOS-to-RouterOS feature
But in older version works :), also windows to windows work, also in my case only problem is MT device where is server other devices in bridged network work. Problem is happen when MT introduce new PPP package.
 
Ulypka
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Wed Jan 09, 2013 8:26 am

Re: v6.13 released!

Fri May 16, 2014 12:22 pm

del.
Last edited by Ulypka on Fri May 16, 2014 1:09 pm, edited 1 time in total.
 
Ulypka
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Wed Jan 09, 2013 8:26 am

Re: v6.13 released!

Fri May 16, 2014 12:24 pm

Ulypka there is no such feature! It is not a bug! Windows doesn't support any tunnel bridging, it is RouterOS-to-RouterOS feature (and RouterOS-to-Cisco)
http://forum.mikrotik.com/viewtopic.php ... 96#p426396


just flashing from 6.7 to 6.11
and stops working
 
npero
Member
Member
Posts: 316
Joined: Tue Mar 01, 2005 1:59 pm
Location: Serbia

Re: v6.13 released!

Fri May 16, 2014 12:25 pm

rextended, I will check for the issue, and try to find out why it is not fixed yet.
And we will try to fix it at 6.14 version.

Check Ticket#2014032466000827 you have explanation how to try.
 
Ulypka
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Wed Jan 09, 2013 8:26 am

Re: v6.13 released!

Fri May 16, 2014 12:27 pm

sergejs
As i understand it will not be correct (that would work in version 6.7)?
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.13 released!

Fri May 16, 2014 12:32 pm

Ulypka there is no such feature! It is not a bug! Windows doesn't support any tunnel bridging, it is RouterOS-to-RouterOS feature
But in older version works :), also windows to windows work, also in my case only problem is MT device where is server other devices in bridged network work. Problem is happen when MT introduce new PPP package.
No, it doesn't. you can't get proper MAC-level communications to Windows in any version of RouterOS, maybe you had some setup that had similar behaviour but i'm sure it is not proper bridging. you can simply see this enabling debug logs and see that BCp protocol is not supported by windows client.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
Ulypka
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Wed Jan 09, 2013 8:26 am

Re: OVPN bridging

Fri May 16, 2014 12:54 pm

macgaiver
I have worked with this configuration version 5.11 to 6.7 on any computer
and 6.8 all broke

http://wiki.mikrotik.com/wiki/OpenVPN
Windows
client of a bridged server (tap)

proto tcp-client

remote openvpn.example.com 1194 # Remote OpenVPN Servername or IP address
dev tap

nobind
persist-key

tls-client
ca ca.crt # Root certificate in the same directory as this configuration file.
cert keys/client.crt
key keys/client.key
 
Ulypka
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Wed Jan 09, 2013 8:26 am

Re: OVPN bridging

Fri May 16, 2014 1:20 pm

apparently do not even try packages sent
You do not have the required permissions to view the files attached to this post.
 
npero
Member
Member
Posts: 316
Joined: Tue Mar 01, 2005 1:59 pm
Location: Serbia

Re: v6.13 released!

Fri May 16, 2014 2:27 pm

Ulypka there is no such feature! It is not a bug! Windows doesn't support any tunnel bridging, it is RouterOS-to-RouterOS feature
But in older version works :), also windows to windows work, also in my case only problem is MT device where is server other devices in bridged network work. Problem is happen when MT introduce new PPP package.
No, it doesn't. you can't get proper MAC-level communications to Windows in any version of RouterOS, maybe you had some setup that had similar behaviour but i'm sure it is not proper bridging. you can simply see this enabling debug logs and see that BCp protocol is not supported by windows client.
Not need full layer 2 support but working like in older version is ok. My configuration is simple MT OpenVPN server in bridge and Windows OpenVPN client for me everything is working only MT device very is server is not accessible. I use OpenVPN because have some location where need to use connection trough proxy server, but now administrators on that network open port for 1723 an gre and everything is switching to PPTP.
But why something is working in older version not working in new version.

And one more thing support not answering on that ticket more that 2 months if support say ok that in new PPP package can be don't ok I can live witout it, but not answering on ticket is not professional because I insist to this feature working.
 
Ulypka
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Wed Jan 09, 2013 8:26 am

Re: OVPN bridging

Wed May 21, 2014 7:50 am

support
As i understand it will not be correct (that would work in version 6.7)?
 
MarcusW
just joined
Posts: 17
Joined: Tue Dec 20, 2011 11:02 am

Re: OVPN bridging

Sat Jun 14, 2014 1:28 am

Same problem here, just tried with 6.15. :( Has someone got any feedback from Mikrotik about this yet?
 
tscarborough
just joined
Posts: 10
Joined: Wed Jun 06, 2007 3:48 am

Re: OVPN bridging

Thu Jun 26, 2014 7:52 pm

I have confirmed this does work in 6.7. I made the mistake of upgrading a ovpn concentrator to 6.15 from 5.26 needless to say all of the connections stopped functioning.


Any update of when or if this will be corrected. I could not even ping the ip of the remote ovpn-out interface after upgrading.

Who is online

Users browsing this forum: No registered users and 109 guests