Community discussions

MikroTik App
 
kellogs
Member Candidate
Member Candidate
Topic Author
Posts: 114
Joined: Sun Jan 04, 2009 10:55 am

queue

Mon May 19, 2014 7:26 am

Hi Members,

I have about 100Mbps bandwidth and has about 5 web servers.

I want to always allocate 10Mbps fixed for these 5 web servers and the rest of the 90Mbps can be used by other servers/office/internet

Any good example rules I could follow?

Thanks!
 
User avatar
Farhadgh
just joined
Posts: 19
Joined: Wed Nov 27, 2013 4:38 pm
Contact:

Re: queue

Wed May 21, 2014 12:09 am

Sure. you can mark their (web servers) connections and pass them through a queue of 10mbps. and pass rest of other bandwidth through another queue of 90mbps (there are many other ways based on your needs).
other questions are welcomed as well.
If answer was helpful, donate a karma :D
Everyday, a better day!
 
kellogs
Member Candidate
Member Candidate
Topic Author
Posts: 114
Joined: Sun Jan 04, 2009 10:55 am

Re: queue

Wed May 21, 2014 4:18 am

karma donated :)

Do you have any example rules?
 
User avatar
Farhadgh
just joined
Posts: 19
Joined: Wed Nov 27, 2013 4:38 pm
Contact:

Re: queue

Wed May 21, 2014 8:28 am

Sure. I consider that your router is configured with basic routes and dst/src nat rules.
follower rules are based on what I think about your current config and maybe you need replace some current nat and mangle rules and routes with similar rules of mine (or you can send your current config so I write exactly what you need)
although I considered your webservers addresses are xxx (add every rule with this value for every webserver you have with its own IP) and your other networks who use other 90 mbps is yyy.
/ip firewall nat add chain=dstnat dst-address=xxx protocol=tcp dst-port=80 action=add-src-to-address-list address-list=webViewerIP address-list-timeout=10m
/ip firewall nat add chain=dstnat src-address-list=webViewerIP action=dst-nat to-addresses=xxx
/ip firewall mangle add chain=prerouting dst-address-list=webViewerIP src-address=xxx action=mark-connection new-connection-mark=webies
/ip firewall mangle add chain=prerouting connection-mark=webies action=mark-packet new-packet-mark=webiesPack
(if you have previously added mark routings based on connection marks, add relevant ones here)
/queue simple add packet-marks=webiesPack max-limit=10M/10M
(now add the same src/dst nat rules base on your need, and mangle rules for recognizing their connections and packets, and make a queue of 90mbps for them).
let me know the result.
you can make queue tree to shape bandwidth better.
Everyday, a better day!

Who is online

Users browsing this forum: accarda and 63 guests