Community discussions

 
disik
just joined
Topic Author
Posts: 4
Joined: Fri May 23, 2014 11:30 pm

ovpn clients cannot access RB router

Sat May 24, 2014 6:59 pm

Strange thing happens. RB is set up as ovpn server in ethernet mode. Ovpn clients have full access to hosts in RB's lan. Everything is okay except one thing, ovpn clients have no access to the RB itself at all.
Maybe I have to add some firewall rules? I have tried various with no success. Maybe bridges, chains?
 
User avatar
scotthammersley
Member Candidate
Member Candidate
Posts: 230
Joined: Fri Feb 22, 2013 7:16 pm
Location: Jackson, MS
Contact:

Re: ovpn clients cannot access RB router

Fri May 30, 2014 6:37 pm

Can you post your settings? Please, include a network diagram.
Expert consulting BGP | MPLS | OSPF | Adv. Route/Switch 1-855-645-7684
MikroTik Trainers
http://www.iparchitechs.com #1 ranked MikroTik consulting firm in North America

Image
 
disik
just joined
Topic Author
Posts: 4
Joined: Fri May 23, 2014 11:30 pm

Re: ovpn clients cannot access RB router

Fri May 30, 2014 7:02 pm

Diagram:
(LAN) ---- (RB) ---- (OVPN client)

Settings:
/interface ovpn-server server
set certificate=server.crt cipher=blowfish128,aes256 default-profile=openvpn-profile enabled=yes keepalive-timeout=16 \
max-mtu=1400 mode=ethernet port=563
/ppp profile
add bridge=bridge-local dns-server=192.168.2.1 local-address=192.168.2.1 name=openvpn-profile remote-address=\
ovpn-address-pool use-compression=yes use-encryption=yes use-ipv6=default
/ip pool
add name=ovpn-address-pool ranges=192.168.2.240/29

Every OVPN client has full access to any host on LAN and to any other OVPN client, but no access to RB itself, which I need a lot.

Who is online

Users browsing this forum: No registered users and 109 guests