Community discussions

 
User avatar
karina
Member
Member
Topic Author
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

IP Cloud

Tue Jun 10, 2014 3:24 pm

Nice new feature :-) What is it?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: IP Cloud

Tue Jun 10, 2014 3:26 pm

enable it and you will see ;)

The Cloud service consists of a DDNS server for your router, and a time server. With a simple command, you can configure your router to receive a free domain name.

Router router can get a free domain name, so that you can connect to it, even if it has a changing IP address. No longer you have the need to learn scripting or sign up for 3rd party services to always have access to your router. Simply enable this feature, and the router will always inform the MikroTik DNS service of any IP address changes, so that you can always connect to it, even if your IP address has changed.
Some uses for this are:

• Set up a secure connection to your home network using PPTP, SSTP or IPSec for use when you need to connect to your home network from somewhere on the Internet
• Watch a security camera on your home network
• Copy files from your home network NAS
• Manage your router

http://wiki.mikrotik.com/wiki/Manual:IP/Cloud
No answer to your question? How to write posts
 
User avatar
karina
Member
Member
Topic Author
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: IP Cloud

Tue Jun 10, 2014 4:13 pm

Nice. Thank you
 
User avatar
sguox
Trainer
Trainer
Posts: 73
Joined: Fri Mar 09, 2012 6:23 pm

Re: IP Cloud

Tue Jun 10, 2014 4:52 pm

Ideally it should be based on trigger eg. DHCP renew, interface up, time server should stick to ntp client with default configuration enabled and pointed to public pool


Sent from my iPad using Tapatalk
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: IP Cloud

Tue Jun 10, 2014 4:58 pm

Ideally it should be based on trigger eg. DHCP renew, interface up, time server should stick to ntp client with default configuration enabled and pointed to public pool


Sent from my iPad using Tapatalk
time server will not be used, if you use NTP
No answer to your question? How to write posts
 
scorpion
just joined
Posts: 3
Joined: Sat Nov 30, 2013 4:59 pm

Re: IP Cloud

Tue Jun 10, 2014 11:49 pm

GR8 Feature.

But What about NAT Networks, how we could get Ddns.
 
joegoldman
Member
Member
Posts: 498
Joined: Mon May 27, 2013 2:05 am

Re: IP Cloud

Wed Jun 11, 2014 5:21 am

GR8 Feature.

But What about NAT Networks, how we could get Ddns.
If your router sits behind NAT and does not get a public IP, then you would never have access to it anyway without the NAT router providing port forwards to you.

The cloud service reports to Mikrotik servers whatever public IP address it comes from. It does nothing to enable services in your mikrotik, just provides DNS name for your router if you have dynamic IP from your provider.
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: IP Cloud

Wed Jun 11, 2014 8:27 am

The question evidently was about 1:1 nat where all ports are redirected to the router's wan behind other nat. Therefore the wan is not equipped with public IP. Does it work in this case?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: IP Cloud

Wed Jun 11, 2014 9:00 am

The question evidently was about 1:1 nat where all ports are redirected to the router's wan behind other nat. Therefore the wan is not equipped with public IP. Does it work in this case?
DNS resolves to the public router, connection is made to this IP, 1:1 NAT should work on your gateway, if you want to redirect these requests to some internal machine.

The cloud DNS will be of course not useful for routers that have no public IP
No answer to your question? How to write posts
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: IP Cloud

Wed Jun 11, 2014 9:48 am

Thus, not interesting for me so far. My ddns scripts work reliably in all cases...
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: IP Cloud

Wed Jun 11, 2014 9:58 am

Thus, not interesting for me so far. My ddns scripts work reliably in all cases...
of course you can still use DDNS scripts. But in this case, you only need to set one setting. No registration, no maintenance, no scripting.
No answer to your question? How to write posts
 
slech
Long time Member
Long time Member
Posts: 533
Joined: Thu Feb 14, 2008 4:03 pm
Location: Moldova, Chisinau

Re: IP Cloud

Wed Jun 11, 2014 10:16 am

Thank you Mikrotik Team!

Nice feature!

Without any scripts now VPN setup and access to my devices with dynamic IP.
sorry for my english
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: IP Cloud

Wed Jun 11, 2014 12:34 pm

I agree. Can be useful for many home users. Like torrent or edonkey clients, webservers, databases... Whatever. I would like to have syslog server, for instance. Or rrd tool for graphing directly in routers. Or at least dude running on mipsbe...
 
SimWhite
just joined
Posts: 22
Joined: Tue Jul 02, 2013 5:05 pm

Re: IP Cloud

Wed Jun 11, 2014 1:05 pm

Hmmm.. I can't find this option on x86.
 
andriys
Forum Guru
Forum Guru
Posts: 1187
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: IP Cloud

Wed Jun 11, 2014 1:14 pm

Hmmm.. I can't find this option on x86.
It is not supported on x86.
See here.
 
Basdno
Member Candidate
Member Candidate
Posts: 118
Joined: Wed Feb 17, 2010 10:11 pm

Re: IP Cloud

Wed Jun 11, 2014 2:03 pm

Interesting and nice new feature!

One of those that simply makes everyday life a little bit easier! :)
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: IP Cloud

Wed Jun 11, 2014 5:24 pm

Well,
Even I was sceptic, I have tried it...
IPCloud.jpg
Still I do not uderstand how Mikrotik could release such stupid thing:
1) It does not recognize the internal ip range (defined by RFC)! There should be check in order to prevent local IP registrations.
2) It writes something as message in the left side of statusbar:
" DDNS server received request from IP 8...". Dammed, why it is cut?? Why it is impossible to see the status message?
3) It gives terrible domain name. I would like to meet some people that will be able to write this address into the browser from memory when they are woken up in the middle of the night. If it is aimed at "home users" than this is not an advance for them.
4) No multiple wans handling.
5) Not working in case of 1:1 nat or dmz. Many of home users do not have public ip on their wan ports, but somehow natted, if ISP allowed this.

Why mikrotik did not get inspiration from DDNS agents in OpenWRT or from TP-Link routers? There is possible to drill-down the list of DDNS providers and fill simple few fields with username, domain and passowrd and it is? Mikrotik could select few mostly used DDNS service providers, create scripts, prepare the user interface cockpit for it and it would be much better. Of course, there could be added option to simply register, or to use mikrotiks own service, but in some user-friendly way. And adding new and new DDNS providers as users repot them. This could be helpful.

Really, really it looks very unprofessional. I am disappointed that (according to my oppinion) so highly valuated development team of mikrotik did something like this.

Isn't this funny?:
[me@myrouter] > ping 30xxxxxxxxxxx.sn.mynetname.net
HOST                                     SIZE TTL TIME  STATUS                                                          
192.168.1.91                               56  64 0ms  
192.168.1.91                               56  64 0ms  
192.168.1.91                               56  64 0ms  
192.168.1.91                               56  64 0ms  
192.168.1.91                               56  64 0ms  
    sent=5 received=5 packet-loss=0% min-rtt=0ms avg-rtt=0ms max-rtt=0ms 

You do not have the required permissions to view the files attached to this post.
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: IP Cloud

Wed Jun 11, 2014 5:35 pm

Still I do not uderstand how Mikrotik could release such stupid thing:
1) It does not recognize the internal ip range (defined by RFC)! There should be check in order to prevent local IP registrations.
2) It writes something as message in the left side of statusbar:
" DDNS server received request from IP 8...". Dammed, why it is cut?? Why it is impossible to see the status message?
3) It gives terrible domain name. I would like to meet some people that will be able to write this address into the browser from memory when they are woken up in the middle of the night. If it is aimed at "home users" than this is not an advance for them.
4) No multiple wans handling.
5) Not working in case of 1:1 nat or dmz. Many of home users do not have public ip on their wan ports, but somehow natted, if ISP allowed this.

Why mikrotik did not get inspiration from DDNS agents in OpenWRT or from TP-Link routers? There is possible to drill-down the list of DDNS providers and fill simple few fields with username, domain and passowrd and it is? Mikrotik could select few mostly used DDNS service providers, create scripts, prepare the user interface cockpit for it and it would be much better. Of course, there could be added option to simply register, or to use mikrotiks own service, but in some user-friendly way. And adding new and new DDNS providers as users repot them. This could be helpful.

Really, really it looks very unprofessional. I am disappointed that (according to my oppinion) so highly valuated development team of mikrotik did something like this.
1) It kind'a does AFAIK... I mean, there's a warning if the public IP detected is different than the one the router sends. The "warning" is in the form of a status message.
2) Can't you resize the window to make the message fit?
3) Anyone (home user or otherwise) can bookmark that name. The point of this feature is to keep the "pointer" to the router permanent, which would not be the case if your public IP changes. More professional users could add a CNAME record to a different domain that they own, and map that new name to name given here.
4) OK, that one's a bummer indeed, though I guess to handle that case, the name would become even less memorable, as it would need to contain an interface identifier (perhaps the default name of the interface, for the sake of permanence).
5) While I haven't yet tried out this myself, from reading the docs, it appears that those should be updated successfully... but with a warning, as pointed out. You're saying that part doesn't work as advertised?
Why mikrotik did not get inspiration from DDNS agents in OpenWRT or from TP-Link routers? There is possible to drill-down the list of DDNS providers and fill simple few fields with username, domain and passowrd and it is?
I can tell you from personal experience that it's VERY difficult to ask from an end user to register any sort of an account for anything, particularly when they can't wrap their head around why it's necessary when they aren't going to be manipulating a thing themselves (but instead let a machine do it for them). The logic goes that if something is publically visible, and you're only setting it up once, it shouldn't require an account, but just a one time request & approval process at worst... It takes some deep mental processing power for end users to figure out that a machine is doing something that they must otherwise do manually themselves (and thus they need to identify themselves, and not the device), and that the device needs a username and password in order to work on their behalf.

Of course, then again, RouterOS isn't used so often by non-techie end users (yet?), so registering an account wouldn't be a hard thing for most RouterOS users to do, so point taken there.
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
sentania
just joined
Posts: 2
Joined: Mon Dec 30, 2013 9:30 pm

Re: IP Cloud

Wed Jun 11, 2014 6:24 pm

3) It gives terrible domain name. I would like to meet some people that will be able to write this address into the browser from memory when they are woken up in the middle of the night. If it is aimed at "home users" than this is not an advance for them.

Easy solution:

CNAME: mikrotik.mydomain.com -> 1234567890.sn.mynetname.net
 
User avatar
lordkappa
Member Candidate
Member Candidate
Posts: 133
Joined: Wed May 16, 2012 1:53 pm
Location: Vancouver, Canada

Re: IP Cloud

Thu Jun 12, 2014 3:36 am

Thanks for a handy feature! Hopefully it sees more refinement to add the ability to specify which Public IP(s) are ddns'd, and the ability to revoke/delete a domain.

I too use my own scripts for DDNS, but this is a very nice feature for those times you just want a domain and don't need any fluff.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: IP Cloud

Thu Jun 12, 2014 9:23 am

Great answer, boen_robot

The feature is not for memorizing the name, but for solving changing IP address issue.
As for multiple WANs - if both public IP addresses work, the feature will work. It will resolve to one of them, and the end goal is reached, you can access your router.
No answer to your question? How to write posts
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: IP Cloud

Thu Jun 12, 2014 10:18 am

Ok. The fact it is not usable for someone does not mean that there couldn't be anyone else that would appreciate this. I hope that one day it evolves into the state that makes it usable also for me. But please, solve the more urgent topics first.
Last edited by jarda on Sat Jun 14, 2014 7:43 am, edited 1 time in total.
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: IP Cloud

Thu Jun 12, 2014 11:06 am

As for multiple WANs - if both public IP addresses work, the feature will work. It will resolve to one of them, and the end goal is reached, you can access your router.
But for some users (particularly professionals; home users don't care I guess) it matters whether they're accessing the router over one WAN or another (e.g. if they're diagnosing connection problems), so there should be a way to explicitly target one.

Ideally, I would hope for a subdomain, with the upper domain being "last updated interface", and the subdomains being an off by default extra, e.g. ether1.1234567890.sn.mynetname.net pointing to the first adapter on the router.


Personally, I used to have two ISPs, and though I only have one today (i.e. I wouldn't immediately take advantage of this if introduced), I can still remember how back in the day, I needed to check connectivity over each ISP separately, so this would've been very welcome, and certainly IS going to be welcomed by people currently in that position.


Oh, and one beef that I actually DO have with this feature - It's not present in x86!!! Yeah, yeah, I saw the "serial number" thing in the release topic... and I have a counter suggestion there too that I haven't yet heard either any "that won't work because [reasons]" or "we'll do it in a few releases time" sort of thing.
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
ibrahiem
just joined
Posts: 1
Joined: Fri Jun 13, 2014 6:04 pm

Re: IP Cloud

Fri Jun 13, 2014 6:14 pm

i have error
DDNS service might not workImage
 
slawekk
just joined
Posts: 24
Joined: Sun Jan 02, 2011 3:48 pm

Re: IP Cloud

Sat Jun 14, 2014 4:05 am

Why you don't use the license key hash or clean license key on x86 for this function?
 
ndbjorne
just joined
Posts: 22
Joined: Sat Dec 15, 2012 5:06 pm
Location: Italy

Re: IP Cloud

Mon Jun 16, 2014 1:28 pm

If the aim is to reach a RB why not extend new ip cloud function with something like
/ip cloud set nat-traversal=yes
(default: no)

to let RB update DNS record to the IP of outer router?

Of course outer router should have been at least configured with port-forwarding to the natted RB for management.
That would grant management to many RB and would make fully reachable all those RBs that are actually the only devices connected to a (DSL) router which redirects all traffic from the internet to their WAN IP.

Regards
Andrea
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: IP Cloud

Mon Jun 16, 2014 1:31 pm

i have error
DDNS service might not workImage
It means that DNS name will work only for routers that have Public IP address
No answer to your question? How to write posts
 
sickofyou
just joined
Posts: 3
Joined: Tue May 22, 2012 3:50 pm

Re: IP Cloud

Mon Jun 16, 2014 2:10 pm

Hi,

I think ndbjorne's idea it would be very useful. If the ip cloud feature gets the public IP, why don't to put it in the DDNS record and let the administrator to grant access natting to the RB?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: IP Cloud

Mon Jun 16, 2014 2:16 pm

we could offer a choice, to send the detected public IP or the detected local IP. Then you could set 1:1 NAT on the gateway if you have access to it.
No answer to your question? How to write posts
 
sickofyou
just joined
Posts: 3
Joined: Tue May 22, 2012 3:50 pm

Re: IP Cloud

Mon Jun 16, 2014 2:31 pm

we could offer a choice, to send the detected public IP or the detected local IP. Then you could set 1:1 NAT on the gateway if you have access to it.
It would be very very nice if we could choose between the two options. With it, the IP Cloud feature will become more useful.
 
User avatar
Bigfoot
Frequent Visitor
Frequent Visitor
Posts: 76
Joined: Sat Jan 15, 2011 10:41 am
Location: South Africa

Re: IP Cloud

Mon Jun 16, 2014 9:57 pm

I don't see the IP Cloud feature on my x86 v6.15.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: IP Cloud

Tue Jun 17, 2014 9:36 am

I don't see the IP Cloud feature on my x86 v6.15.
It is only for RouterBOARD devices
No answer to your question? How to write posts
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: IP Cloud

Tue Jun 17, 2014 1:34 pm

I don't see the IP Cloud feature on my x86 v6.15.
It is only for RouterBOARD devices
... for now... hopefully?
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
magic
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Fri Mar 04, 2005 9:53 pm
Location: Sopron, Hungary
Contact:

Re: IP Cloud

Tue Jun 17, 2014 2:04 pm

we could offer a choice, to send the detected public IP or the detected local IP. Then you could set 1:1 NAT on the gateway if you have access to it.
This would be a very nice feature. Our router is in the DMZ and have the 192.168.1.2 address (detected ip is in the 188.142.x.x range), so the function is unuseable now because the dns system give back to local ip.
Krisztian Gancs
RLAN Internet Ltd.
http://www.rlan.hu
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 778
Joined: Mon May 14, 2012 9:30 pm

Re: IP Cloud

Sat Jun 21, 2014 3:46 pm

we could offer a choice, to send the detected public IP or the detected local IP. Then you could set 1:1 NAT on the gateway if you have access to it.
ABSOLUTELY a must have.

Due to the use of Fios or the need to keep Xfinity Voip/Modem/Routers inline... many companies I work with are in the DMZ. If there were someway to tell the system to use the actual WAN IP that would make it usable for a lot more home users.

Many home users and AV integrators would really appreciate if we could finally have a winbox option to enter our credentials for dyndns.

Peronally, I lean heavily on my dyndns updater script.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
Brazd
just joined
Posts: 10
Joined: Mon Mar 31, 2014 9:34 am
Location: Moskow (Hot Russia)

Re: IP Cloud

Mon Jul 14, 2014 2:26 am

What prevents link it (/ip cloud) with interface?
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: IP Cloud

Mon Jul 14, 2014 10:15 am


ABSOLUTELY a must have.

Due to the use of Fios or the need to keep Xfinity Voip/Modem/Routers inline... many companies I work with are in the DMZ. If there were someway to tell the system to use the actual WAN IP that would make it usable for a lot more home users.

Many home users and AV integrators would really appreciate if we could finally have a winbox option to enter our credentials for dyndns.

Peronally, I lean heavily on my dyndns updater script.
this is already available in the 6.16rc18 (via CLI interface)
 
Brazd
just joined
Posts: 10
Joined: Mon Mar 31, 2014 9:34 am
Location: Moskow (Hot Russia)

Re: IP Cloud

Mon Jul 14, 2014 10:20 am

Very good. Waiting new release :). Thanks.
 
jsaang
just joined
Posts: 2
Joined: Sun Jul 20, 2014 1:44 pm

Re: IP Cloud

Sun Jul 20, 2014 1:47 pm

would somebody mind to instruct me to access the mt router using cloud ip....???
 
Brazd
just joined
Posts: 10
Joined: Mon Mar 31, 2014 9:34 am
Location: Moskow (Hot Russia)

Re: IP Cloud

Mon Jul 21, 2014 10:32 am

would somebody mind to instruct me to access the mt router using cloud ip....???
Aaa....
WinBox-Ip-Cloude-Enable

or
/ip cloud
set enabled=yes

and You get name like xxxxxxxxxxxxxxx.sn.mynetname.net with setuped Your "white" ip
 
Toiletbowl
Member Candidate
Member Candidate
Posts: 169
Joined: Fri Jun 03, 2011 6:49 am
Location: Boracay Philippines

Re: IP Cloud

Tue Jul 22, 2014 5:06 am

I don't see the IP Cloud feature on my x86 v6.15.
It is only for RouterBOARD devices
normis

what ros version this IP cloud features?

thanks
 
npero
Member
Member
Posts: 316
Joined: Tue Mar 01, 2005 1:59 pm
Location: Serbia

Re: IP Cloud

Tue Jul 22, 2014 7:09 am


what ros version this IP cloud features?

thanks
I thing from version 6.13 but use latest version 6.17 if your router don't have public address, because in 6.16/6.17 can use external address for update.
 
Buzz
just joined
Posts: 13
Joined: Sat Aug 09, 2014 11:44 am

Re: IP Cloud

Sat Aug 09, 2014 11:58 am

nice feature , but i have a little problem when the power is off (power loss) and after turning my 951Ui-2HnD on again it doesn't update the ip automatically

is there anyway to force update every startup or after power loss
my device is 951Ui-2HnD 6.18

thank u in advance
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: IP Cloud

Mon Aug 11, 2014 4:31 pm

it will refresh when router is starting up. (at least it should and our testing has showed that it does)

Can you tell us what you did and how IP information was not updated properly on router booting up?
 
Buzz
just joined
Posts: 13
Joined: Sat Aug 09, 2014 11:44 am

Re: IP Cloud

Thu Aug 14, 2014 2:37 am

it will refresh when router is starting up. (at least it should and our testing has showed that it does)

Can you tell us what you did and how IP information was not updated properly on router booting up?
the ip doesn't change after power loss even it shows it is updated with the previous ip and won't update with the new ip until I force update by myself
 
npero
Member
Member
Posts: 316
Joined: Tue Mar 01, 2005 1:59 pm
Location: Serbia

Re: IP Cloud

Thu Aug 14, 2014 8:31 am

Buzz your are right IP Cloud have bug if you behind NAT not update IP address because not see address is changed, I all ready write support but no answer they say update every minutes but it is not true they update on change but if router behind NAT not see change and not update must click force update. Have couple router with IP cloud with external address and nat they all perform the some.

Because of that to make IP cloud use behind NAT put
/ip cloud force-update


in scheduler I put interval 3 minutes and working perfect.

If router have external address it is ok.
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: IP Cloud

Thu Aug 14, 2014 8:36 am

Or use normal dynamic dns service that works reliably as you want...
 
npero
Member
Member
Posts: 316
Joined: Tue Mar 01, 2005 1:59 pm
Location: Serbia

Re: IP Cloud

Thu Aug 14, 2014 8:46 am

Or use normal dynamic dns service that works reliably as you want...
Of course but what is reliably today, no-ip before couple weeks not working almost one week, other service what I am using not have possibility to change TTL, IP cloud is almost perfect scheduler resolve bug :D.
Recommendation for reliably service, I don't have possibility to use fix IP on every location ?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: IP Cloud

Thu Aug 14, 2014 10:17 am

Buzz your are right IP Cloud have bug if you behind NAT not update IP address because not see address is changed, I all ready write support but no answer they say update every minutes but it is not true they update on change but if router behind NAT not see change and not update must click force update. Have couple router with IP cloud with external address and nat they all perform the some.

Because of that to make IP cloud use behind NAT put
/ip cloud force-update


in scheduler I put interval 3 minutes and working perfect.

If router have external address it is ok.
thanks, we will make this work in the next routeros version
No answer to your question? How to write posts
 
npero
Member
Member
Posts: 316
Joined: Tue Mar 01, 2005 1:59 pm
Location: Serbia

Re: IP Cloud

Thu Aug 14, 2014 11:14 am

Thanks very much.

If you need more information I send it you supout.rif before almost two weeks 30.6 with that problem Ticket#2014073066000442.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: IP Cloud

Thu Aug 14, 2014 11:20 am

Thanks very much.

If you need more information I send it you supout.rif before almost two weeks 30.6 with that problem Ticket#2014073066000442.
Thanks, but the issue is very clear. If RouterOS doesn't see any IP changes, it doesn't do the update. It doesn't know that the ISP changed the IP on their router. We will make an option to send force update every x minutes, if outgoing address is set to be used.
No answer to your question? How to write posts
 
Buzz
just joined
Posts: 13
Joined: Sat Aug 09, 2014 11:44 am

Re: IP Cloud

Fri Aug 15, 2014 12:40 am

Buzz your are right IP Cloud have bug if you behind NAT not update IP address because not see address is changed, I all ready write support but no answer they say update every minutes but it is not true they update on change but if router behind NAT not see change and not update must click force update. Have couple router with IP cloud with external address and nat they all perform the some.

Because of that to make IP cloud use behind NAT put
/ip cloud force-update


in scheduler I put interval 3 minutes and working perfect.

If router have external address it is ok.
many thanks , that is what I was looking for , and u r right my routerboard is behind nat
 
freemannnn
Long time Member
Long time Member
Posts: 669
Joined: Sun Oct 13, 2013 7:29 pm

Re: IP Cloud

Fri Aug 15, 2014 11:47 pm

Great feature. Turn it on to all my clients and disable duckdns script!
 
kei888
newbie
Posts: 47
Joined: Fri Feb 07, 2014 7:54 am

Re: IP Cloud

Sat Sep 06, 2014 12:35 pm

Hi Buzz!

Can you show us the configuration of your Scheduler for the IP Cloud?

Thank you.
 
Brazd
just joined
Posts: 10
Joined: Mon Mar 31, 2014 9:34 am
Location: Moskow (Hot Russia)

Re: IP Cloud

Sat Sep 06, 2014 1:37 pm

SCRIPT:

# Setup of join to NO-IP.com
:local ddnsuser "noipusername"
:local ddnspass "password"
:local ddnshostname "yourname.no-ip.info"
:local ddnsinterface "ether1"

# global VARs
:global ddnslastipINT0
:local str
:local ddnsip
:local ip

:if ([ :typeof $ddnslastipINT0 ] = nil ) do={ :global ddnslastipINT0 "0" }

:local ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]

:if ([ :typeof $ddnsip ] = nil ) do={
:log info ("ServiceDNS: No ip address on $ddnsinterface .")
} else={

# remove mask from get Ip from interface
:for i from=( [:len $ddnsip] - 1) to=0 do={
:if ( [:pick $ddnsip $i] = "/") do={
:set ddnsip [:pick $ddnsip 0 $i];
}
}

:if ($ddnsip != $ddnslastipINT0) do={

:log info ("ServiceDNS: $ddnshostname -> $ddnsip")

# sending new IP to NO-IP over HTTP request
:local str "/nic/update?hostname=$ddnshostname&myip=$ddnsip"
/tool fetch url="http://dynupdate.no-ip.com/$str" mode=http user=$ddnsuser password=$ddnspass \ dst-path=("/ServiceDNS.".$ddnshostname)
:delay 1

# Save result to log file
:local str [/file find name="ServiceDNS.$ddnshostname"];
:log info [/file get $str contents];
/file remove $str
:global ddnslastipINT0 $ddnsip

}


Author not me, but it work on my MT for two interfaces.
For it I change ddnslastipINT0 to ddnslastipINT1 or ddnslastipINT2 etc. :)
 
kei888
newbie
Posts: 47
Joined: Fri Feb 07, 2014 7:54 am

Re: IP Cloud

Sun Sep 07, 2014 2:59 am

Hi buzz!

Can you show us the screenshot or configuration of the schedule for Cloud IP?

I think my cloud IP is not updating.
 
kei888
newbie
Posts: 47
Joined: Fri Feb 07, 2014 7:54 am

Re: IP Cloud

Sun Sep 07, 2014 3:10 am

Hi Brazd!
Author not me, but it work on my MT for two interfaces.
For it I change ddnslastipINT0 to ddnslastipINT1 or ddnslastipINT2 etc. :)
For what is this? How can we know what to put on the "ddnslastipINTx"?

Thank you.a
 
npero
Member
Member
Posts: 316
Joined: Tue Mar 01, 2005 1:59 pm
Location: Serbia

Re: IP Cloud

Sun Sep 07, 2014 8:12 am

Hi buzz!

Can you show us the screenshot or configuration of the schedule for Cloud IP?

I think my cloud IP is not updating.
Here is it screen shoot.
You do not have the required permissions to view the files attached to this post.
 
Brazd
just joined
Posts: 10
Joined: Mon Mar 31, 2014 9:34 am
Location: Moskow (Hot Russia)

Re: IP Cloud

Sun Sep 07, 2014 1:56 pm

kei888

Sorry... I fought with NO-IP 2 days, and now fixed on it. Skiped in Your post "Cloud IP".
 
DBob
Frequent Visitor
Frequent Visitor
Posts: 79
Joined: Fri Jun 10, 2011 4:13 pm

Re: IP Cloud

Wed Sep 10, 2014 2:12 pm

Really nice feature!
I'm using to connect mikrotik devices between home and rent over EoIP, and at both sides, IPs are dynamic.
 
Buzz
just joined
Posts: 13
Joined: Sat Aug 09, 2014 11:44 am

Re: IP Cloud

Sun Sep 21, 2014 12:42 am

Hi buzz!

Can you show us the screenshot or configuration of the schedule for Cloud IP?

I think my cloud IP is not updating.
sorry for my delayed reply
change interval to determine how often the schedule run, in my case every 30 min
You do not have the required permissions to view the files attached to this post.
 
User avatar
saintofinternet
Forum Veteran
Forum Veteran
Posts: 757
Joined: Thu Oct 15, 2009 3:52 am

Re: IP Cloud

Sat Dec 06, 2014 3:34 am

3) It gives terrible domain name. I would like to meet some people that will be able to write this address into the browser from memory when they are woken up in the middle of the night. If it is aimed at "home users" than this is not an advance for them.

Easy solution:

CNAME: mikrotik.mydomain.com -> 1234567890.sn.mynetname.net

the CNAME idea worked perfectly with the NO-IP
by professionals, for professionals....
Don't forget to give KARMA!!!
 
cutedrummerboy
Member Candidate
Member Candidate
Posts: 137
Joined: Thu Nov 14, 2013 6:32 pm

Re: IP Cloud

Sat Dec 13, 2014 5:58 pm

hey, i am behind 1 to 1 NAT and my isp just change my public ip every 10 minutes. can anyone tell me the update frequency of ip cloud?
Device: RB2011UIAS-RM, RB750GL, CISCO SG300-28, UNIFI UAP-LR
 
User avatar
saintofinternet
Forum Veteran
Forum Veteran
Posts: 757
Joined: Thu Oct 15, 2009 3:52 am

Re: IP Cloud

Sun Dec 14, 2014 3:35 am

the frequency can be decided through "scheduler"...
by professionals, for professionals....
Don't forget to give KARMA!!!
 
cutedrummerboy
Member Candidate
Member Candidate
Posts: 137
Joined: Thu Nov 14, 2013 6:32 pm

Re: IP Cloud

Sun Dec 14, 2014 1:59 pm

yup done, but i actually want to know the default update frequency of this service when anyone behind 1 to 1 nat.
Device: RB2011UIAS-RM, RB750GL, CISCO SG300-28, UNIFI UAP-LR
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 778
Joined: Mon May 14, 2012 9:30 pm

Re: IP Cloud

Mon Dec 15, 2014 12:51 am

If the ip on the interface changes.... documentation states 1 minute.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
cutedrummerboy
Member Candidate
Member Candidate
Posts: 137
Joined: Thu Nov 14, 2013 6:32 pm

Re: IP Cloud

Mon Dec 15, 2014 5:46 am

that already i know, but if the ip remain unchanged then what will be the update frequency?
Device: RB2011UIAS-RM, RB750GL, CISCO SG300-28, UNIFI UAP-LR
 
npero
Member
Member
Posts: 316
Joined: Tue Mar 01, 2005 1:59 pm
Location: Serbia

Re: IP Cloud

Mon Dec 15, 2014 10:36 am

You need this ONLY if router board is behind NAT not have external address on one of interfaces.
If router board have external address then monitoring address change and update on change.

If behind NAT then address not change and because of that need scripts to force update it is bug in software because need to monitoring address change on some other way I have open ticket for this.
 
Valerio5000
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Fri Dec 06, 2013 2:38 am

Re: IP Cloud

Sun Dec 28, 2014 9:46 pm

Hello, on ROS 6:24 as you disable this function? I have a static public ip and I noticed that if under "IP> CLOUD off this feature by writing XXX.sn.mynetname.net the login page webfig remains accessible.
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: IP Cloud

Sun Dec 28, 2014 10:13 pm

Because of cached dns records. Probably.
 
Valerio5000
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Fri Dec 06, 2013 2:38 am

Re: IP Cloud

Sun Dec 28, 2014 11:55 pm

Because of cached dns records. Probably.
and then? What can I do? :D

I already have a public ip and I do not need this (excellent) service. How can I disable it and delete the URL XXX.sn.mynetname.net? Right now it is still accessible though the option is disabled!
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: IP Cloud

Mon Dec 29, 2014 7:51 am

IMHO it is far away from to be called excellent service. I don't use it. On the other hand, if you registered your own domain, it doesn't matter if ip cloud is still pointing at the same ip address...
 
bestefan
just joined
Posts: 17
Joined: Fri Nov 21, 2008 9:23 am

Re: IP Cloud

Mon Jan 05, 2015 7:09 pm

Hi,
IP Cloud is very useful.
My question is the following.
I would like to protect my router with dropping all incoming traffic except a member of an allowed address list.
How can I make an exception in a firewall (allowed IP or port) for a working Mikrotik Cloud?

Regards
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: IP Cloud

Mon Jan 05, 2015 7:19 pm

Your question has no relation to ip cloud. Just make address list in firewall, and accept in input and forward chains only the packets matching your address list in src. Also add other two rules dropping the rest.
 
bestefan
just joined
Posts: 17
Joined: Fri Nov 21, 2008 9:23 am

Re: IP Cloud

Mon Jan 05, 2015 11:11 pm

Hi Jarda,

But I have to know the IP address of the Mikrotik Cloud service server, and put it in to the allowed address list in my firewall, otherwise of course Mikrotik cloud service not works.
Meanwhile I have traced the mentioned address myself: 81.198.87.240.
I think alternatively it is possible to allow incoming traffic on the dst port 15252 in my router, because the update process of the cloud service uses this dst port.
Now already works fine.
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: IP Cloud

Tue Jan 06, 2015 12:49 am

I don't use ip cloud, because I use other dynamic dns service that allows me to manage my domains, ttl and everything. Therefore I see ip cloud to be useless thing because you can't manage anything. Even I don't believe it needs any access to your device, it would be really silly if it is true.
 
ngnr
just joined
Posts: 11
Joined: Mon Jun 09, 2014 11:52 pm
Location: Spain

Re: IP Cloud

Tue Jan 06, 2015 1:29 am

I was under the impression that IP Cloud was just a dynamic DNS built into Mkt devices. Shouldn't the source address of the connection be the device IP?
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: IP Cloud

Tue Jan 06, 2015 5:30 pm

It depends. Normally you can manage what ip is linked to your dns name...
 
User avatar
acald3ron
just joined
Posts: 18
Joined: Tue Jan 06, 2015 8:26 am
Location: Rosarito, México
Contact:

Re: IP Cloud

Tue Jan 27, 2015 10:06 pm

only suport ipv4 ?
 
siavashblade
just joined
Posts: 4
Joined: Wed Feb 25, 2015 1:02 pm

Re: IP Cloud

Wed Feb 25, 2015 4:23 pm

hi guys I have a problem with this can you help me?
first of all after I enable DDNS, in the status section it tells me that:
"DDNS server received request from ip ...(the public ip adress)... but your local ip was 192.168.1.6 (which is my gateway ip). DDNS service might not work."
and I can't ping the DNS name it gives me 100% timeout then I've added this command:"/ip firewall filter add action=accept chain=input disabled=no dst-port=8291 protocol=tcp place-before=0"
but this didnt help either! :|
what should I do?
I have ip cameras in my work place and I want to watch them from home via this feature.
can you help me?
 
damt
just joined
Posts: 1
Joined: Wed Mar 11, 2015 10:56 am

Re: IP Cloud

Wed Mar 11, 2015 11:19 am

hi every one

i have little problem in RB when i want to active my cloud i went to winbox - ip - but the problem is i didn't see cloud it's hidden i don't know where is it --------- can help me what to do or how to show the cloud icon

note: RB is CC1036 12 4s and OS ver: 6.5
best wishes
look forwards to hear you soon
ali
 
krisjans
just joined
Posts: 13
Joined: Wed Jun 11, 2014 2:59 pm

Re: IP Cloud

Wed Mar 11, 2015 11:37 am

note: RB is CC1036 12 4s and OS ver: 6.5
Hi,
cloud features appeared on version 6.14.
BR
 
hsabrey
just joined
Posts: 20
Joined: Tue Jul 01, 2014 2:37 pm

Re: IP Cloud

Tue Jun 02, 2015 8:11 pm

Hello Gents,

i want to inquiry if there are any sites which allow you to connect your routers (NASs) of your network in one place so you can see their state and access to them
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Tue Jun 02, 2015 10:51 pm

Use whatever network management system or at least something like overlook whiz on your Android phone.
 
Alaaalaa
just joined
Posts: 5
Joined: Sun May 24, 2015 9:41 pm

Re: IP Cloud

Fri Jun 05, 2015 11:32 am

I got My DNS name, but when I am trying to log in into my RB 951 ui 2HnD it says wrong username or password why ??!!
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: IP Cloud

Fri Jun 05, 2015 11:56 am

it means you don't have a public IP, and the DNS name was assigned not to your router, but to your provider (ISP) gateway
No answer to your question? How to write posts
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: IP Cloud

Tue Jun 09, 2015 4:19 pm

Because of cached dns records. Probably.
and then? What can I do? :D

I already have a public ip and I do not need this (excellent) service. How can I disable it and delete the URL XXX.sn.mynetname.net? Right now it is still accessible though the option is disabled!

update to newer version of RouterOS. When you disable DDNS it will remove the entry from our servers (wait for the status update in '/ip cloud' menu).

It will send 1 UDP packets to unregister from the service.
 
quyn
just joined
Posts: 1
Joined: Tue Jul 14, 2015 7:32 am

Re: IP Cloud

Mon Jan 04, 2016 8:49 am

Our customers can not see the camera out there, there must DNS Server MikroTik is faulty ?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: IP Cloud

Mon Jan 04, 2016 10:09 am

Our customers can not see the camera out there, there must DNS Server MikroTik is faulty ?
We had a service disruption. It is fixed now.
No answer to your question? How to write posts
 
rea1ity
just joined
Posts: 24
Joined: Mon Jun 24, 2013 10:24 am

Re: IP Cloud

Tue Jan 26, 2016 8:08 pm

Hi

Cloud DDNS is very welcome to me.
But how can I configure to connect SSTP VPN?

this following guide was not for me.
http://wiki.mikrotik.com/wiki/Manual:In ... -Site_SSTP
their are requires two static IP but I'm just have two dynamic IPs.

Hope you let me know the instruction for configure site to site SSTP VPN connection.
 
evince
Member
Member
Posts: 307
Joined: Thu Jul 05, 2012 12:11 pm
Location: Weiswampach - Luxemburg
Contact:

Re: IP Cloud

Wed Jan 27, 2016 11:57 am

Hello,

IP Cloud is a great feature, btw how to assign it to another interface if i run 2 ISP?

Thank you in advance,
 
freemannnn
Long time Member
Long time Member
Posts: 669
Joined: Sun Oct 13, 2013 7:29 pm

Re: IP Cloud

Wed Jan 27, 2016 1:59 pm

ip cloud is really a great feature. i connect with winbox from my home to all my customers and examing/change/upgrade their configuration..
the only thing i want is to select from which wan update when u have dual wan for example 1 wan pppoe + 1 wan dhcp.
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: IP Cloud

Sat Feb 06, 2016 9:19 am

For those who are interested in my DNS Exit script:
http://forum.mikrotik.com/viewtopic.php?f=9&t=104578
 
eol
just joined
Posts: 7
Joined: Mon May 28, 2007 6:00 pm

Re: IP Cloud

Sat Feb 06, 2016 3:25 pm

Useful in some cases, but back into the future - do you have plans for more deeply integration DDNS relative services with routeros features ?
I mean dynamic and periodic check and resolve in src/dst in GRE/IPinIP/EoIP tunnels and other VPNs, firewall filters, nat rules, dynamic queues and so one?

Sorry in case someone of administrators consider this as off-topic but I didn't find dedicated topic for Feature Request.
 
k750
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Fri Feb 19, 2016 4:40 pm
Location: France / Paris

Re: IP Cloud

Tue Mar 01, 2016 11:01 pm

Hello,
Do you know if this option works with Synology server ?
Thank you
CCR1009-8G-1S-1S+PC - RouterOS 6.40.5
 
deanMKD1
Member
Member
Posts: 350
Joined: Fri Dec 12, 2014 12:06 am
Location: Macedonia
Contact:

Re: IP Cloud

Wed Mar 02, 2016 1:09 am

Hello,
Do you know if this option works with Synology server ?
Thank you
Of course that will work, but you need to add a NAT rule to point to your NAS also.
 
k750
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Fri Feb 19, 2016 4:40 pm
Location: France / Paris

Re: IP Cloud

Wed Mar 02, 2016 2:06 am

Of course that will work, but you need to add a NAT rule to point to your NAS also.
Hello and thank you for your answer
Do you know where this goes NAT rule?
My server is plugged into the ether 3 Port
I grieve not know but networks
Thank you in advance
Claude
CCR1009-8G-1S-1S+PC - RouterOS 6.40.5
 
deanMKD1
Member
Member
Posts: 350
Joined: Fri Dec 12, 2014 12:06 am
Location: Macedonia
Contact:

Re: IP Cloud

Thu Mar 03, 2016 12:38 pm

Of course that will work, but you need to add a NAT rule to point to your NAS also.
Hello and thank you for your answer
Do you know where this goes NAT rule?
My server is plugged into the ether 3 Port
I grieve not know but networks
Thank you in advance
Claude
1. Set static IP for NAS.
2. Set NAT to that NAS IP adress

Replace port 21 in my tutorial, to port of NAS.
 
k750
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Fri Feb 19, 2016 4:40 pm
Location: France / Paris

Re: IP Cloud

Wed Mar 09, 2016 10:24 pm

Good morning and thank you for your answers
It works
CCR1009-8G-1S-1S+PC - RouterOS 6.40.5
 
Puffer
just joined
Posts: 17
Joined: Mon Mar 08, 2010 2:09 pm

Re: IP Cloud

Fri Dec 23, 2016 3:12 pm

Hi Gents
Great feature
I hope I have not missed it. Does Cloud.Mikrotik.com always resolve to the same address ?
I don't allow a default gateway so would like to allow only the addresses used by cloud.

Rgds Puffer
 
k750
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Fri Feb 19, 2016 4:40 pm
Location: France / Paris

Re: IP Cloud

Sat Dec 24, 2016 11:33 am

Hello,
These 2 links no longer work
-------------------------------------
Bonjour,
Ces 2 liens ne fonctionnent plus

1. Set static IP for NAS.
2. Set NAT to that NAS IP adress
CCR1009-8G-1S-1S+PC - RouterOS 6.40.5
 
User avatar
zipvault
Member Candidate
Member Candidate
Posts: 144
Joined: Fri Dec 23, 2016 8:15 am

Re: IP Cloud

Wed Dec 28, 2016 1:35 pm

why is my cloud settings greyed out?
ZipVault
 
User avatar
NetHorror
just joined
Posts: 17
Joined: Fri Dec 06, 2013 8:12 am

Re: IP Cloud

Tue Jan 31, 2017 8:17 am

If you has problem with ip cloud you should add cloud server to allow filter (cloud.mikrotik.com)

This helped me
MTCNA, MTCRE, MTCTCE, MTCWE
 
jebz
Member Candidate
Member Candidate
Posts: 239
Joined: Sun May 01, 2011 12:03 pm
Location: Australia

Re: IP Cloud

Sun Jul 30, 2017 5:19 am

On a router with multiple WAN ports what is the best way to direct Cloud DDNS to register a particular interface?
 
LetArch
just joined
Posts: 1
Joined: Thu Aug 09, 2018 5:09 pm

Re: IP Cloud

Thu Aug 09, 2018 5:12 pm

How-to change dns name my mikrotik? It's need for secure access. Dns name my mikrotik has been know other people. Very need help!
 
User avatar
pukkita
Trainer
Trainer
Posts: 2984
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: IP Cloud

Fri Aug 10, 2018 12:13 pm

You can't AFAIK, dns name is made up from Routerboard serial.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: IP Cloud

Fri Sep 14, 2018 9:53 am

How-to change dns name my mikrotik? It's need for secure access. Dns name my mikrotik has been know other people. Very need help!
if you have your own DNS, you can use router FQDN as a CNAME entry and configure your services to reply to your proper name and ignore the rest.
 
Sob
Forum Guru
Forum Guru
Posts: 4812
Joined: Mon Apr 20, 2009 9:11 pm

Re: IP Cloud

Fri Sep 14, 2018 7:51 pm

It doesn't solve the problem that someone already knows the xxx.sn.mynetname.net hostname, because it will still exist. On the other hand, it shouldn't be a problem in the first place. If whole security is built on the fact that other people don't know the address of router, there's something wrong with it.
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply.
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: IP Cloud

Fri Sep 14, 2018 10:14 pm

Janisk, we, who have our own dns, do not use your ip cloud service at all. Happily.
 
mkx
Forum Guru
Forum Guru
Posts: 3223
Joined: Thu Mar 03, 2016 10:23 pm

Re: IP Cloud

Fri Sep 14, 2018 10:27 pm

Janisk, we, who have our own dns, do not use your ip cloud service at all. Happily.
I'm pretty sure that (W)ISPs are not target audience for cloud DNS, minority among home users are. Minority that is exposing some (small) part of home computing resources to internet (if only to have remote administration) and are doomed with being forced to use dynamic IP address. Or blessed, depends on what perspective you take. I guess quite a few of those don't have possibility to create a less cryptic DNS alias as not many home users have DNS (sub)domain at their disposal.

Myself, I do have my own domain and still use cloud dns. I never found necessary to play with my own way of doing DDNS.
BR,
Metod
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: IP Cloud

Sat Sep 15, 2018 5:41 am

Ok. "We" was too broad. Let's correct it to "me and maybe some others".

I didn't mean own dns server (necessarily) but public ddns service which is implementable both for static and dynamic (by script) ip addresses.

I am not considering myself to be ISP. I just play with networks and I am really big fan of mikrotik. Unfortunately there are some things that are really principally bad. Whatever "calling home" activities, like the ip cloud for example.

But yes. Facebook seems to be much worse and still people do use it...

So do what you think, but think what you do. If you believe something is fine, think again.
 
Sob
Forum Guru
Forum Guru
Posts: 4812
Joined: Mon Apr 20, 2009 9:11 pm

Re: IP Cloud

Sat Sep 15, 2018 6:38 am

"Calling home" is something else, this is opt-in, you choose if you want it or not. If I need DDNS service without running my own DNS infrastructure, I have to trust someone else. Whether it's MikroTik or some public DDNS provider, there's not much difference.

And solution with CNAME is actually very interesting. The xxx.sn.mynetname.net is not easy to remember, something like server1.mydomain.tld is better. But for your own DNS infrastructure, you need at least two nameservers and more experience running them than most people have. While own domain hosted on registrar's nameservers costs almost nothing and requires zero experience.
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply.
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: IP Cloud

Sat Sep 15, 2018 9:22 pm

Sure I admit it could be useful for some users. But there are other alternatives that do not disclose you as mikrotik running ip. What we saw during last two years after reading repetitively that there is no way to run custom code in ros and none can run anything on system level with high privileges, it is not wise to put yourself to single world ip cloud device list. Of course I trust mikrotik, otherwise I would not use their products and software, but I cannot be sure that thair lists will not be compromised or stolen. Therefore I will rather continue using different service that just joins ip with domain name without saying anything more to anyone.
 
Sob
Forum Guru
Forum Guru
Posts: 4812
Joined: Mon Apr 20, 2009 9:11 pm

Re: IP Cloud

Sun Sep 16, 2018 3:00 am

Well, in theory, you can find all MikroTik devices (those with enabled DDNS) by trying all different combinations of xxx.sn.mynetname.net. But in practice, xxx is an awful lot of combinations, so I wouldn't be worried about that.
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply.

Who is online

Users browsing this forum: No registered users and 74 guests