Page 1 of 1

IP Cloud

Posted: Tue Jun 10, 2014 3:24 pm
by karina
Nice new feature :-) What is it?

Re: IP Cloud

Posted: Tue Jun 10, 2014 3:26 pm
by normis
enable it and you will see ;)

The Cloud service consists of a DDNS server for your router, and a time server. With a simple command, you can configure your router to receive a free domain name.

Router router can get a free domain name, so that you can connect to it, even if it has a changing IP address. No longer you have the need to learn scripting or sign up for 3rd party services to always have access to your router. Simply enable this feature, and the router will always inform the MikroTik DNS service of any IP address changes, so that you can always connect to it, even if your IP address has changed.
Some uses for this are:

• Set up a secure connection to your home network using PPTP, SSTP or IPSec for use when you need to connect to your home network from somewhere on the Internet
• Watch a security camera on your home network
• Copy files from your home network NAS
• Manage your router

http://wiki.mikrotik.com/wiki/Manual:IP/Cloud

Re: IP Cloud

Posted: Tue Jun 10, 2014 4:13 pm
by karina
Nice. Thank you

Re: IP Cloud

Posted: Tue Jun 10, 2014 4:52 pm
by sguox
Ideally it should be based on trigger eg. DHCP renew, interface up, time server should stick to ntp client with default configuration enabled and pointed to public pool


Sent from my iPad using Tapatalk

Re: IP Cloud

Posted: Tue Jun 10, 2014 4:58 pm
by normis
Ideally it should be based on trigger eg. DHCP renew, interface up, time server should stick to ntp client with default configuration enabled and pointed to public pool


Sent from my iPad using Tapatalk
time server will not be used, if you use NTP

Re: IP Cloud

Posted: Tue Jun 10, 2014 11:49 pm
by scorpion
GR8 Feature.

But What about NAT Networks, how we could get Ddns.

Re: IP Cloud

Posted: Wed Jun 11, 2014 5:21 am
by joegoldman
GR8 Feature.

But What about NAT Networks, how we could get Ddns.
If your router sits behind NAT and does not get a public IP, then you would never have access to it anyway without the NAT router providing port forwards to you.

The cloud service reports to Mikrotik servers whatever public IP address it comes from. It does nothing to enable services in your mikrotik, just provides DNS name for your router if you have dynamic IP from your provider.

Re: IP Cloud

Posted: Wed Jun 11, 2014 8:27 am
by jarda
The question evidently was about 1:1 nat where all ports are redirected to the router's wan behind other nat. Therefore the wan is not equipped with public IP. Does it work in this case?

Re: IP Cloud

Posted: Wed Jun 11, 2014 9:00 am
by normis
The question evidently was about 1:1 nat where all ports are redirected to the router's wan behind other nat. Therefore the wan is not equipped with public IP. Does it work in this case?
DNS resolves to the public router, connection is made to this IP, 1:1 NAT should work on your gateway, if you want to redirect these requests to some internal machine.

The cloud DNS will be of course not useful for routers that have no public IP

Re: IP Cloud

Posted: Wed Jun 11, 2014 9:48 am
by jarda
Thus, not interesting for me so far. My ddns scripts work reliably in all cases...

Re: IP Cloud

Posted: Wed Jun 11, 2014 9:58 am
by normis
Thus, not interesting for me so far. My ddns scripts work reliably in all cases...
of course you can still use DDNS scripts. But in this case, you only need to set one setting. No registration, no maintenance, no scripting.

Re: IP Cloud

Posted: Wed Jun 11, 2014 10:16 am
by slech
Thank you Mikrotik Team!

Nice feature!

Without any scripts now VPN setup and access to my devices with dynamic IP.

Re: IP Cloud

Posted: Wed Jun 11, 2014 12:34 pm
by jarda
I agree. Can be useful for many home users. Like torrent or edonkey clients, webservers, databases... Whatever. I would like to have syslog server, for instance. Or rrd tool for graphing directly in routers. Or at least dude running on mipsbe...

Re: IP Cloud

Posted: Wed Jun 11, 2014 1:05 pm
by SimWhite
Hmmm.. I can't find this option on x86.

Re: IP Cloud

Posted: Wed Jun 11, 2014 1:14 pm
by andriys
Hmmm.. I can't find this option on x86.
It is not supported on x86.
See here.

Re: IP Cloud

Posted: Wed Jun 11, 2014 2:03 pm
by Basdno
Interesting and nice new feature!

One of those that simply makes everyday life a little bit easier! :)

Re: IP Cloud

Posted: Wed Jun 11, 2014 5:24 pm
by jarda
Well,
Even I was sceptic, I have tried it...
IPCloud.jpg
Still I do not uderstand how Mikrotik could release such stupid thing:
1) It does not recognize the internal ip range (defined by RFC)! There should be check in order to prevent local IP registrations.
2) It writes something as message in the left side of statusbar:
" DDNS server received request from IP 8...". Dammed, why it is cut?? Why it is impossible to see the status message?
3) It gives terrible domain name. I would like to meet some people that will be able to write this address into the browser from memory when they are woken up in the middle of the night. If it is aimed at "home users" than this is not an advance for them.
4) No multiple wans handling.
5) Not working in case of 1:1 nat or dmz. Many of home users do not have public ip on their wan ports, but somehow natted, if ISP allowed this.

Why mikrotik did not get inspiration from DDNS agents in OpenWRT or from TP-Link routers? There is possible to drill-down the list of DDNS providers and fill simple few fields with username, domain and passowrd and it is? Mikrotik could select few mostly used DDNS service providers, create scripts, prepare the user interface cockpit for it and it would be much better. Of course, there could be added option to simply register, or to use mikrotiks own service, but in some user-friendly way. And adding new and new DDNS providers as users repot them. This could be helpful.

Really, really it looks very unprofessional. I am disappointed that (according to my oppinion) so highly valuated development team of mikrotik did something like this.

Isn't this funny?:
[me@myrouter] > ping 30xxxxxxxxxxx.sn.mynetname.net
HOST                                     SIZE TTL TIME  STATUS                                                          
192.168.1.91                               56  64 0ms  
192.168.1.91                               56  64 0ms  
192.168.1.91                               56  64 0ms  
192.168.1.91                               56  64 0ms  
192.168.1.91                               56  64 0ms  
    sent=5 received=5 packet-loss=0% min-rtt=0ms avg-rtt=0ms max-rtt=0ms 


Re: IP Cloud

Posted: Wed Jun 11, 2014 5:35 pm
by boen_robot
Still I do not uderstand how Mikrotik could release such stupid thing:
1) It does not recognize the internal ip range (defined by RFC)! There should be check in order to prevent local IP registrations.
2) It writes something as message in the left side of statusbar:
" DDNS server received request from IP 8...". Dammed, why it is cut?? Why it is impossible to see the status message?
3) It gives terrible domain name. I would like to meet some people that will be able to write this address into the browser from memory when they are woken up in the middle of the night. If it is aimed at "home users" than this is not an advance for them.
4) No multiple wans handling.
5) Not working in case of 1:1 nat or dmz. Many of home users do not have public ip on their wan ports, but somehow natted, if ISP allowed this.

Why mikrotik did not get inspiration from DDNS agents in OpenWRT or from TP-Link routers? There is possible to drill-down the list of DDNS providers and fill simple few fields with username, domain and passowrd and it is? Mikrotik could select few mostly used DDNS service providers, create scripts, prepare the user interface cockpit for it and it would be much better. Of course, there could be added option to simply register, or to use mikrotiks own service, but in some user-friendly way. And adding new and new DDNS providers as users repot them. This could be helpful.

Really, really it looks very unprofessional. I am disappointed that (according to my oppinion) so highly valuated development team of mikrotik did something like this.
1) It kind'a does AFAIK... I mean, there's a warning if the public IP detected is different than the one the router sends. The "warning" is in the form of a status message.
2) Can't you resize the window to make the message fit?
3) Anyone (home user or otherwise) can bookmark that name. The point of this feature is to keep the "pointer" to the router permanent, which would not be the case if your public IP changes. More professional users could add a CNAME record to a different domain that they own, and map that new name to name given here.
4) OK, that one's a bummer indeed, though I guess to handle that case, the name would become even less memorable, as it would need to contain an interface identifier (perhaps the default name of the interface, for the sake of permanence).
5) While I haven't yet tried out this myself, from reading the docs, it appears that those should be updated successfully... but with a warning, as pointed out. You're saying that part doesn't work as advertised?
Why mikrotik did not get inspiration from DDNS agents in OpenWRT or from TP-Link routers? There is possible to drill-down the list of DDNS providers and fill simple few fields with username, domain and passowrd and it is?
I can tell you from personal experience that it's VERY difficult to ask from an end user to register any sort of an account for anything, particularly when they can't wrap their head around why it's necessary when they aren't going to be manipulating a thing themselves (but instead let a machine do it for them). The logic goes that if something is publically visible, and you're only setting it up once, it shouldn't require an account, but just a one time request & approval process at worst... It takes some deep mental processing power for end users to figure out that a machine is doing something that they must otherwise do manually themselves (and thus they need to identify themselves, and not the device), and that the device needs a username and password in order to work on their behalf.

Of course, then again, RouterOS isn't used so often by non-techie end users (yet?), so registering an account wouldn't be a hard thing for most RouterOS users to do, so point taken there.

Re: IP Cloud

Posted: Wed Jun 11, 2014 6:24 pm
by sentania
3) It gives terrible domain name. I would like to meet some people that will be able to write this address into the browser from memory when they are woken up in the middle of the night. If it is aimed at "home users" than this is not an advance for them.

Easy solution:

CNAME: mikrotik.mydomain.com -> 1234567890.sn.mynetname.net

Re: IP Cloud

Posted: Thu Jun 12, 2014 3:36 am
by lordkappa
Thanks for a handy feature! Hopefully it sees more refinement to add the ability to specify which Public IP(s) are ddns'd, and the ability to revoke/delete a domain.

I too use my own scripts for DDNS, but this is a very nice feature for those times you just want a domain and don't need any fluff.

Re: IP Cloud

Posted: Thu Jun 12, 2014 9:23 am
by normis
Great answer, boen_robot

The feature is not for memorizing the name, but for solving changing IP address issue.
As for multiple WANs - if both public IP addresses work, the feature will work. It will resolve to one of them, and the end goal is reached, you can access your router.

Re: IP Cloud

Posted: Thu Jun 12, 2014 10:18 am
by jarda
Ok. The fact it is not usable for someone does not mean that there couldn't be anyone else that would appreciate this. I hope that one day it evolves into the state that makes it usable also for me. But please, solve the more urgent topics first.

Re: IP Cloud

Posted: Thu Jun 12, 2014 11:06 am
by boen_robot
As for multiple WANs - if both public IP addresses work, the feature will work. It will resolve to one of them, and the end goal is reached, you can access your router.
But for some users (particularly professionals; home users don't care I guess) it matters whether they're accessing the router over one WAN or another (e.g. if they're diagnosing connection problems), so there should be a way to explicitly target one.

Ideally, I would hope for a subdomain, with the upper domain being "last updated interface", and the subdomains being an off by default extra, e.g. ether1.1234567890.sn.mynetname.net pointing to the first adapter on the router.


Personally, I used to have two ISPs, and though I only have one today (i.e. I wouldn't immediately take advantage of this if introduced), I can still remember how back in the day, I needed to check connectivity over each ISP separately, so this would've been very welcome, and certainly IS going to be welcomed by people currently in that position.


Oh, and one beef that I actually DO have with this feature - It's not present in x86!!! Yeah, yeah, I saw the "serial number" thing in the release topic... and I have a counter suggestion there too that I haven't yet heard either any "that won't work because [reasons]" or "we'll do it in a few releases time" sort of thing.

Re: IP Cloud

Posted: Fri Jun 13, 2014 6:14 pm
by ibrahiem
i have error
DDNS service might not workImage

Re: IP Cloud

Posted: Sat Jun 14, 2014 4:05 am
by slawekk
Why you don't use the license key hash or clean license key on x86 for this function?

Re: IP Cloud

Posted: Mon Jun 16, 2014 1:28 pm
by ndbjorne
If the aim is to reach a RB why not extend new ip cloud function with something like
/ip cloud set nat-traversal=yes
(default: no)

to let RB update DNS record to the IP of outer router?

Of course outer router should have been at least configured with port-forwarding to the natted RB for management.
That would grant management to many RB and would make fully reachable all those RBs that are actually the only devices connected to a (DSL) router which redirects all traffic from the internet to their WAN IP.

Regards

Re: IP Cloud

Posted: Mon Jun 16, 2014 1:31 pm
by normis
i have error
DDNS service might not workImage
It means that DNS name will work only for routers that have Public IP address

Re: IP Cloud

Posted: Mon Jun 16, 2014 2:10 pm
by sickofyou
Hi,

I think ndbjorne's idea it would be very useful. If the ip cloud feature gets the public IP, why don't to put it in the DDNS record and let the administrator to grant access natting to the RB?

Re: IP Cloud

Posted: Mon Jun 16, 2014 2:16 pm
by normis
we could offer a choice, to send the detected public IP or the detected local IP. Then you could set 1:1 NAT on the gateway if you have access to it.

Re: IP Cloud

Posted: Mon Jun 16, 2014 2:31 pm
by sickofyou
we could offer a choice, to send the detected public IP or the detected local IP. Then you could set 1:1 NAT on the gateway if you have access to it.
It would be very very nice if we could choose between the two options. With it, the IP Cloud feature will become more useful.

Re: IP Cloud

Posted: Mon Jun 16, 2014 9:57 pm
by Bigfoot
I don't see the IP Cloud feature on my x86 v6.15.

Re: IP Cloud

Posted: Tue Jun 17, 2014 9:36 am
by normis
I don't see the IP Cloud feature on my x86 v6.15.
It is only for RouterBOARD devices

Re: IP Cloud

Posted: Tue Jun 17, 2014 1:34 pm
by boen_robot
I don't see the IP Cloud feature on my x86 v6.15.
It is only for RouterBOARD devices
... for now... hopefully?

Re: IP Cloud

Posted: Tue Jun 17, 2014 2:04 pm
by magic
we could offer a choice, to send the detected public IP or the detected local IP. Then you could set 1:1 NAT on the gateway if you have access to it.
This would be a very nice feature. Our router is in the DMZ and have the 192.168.1.2 address (detected ip is in the 188.142.x.x range), so the function is unuseable now because the dns system give back to local ip.

Re: IP Cloud

Posted: Sat Jun 21, 2014 3:46 pm
by gotsprings
we could offer a choice, to send the detected public IP or the detected local IP. Then you could set 1:1 NAT on the gateway if you have access to it.
ABSOLUTELY a must have.

Due to the use of Fios or the need to keep Xfinity Voip/Modem/Routers inline... many companies I work with are in the DMZ. If there were someway to tell the system to use the actual WAN IP that would make it usable for a lot more home users.

Many home users and AV integrators would really appreciate if we could finally have a winbox option to enter our credentials for dyndns.

Peronally, I lean heavily on my dyndns updater script.

Re: IP Cloud

Posted: Mon Jul 14, 2014 2:26 am
by Brazd
What prevents link it (/ip cloud) with interface?

Re: IP Cloud

Posted: Mon Jul 14, 2014 10:15 am
by janisk

ABSOLUTELY a must have.

Due to the use of Fios or the need to keep Xfinity Voip/Modem/Routers inline... many companies I work with are in the DMZ. If there were someway to tell the system to use the actual WAN IP that would make it usable for a lot more home users.

Many home users and AV integrators would really appreciate if we could finally have a winbox option to enter our credentials for dyndns.

Peronally, I lean heavily on my dyndns updater script.
this is already available in the 6.16rc18 (via CLI interface)

Re: IP Cloud

Posted: Mon Jul 14, 2014 10:20 am
by Brazd
Very good. Waiting new release :). Thanks.

Re: IP Cloud

Posted: Sun Jul 20, 2014 1:47 pm
by jsaang
would somebody mind to instruct me to access the mt router using cloud ip....???

Re: IP Cloud

Posted: Mon Jul 21, 2014 10:32 am
by Brazd
would somebody mind to instruct me to access the mt router using cloud ip....???
Aaa....
WinBox-Ip-Cloude-Enable

or
/ip cloud
set enabled=yes

and You get name like xxxxxxxxxxxxxxx.sn.mynetname.net with setuped Your "white" ip

Re: IP Cloud

Posted: Tue Jul 22, 2014 5:06 am
by Toiletbowl
I don't see the IP Cloud feature on my x86 v6.15.
It is only for RouterBOARD devices
normis

what ros version this IP cloud features?

thanks

Re: IP Cloud

Posted: Tue Jul 22, 2014 7:09 am
by npero

what ros version this IP cloud features?

thanks
I thing from version 6.13 but use latest version 6.17 if your router don't have public address, because in 6.16/6.17 can use external address for update.

Re: IP Cloud

Posted: Sat Aug 09, 2014 11:58 am
by Buzz
nice feature , but i have a little problem when the power is off (power loss) and after turning my 951Ui-2HnD on again it doesn't update the ip automatically

is there anyway to force update every startup or after power loss
my device is 951Ui-2HnD 6.18

thank u in advance

Re: IP Cloud

Posted: Mon Aug 11, 2014 4:31 pm
by janisk
it will refresh when router is starting up. (at least it should and our testing has showed that it does)

Can you tell us what you did and how IP information was not updated properly on router booting up?

Re: IP Cloud

Posted: Thu Aug 14, 2014 2:37 am
by Buzz
it will refresh when router is starting up. (at least it should and our testing has showed that it does)

Can you tell us what you did and how IP information was not updated properly on router booting up?
the ip doesn't change after power loss even it shows it is updated with the previous ip and won't update with the new ip until I force update by myself

Re: IP Cloud

Posted: Thu Aug 14, 2014 8:31 am
by npero
Buzz your are right IP Cloud have bug if you behind NAT not update IP address because not see address is changed, I all ready write support but no answer they say update every minutes but it is not true they update on change but if router behind NAT not see change and not update must click force update. Have couple router with IP cloud with external address and nat they all perform the some.

Because of that to make IP cloud use behind NAT put
/ip cloud force-update


in scheduler I put interval 3 minutes and working perfect.

If router have external address it is ok.

Re: IP Cloud

Posted: Thu Aug 14, 2014 8:36 am
by jarda
Or use normal dynamic dns service that works reliably as you want...

Re: IP Cloud

Posted: Thu Aug 14, 2014 8:46 am
by npero
Or use normal dynamic dns service that works reliably as you want...
Of course but what is reliably today, no-ip before couple weeks not working almost one week, other service what I am using not have possibility to change TTL, IP cloud is almost perfect scheduler resolve bug :D.
Recommendation for reliably service, I don't have possibility to use fix IP on every location ?

Re: IP Cloud

Posted: Thu Aug 14, 2014 10:17 am
by normis
Buzz your are right IP Cloud have bug if you behind NAT not update IP address because not see address is changed, I all ready write support but no answer they say update every minutes but it is not true they update on change but if router behind NAT not see change and not update must click force update. Have couple router with IP cloud with external address and nat they all perform the some.

Because of that to make IP cloud use behind NAT put
/ip cloud force-update


in scheduler I put interval 3 minutes and working perfect.

If router have external address it is ok.
thanks, we will make this work in the next routeros version

Re: IP Cloud

Posted: Thu Aug 14, 2014 11:14 am
by npero
Thanks very much.

If you need more information I send it you supout.rif before almost two weeks 30.6 with that problem Ticket#2014073066000442.

Re: IP Cloud

Posted: Thu Aug 14, 2014 11:20 am
by normis
Thanks very much.

If you need more information I send it you supout.rif before almost two weeks 30.6 with that problem Ticket#2014073066000442.
Thanks, but the issue is very clear. If RouterOS doesn't see any IP changes, it doesn't do the update. It doesn't know that the ISP changed the IP on their router. We will make an option to send force update every x minutes, if outgoing address is set to be used.

Re: IP Cloud

Posted: Fri Aug 15, 2014 12:40 am
by Buzz
Buzz your are right IP Cloud have bug if you behind NAT not update IP address because not see address is changed, I all ready write support but no answer they say update every minutes but it is not true they update on change but if router behind NAT not see change and not update must click force update. Have couple router with IP cloud with external address and nat they all perform the some.

Because of that to make IP cloud use behind NAT put
/ip cloud force-update


in scheduler I put interval 3 minutes and working perfect.

If router have external address it is ok.
many thanks , that is what I was looking for , and u r right my routerboard is behind nat

Re: IP Cloud

Posted: Fri Aug 15, 2014 11:47 pm
by freemannnn
Great feature. Turn it on to all my clients and disable duckdns script!

Re: IP Cloud

Posted: Sat Sep 06, 2014 12:35 pm
by kei888
Hi Buzz!

Can you show us the configuration of your Scheduler for the IP Cloud?

Thank you.

Re: IP Cloud

Posted: Sat Sep 06, 2014 1:37 pm
by Brazd
SCRIPT:

# Setup of join to NO-IP.com
:local ddnsuser "noipusername"
:local ddnspass "password"
:local ddnshostname "yourname.no-ip.info"
:local ddnsinterface "ether1"

# global VARs
:global ddnslastipINT0
:local str
:local ddnsip
:local ip

:if ([ :typeof $ddnslastipINT0 ] = nil ) do={ :global ddnslastipINT0 "0" }

:local ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]

:if ([ :typeof $ddnsip ] = nil ) do={
:log info ("ServiceDNS: No ip address on $ddnsinterface .")
} else={

# remove mask from get Ip from interface
:for i from=( [:len $ddnsip] - 1) to=0 do={
:if ( [:pick $ddnsip $i] = "/") do={
:set ddnsip [:pick $ddnsip 0 $i];
}
}

:if ($ddnsip != $ddnslastipINT0) do={

:log info ("ServiceDNS: $ddnshostname -> $ddnsip")

# sending new IP to NO-IP over HTTP request
:local str "/nic/update?hostname=$ddnshostname&myip=$ddnsip"
/tool fetch url="http://dynupdate.no-ip.com/$str" mode=http user=$ddnsuser password=$ddnspass \ dst-path=("/ServiceDNS.".$ddnshostname)
:delay 1

# Save result to log file
:local str [/file find name="ServiceDNS.$ddnshostname"];
:log info [/file get $str contents];
/file remove $str
:global ddnslastipINT0 $ddnsip

}


Author not me, but it work on my MT for two interfaces.
For it I change ddnslastipINT0 to ddnslastipINT1 or ddnslastipINT2 etc. :)

Re: IP Cloud

Posted: Sun Sep 07, 2014 2:59 am
by kei888
Hi buzz!

Can you show us the screenshot or configuration of the schedule for Cloud IP?

I think my cloud IP is not updating.

Re: IP Cloud

Posted: Sun Sep 07, 2014 3:10 am
by kei888
Hi Brazd!
Author not me, but it work on my MT for two interfaces.
For it I change ddnslastipINT0 to ddnslastipINT1 or ddnslastipINT2 etc. :)
For what is this? How can we know what to put on the "ddnslastipINTx"?

Thank you.a

Re: IP Cloud

Posted: Sun Sep 07, 2014 8:12 am
by npero
Hi buzz!

Can you show us the screenshot or configuration of the schedule for Cloud IP?

I think my cloud IP is not updating.
Here is it screen shoot.

Re: IP Cloud

Posted: Sun Sep 07, 2014 1:56 pm
by Brazd
kei888

Sorry... I fought with NO-IP 2 days, and now fixed on it. Skiped in Your post "Cloud IP".

Re: IP Cloud

Posted: Wed Sep 10, 2014 2:12 pm
by DBob
Really nice feature!
I'm using to connect mikrotik devices between home and rent over EoIP, and at both sides, IPs are dynamic.

Re: IP Cloud

Posted: Sun Sep 21, 2014 12:42 am
by Buzz
Hi buzz!

Can you show us the screenshot or configuration of the schedule for Cloud IP?

I think my cloud IP is not updating.
sorry for my delayed reply
change interval to determine how often the schedule run, in my case every 30 min

Re: IP Cloud

Posted: Sat Dec 06, 2014 3:34 am
by saintofinternet
3) It gives terrible domain name. I would like to meet some people that will be able to write this address into the browser from memory when they are woken up in the middle of the night. If it is aimed at "home users" than this is not an advance for them.

Easy solution:

CNAME: mikrotik.mydomain.com -> 1234567890.sn.mynetname.net

the CNAME idea worked perfectly with the NO-IP

Re: IP Cloud

Posted: Sat Dec 13, 2014 5:58 pm
by cutedrummerboy
hey, i am behind 1 to 1 NAT and my isp just change my public ip every 10 minutes. can anyone tell me the update frequency of ip cloud?

Re: IP Cloud

Posted: Sun Dec 14, 2014 3:35 am
by saintofinternet
the frequency can be decided through "scheduler"...

Re: IP Cloud

Posted: Sun Dec 14, 2014 1:59 pm
by cutedrummerboy
yup done, but i actually want to know the default update frequency of this service when anyone behind 1 to 1 nat.

Re: IP Cloud

Posted: Mon Dec 15, 2014 12:51 am
by gotsprings
If the ip on the interface changes.... documentation states 1 minute.

Re: IP Cloud

Posted: Mon Dec 15, 2014 5:46 am
by cutedrummerboy
that already i know, but if the ip remain unchanged then what will be the update frequency?

Re: IP Cloud

Posted: Mon Dec 15, 2014 10:36 am
by npero
You need this ONLY if router board is behind NAT not have external address on one of interfaces.
If router board have external address then monitoring address change and update on change.

If behind NAT then address not change and because of that need scripts to force update it is bug in software because need to monitoring address change on some other way I have open ticket for this.

Re: IP Cloud

Posted: Sun Dec 28, 2014 9:46 pm
by Valerio5000
Hello, on ROS 6:24 as you disable this function? I have a static public ip and I noticed that if under "IP> CLOUD off this feature by writing XXX.sn.mynetname.net the login page webfig remains accessible.

Re: IP Cloud

Posted: Sun Dec 28, 2014 10:13 pm
by jarda
Because of cached dns records. Probably.

Re: IP Cloud

Posted: Sun Dec 28, 2014 11:55 pm
by Valerio5000
Because of cached dns records. Probably.
and then? What can I do? :D

I already have a public ip and I do not need this (excellent) service. How can I disable it and delete the URL XXX.sn.mynetname.net? Right now it is still accessible though the option is disabled!

Re: IP Cloud

Posted: Mon Dec 29, 2014 7:51 am
by jarda
IMHO it is far away from to be called excellent service. I don't use it. On the other hand, if you registered your own domain, it doesn't matter if ip cloud is still pointing at the same ip address...

Re: IP Cloud

Posted: Mon Jan 05, 2015 7:09 pm
by bestefan
Hi,
IP Cloud is very useful.
My question is the following.
I would like to protect my router with dropping all incoming traffic except a member of an allowed address list.
How can I make an exception in a firewall (allowed IP or port) for a working Mikrotik Cloud?

Regards

Re: IP Cloud

Posted: Mon Jan 05, 2015 7:19 pm
by jarda
Your question has no relation to ip cloud. Just make address list in firewall, and accept in input and forward chains only the packets matching your address list in src. Also add other two rules dropping the rest.

Re: IP Cloud

Posted: Mon Jan 05, 2015 11:11 pm
by bestefan
Hi Jarda,

But I have to know the IP address of the Mikrotik Cloud service server, and put it in to the allowed address list in my firewall, otherwise of course Mikrotik cloud service not works.
Meanwhile I have traced the mentioned address myself: 81.198.87.240.
I think alternatively it is possible to allow incoming traffic on the dst port 15252 in my router, because the update process of the cloud service uses this dst port.
Now already works fine.

Re: IP Cloud

Posted: Tue Jan 06, 2015 12:49 am
by jarda
I don't use ip cloud, because I use other dynamic dns service that allows me to manage my domains, ttl and everything. Therefore I see ip cloud to be useless thing because you can't manage anything. Even I don't believe it needs any access to your device, it would be really silly if it is true.

Re: IP Cloud

Posted: Tue Jan 06, 2015 1:29 am
by ngnr
I was under the impression that IP Cloud was just a dynamic DNS built into Mkt devices. Shouldn't the source address of the connection be the device IP?

Re: IP Cloud

Posted: Tue Jan 06, 2015 5:30 pm
by jarda
It depends. Normally you can manage what ip is linked to your dns name...

Re: IP Cloud

Posted: Tue Jan 27, 2015 10:06 pm
by acald3ron
only suport ipv4 ?

Re: IP Cloud

Posted: Wed Feb 25, 2015 4:23 pm
by siavashblade
hi guys I have a problem with this can you help me?
first of all after I enable DDNS, in the status section it tells me that:
"DDNS server received request from ip ...(the public ip adress)... but your local ip was 192.168.1.6 (which is my gateway ip). DDNS service might not work."
and I can't ping the DNS name it gives me 100% timeout then I've added this command:"/ip firewall filter add action=accept chain=input disabled=no dst-port=8291 protocol=tcp place-before=0"
but this didnt help either! :|
what should I do?
I have ip cameras in my work place and I want to watch them from home via this feature.
can you help me?

Re: IP Cloud

Posted: Wed Mar 11, 2015 11:19 am
by damt
hi every one

i have little problem in RB when i want to active my cloud i went to winbox - ip - but the problem is i didn't see cloud it's hidden i don't know where is it --------- can help me what to do or how to show the cloud icon

note: RB is CC1036 12 4s and OS ver: 6.5
best wishes
look forwards to hear you soon
ali

Re: IP Cloud

Posted: Wed Mar 11, 2015 11:37 am
by krisjans
note: RB is CC1036 12 4s and OS ver: 6.5
Hi,
cloud features appeared on version 6.14.
BR

Re: IP Cloud

Posted: Tue Jun 02, 2015 8:11 pm
by hsabrey
Hello Gents,

i want to inquiry if there are any sites which allow you to connect your routers (NASs) of your network in one place so you can see their state and access to them

Posted: Tue Jun 02, 2015 10:51 pm
by jarda
Use whatever network management system or at least something like overlook whiz on your Android phone.

Re: IP Cloud

Posted: Fri Jun 05, 2015 11:32 am
by Alaaalaa
I got My DNS name, but when I am trying to log in into my RB 951 ui 2HnD it says wrong username or password why ??!!

Re: IP Cloud

Posted: Fri Jun 05, 2015 11:56 am
by normis
it means you don't have a public IP, and the DNS name was assigned not to your router, but to your provider (ISP) gateway

Re: IP Cloud

Posted: Tue Jun 09, 2015 4:19 pm
by janisk
Because of cached dns records. Probably.
and then? What can I do? :D

I already have a public ip and I do not need this (excellent) service. How can I disable it and delete the URL XXX.sn.mynetname.net? Right now it is still accessible though the option is disabled!

update to newer version of RouterOS. When you disable DDNS it will remove the entry from our servers (wait for the status update in '/ip cloud' menu).

It will send 1 UDP packets to unregister from the service.

Re: IP Cloud

Posted: Mon Jan 04, 2016 8:49 am
by quyn
Our customers can not see the camera out there, there must DNS Server MikroTik is faulty ?

Re: IP Cloud

Posted: Mon Jan 04, 2016 10:09 am
by normis
Our customers can not see the camera out there, there must DNS Server MikroTik is faulty ?
We had a service disruption. It is fixed now.

Re: IP Cloud

Posted: Tue Jan 26, 2016 8:08 pm
by rea1ity
Hi

Cloud DDNS is very welcome to me.
But how can I configure to connect SSTP VPN?

this following guide was not for me.
http://wiki.mikrotik.com/wiki/Manual:In ... -Site_SSTP
their are requires two static IP but I'm just have two dynamic IPs.

Hope you let me know the instruction for configure site to site SSTP VPN connection.

Re: IP Cloud

Posted: Wed Jan 27, 2016 11:57 am
by evince
Hello,

IP Cloud is a great feature, btw how to assign it to another interface if i run 2 ISP?

Thank you in advance,

Re: IP Cloud

Posted: Wed Jan 27, 2016 1:59 pm
by freemannnn
ip cloud is really a great feature. i connect with winbox from my home to all my customers and examing/change/upgrade their configuration..
the only thing i want is to select from which wan update when u have dual wan for example 1 wan pppoe + 1 wan dhcp.

Re: IP Cloud

Posted: Sat Feb 06, 2016 9:19 am
by jarda
For those who are interested in my DNS Exit script:
http://forum.mikrotik.com/viewtopic.php?f=9&t=104578

Re: IP Cloud

Posted: Sat Feb 06, 2016 3:25 pm
by eol
Useful in some cases, but back into the future - do you have plans for more deeply integration DDNS relative services with routeros features ?
I mean dynamic and periodic check and resolve in src/dst in GRE/IPinIP/EoIP tunnels and other VPNs, firewall filters, nat rules, dynamic queues and so one?

Sorry in case someone of administrators consider this as off-topic but I didn't find dedicated topic for Feature Request.

Re: IP Cloud

Posted: Tue Mar 01, 2016 11:01 pm
by k750
Hello,
Do you know if this option works with Synology server ?
Thank you

Re: IP Cloud

Posted: Wed Mar 02, 2016 1:09 am
by deanMKD1
Hello,
Do you know if this option works with Synology server ?
Thank you
Of course that will work, but you need to add a NAT rule to point to your NAS also.

Re: IP Cloud

Posted: Wed Mar 02, 2016 2:06 am
by k750
Of course that will work, but you need to add a NAT rule to point to your NAS also.
Hello and thank you for your answer
Do you know where this goes NAT rule?
My server is plugged into the ether 3 Port
I grieve not know but networks
Thank you in advance
Claude

Re: IP Cloud

Posted: Thu Mar 03, 2016 12:38 pm
by deanMKD1
Of course that will work, but you need to add a NAT rule to point to your NAS also.
Hello and thank you for your answer
Do you know where this goes NAT rule?
My server is plugged into the ether 3 Port
I grieve not know but networks
Thank you in advance
Claude
1. Set static IP for NAS.
2. Set NAT to that NAS IP adress

Replace port 21 in my tutorial, to port of NAS.

Re: IP Cloud

Posted: Wed Mar 09, 2016 10:24 pm
by k750
Good morning and thank you for your answers
It works

Re: IP Cloud

Posted: Fri Dec 23, 2016 3:12 pm
by Puffer
Hi Gents
Great feature
I hope I have not missed it. Does Cloud.Mikrotik.com always resolve to the same address ?
I don't allow a default gateway so would like to allow only the addresses used by cloud.

Rgds Puffer

Re: IP Cloud

Posted: Sat Dec 24, 2016 11:33 am
by k750
Hello,
These 2 links no longer work
-------------------------------------
Bonjour,
Ces 2 liens ne fonctionnent plus

1. Set static IP for NAS.
2. Set NAT to that NAS IP adress

Re: IP Cloud

Posted: Wed Dec 28, 2016 1:35 pm
by zipvault
why is my cloud settings greyed out?

Re: IP Cloud

Posted: Tue Jan 31, 2017 8:17 am
by NetHorror
If you has problem with ip cloud you should add cloud server to allow filter (cloud.mikrotik.com)

This helped me

Re: IP Cloud

Posted: Sun Jul 30, 2017 5:19 am
by jebz
On a router with multiple WAN ports what is the best way to direct Cloud DDNS to register a particular interface?

Re: IP Cloud

Posted: Thu Aug 09, 2018 5:12 pm
by LetArch
How-to change dns name my mikrotik? It's need for secure access. Dns name my mikrotik has been know other people. Very need help!

Re: IP Cloud

Posted: Fri Aug 10, 2018 12:13 pm
by pukkita
You can't AFAIK, dns name is made up from Routerboard serial.

Re: IP Cloud

Posted: Fri Sep 14, 2018 9:53 am
by janisk
How-to change dns name my mikrotik? It's need for secure access. Dns name my mikrotik has been know other people. Very need help!
if you have your own DNS, you can use router FQDN as a CNAME entry and configure your services to reply to your proper name and ignore the rest.

Re: IP Cloud

Posted: Fri Sep 14, 2018 7:51 pm
by Sob
It doesn't solve the problem that someone already knows the xxx.sn.mynetname.net hostname, because it will still exist. On the other hand, it shouldn't be a problem in the first place. If whole security is built on the fact that other people don't know the address of router, there's something wrong with it.

Re: IP Cloud

Posted: Fri Sep 14, 2018 10:14 pm
by jarda
Janisk, we, who have our own dns, do not use your ip cloud service at all. Happily.

Re: IP Cloud

Posted: Fri Sep 14, 2018 10:27 pm
by mkx
Janisk, we, who have our own dns, do not use your ip cloud service at all. Happily.
I'm pretty sure that (W)ISPs are not target audience for cloud DNS, minority among home users are. Minority that is exposing some (small) part of home computing resources to internet (if only to have remote administration) and are doomed with being forced to use dynamic IP address. Or blessed, depends on what perspective you take. I guess quite a few of those don't have possibility to create a less cryptic DNS alias as not many home users have DNS (sub)domain at their disposal.

Myself, I do have my own domain and still use cloud dns. I never found necessary to play with my own way of doing DDNS.

Re: IP Cloud

Posted: Sat Sep 15, 2018 5:41 am
by jarda
Ok. "We" was too broad. Let's correct it to "me and maybe some others".

I didn't mean own dns server (necessarily) but public ddns service which is implementable both for static and dynamic (by script) ip addresses.

I am not considering myself to be ISP. I just play with networks and I am really big fan of mikrotik. Unfortunately there are some things that are really principally bad. Whatever "calling home" activities, like the ip cloud for example.

But yes. Facebook seems to be much worse and still people do use it...

So do what you think, but think what you do. If you believe something is fine, think again.

Re: IP Cloud

Posted: Sat Sep 15, 2018 6:38 am
by Sob
"Calling home" is something else, this is opt-in, you choose if you want it or not. If I need DDNS service without running my own DNS infrastructure, I have to trust someone else. Whether it's MikroTik or some public DDNS provider, there's not much difference.

And solution with CNAME is actually very interesting. The xxx.sn.mynetname.net is not easy to remember, something like server1.mydomain.tld is better. But for your own DNS infrastructure, you need at least two nameservers and more experience running them than most people have. While own domain hosted on registrar's nameservers costs almost nothing and requires zero experience.

Re: IP Cloud

Posted: Sat Sep 15, 2018 9:22 pm
by jarda
Sure I admit it could be useful for some users. But there are other alternatives that do not disclose you as mikrotik running ip. What we saw during last two years after reading repetitively that there is no way to run custom code in ros and none can run anything on system level with high privileges, it is not wise to put yourself to single world ip cloud device list. Of course I trust mikrotik, otherwise I would not use their products and software, but I cannot be sure that thair lists will not be compromised or stolen. Therefore I will rather continue using different service that just joins ip with domain name without saying anything more to anyone.

Re: IP Cloud

Posted: Sun Sep 16, 2018 3:00 am
by Sob
Well, in theory, you can find all MikroTik devices (those with enabled DDNS) by trying all different combinations of xxx.sn.mynetname.net. But in practice, xxx is an awful lot of combinations, so I wouldn't be worried about that.