Community discussions

 
User avatar
rmmccann
Member Candidate
Member Candidate
Topic Author
Posts: 182
Joined: Tue Sep 25, 2012 11:15 pm
Location: USA

Feature Request: Specify Source Address in DNS Server

Tue Jun 24, 2014 4:11 pm

I think a nice feature would be to specify the source address to use for DNS queries made by the Mikrotik DNS Server.

I use DNS based content filtering for several of my clients - many of these clients have multiple IP addresses with different policies for each IP (hotspot network, corporate network, etc). I cannot use the MT for DNS in a lot of these scenarios because it doesn't allow me to specify which IP should make the request. This affects which policy is being applied to the DNS request and either blocks or allows content which shouldn't be.
A common mistake that people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools. --Douglas Adams
 
User avatar
rickfrey
Trainer
Trainer
Posts: 610
Joined: Sun Feb 14, 2010 11:41 pm
Location: Van, Texas
Contact:

Re: Feature Request: Specify Source Address in DNS Server

Tue Jun 24, 2014 6:51 pm

Being able to specify the source address would be extremely helpful! +1
Launch your company forward with professional training!
http://rickfreyconsulting.com/product-c ... raining-2/
 
User avatar
dohmniq
Frequent Visitor
Frequent Visitor
Posts: 78
Joined: Sat Nov 17, 2012 12:17 pm

Re: Feature Request: Specify Source Address in DNS Server

Tue Jun 24, 2014 7:15 pm

Possible work-around could be to add a route and specify the pref-src option:

/ip route add dst-address=remote.dns gateway=some-gateway.lan pref-src=dns.ip.src.address

If you don't want to hard-code the gateway field then you might be able to get away with using another IP on the MT box so it routes to itself and then on to final destination.
 
User avatar
rmmccann
Member Candidate
Member Candidate
Topic Author
Posts: 182
Joined: Tue Sep 25, 2012 11:15 pm
Location: USA

Re: Feature Request: Specify Source Address in DNS Server

Thu Jun 26, 2014 6:03 pm

Possible work-around could be to add a route and specify the pref-src option:

/ip route add dst-address=remote.dns gateway=some-gateway.lan pref-src=dns.ip.src.address

If you don't want to hard-code the gateway field then you might be able to get away with using another IP on the MT box so it routes to itself and then on to final destination.
Would this not redirect ALL traffic destined to that DNS server with the preferred source IP specified? If so, this wouldn't work for my application - need to allow certain requests (say from inside LAN AD server) to come from one source IP and other requests using the MT as DNS server to come from another.

Honestly, it would be nice to be able to specify source IP for any service where the router is making a query or request - including NTP client and others.
A common mistake that people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools. --Douglas Adams
 
HaPe
Member Candidate
Member Candidate
Posts: 232
Joined: Fri Feb 10, 2012 10:24 pm
Location: Poland

Re: Feature Request: Specify Source Address in DNS Server

Sat Jun 28, 2014 7:55 pm

Great idea. It should be possible to change source ip for services, for ipv4 and ipv6 separately.
In anticipation on new The Dude release.

Who is online

Users browsing this forum: Google [Bot] and 92 guests