Community discussions

MUM Europe 2020
 
rebel2234
newbie
Topic Author
Posts: 42
Joined: Sat May 20, 2006 6:23 am

Site-to-Site IPSEC slow SQL

Wed Jul 02, 2014 11:12 pm

Hello,

I have followed this tutorial http://gregsowell.com/?p=787 to create an IPSEC tunnel between two locations. Each location is on its own subnet (192.168.1.0/24 and 192.168.2.0/24). I can ping remote hosts through the tunnel and even browse file shares remotely. SMB transfers work great can D/L at 3mbit/sec from one location and 5mbit/sec from other location (one side has 3mbit of upload and the other has 5mbit).

Largest packet I can send over tunnel is 1438 (verified using ping tool and don't fragment). Also added the following to each router:
Site-A: RB750G
/ip firewall mangle add chain=forward action=change-mss new-mss=1418 passthrough=yes tcp-flags=syn protocol=tcp src-address=192.168.1.0/24 dst-address=192.168.2.0/24 tcp-mss=!0-1418
Site-B: RB951-2n
/ip firewall mangle add chain=forward action=change-mss new-mss=1418 passthrough=yes tcp-flags=syn protocol=tcp src-address=192.168.2.0/24 dst-address=192.168.1.0/24 tcp-mss=!0-1418
Site-A hosts a SQL server which clients from Site-B access. SQL is very sluggish over the VPN (torching the connection reveals remote clients are only downloading about 50-57kbps when accessing SQL tables from within their program).

Any ideas why this is so slow? As I said before a windows file share will download at 3 or 5 mbit/sec depending on location because upload speed differs at each location.
 
User avatar
payday
Member Candidate
Member Candidate
Posts: 233
Joined: Thu Aug 16, 2012 11:05 pm

Re: Site-to-Site IPSEC slow SQL

Thu Jul 03, 2014 12:27 am

This is typical problem with SQL accessed over VPN. It does not matter what VPN device you use - MikroTik or anything else. Even if you have high bandwidth. AFAIR the problem is high latency of single packets.
Unfortunately there is no simple solution to this. For example: we use Remote Apps on Terminal Servers to run database applications.
Last edited by payday on Thu Jul 03, 2014 8:43 pm, edited 1 time in total.
 
rebel2234
newbie
Topic Author
Posts: 42
Joined: Sat May 20, 2006 6:23 am

Re: Site-to-Site IPSEC slow SQL

Thu Jul 03, 2014 12:45 am

This is typical problem with SQL (and Oracle) accessed over VPN. It does not matter what VPN device you use - MikroTik or anything else. Even if you have high bandwidth. AFAIR the problem is high latency of single packets.
Unfortunately there is no simple solution to this. For example: we use Remote Apps on Terminal Servers to run database applications.
This is exactly what I thought. From what I gather it is because SQL is very serialized eg. request>response>request>response etc. etc. If you have a 50ms vpn link it is 50ms between each one of these transactions and listing a table of say 1000 entry's would likely take 50000ms (1000x50) or 50 sec! RDP it is!

Thanks!

Who is online

Users browsing this forum: BitHaulers, Blender, crosswind, krzysztofciupala, Sob, waszpaw, Zacharias and 147 guests