Community discussions

MUM Europe 2020
 
safiullahtariq
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 81
Joined: Sun Apr 06, 2014 9:21 pm
Location: Lahore Pakistan

Internet Settings

Tue Jul 08, 2014 8:45 pm

Hello All,

I have an issue and i require advice.

I have a site (Site-1) which has IP address series of 192.168.0.x.
And another site (Site-2) whcih has series of 192.168.2.x

Both sites are connected via UBNT wireless equipment. I have seperate internet connection on both sites. Site-1's internet

router is 192.168.0.1 and it is connected to RB750GL (192.168.0.60).

Site-2's internet router is 192.168.2.2 and RB750GL is 192.168.2.1. I am also attaching a picture so that you can have a

better idea. I am able to route between the sites and easily access the computers of either site.

What I want to do is, when the internet connection at site-2 is down, I want the internet of Site-1 to be used at site-2.

What i currently do is, I change the gateway of the PC to RB750's IP (192.168.2.1) and DNS to 192.168.0.1(IP of the router

at site-1).

But this, I have to do manually and there are some devices (such as security DVR) which cannot be changed as easily.

Please correct me if I am wrong, I think I should be able to surf the internet if i have the IP of my PC (at site-2)

192.168.2.30/24, gateway 192.168.2.2, Primary DNS 192.168.2.2 and alternate DNS 192.168.0.1 when the internet at site-2

(192.168.2.2) is down. But If i change the gateway IP to 192.168.2.1 (Mikrotik's IP) I am able to use the internet from

site-1. But i dont think it is a good practice and it causes me problems.

I feel ignorant because I feel that in the past the above situation use to work (with 192.168.2.2 as gateway IP).

I actually have 1 more site connected to this network and I am running RIP v2. At the moment, I dont have any issues in

routing at all. All i require is help in above situation.

Please do advice me what can I do.

Best Regards,

Safiullah Tariq.
You do not have the required permissions to view the files attached to this post.
 
troy
Member
Member
Posts: 308
Joined: Thu Jun 30, 2005 6:47 pm

Re: Internet Settings

Mon Jul 14, 2014 9:00 pm

Given the diagram you provided, you should never have to change the route on anything other than the 750 at either of the remote sites (every computer, printer, and other device at each site should be using the local RB750 as the default route.

The better option, would be to implement OSPF. Each router would advertise it's connected networks, and the router at the office would also advertise a default route.

If the Office-Factory link goes down, the Factory router will automatically re-route traffic through it's connection to Godown.

If the Office-Godown link goes down, the Godown router will automatically re-route traffic through it's connection to the Factory.

Check the Mikrotik OSPF Manual for details on how to implement it. It would take 5 minutes for someone with OSPF experience to set up. Without experience, it shouldn't take much longer than that if you work directly from the OSPF Examples.

The only thing I would emphasize, is the use of loopback addresses, which can help avoid a lot of headache, as it will always be available, unlike addresses attached to physical interfaces. Each router must have a unique address. I'd use 10.0.0.1, 10.0.0.2, and 10.0.0.3. Use these loopback addresses as the router-id. They are also useful as the management address.

Your Office router will probably look like this:

ros code

/interface bridge add name=lo0
/ip address add address=10.0.0.1/32 interface=lo0
/routing ospf instance set 0 router-id=10.0.0.1 distribute-default=always-as-type-1
/routing ospf networks add network=10.1.1.0/24
/routing ospf networks add network=10.10.1.0/24
Once you've configured OSPF on the other two routers (they do not distribute default), each router should see the other two.

BTW, once this is done, remove all static routes from the office router, except the default.

Good luck,

Who is online

Users browsing this forum: aix150, memphisgd, mgi2003, MSN [Bot], Nirox and 81 guests