Community discussions

MikroTik App
 
mgob1985
newbie
Topic Author
Posts: 28
Joined: Wed Jun 18, 2014 3:02 pm

Large route table, removing a static

Wed Jul 09, 2014 12:34 am

Perhaps this has been answered before, I tried searching for it but so far I've come up empty.

I have a CCR with ~2.5 million routes ( BGP, OSPF etc. ) it also has a handful of static routes.... how can I modify a static route? The ID value is constantly changing with BGP etc.

Thanks,
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 12003
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: Large route table, removing a static

Wed Jul 09, 2014 3:38 pm

simply specify the actual value as parameters for change,

first example:
/ip route set parameters=value [find where comment="actual comment" and distance=1 and dst-address=1.11.23.0/24 and gateway=89.22.121.4 and pref-src=89.22.121.2]
inside [ ] you can omit or place any parameters, but do not place less than identifyng correctly the route.


second example:
identify each static route with one comment, like "RT0000023" or "RT0000023 never mind about other comment here" (for unique comment ID use only letters and numbers, and use "0" as placeholders)
and do tis:
/ip route set parameters=value [find where comment~"RT0000023"]
Last edited by rextended on Wed Jul 09, 2014 3:45 pm, edited 1 time in total.
 
mgob1985
newbie
Topic Author
Posts: 28
Joined: Wed Jun 18, 2014 3:02 pm

Re: Large route table, removing a static

Wed Jul 09, 2014 3:44 pm

Thanks! now, does this work for remove too? I know you could do this for a set but.... never tried this with a remove.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 12003
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: Large route table, removing a static

Wed Jul 09, 2014 3:47 pm

Yes:
/ip route remove [find where comment="actual comment" and distance=1 and dst-address=1.11.23.0/24 and gateway=89.22.121.4 and pref-src=89.22.121.2]
/ip route remove [find where comment~"RT0000023"]

but I prefer:
/ip route set disabled=yes [find where comment="actual comment" and distance=1 and dst-address=1.11.23.0/24 and gateway=89.22.121.4 and pref-src=89.22.121.2]
/ip route set disabled=yes [find where comment~"RT0000023"]
and after some days if all works I remove disabled routes
 
mgob1985
newbie
Topic Author
Posts: 28
Joined: Wed Jun 18, 2014 3:02 pm

Re: Large route table, removing a static

Wed Jul 09, 2014 3:48 pm

I can confirm both of those examples work. You rock, thank you!
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 12003
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: Large route table, removing a static

Wed Jul 09, 2014 3:52 pm

Nothing, and thanks for karma!
 
ste
Forum Guru
Forum Guru
Posts: 1924
Joined: Sun Feb 13, 2005 11:21 pm

Re: Large route table, removing a static

Wed Feb 27, 2019 12:19 pm

I know it is an old topic. Any changes which speeds up route changes/removals with big routing tables.

Esp. with a pending problem it is crazy to sit there waiting minutes until a command finishes.
 
joegoldman
Forum Veteran
Forum Veteran
Posts: 767
Joined: Mon May 27, 2013 2:05 am

Re: Large route table, removing a static

Wed Feb 27, 2019 12:35 pm

Yes this is my main complaint with Mikrotik at the core at the moment - it can import full tables in good-enough time but convergence is slow as when adding routes or removing routes - up to 5-10 minutes for me with about 1million BGP routes (With some static). I couldnt imagine running a CCR with multiple full transit feeds i.e. upwards of 2milliion routes, just because convergence time will take way too long.

Hopefully this is something that be improved in due time - not sure if its a kernel limitation on current network stack or not.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 7054
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: Large route table, removing a static  [SOLVED]

Wed Feb 27, 2019 12:45 pm

We are working on improvments.

Who is online

Users browsing this forum: BrianHiggins, NetHorror, scoobyn8 and 95 guests