Community discussions

MikroTik App
 
Toiletbowl
Member Candidate
Member Candidate
Topic Author
Posts: 169
Joined: Fri Jun 03, 2011 6:49 am
Location: Boracay Philippines

how to block teamviewer?

Thu Jul 17, 2014 10:47 am

Hi to all

i would like to know if possible to block teamviewer application?

thanks
 
User avatar
dynek
Member Candidate
Member Candidate
Posts: 198
Joined: Tue Jan 21, 2014 10:03 pm

Re: how to block teamviewer?

Thu Jul 17, 2014 11:30 am

Yes it is.
 
User avatar
Caci99
Forum Guru
Forum Guru
Posts: 1072
Joined: Wed Feb 21, 2007 2:26 pm
Location: Tirane
Contact:

Re: how to block teamviewer?

Thu Jul 17, 2014 1:17 pm

Hi to all

i would like to know if possible to block teamviewer application?

thanks
I don't think it is possible to do it through firewall filter since teamviewer uses port 80 and 443. So I would go by adding static entries in dns, and redirecting dns requests to the router:
/ip dns static
add name="teamviewer.com" address=127.0.0.1 ttl=1d
-Toni-
Don't crash the ambulance, whatever you do
 
User avatar
Phaere
just joined
Posts: 23
Joined: Thu Jul 17, 2014 3:01 pm
Location: Kyiv

Re: how to block teamviewer?

Thu Jul 17, 2014 3:08 pm

Just block 178.77.120.0/24 dst subnet if forward chain for src address, that shouldn't have access.
 
Thalid
newbie
Posts: 38
Joined: Sun Mar 31, 2013 11:33 pm

Re: how to block teamviewer?

Thu Jul 17, 2014 4:28 pm

been googeling this subject myself and the stuff people talks of is useing squid and Ids
 
RogerWilco
Member
Member
Posts: 384
Joined: Wed Feb 16, 2011 6:02 am
Location: Australia

Re: how to block teamviewer?

Fri Jul 18, 2014 2:12 am

Why would you want to block it?
 
Toiletbowl
Member Candidate
Member Candidate
Topic Author
Posts: 169
Joined: Fri Jun 03, 2011 6:49 am
Location: Boracay Philippines

Re: how to block teamviewer?

Fri Jul 18, 2014 4:49 am

Why would you want to block it?
hi roger

due of company policy :) thanks guys your prompt response gonna try this if this TV wont pass through via 443.

thanks
 
Toiletbowl
Member Candidate
Member Candidate
Topic Author
Posts: 169
Joined: Fri Jun 03, 2011 6:49 am
Location: Boracay Philippines

Re: how to block teamviewer?

Fri Jul 18, 2014 5:00 am

Hi to all

i would like to know if possible to block teamviewer application?

thanks
I don't think it is possible to do it through firewall filter since teamviewer uses port 80 and 443. So I would go by adding static entries in dns, and redirecting dns requests to the router:
/ip dns static
add name="teamviewer.com" address=127.0.0.1 ttl=1d
hi caci

the redirecting to router teamviewer.com it works but adding www. it passthrough and it seems working now the teamviewer application doesn"t handshake

102 ;;; teamviewer_deny
chain=forward action=drop src-address=178.77.120.0/24
in-interface=all-etherne



myron
 
Toiletbowl
Member Candidate
Member Candidate
Topic Author
Posts: 169
Joined: Fri Jun 03, 2011 6:49 am
Location: Boracay Philippines

Re: how to block teamviewer?

Fri Jul 18, 2014 5:25 am

Hi to all

i would like to know if possible to block teamviewer application?

thanks
I don't think it is possible to do it through firewall filter since teamviewer uses port 80 and 443. So I would go by adding static entries in dns, and redirecting dns requests to the router:
/ip dns static
add name="teamviewer.com" address=127.0.0.1 ttl=1d
hi caci

the redirecting to router teamviewer.com it works but adding www. it passthrough and it seems working now the teamviewer application doesn"t handshake >>> ;;; teamviewer_deny chain=forward action=drop src-address=178.77.120.0/24 in-interface=all-ethernet

but if i block specific port let say office at port2/ether2 (src-address=178.77.120.0/24 in-interface=office) it doesnt work ehhhh...

myron
 
RogerWilco
Member
Member
Posts: 384
Joined: Wed Feb 16, 2011 6:02 am
Location: Australia

Re: how to block teamviewer?

Fri Jul 18, 2014 6:24 am

Why would you want to block it?
hi roger

due of company policy :) thanks guys your prompt response gonna try this if this TV wont pass through via 443.

thanks
Ahh, right. Thought it was odd why an individual or household would want to.
 
sias
just joined
Posts: 6
Joined: Wed Sep 15, 2010 2:48 pm

Re: how to block teamviewer?

Wed Mar 20, 2019 4:36 pm

TeamViewer prefers to make outbound TCP and UDP connections over port 5938 – this is the primary port it uses, and TeamViewer performs best using this port.

script for address marking
/ip firewall filter
add chain=forward action=add-dst-to-address-list comment="learn the addresses" protocol=tcp address-list=TeamviewerServers address-list-timeout=none-static dst-port=5938

script for drop trafic for address-list
/ip firewall filter
add action=drop chain=forward comment="Drop all traffic from address on TeamviewerServers" src-address-list=TeamviewerServers
add action=drop chain=forward comment="Drop all traffic from address on TeamviewerServers" dst-address-list=TeamviewerServers
add action=drop chain=input comment="Drop all traffic from address on TeamviewerServers" src-address-list=TeamviewerServers
 
anav
Forum Guru
Forum Guru
Posts: 4709
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: how to block teamviewer?

Wed Mar 20, 2019 7:39 pm

Why would you want to block it?
hi roger

due of company policy :) thanks guys your prompt response gonna try this if this TV wont pass through via 443.

thanks
COMPANY POLICY
Accessing TeamViewer First Time - Warning
Accessing TeamViewer Second Time - Second Warning and Counselling
Accessing TeamViewer Third Time - Third and Final Warning (and Fine)
Accessing TeamViewer Last time - Fired.

Problem solved.

( You cannot stop idiots, you can only get rid of them)
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
dkorzhevin
just joined
Posts: 6
Joined: Mon Jul 22, 2019 2:05 pm

Re: how to block teamviewer?

Mon Jul 22, 2019 2:11 pm

Hi,

Does this solution still applicable?

Who is online

Users browsing this forum: Lifz, markos222, oskarsk and 76 guests