Page 1 of 1

how to block teamviewer?

Posted: Thu Jul 17, 2014 10:47 am
by Toiletbowl
Hi to all

i would like to know if possible to block teamviewer application?

thanks

Re: how to block teamviewer?

Posted: Thu Jul 17, 2014 11:30 am
by dynek
Yes it is.

Re: how to block teamviewer?

Posted: Thu Jul 17, 2014 1:17 pm
by Caci99
Hi to all

i would like to know if possible to block teamviewer application?

thanks
I don't think it is possible to do it through firewall filter since teamviewer uses port 80 and 443. So I would go by adding static entries in dns, and redirecting dns requests to the router:
/ip dns static
add name="teamviewer.com" address=127.0.0.1 ttl=1d

Re: how to block teamviewer?

Posted: Thu Jul 17, 2014 3:08 pm
by Phaere
Just block 178.77.120.0/24 dst subnet if forward chain for src address, that shouldn't have access.

Re: how to block teamviewer?

Posted: Thu Jul 17, 2014 4:28 pm
by Thalid
been googeling this subject myself and the stuff people talks of is useing squid and Ids

Re: how to block teamviewer?

Posted: Fri Jul 18, 2014 2:12 am
by RogerWilco
Why would you want to block it?

Re: how to block teamviewer?

Posted: Fri Jul 18, 2014 4:49 am
by Toiletbowl
Why would you want to block it?
hi roger

due of company policy :) thanks guys your prompt response gonna try this if this TV wont pass through via 443.

thanks

Re: how to block teamviewer?

Posted: Fri Jul 18, 2014 5:00 am
by Toiletbowl
Hi to all

i would like to know if possible to block teamviewer application?

thanks
I don't think it is possible to do it through firewall filter since teamviewer uses port 80 and 443. So I would go by adding static entries in dns, and redirecting dns requests to the router:
/ip dns static
add name="teamviewer.com" address=127.0.0.1 ttl=1d
hi caci

the redirecting to router teamviewer.com it works but adding www. it passthrough and it seems working now the teamviewer application doesn"t handshake

102 ;;; teamviewer_deny
chain=forward action=drop src-address=178.77.120.0/24
in-interface=all-etherne



myron

Re: how to block teamviewer?

Posted: Fri Jul 18, 2014 5:25 am
by Toiletbowl
Hi to all

i would like to know if possible to block teamviewer application?

thanks
I don't think it is possible to do it through firewall filter since teamviewer uses port 80 and 443. So I would go by adding static entries in dns, and redirecting dns requests to the router:
/ip dns static
add name="teamviewer.com" address=127.0.0.1 ttl=1d
hi caci

the redirecting to router teamviewer.com it works but adding www. it passthrough and it seems working now the teamviewer application doesn"t handshake >>> ;;; teamviewer_deny chain=forward action=drop src-address=178.77.120.0/24 in-interface=all-ethernet

but if i block specific port let say office at port2/ether2 (src-address=178.77.120.0/24 in-interface=office) it doesnt work ehhhh...

myron

Re: how to block teamviewer?

Posted: Fri Jul 18, 2014 6:24 am
by RogerWilco
Why would you want to block it?
hi roger

due of company policy :) thanks guys your prompt response gonna try this if this TV wont pass through via 443.

thanks
Ahh, right. Thought it was odd why an individual or household would want to.

Re: how to block teamviewer?

Posted: Wed Mar 20, 2019 4:36 pm
by sias
TeamViewer prefers to make outbound TCP and UDP connections over port 5938 – this is the primary port it uses, and TeamViewer performs best using this port.

script for address marking
/ip firewall filter
add chain=forward action=add-dst-to-address-list comment="learn the addresses" protocol=tcp address-list=TeamviewerServers address-list-timeout=none-static dst-port=5938

script for drop trafic for address-list
/ip firewall filter
add action=drop chain=forward comment="Drop all traffic from address on TeamviewerServers" src-address-list=TeamviewerServers
add action=drop chain=forward comment="Drop all traffic from address on TeamviewerServers" dst-address-list=TeamviewerServers
add action=drop chain=input comment="Drop all traffic from address on TeamviewerServers" src-address-list=TeamviewerServers

Re: how to block teamviewer?

Posted: Wed Mar 20, 2019 7:39 pm
by anav
Why would you want to block it?
hi roger

due of company policy :) thanks guys your prompt response gonna try this if this TV wont pass through via 443.

thanks
COMPANY POLICY
Accessing TeamViewer First Time - Warning
Accessing TeamViewer Second Time - Second Warning and Counselling
Accessing TeamViewer Third Time - Third and Final Warning (and Fine)
Accessing TeamViewer Last time - Fired.

Problem solved.

( You cannot stop idiots, you can only get rid of them)

Re: how to block teamviewer?

Posted: Mon Jul 22, 2019 2:11 pm
by dkorzhevin
Hi,

Does this solution still applicable?