Community discussions

MikroTik App
 
davidw
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 91
Joined: Fri Apr 27, 2007 11:11 pm

Appending ?safe=active to google searches

Mon Jul 28, 2014 10:12 am

Hi There,

Can anyone help with the following.

I want to create an Ip Web proxy access rule that appends "?safe=active" to all google searches.

So http://www.google.com would redirect http://www.google.com?safe=active

I have tried this
/ip proxy access
add action=deny disabled=no dst-host=*.google.* dst-port="" redirect-to="https://www.google.com\?safe=active"

but it ends up redirecting to https//www.google.com\?safe=active (ie its missing the colon)

any ideas ?

Thanks
 
User avatar
Arpanet
Member Candidate
Member Candidate
Posts: 268
Joined: Sat Aug 24, 2013 8:26 pm

Re: Appending ?safe=active to google searches

Mon Jul 28, 2014 4:31 pm

first you have to allow google's domains.
/ip proxy access
add action=allow disabled=no dst-host=*.google.* 
then you can redirect
/ip proxy access
add action=deny disabled=no dst-host=*.google.* dst-port="" redirect-to="https://www.google.com/?safe=active"
Arpanet.
There's no distance in the world.

Who is online

Users browsing this forum: miladz13, olgale, sindy and 49 guests