Community discussions

MikroTik App
 
crb343
just joined
Topic Author
Posts: 1
Joined: Tue Jul 29, 2014 4:46 am

Non-NAT Static Routing

Tue Jul 29, 2014 5:08 am

Hi All,

I've been a lurker for quite a while, but this is my first time posting.
I've tried searching through the forum for similar topics, but haven't had any luck.

Here's what I'm needing:

I've been given a 74.xxx.xxx.xxx IP from my ISP.
I work for a company that has given me address space on a 19x.xxx.xxx.xxxx subnet.
They've given me 6 usable IPs (/29).
I'm working with a RB751U.

I feel like I'm doing something wrong here, and I'm looking for advice.
I need my router to allow public access to devices on the 19x.xxx.xxx.xxx/29 space.
I'd ideally like to have publicly accessible servers on this Mikrotik.

Addresses
eth1: 74.xxx.xxx.xxx
Network: 74.xxx.xxx.1 (ISP gateway)
eth2 (master port for bridge-local):
19x.xxx.xxx.89
Network: 19x.xxx.xxx.88/29

I can ping out to the internet through eth1, but I can't get out to the internet on any devices I statically assign from the bridge-local interface.
From eth1, I can ping any IP.
From eth2/bridge-local, nothing.
From my test machine, which I'm statically assigning 19x.xxx.xxx.90 (19x.xxx.xxx.89 is g/w, 255.255.255.248 is s/net mask), I can ping the 74.xxx.xxx.xxx (eth1) interface (NOT the .1 ISP Gateway), the .89 address, but not anything external.
I can ping myself (.90) from bridge-local (.89).

Routes are as follows:
Dest: 0.0.0.0/0 GW: 74.xxx.xxx.xxx reachable eth1-gateway Pref. Src:
Dest: 74.xxx.xxx.1 GW: eth1-gateway reachable Pref. Src: 74.xxx.xxx.xxx
Dest: 19x.xxx.xxx.88 GW: bridge-local reachable Pref. Src: 19x.xxx.xxx.89

I feel like my subnets aren't able to communicate, but I can't figure out how to resolve my issue.
Any and all input will be much appreciated!
Let me know if there's any other information I can provide.
 
cutedrummerboy
Member Candidate
Member Candidate
Posts: 137
Joined: Thu Nov 14, 2013 6:32 pm

Re: Non-NAT Static Routing

Thu Jul 31, 2014 6:22 am

your isp gateway router must have a route towards your interface:

destination 19x.xxx.xxx.xxx/29 with gateway <your router's wan ip>
Device: RB2011UIAS-RM, RB750GL, CISCO SG300-28, UNIFI UAP-LR

Who is online

Users browsing this forum: chaigeo, jvanhambelgium, mlaz, poizzon, rushlife, saathiyabneha, safik and 54 guests