Community discussions

MUM Europe 2020
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24325
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

v6.18

Fri Aug 01, 2014 2:29 pm

What's new in 6.18 (2014-Aug-01 10:47):

*) sstp - report TLS encryption as well;
*) safe mode - do not allow user with less permissions to disrupt active safe mode;
*) console - print command does not try to reuse item numbers assigned by
previous invocations of 'print' when doing 'print where' or 'print follow',
items are numbered consecutively starting from '0'.
*) console - fix compact export of some partially modified
configuration values;
*) api - use the same syntax for property values as is used in 'print detail'
output, with the exception of numbers, that are not shown with suffixes
(K/M/G/T or bitrate) and are not contracted or separated into digit groups,
and "yes"/"no" values that continue to be reported as "true"/"false".
*) console - show internal numbers in the form returned by 'find' (like *9A0F)
instead of "(unknown)" when configuration refers to
deleted items. This change also applies to API.
*) ipsec - fix addition of default policy template;
*) console - values of type 'nil' were returning 'nil' as result of most
operations. Now it compares less than all values except 'nil'
and 'nothing', and compares inequal to all values except 'nil'.
This was changed to make 'print where' and 'find where' more useful.
An example. Previously the following command
/ip route print where routing-mark!=nosuch
Would not print routes that had no value for 'routing-mark' set, because
(nil != "nosuch") was equal to nil. Now it evaluates to 'true', and this
command will also print all routes that have no 'routing-mark' value set.
*) l2tp - fixed problem on CCR where server responded with wrong source address;
*) console export - put qutes around item names that start with a digit;
*) sntp client - added support for dns lookup of ntp servers;
*) console - when exporting to file, use name ending in '.in_progress', and
rename when export finishes;
*) bridge setups sometimes could crash on CCR devices;
*) fixed port flapping in 1G mode on sfp-sfpplus1 on CRS226;
*) fixed SXT ac model losing it's interface if changing regulatory settings in "routerboard" menu
As usual, version can be found on our download page, or just click "check for updates" if you already run som v6.x release
No answer to your question? How to write posts
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1122
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: v6.18

Fri Aug 01, 2014 2:30 pm

On 6.18 x86, I do not see the IP>Cloud menu anymore, not in console either.

Any comments?
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1723
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.18

Fri Aug 01, 2014 2:34 pm

ip cloud is only for MT hardware, not x86.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1220
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6.18

Fri Aug 01, 2014 2:34 pm

Shouldn't the cloud menu be not available on x86?
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24325
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.18

Fri Aug 01, 2014 2:41 pm

There is nothing that is supposed to work for x86 in this menu. So why confuse people
No answer to your question? How to write posts
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1122
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: v6.18

Fri Aug 01, 2014 2:49 pm

Yeah, its not supposed to work on x86, but the fact that the menu is completely missing is a bit misleading to me personally.
It would make more sense IMO to show it anyway, but show "Only supported on RouterBoards"

Also, importing an export file which has "/ip cloud" setting defined in it will fail on x86 this way.

Of course, that is nit-picking and only my personal opinion :)
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: v6.18

Fri Aug 01, 2014 3:07 pm

Ok, if I install this version, the wireless package; is it the 'legacy' one, or the new -fp one? Or do I still install the wireless CAPsMAN package to get the new wireless package?

Or, when a radio already has wireless-fp installed, an upgrade (with the auto process in sys/package/upgrade sequence) will automatically install the upgrade for the wireless -fp, or do I also load the Wirless CAPsMAN?

I am confused now after this post; http://forum.mikrotik.com/viewtopic.php ... 12#p440012

So, can we have a very, very clear statement on what we need to do in the upgrade from different versions, already or not already installed -fp, to get the new wireless features installed on a board that is going to run 6.18...

Please....
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24325
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.18

Fri Aug 01, 2014 3:11 pm

It will not mess with your packages. CAPSMAN and 802.11ac still requires Wireess-FP.
If you use legacy wireless, upgrade will install legacy wireless. If you have wireless-fp, upgrade will update wireless-fp.

If you use wireless legacy, and decide you want to use wireless-fp, simply upgrade, and then enable wireless-fp in packages menu (it is included in the bundle).
No answer to your question? How to write posts
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Fri Aug 01, 2014 3:54 pm

Ohhhhhhh! :D

You omit this on changelog:

*) webfig: fixed right when creating new script or schedule, now is possible to set/unset ftp right;
*) winbox: fixed right when creating new script or schedule, now is possible to set/unset ftp right;
*) user-manager: fixed profile limitation creation, now is possible to specify the owner;

;)

You are joking with me? :lol: All the bug I find and (very thanks!) your staff fix are never written on changelog!!!
Last edited by rextended on Fri Aug 01, 2014 4:14 pm, edited 1 time in total.
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Fri Aug 01, 2014 4:09 pm

Secondary BUG/ Missing feature:
/interface wireless reset-configuration DO NOT ASK FOR CONFIRMATION ON CLI
(using Winbox and pressing the button ask the confirmation)
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24325
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.18

Fri Aug 01, 2014 4:45 pm

Ohhhhhhh! :D

You omit this on changelog:

*) webfig: fixed right when creating new script or schedule, now is possible to set/unset ftp right;
*) winbox: fixed right when creating new script or schedule, now is possible to set/unset ftp right;
*) user-manager: fixed profile limitation creation, now is possible to specify the owner;
did you check if this is fixed ?
No answer to your question? How to write posts
 
kowal
just joined
Posts: 5
Joined: Sun Jul 06, 2014 2:23 am

Re: v6.18

Fri Aug 01, 2014 5:10 pm

BUG!

I've remotely upgraded my home 951G-2HnD from 6.17 to 6.18 and after reboot I can't ping anything, mac address and vlans were disappeared from my home switch but link is up - after work I will check what's wrong, CCR-1009-1S-1S+ was been successfully updated without problems...
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Fri Aug 01, 2014 6:14 pm

Yes, yes, are fixed! :D
various_fix.jpg
Last edited by rextended on Fri Aug 01, 2014 6:28 pm, edited 1 time in total.
I'm Italian, not English. Sorry for my imperfect grammar.
 
avantwireless
Member Candidate
Member Candidate
Posts: 137
Joined: Mon Nov 07, 2005 3:04 am

Re: v6.18

Fri Aug 01, 2014 6:14 pm

Still seeing ethernet interface flapping with QRT. Is there work ongoing to understand and fix this or is it a replace the device problem?
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Fri Aug 01, 2014 6:19 pm

Still seeing ethernet interface flapping with QRT. Is there work ongoing to understand and fix this or is it a replace the device problem?
I have installed 4 qrt with it's own PoE and the port is not flapping! (on 6.17, I must try 6.18)
I'm Italian, not English. Sorry for my imperfect grammar.
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: v6.18

Fri Aug 01, 2014 6:20 pm

7 hours after the 6.18 was made available still only a hand full of small issues surfaced amongst us users??? What is this, do we finally see a very reliable version or is everybody already having his friday afternoon party before going on holidays.... :D

All I notice so far is the package upgrade in winbox is not working. Probably because the servers are either overloaded, or also on holiday...?
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
ropeba
Member Candidate
Member Candidate
Posts: 220
Joined: Sat Jul 29, 2006 4:13 pm

Re: v6.18

Fri Aug 01, 2014 6:21 pm

IGMP proxy is still broken in 6.18!!!!
Since when do you plan ignoring major bugs and problems???? I can't understand that mikrotik don't know how to fix simple problem with IGMP proxy, for which I believe half hour would be enough!
It's sad that you are selling broken products, you don't wont to fix them nor you wont refund money!
Last edited by ropeba on Fri Aug 01, 2014 6:35 pm, edited 2 times in total.
 
User avatar
erebusodora
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Mon Jan 23, 2012 3:46 pm
Location: Bulgaria

Re: v6.18

Fri Aug 01, 2014 6:25 pm

When upgrade from System Packages Check for Upgrades - I resieve ERROR - getting changelog --->Error:conection timed out
When click on "Download &Upgrade" nothing is hapen.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Fri Aug 01, 2014 6:30 pm

Changelog are overloaded, please be patient.
I'm Italian, not English. Sorry for my imperfect grammar.
 
avantwireless
Member Candidate
Member Candidate
Posts: 137
Joined: Mon Nov 07, 2005 3:04 am

Re: v6.18

Fri Aug 01, 2014 6:33 pm

Still seeing ethernet interface flapping with QRT. Is there work ongoing to understand and fix this or is it a replace the device problem?
I have installed 4 qrt with it's own PoE and the port is not flapping! (on 6.17, I must try 6.18)


We have many QRT's that don't have flapping. It's not every board that does it. We are seeing it in somewhere between 10 and 20 % of boards
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Fri Aug 01, 2014 6:39 pm

Yourself find the solution: is not related to RouterOS version, maybe BIOS [firmware] version?
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: v6.18

Fri Aug 01, 2014 7:29 pm

*) api - use the same syntax for property values as is used in 'print detail'
output, with the exception of numbers, that are not shown with suffixes
(K/M/G/T or bitrate) and are not contracted or separated into digit groups,
and "yes"/"no" values that continue to be reported as "true"/"false".
So what has changed? When I first saw that part in the change log (in the RC days...), I was starting to think exactly that suffixed numbers and Boolean values are changed, but no... They're an exception, so what's different from before here?
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
payday
Member Candidate
Member Candidate
Posts: 233
Joined: Thu Aug 16, 2012 11:05 pm

Re: v6.18

Fri Aug 01, 2014 10:52 pm

7 hours after the 6.18 was made available still only a hand full of small issues surfaced amongst us users??? What is this, do we finally see a very reliable version or is everybody already having his friday afternoon party before going on holidays....
I must admit it looks strange. I was really afraid to upgrade because of that ;). How is this possible that nobody found any bug?! If there is nothing wrong means something is wrong! Maybe after update everybody have their devices bricked and cannot access forum?! ;)
Only ropeba gave me some faith.... ;)

Anyway, I have updated and everything is OK. Thanks MikroTik for fixes and improvements!
 
digitalis99
just joined
Posts: 1
Joined: Fri Aug 01, 2014 10:40 pm

Re: v6.18

Sat Aug 02, 2014 7:31 am

I actually have a problem, which was present with 6.17 when I upgraded from 6.15. I have a single IPSec tunnel that's bouncing up and down constantly on 6.17+. It'll be up 10 minutes, down 20, up 15, down 30, up 5, down 10... Seems to be no rhyme or reason to why it's up or down. 6.15 was stable. No settings have been changed since the upgrade. I noticed a lot of IPSec "fixes" in the changelog...sounds like a real fix is needed.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Sat Aug 02, 2014 9:56 am

:cry: 6.18 on ppc RB1100AHx2 :cry:

STILL DO KERNEL PANIC FROM WHEN YOU HAVE REWRITED MPPE ON 6.8!!! :!:

ON CLIENT SIDE 6.18 NEVER CRASH, INDEPENDENTLY HOW YOU CONFIGURE THEM OR WHAT SERVER VERSION YOU USE

I have already submitted ticket at support and clearly explained how very simply you can duplicate the kernel crash/panic

I have also talk directly with some MikroTik Staff at MUM Venice 2014

pppoe-server + MRRU 1614 + MPPE encryption enabled + EoIP 1500 MTU = Kernel Panic when 1st user access by pppoe-client

And I'm still forced to use 6.7 on my 4 pppoe-server RB1100AHx2

Pratically near all devices on my network have 6.17 and I'm forced to still use 6.7 on pppoe-servers for the MPPE bug!

Ticket#2014032566001217 (2014-03-25) BUG 6.12: Replicable kernel crash when try to discover why winbox not working well from 6.8 over IP obtained from pppoe-client

http://forum.mikrotik.com/viewtopic.php ... el#p417272
http://forum.mikrotik.com/viewtopic.php ... el#p421250
http://forum.mikrotik.com/viewtopic.php ... el#p411334
http://forum.mikrotik.com/viewtopic.php ... el#p412594
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1220
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6.18

Sun Aug 03, 2014 2:57 am

Packet sniffer seems to have stopped working in this release on my RB1100AHx2.
It works on CRS-125 and RB915G.
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
LaZyLion
just joined
Posts: 23
Joined: Fri May 09, 2014 10:27 am

Re: v6.18

Sun Aug 03, 2014 2:58 am

I see the following in change log:

*) sntp client - added support for dns lookup of ntp servers;


Does that mean I can put "pool.ntp.org" into Primary Server?

/system ntp client set primary-ntp="pool.ntp.org"
invalid value for argument primary-ntp:
invalid value for argument ip-address
invalid value for argument ipv6-address


How does this work?
 
Clauu
Member Candidate
Member Candidate
Posts: 205
Joined: Fri Mar 21, 2014 8:27 pm
Location: RO

Re: v6.18

Sun Aug 03, 2014 10:36 am

Upgrading from winbox led to a total mess no packages installed no prev configuration no nothing.. had to reboot again and fortunately i had an old backup for my config..
Last edited by Clauu on Sun Aug 03, 2014 2:11 pm, edited 1 time in total.
Having fun with RB850Gx2, RB2011UiAS-2HnD, RB260GSP, RB751U-2HnD, CRS112, RB3011UiAS, hAP ac, cAP ac and hAP ac². More others on the way :-)
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Sun Aug 03, 2014 11:23 am

Upgrading from winbox led to a total mess no packages installed no prev configuration no nothing.. had to reboot again and fortunately i had an old backup for my config..
You do not provide any relevant detail.
I'm Italian, not English. Sorry for my imperfect grammar.
 
Neilson
Member Candidate
Member Candidate
Posts: 174
Joined: Tue Nov 06, 2012 10:42 pm
Location: Auckland, New Zealand

Re: v6.18

Sun Aug 03, 2014 11:56 am

I can hopefully provide some more detail here.

I had 2 x CCR1016-12G set up on the network running 6.17 with all packages installed (and un needed packages disabled) and with 3.18 router bios installed. The packages disabled are the likes of DHCP, Calea, GPS, Hotspot, Open Flow, PPP, UPS, User Manager, Wireless as they are not needed.

These routers are being built up to replace an MPLS core network and is not yet in production so they can be used for testing.

I opened up the router remotely through the Dude winbox option. Then I clicked Settings > Packages and then clicked Check for updates. The update to 6.18 was offered and I clicked download and upgrade. The downloads started slowly then sped up and slowed down again. Once downloaded they rebooted and I was disconnected. They didn't come back after the reboot.

I have not yet had a chance to go on site with the routers and do additional reboots (Will do so) but maybe this will be enough for some people to start testing to validate or for Mikrotik themselves to take a look.

Thank you all for your time.

Regards
Alexander
 
Clauu
Member Candidate
Member Candidate
Posts: 205
Joined: Fri Mar 21, 2014 8:27 pm
Location: RO

Re: v6.18

Sun Aug 03, 2014 12:42 pm

Upgrading from winbox led to a total mess no packages installed no prev configuration no nothing.. had to reboot again and fortunately i had an old backup for my config..
You do not provide any relevant detail.
Such as? I just simply hit download&upgrade and shit happened.. :) from 6.17 to 6.18
Having fun with RB850Gx2, RB2011UiAS-2HnD, RB260GSP, RB751U-2HnD, CRS112, RB3011UiAS, hAP ac, cAP ac and hAP ac². More others on the way :-)
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1220
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6.18

Sun Aug 03, 2014 1:16 pm

e.g. what type of router and router firmware?
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
Clauu
Member Candidate
Member Candidate
Posts: 205
Joined: Fri Mar 21, 2014 8:27 pm
Location: RO

Re: v6.18

Sun Aug 03, 2014 1:58 pm

rb2011uias-2hnd, 3.18 firmware version
Having fun with RB850Gx2, RB2011UiAS-2HnD, RB260GSP, RB751U-2HnD, CRS112, RB3011UiAS, hAP ac, cAP ac and hAP ac². More others on the way :-)
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1220
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6.18

Sun Aug 03, 2014 7:58 pm

Maybe you should try again to update (maybe a file corruption on download or similar).
I upgraded 3 devices with the same processor and firmware with no issue.
And no one else seem to have troubles.
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
IntrusDave
Forum Guru
Forum Guru
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: v6.18

Mon Aug 04, 2014 6:56 am

I lost 5 routers in the update, so I wouldn't say "no one else has had any troubles". I've also seen several other posts with problems.

Something in the 6.16/6.17 config killed 3x CCR1009-8G-1S-1S+ and 2x CCR1016-12G.
My CCR1009: 3 out of 22 units updated, then continuously rebooted at "Starting Services"
My CCR1016: 2 out of 9 units updates, then hung at "loading kernel from band"

All 5 units seem to have a problem with the config. resetting the devices to factory allowed them to boot. However each returned to the crashed state once the config was restored. I was able to revert to 6.15, restore, then export compact, then copy/paste each section of the export that I needed, leaving out anything that wasn't required to get back up and running. I was never able to figure out what exactly was killing them.
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
infused
Member
Member
Posts: 305
Joined: Fri Dec 28, 2012 2:33 pm

Re: v6.18

Mon Aug 04, 2014 7:08 am

Keen to hear some CCR feedback.

I'm still on 6.3
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1723
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.18

Mon Aug 04, 2014 7:38 am

I lost 5 routers in the update, so I wouldn't say "no one else has had any troubles". I've also seen several other posts with problems.

Something in the 6.16/6.17 config killed 3x CCR1009-8G-1S-1S+ and 2x CCR1016-12G.
My CCR1009: 3 out of 22 units updated, then continuously rebooted at "Starting Services"
My CCR1016: 2 out of 9 units updates, then hung at "loading kernel from band"

All 5 units seem to have a problem with the config. resetting the devices to factory allowed them to boot. However each returned to the crashed state once the config was restored. I was able to revert to 6.15, restore, then export compact, then copy/paste each section of the export that I needed, leaving out anything that wasn't required to get back up and running. I was never able to figure out what exactly was killing them.
send all supout.rif files to support@mikrotik.com and i think network diagram should be added also.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
a.devecerski
just joined
Posts: 22
Joined: Tue Jan 24, 2006 11:23 pm

Re: v6.18

Mon Aug 04, 2014 9:04 am

What's new in 6.18 (2014-Aug-01 10:47):

...
*) ipsec - fix addition of default policy template;
...
Slight changes from behavior reported in v6.17 (http://forum.mikrotik.com//viewtopic.ph ... 50#p437763), multiple "ipsec, error" instead of "ipsec, warning, critical".
No changes in config made since upgrade v6.15 -> v6.17
You do not have the required permissions to view the files attached to this post.
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1220
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6.18

Mon Aug 04, 2014 9:09 am

I lost 5 routers in the update, so I wouldn't say "no one else has had any troubles". I've also seen several other posts with problems.
My bad then. There where no complains posted for 6.17->6.18 regarding this...
Please let us know! And especially let Mikrotik know.
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24325
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.18

Mon Aug 04, 2014 9:22 am

At this point in time we can confirm that change of L2MTU value on CCR devices can cause a crash in RouterOS v6.18 - Current 6.19rc version fixes this issue, it is on our download page, below regular downloads
No answer to your question? How to write posts
 
akarag
just joined
Posts: 5
Joined: Mon Aug 04, 2014 5:46 pm

Re: v6.18

Mon Aug 04, 2014 5:54 pm

Hello,

I have been using Mikrotik and RouterOS for quite a long but never experienced such a problem as that happened today when i upgraded to v6.18
I have a routerboard 493G and routeros v6.17 with 2 wireless interfaces (atheros MT interfaces). I upgraded today to v6.18 to take advantage of the sstp fix. When i tried to connect to the router via winbox I received a Microsoft Visual C++ runtime error. I cannot access the router via wireless interfaces, only via the ethernet and only to webfig.
I have two urgent questions

1. How to downgrade to v6.17 (never before experienced an issue so I have never done this before).
2. If i downgrade to v6.17 should I have the WINBOX Microsoft Visual C++ runtime error ?
3. Is there any other way to overcome the WINBOX runtime error?

Thank you
 
jetelina
newbie
Posts: 28
Joined: Thu Jun 27, 2013 11:22 pm

Re: v6.18

Mon Aug 04, 2014 6:00 pm

Hi,
I'm interested in this also. I tried to put "cz.pool.ntp.org" in WebFig into NTP Client settings, but it doesn't accept that value.

What is feature "*) sntp client - added support for dns lookup of ntp servers;" for?

I see the following in change log:

*) sntp client - added support for dns lookup of ntp servers;


Does that mean I can put "pool.ntp.org" into Primary Server?

/system ntp client set primary-ntp="pool.ntp.org"
invalid value for argument primary-ntp:
invalid value for argument ip-address
invalid value for argument ipv6-address


How does this work?
Last edited by jetelina on Tue Mar 22, 2016 12:54 pm, edited 1 time in total.
Mikrotik RB750GL - RouterOS 6.41.4
 
tedkuban
just joined
Posts: 9
Joined: Wed Apr 16, 2014 9:15 am

Re: v6.18

Mon Aug 04, 2014 6:35 pm

What's new in 6.18 (2014-Aug-01 10:47):

*) sntp client - added support for dns lookup of ntp servers;
Added property "server-dns-names" in "/system ntp client" not shown in Winbox interface.
It is a bug or a feature?
 
tedkuban
just joined
Posts: 9
Joined: Wed Apr 16, 2014 9:15 am

Re: v6.18

Mon Aug 04, 2014 6:40 pm

Hi,
I'm interested in this also. I tried to put "cz.pool.ntp.org" in WebFig into NTP Client settings, but it doesn't accept that value.

What is feature "*) sntp client - added support for dns lookup of ntp servers;" for?

Roman


I see the following in change log:

*) sntp client - added support for dns lookup of ntp servers;


Does that mean I can put "pool.ntp.org" into Primary Server?

/system ntp client set primary-ntp="pool.ntp.org"
invalid value for argument primary-ntp:
invalid value for argument ip-address
invalid value for argument ipv6-address


How does this work?
You can put 0.pool.ntp.org in Winbox primary-ntp field and 1.pool.ntp.org in secondary-ntp field, but RouterOS will change dns names to resolved IP addressess.
You can use "/system ntp client set server-dns-names="0.pool.ntp.org,1.pool.ntp.org", but this DNS names can't be viewed or changed in Winbox.
 
spike232
just joined
Posts: 19
Joined: Thu Mar 31, 2011 10:09 pm

Re: v6.18

Mon Aug 04, 2014 11:11 pm

If anyone has set the server-dns-names in the console I would recommend you get a backup now!

I have managed to brick my RB493G (mipsbe) 3 times already, the last 2 times were to be sure that was the cause and it wasent a fluke, after setting that and rebooting it would get to starting services then all the lights would go out and it would wait for about 30seconds then reboot and keep doing this.

I have also lost contact with a remote RB951-2n (mipsbe) which this setting was set but was not rebooted, so perhaps it periodically checks this setting not just on bootup
 
ytuxedo002
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Fri Apr 13, 2012 11:36 pm

Re: v6.18

Tue Aug 05, 2014 1:56 am

I'm having an issue with NTP on upgrading. None of my boxes will grab time anymore. I'm not sure what to do. It is affecting some of my services.

I have tried several ntp servers, i have disabled and enabled. It will convert the names to IP's but it will not update time.

Any suggestions?

I have the same issue on RB751's RB2011's, RB450G's.

Thanks
 
xcom
Frequent Visitor
Frequent Visitor
Posts: 80
Joined: Sat Jul 05, 2014 8:59 pm

Re: v6.18

Tue Aug 05, 2014 2:34 am

I'm having an issue with NTP on upgrading. None of my boxes will grab time anymore. I'm not sure what to do. It is affecting some of my services.

I have tried several ntp servers, i have disabled and enabled. It will convert the names to IP's but it will not update time.

Any suggestions?

I have the same issue on RB751's RB2011's, RB450G's.

Thanks
Just for info purposes...

Working fine here using a CRS.
 
Netstumble
just joined
Posts: 24
Joined: Tue Aug 05, 2014 9:11 am

Re: v6.18

Tue Aug 05, 2014 9:42 am

Hi :D
Problem:
RB450G
firmware: 3.18
Simple setup: 1 WAN (pppoe client to a bridged vdsl modem) 1 LAN masqueraded to WAN, a basic firewall and some QoS.
I was running 6.15 and it was fine.
Upgraded to 6.18.
Device hung/stuck on reboot.
After 15min I had to hard reset it, after that it came online @ 6.18.
I upgraded to the latest firmware & reboot.
System came back online, but errors out when on system/packages
I mark an un-needed package for uninstall: "Uninstall Error - can not uninstall bundled package (6)"
I downgraded to 6.17.
Reboots correctly, and it looks ok (I can mark packages for uninstall).
I again upgrade to 6.18.
Device reboots correctly,
but I can't select packages for uninstall (same error as above),
*and* the pppoe client on the WAN interface is lost.
On NAT/Firewall/Mangle/UPNP and everywhere else where the pppoe interface was mentioned I see a red "unknown" entry.
At this point I connect a spare router and make a coffee, lol.

Any ideas?
Should I netinstall it?
I have no prob reinstalling or redoing my config since it's a simple setup,
but if something triggers this behavior on RB maybe it should be investigated.
If needed I can send my config to devs if any1 has the will to troubleshot further.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Tue Aug 05, 2014 10:21 am

Use netisntall 6.18 for install routeros-mipsbe.6.18.npk and I suggest you lose the habit to uninstall the packets, simply disable them, if you not want see the menù on interface.
I'm Italian, not English. Sorry for my imperfect grammar.
 
Vox
just joined
Posts: 1
Joined: Tue Aug 05, 2014 5:03 pm

Re: v6.18

Tue Aug 05, 2014 5:14 pm

Hi there. Does anyone see a problem with IPSEC session estabilishment on 6.18 please?
PC form LAN (Shrewsoft VPN ver. 2.2.2) cant connect Cisco ASA in the public Internet now. RB 951G-2HnD does NAT on my LAN perimeter.
As ASA is out of my control, I cant provide more details form its log. Anyway ASA admin said something about "Duplicate first packet"...

I am sure on older RouterOS version everything worked fine. Unfortunatelly I dont have 6.17 packages as you dont provide them for download any more...

When establishing the VPN through my mobile connection, tunnel is brought up succesfuly = there is something wrong with RB :-(
 
poizzon
Member Candidate
Member Candidate
Posts: 113
Joined: Fri Jun 21, 2013 12:53 pm

Re: v6.18

Tue Aug 05, 2014 5:25 pm

What's new in 6.18 (2014-Aug-01 10:47):

...
*) ipsec - fix addition of default policy template;
...
Slight changes from behavior reported in v6.17
......
, multiple "ipsec, error" instead of "ipsec, warning, critical".
No changes in config made since upgrade v6.15 -> v6.17
confirming, gotting errors after upgrade to 6.17, or 6.18

17:19:07 ipsec,error phase1 negotiation failed due to time up. 5d7ba3d6d4252e4b:0000000000000000
17:19:07 ipsec,error phase1 negotiation failed due to time up. 5d7ba3d6d4252e4b:0000000000000000
17:19:47 ipsec,error phase1 negotiation failed due to time up. cae713db59572933:0000000000000000
17:20:07 ipsec,error phase1 negotiation failed due to time up. c08ab248d1276719:0000000000000000
17:20:47 ipsec,error phase1 negotiation failed due to time up. f87e500423412150:0000000000000000
--
poi
 
atopcu
just joined
Posts: 8
Joined: Mon Dec 27, 2004 8:58 pm

Re: v6.18

Tue Aug 05, 2014 5:39 pm

I upgrade a RB411AH from 5.25 to 6.18.
it has two virtual AP on wlan1 and two VLAN on ether1 interfaces. And two bridges to bridge each VLAN and virtual AP.
this config seen still working on 6.18. But both VLANs and both virtual APs are "slave" (Interfaces marked by "S" on interface list). What can I do ?
other APs have same configuration and there is no this issue. They are still 5.25.

exported configuration is following:

Regards,
Adnan
-------------------------
# aug/05/2014 17:36:24 by RouterOS 6.18
# software id = ------
#
/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
/interface bridge
add l2mtu=1522 name=bridge-AP-HotSpot protocol-mode=none
add l2mtu=1522 name=bridge-AP-WLAN protocol-mode=none
/interface vlan
add interface=ether1-gateway l2mtu=1522 name=vlan-HOTSPOT vlan-id=999
add interface=ether1-gateway l2mtu=1522 name=vlan-WLAN vlan-id=1000
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g bridge-mode=disabled disabled=no frequency=2437 hide-ssid=yes hw-retries=4 l2mtu=2290 mac-address=00:0C:42:02:54:00 mode=ap-bridge radio-name=HONU-AP1 security-profile=\
BackBond wireless-protocol=unspecified
add default-forwarding=no disabled=no l2mtu=2290 mac-address=02:0C:42:02:54:01 master-interface=wlan1 name=wlan1-AP-HotSpot security-profile=wp-hotspot ssid=GoldenKey_WiFi wds-cost-range=0 wds-default-cost=0
add disabled=no l2mtu=2290 mac-address=02:0C:42:02:54:03 master-interface=wlan1 name=wlan1-AP-WLAN security-profile=wp-wlan ssid=GoldenKey_WLAN wds-cost-range=0 wds-default-cost=0
/interface wireless manual-tx-power-table
set wlan1 manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mbps:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps:17,48Mbps:17,54Mbps:17,HT20-0:0,HT20-1:0,HT20-2:0,HT20-3:0,HT20-4:0,HT20-5:0,HT20-6:0,HT20-7:\
0,HT40-0:0,HT40-1:0,HT40-2:0,HT40-3:0,HT40-4:0,HT40-5:0,HT40-6:0,HT40-7:0"
/interface bridge port
add bridge=bridge-AP-HotSpot interface=vlan-HOTSPOT
add bridge=bridge-AP-HotSpot interface=wlan1-AP-HotSpot
add bridge=bridge-AP-WLAN interface=wlan1-AP-WLAN
add bridge=bridge-AP-WLAN interface=vlan-WLAN
/interface mesh port
add
 
DLNoah
Member Candidate
Member Candidate
Posts: 144
Joined: Fri Nov 12, 2010 5:33 pm

Re: v6.18

Tue Aug 05, 2014 5:56 pm

I upgrade a RB411AH from 5.25 to 6.18.
it has two virtual AP on wlan1 and two VLAN on ether1 interfaces. And two bridges to bridge each VLAN and virtual AP.
this config seen still working on 6.18. But both VLANs and both virtual APs are "slave" (Interfaces marked by "S" on interface list). What can I do ?
The display as Slave is by design; interfaces that are members of a bridge are "enslaved" by that bridge, and cannot be assigned to other bridges or switch groups.

Other than the display change, there shouldn't be any effect on your existing configurations (DHCP server still has to run specifically on the bridge rather than one of the member ports, IPs on a member port will respond on any port on the bridge, etc.)

Judging by the pre-release notes for the testing versions of v6.19, it looks like there will be some changes to how the firewall rules handle in-interface/out-interface matching on bridge members, so that will be something to pay attention to going forward. (Or, at least, the firewall rules will explicitly mark as Invalid if you match in-interface/out-interface on bridge members -- I don't know for sure if firewall rules actually successfully match in-interface for bridge member ports right now).
 
LaZyLion
just joined
Posts: 23
Joined: Fri May 09, 2014 10:27 am

Re: v6.18

Wed Aug 06, 2014 1:41 am

Hi,
I'm interested in this also. I tried to put "cz.pool.ntp.org" in WebFig into NTP Client settings, but it doesn't accept that value.

What is feature "*) sntp client - added support for dns lookup of ntp servers;" for?

Roman


I see the following in change log:

*) sntp client - added support for dns lookup of ntp servers;


Does that mean I can put "pool.ntp.org" into Primary Server?

/system ntp client set primary-ntp="pool.ntp.org"
invalid value for argument primary-ntp:
invalid value for argument ip-address
invalid value for argument ipv6-address


How does this work?
You can put 0.pool.ntp.org in Winbox primary-ntp field and 1.pool.ntp.org in secondary-ntp field, but RouterOS will change dns names to resolved IP addressess.
You can use "/system ntp client set server-dns-names="0.pool.ntp.org,1.pool.ntp.org", but this DNS names can't be viewed or changed in Winbox.


So it is the equivalent of doing:
/system ntp client set enabled=yes primary-ntp=[:resolve pool.ntp.org];


It recognizes that it was given a FQDN instead of an ip and resolves it on the spot, then stores the ip.
 
AlexS
Member Candidate
Member Candidate
Posts: 259
Joined: Thu Oct 10, 2013 7:21 am

Re: v6.18

Wed Aug 06, 2014 7:23 am


<snip>


So it is the equivalent of doing:
/system ntp client set enabled=yes primary-ntp=[:resolve pool.ntp.org];


It recognizes that it was given a FQDN instead of an ip and resolves it on the spot, then stores the ip.
Would be nice if it stored the dns name and resolved each time ntp client was restarted ..
 
BobcatGuy
Member Candidate
Member Candidate
Posts: 224
Joined: Thu Apr 19, 2007 7:41 am

Re: v6.18

Wed Aug 06, 2014 8:41 am

Anyone try installing 6.18 on a RB 112?
Perhaps I should have asked this BEFORE I sent the upgrade package to the RB112, and rebooted it....

Its a 7 hour drive to go to it..... and its been 10 minutes and has not connected the VPN back yet..... oh no... :-)

ADD:

WEll, it rebooted finaly, and connected the VPN, thankfully.. :-) Still on version 4.17 however, nothing in the log, other then router rebooted. Hmm, should I even upgrade this?
 
atopcu
just joined
Posts: 8
Joined: Mon Dec 27, 2004 8:58 pm

Re: v6.18

Wed Aug 06, 2014 8:55 am

Other than the display change, there shouldn't be any effect on your existing configurations (DHCP server still has to run specifically on the bridge rather than one of the member ports, IPs on a member port will respond on any port on the bridge, etc.).
Thanks DLNoah. There is no IP address or DHCP Server on bridge or bridge member interfaces.

Regards.
 
User avatar
CyberTod
Long time Member
Long time Member
Posts: 511
Joined: Wed Jan 25, 2012 10:23 am

Re: v6.18

Wed Aug 06, 2014 9:08 am

Anyone try installing 6.18 on a RB 112?
Perhaps I should have asked this BEFORE I sent the upgrade package to the RB112, and rebooted it....

Its a 7 hour drive to go to it..... and its been 10 minutes and has not connected the VPN back yet..... oh no... :-)

ADD:

WEll, it rebooted finaly, and connected the VPN, thankfully.. :-) Still on version 4.17 however, nothing in the log, other then router rebooted. Hmm, should I even upgrade this?
Taken from the Mikrotik download page :
RB111, RB112, RB133C, RB150 devices are not supported in v6, please use v5

And even for v5 - be sure to upgrade firmware to 2.18 first.
 
BobcatGuy
Member Candidate
Member Candidate
Posts: 224
Joined: Thu Apr 19, 2007 7:41 am

Re: v6.18

Wed Aug 06, 2014 9:11 am

Does ver 5 help with the 100 % cpu issue? I cant access the thing running 4.17 some times... I know its slow, but, I should be able to configure it.. :-)
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Wed Aug 06, 2014 10:10 am

Does ver 5 help with the 100 % cpu issue? I cant access the thing running 4.17 some times... I know its slow, but, I should be able to configure it.. :-)
On RB112 use 3.30.
I'm Italian, not English. Sorry for my imperfect grammar.
 
Dudu
just joined
Posts: 3
Joined: Thu Jul 10, 2014 4:37 pm
Location: Hungary

Re: v6.18

Wed Aug 06, 2014 11:54 am

Hi!

I can't create backup file:
/log print
09:46:25 backup,critical error creating backup file: could not read all configuration files 
/file print
1 rb-20140805-0813.backup       backup      575.7KiB aug/05/2014 08:13:07 -> 6.17
2 rb-daily.backup      backup                   206.8KiB aug/06/2014 00:00:00 -> 6.18
Look the file size!

I upgrade my RouterBoard RB2011 UAS-RM software 6.17 -> 6.18
/system routerboard print 
  routerboard: yes
  model: 2011UiAS
  serial-number: xxxxxxxxxxxxxx
  current-firmware: 3.18
  upgrade-firmware: 3.18
Any idea?
Last edited by Dudu on Wed Aug 06, 2014 12:23 pm, edited 1 time in total.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8320
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.18

Wed Aug 06, 2014 12:19 pm

Would be nice if it stored the dns name and resolved each time ntp client was restarted ..
"/system ntp client set server-dns-names=" works exactly as you want. to switch to DNS resolution you need to do that:
/system ntp client 
set primary-ntp=0.0.0.0
set secondary-ntp=0.0.0.0     
set server-dns-names=pool.ntp.org
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2297
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: v6.18

Wed Aug 06, 2014 7:03 pm

Anyone try installing 6.18 on a RB 112?
You did not see on download page??
RB111, RB112, RB133C, RB150 devices are not supported in v6, please use v5.
LAN, FTTx, Wireless. ISP operator
 
User avatar
bajodel
Long time Member
Long time Member
Posts: 545
Joined: Sun Nov 24, 2013 8:30 am
Location: Italy

Re: v6.18

Wed Aug 06, 2014 7:09 pm

Would be nice if it stored the dns name and resolved each time ntp client was restarted ..
"/system ntp client set server-dns-names=" works exactly as you want. to switch to DNS resolution you need to do that:
/system ntp client 
set primary-ntp=0.0.0.0
set secondary-ntp=0.0.0.0     
set server-dns-names=pool.ntp.org
Testing on some lab devices I've here:

It Works on light SNTP Client (912UAG-5HPnD)
It's not working on full NTP Package Client (CRS125-24G-1S)

Actually I cannot install/uninstall NTP Pkg from them to test further..
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8320
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.18

Wed Aug 06, 2014 7:47 pm

It Works on light SNTP Client
It's not working on full NTP Package Client
probably that's why they wrote 'sntp' in Changelog :)
hope they'll port that to ntp client also, as many people use ntp server
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
AlexS
Member Candidate
Member Candidate
Posts: 259
Joined: Thu Oct 10, 2013 7:21 am

Re: v6.18

Thu Aug 07, 2014 2:56 am

Would be nice if it stored the dns name and resolved each time ntp client was restarted ..
"/system ntp client set server-dns-names=" works exactly as you want. to switch to DNS resolution you need to do that:
/system ntp client 
set primary-ntp=0.0.0.0
set secondary-ntp=0.0.0.0     
set server-dns-names=pool.ntp.org
Oh okay, i must have miss read, i thought

set primary and secondary only took ip address

and set server-dns-names took dns names, but as it saved them to memory it converted them into ip address and that conversion only happened once.
 
VagnerBecker
just joined
Posts: 18
Joined: Wed Mar 13, 2013 3:49 pm
Location: Brasil

Re: v6.18

Thu Aug 07, 2014 3:49 am

Hi guys,

I found two bugs export
1º To export bgp conf in the IPv6 network as exports 0.0.0.0/0 in verbose mode normally export.
2º NTP Client does not export servers with IPv6 addresses or the verbose or compact in

Some SXT Lite5 have the following warning "system, error, critical System rebooted because of kernel failure" in both the 6.17 and the 6.18 version

Regards,

Vagner Felipe Becker
 
User avatar
viainternet
just joined
Posts: 13
Joined: Tue Jul 29, 2014 3:38 am
Location: São Paulo - Brasil
Contact:

Re: v6.18

Thu Aug 07, 2014 4:55 am

:mrgreen: Hello

the new OS version 6:18 solved all the problems found in the previous version.
Model: RouterBoard SXT Series

kind regards.
 
makstex
newbie
Posts: 46
Joined: Fri Mar 27, 2009 6:31 am

Re: v6.18

Thu Aug 07, 2014 8:15 am

model: 2011UAS-2HnD
routeros: 6.18

Problem:
If you are using dynamic NTP server to get a DHCP client, NTP Client does not work.

ps: when a static address of the NTP server matches the dynamic.
 
VagnerBecker
just joined
Posts: 18
Joined: Wed Mar 13, 2013 3:49 pm
Location: Brasil

Re: v6.18

Thu Aug 07, 2014 2:09 pm

Another "problem" the SXT 5HPnD to do a reset they lose the configuration of the LEDs, this is already happening to some versions ...
 
_saik0
Member Candidate
Member Candidate
Posts: 127
Joined: Sun Aug 26, 2007 11:18 pm

Re: v6.18

Thu Aug 07, 2014 8:11 pm

Still same issues regarding IPsec like in 6.17.
L2TP/IPSec tunnels disconnecting and only SA policy flush helps - no log messages indicating problems visible.
 
maruhpro
just joined
Posts: 5
Joined: Thu Aug 07, 2014 8:56 pm
Location: Osorio/RS, Brazil
Contact:

Re: v6.18

Thu Aug 07, 2014 9:00 pm

In version 6.17 I use these scripts to generate backups, but in 6.18 doesn`t work. This script isn`t generated by routeros, System -> Scripts doesn`t show anything.

/system script
add name=backup-gen policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="/e\
xport file=([/system identity get name] . \"-\" . \\\
\n[:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 \
3] . [:pick [/system clock get date] 4 6]);\r\
\n"
add name=backup-rem policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source=":f\
oreach i in=[/file find] do={:if ([:typeof [:find [/file get \$i name] \".rs\
c\"]]!=\"nil\") do={/file remove \$i}}"

Sorry by my poor english, i`m brazilian.
 
Ham
just joined
Posts: 18
Joined: Thu Oct 27, 2011 1:27 am

Re: v6.18

Sat Aug 09, 2014 6:55 am

rb2011uias-2hnd, 3.18 firmware version
Can confirm this as well with my rb2011uias-2hnd, all bridges disappeared, all interfaces lost there settings (names, switchgroups etc) many more weird things as well, lucky I had a backup to restore, all is well after that.

Will be staying away from 6.18 in a production environment
 
Clauu
Member Candidate
Member Candidate
Posts: 205
Joined: Fri Mar 21, 2014 8:27 pm
Location: RO

Re: v6.18

Tue Aug 12, 2014 8:43 am

No more vpn-pptp interruptions for winbox after 1day, good job for this one
Having fun with RB850Gx2, RB2011UiAS-2HnD, RB260GSP, RB751U-2HnD, CRS112, RB3011UiAS, hAP ac, cAP ac and hAP ac². More others on the way :-)
 
Dudu
just joined
Posts: 3
Joined: Thu Jul 10, 2014 4:37 pm
Location: Hungary

Re: v6.18

Tue Aug 12, 2014 4:33 pm

In version 6.17 I use these scripts to generate backups, but in 6.18 doesn`t work. This script isn`t generated by routeros, System -> Scripts doesn`t show anything.

/system script
add name=backup-gen policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="/e\
xport file=([/system identity get name] . \"-\" . \\\
\n[:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 \
3] . [:pick [/system clock get date] 4 6]);\r\
\n"
add name=backup-rem policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source=":f\
oreach i in=[/file find] do={:if ([:typeof [:find [/file get \$i name] \".rs\
c\"]]!=\"nil\") do={/file remove \$i}}"

Sorry by my poor english, i`m brazilian.
The old script work, but if i click the "Backup" button, i show that in the log file:

15:32:36 backup,critical error creating backup file: could not read all configuration files
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Tue Aug 12, 2014 6:55 pm

In version 6.17 I use these scripts to generate backups, but in 6.18 doesn`t work. This script isn`t generated by routeros, System -> Scripts doesn`t show anything.

/system script
add name=backup-gen policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="/e\
xport file=([/system identity get name] . \"-\" . \\\
\n[:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 \
3] . [:pick [/system clock get date] 4 6]);\r\
\n"
add name=backup-rem policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source=":f\
oreach i in=[/file find] do={:if ([:typeof [:find [/file get \$i name] \".rs\
c\"]]!=\"nil\") do={/file remove \$i}}"

Sorry by my poor english, i`m brazilian.
Poor english???
Poor scripts...

backup-rem:
/file remove [find where name~".rsc"];
backup-gen:
/export file=([/system identity get name]."-".[:pick [/system clock get date] 7 11].[:pick [/system clock get date] 0 3].[:pick [/system clock get date] 4 6]);
I'm Italian, not English. Sorry for my imperfect grammar.
 
infused
Member
Member
Posts: 305
Joined: Fri Dec 28, 2012 2:33 pm

Re: v6.18

Wed Aug 13, 2014 7:42 am

Is there a good site for scripting in v6?
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Wed Aug 13, 2014 9:24 am

Is there a good site for scripting in v6?
Here... (on Scripting section)
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
jp
Long time Member
Long time Member
Posts: 599
Joined: Wed Mar 02, 2005 5:06 am
Location: Maine
Contact:

Re: v6.18

Thu Aug 14, 2014 5:00 pm

Appreciate the NTP changes.

Seeing something strange on ip neigbhor though on this 6.18 x86 install
Don't know what *f0000 is but perhaps a programming error
You do not have the required permissions to view the files attached to this post.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Thu Aug 14, 2014 5:32 pm

What programming error?

Is the dynamic interface on neighbor list <ppptp-111lucia>.
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8320
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.18

Thu Aug 14, 2014 5:40 pm

Seeing something strange on ip neigbhor though on this 6.18 x86 install
Don't know what *f0000 is but perhaps a programming error
check
:put [/interface pptp-server find ] 
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Thu Aug 14, 2014 5:42 pm

Seeing something strange on ip neigbhor though on this 6.18 x86 install
Don't know what *f0000 is but perhaps a programming error
check
:put [/interface pptp-server find ] 
As I have just writed:

Is the dynamic interface on neighbor list <ppptp-111lucia>.


*) console - show internal numbers in the form returned by 'find' (like *9A0F)
instead of "(unknown)" when configuration refers to
deleted items.
[or dynamic items]
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8320
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.18

Thu Aug 14, 2014 5:48 pm

so, WinBox should show '(unknown)' in discovery interfaces. is it so?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Thu Aug 14, 2014 6:06 pm

No, this affect only CLI, winbox still use old style.
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
jp
Long time Member
Long time Member
Posts: 599
Joined: Wed Mar 02, 2005 5:06 am
Location: Maine
Contact:

Re: v6.18

Thu Aug 14, 2014 6:46 pm

But it's not a deleted item, it's an active item.
Also what is the benefit of using the internal #?
You do not have the required permissions to view the files attached to this post.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8320
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.18

Thu Aug 14, 2014 7:10 pm

jp, what do you see in WinBox? just for the information...
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
jp
Long time Member
Long time Member
Posts: 599
Joined: Wed Mar 02, 2005 5:06 am
Location: Maine
Contact:

Re: v6.18

Thu Aug 14, 2014 7:30 pm

"can't get there from here" is a saying we have... It's on another network, but I can ssh via a jump point. I'll check it later.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Thu Aug 14, 2014 9:54 pm

Chupaka, jp:

The advantage is "clear": do not loss time to convert ID to name on CLI and on this way is clearly visible if the interface is dynamic (= you can not set nothing here) or is static (=you can set item here).

In my pppoe server the machine do not lost time to "render" dynamics entry... with 1000 users...
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8320
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.18

Thu Aug 14, 2014 11:11 pm

it looks like a bug, not like a 'feature'
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
shellton
just joined
Posts: 18
Joined: Mon May 31, 2004 10:05 pm

Re: v6.18

Thu Aug 14, 2014 11:31 pm

Hello,

Just upgraded to 6.18 ver my rb2011, no i can`t connect by winbox ...
Untitled1.png
Regards,
You do not have the required permissions to view the files attached to this post.
Last edited by shellton on Thu Aug 14, 2014 11:35 pm, edited 1 time in total.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Thu Aug 14, 2014 11:34 pm

open on webfig, disable ip services winbox, reboot, open again webfig enable winbox, reboot, open winbox and before connect to rb, clear the cache.
I'm Italian, not English. Sorry for my imperfect grammar.
 
shellton
just joined
Posts: 18
Joined: Mon May 31, 2004 10:05 pm

Re: v6.18

Thu Aug 14, 2014 11:44 pm

Hmz ,, It does not help ...
 
User avatar
jp
Long time Member
Long time Member
Posts: 599
Joined: Wed Mar 02, 2005 5:06 am
Location: Maine
Contact:

Re: v6.18

Fri Aug 15, 2014 12:37 am

Looks fine in Winbox.
You do not have the required permissions to view the files attached to this post.
 
User avatar
machack
newbie
Posts: 47
Joined: Fri Jun 01, 2007 9:35 pm
Location: San Luis Argentina
Contact:

Re: v6.18

Fri Aug 15, 2014 3:59 am

En wimbox, el trafico de las interface aparece y desaparece.
Alguien tiene ese problema?

---------------------------------------------------

In wimbox, traffic of the interface appears and disappears.
Anyone have this problem?
Cesar Javier Robles
www.WindNet.com.ar
MTCNA - MTCTCE - MTCRE - MTCWE
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8320
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.18

Fri Aug 15, 2014 12:49 pm

Looks fine in Winbox.
then it's definitely a bug :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
Dudu
just joined
Posts: 3
Joined: Thu Jul 10, 2014 4:37 pm
Location: Hungary

Re: v6.18

Fri Aug 15, 2014 2:48 pm

Anybody have a same problem?
Hi!

I can't create backup file:
/log print
09:46:25 backup,critical error creating backup file: could not read all configuration files 
/file print
1 rb-20140805-0813.backup       backup      575.7KiB aug/05/2014 08:13:07 -> 6.17
2 rb-daily.backup      backup                   206.8KiB aug/06/2014 00:00:00 -> 6.18
Look the file size!

I upgrade my RouterBoard RB2011 UAS-RM software 6.17 -> 6.18
/system routerboard print 
  routerboard: yes
  model: 2011UiAS
  serial-number: xxxxxxxxxxxxxx
  current-firmware: 3.18
  upgrade-firmware: 3.18
Any idea?
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: v6.18

Fri Aug 15, 2014 4:02 pm

jp, can you look up what internal ID this interface has, if this is same as listed *F0000 then it should be displayed with its correct name, if ID is different, means that discovery was made but then interface changed (reconnect of dynamic interface) and you see the result.
 
User avatar
payday
Member Candidate
Member Candidate
Posts: 233
Joined: Thu Aug 16, 2012 11:05 pm

Re: v6.18

Fri Aug 15, 2014 7:57 pm

Hello,
Just upgraded to 6.18 ver my rb2011, no i can`t connect by winbox ...
Regards,
Open folder %appdata%\mikrotik\winbox and delete subfolder 6.18-*
 
shellton
just joined
Posts: 18
Joined: Mon May 31, 2004 10:05 pm

Re: v6.18

Fri Aug 15, 2014 9:30 pm

Just tryed this , no result .
The same error,
 
JanezFord
Member Candidate
Member Candidate
Posts: 264
Joined: Wed May 23, 2012 10:58 am

Re: v6.18

Fri Aug 15, 2014 11:00 pm

I upgraded my devices from 6.17 to 6.18 and lost graphing data on some (crs125, rb450g, rb912, rb2011uas) but not all (rb711, rb750, rb800) and also all static dhcp entries for my hosts on some (crs125, rb2011uas) but not all (rb450g and rb800 are ok).

Apart from this everything seems ok for now ...

JF.
 
Sob
Forum Guru
Forum Guru
Posts: 4887
Joined: Mon Apr 20, 2009 9:11 pm

Re: v6.18

Sat Aug 16, 2014 4:26 pm

If anyone has set the server-dns-names in the console I would recommend you get a backup now!

I have managed to brick my RB493G (mipsbe) 3 times already, the last 2 times were to be sure that was the cause and it wasent a fluke, after setting that and rebooting it would get to starting services then all the lights would go out and it would wait for about 30seconds then reboot and keep doing this.
I got few more details for this. Everything is fine as long as device has immediate network access on next boot. Otherwise it goes into endless reboot loop. I discovered this when I was playing with my new pair of SXTs:

SXT as AP, with internet connectivity on ethernet -> no problem
SXT as client, which would only get connectivity after connecting to AP -> reboot loop

So I reset the configuration using button, set all my config again (including server-dns-names of course :)) and everything seemed to work fine - until next boot. I first thought there was something wrong with one device, but then I switched them (it was pretty much a happy accident) and suddenly the problem went from one to another, so it was clear that it must be something else.
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply.
 
infused
Member
Member
Posts: 305
Joined: Fri Dec 28, 2012 2:33 pm

Re: v6.18

Tue Aug 19, 2014 3:11 am

Anyone running the latest RC on the CCR? How is the performance?
 
littlebill
Member Candidate
Member Candidate
Posts: 231
Joined: Sat Apr 30, 2011 3:11 am

Re: v6.18

Thu Aug 21, 2014 5:26 am

did sstp for win7 clients ever get fixed? or disconnects on pptp when logged into winbox? this all broke after 6.7? anyone not seeing these issues anymore?
 
WideRange
just joined
Posts: 1
Joined: Sun Feb 12, 2012 10:35 am

Re: v6.18

Thu Aug 21, 2014 5:44 pm

I'm seeing an issue in 6.18 which is also present in 6.15 (and maybe others) where the TX & RX rates on one switch group (ports 1-5) all go to 0 for one second, then will double for the next second. This was not present in older firmwares (I know it wasn't there in 6.7). i think it is just a reporting problem as I've not head complaints from customers.

Has anyone else seen this behavior after upgrading firmware? We have only upgraded a couple of our routers but have seen the behavior on both. The Routerboard firmware was also upgraded to match what came with the routerOS firmware.

Not sure if this is happening on other models, both of ours are RB1100AHx2's.

--Andrew Duey
 
Clauu
Member Candidate
Member Candidate
Posts: 205
Joined: Fri Mar 21, 2014 8:27 pm
Location: RO

Re: v6.18

Thu Aug 21, 2014 8:47 pm

or disconnects on pptp when logged into winbox?
Yep, seems like it;s fixed :)
Having fun with RB850Gx2, RB2011UiAS-2HnD, RB260GSP, RB751U-2HnD, CRS112, RB3011UiAS, hAP ac, cAP ac and hAP ac². More others on the way :-)
 
User avatar
CyberTod
Long time Member
Long time Member
Posts: 511
Joined: Wed Jan 25, 2012 10:23 am

Re: v6.18

Fri Aug 22, 2014 8:37 am

Is this a display bug or the setting doesnt work ?
80-eeeC.jpg
I have setup a eeeC channel, but the status shows :
80-Ceee.jpg
The client also shows it as Ceee and there is nothing I can check the real frequency usage.
No matter what type of channel I select in it is always Ceee in status for the running link.
You do not have the required permissions to view the files attached to this post.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2949
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.18

Fri Aug 22, 2014 9:08 am

Frequency range on selected country?
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
CyberTod
Long time Member
Long time Member
Posts: 511
Joined: Wed Jan 25, 2012 10:23 am

Re: v6.18

Fri Aug 22, 2014 9:12 am

It is on superchannel for testing at the moment.
 
athlonxp78
just joined
Posts: 13
Joined: Wed Feb 10, 2010 4:17 am

Re: v6.18

Mon Aug 25, 2014 3:23 am

I'm seeing an issue in 6.18 which is also present in 6.15 (and maybe others) where the TX & RX rates on one switch group (ports 1-5) all go to 0 for one second, then will double for the next second. This was not present in older firmwares (I know it wasn't there in 6.7). i think it is just a reporting problem as I've not head complaints from customers.

Has anyone else seen this behavior after upgrading firmware? We have only upgraded a couple of our routers but have seen the behavior on both. The Routerboard firmware was also upgraded to match what came with the routerOS firmware.

Not sure if this is happening on other models, both of ours are RB1100AHx2's.

--Andrew Duey
+1

We see that in 3 x RB450G, in every RB i´ve a bridge configured...
The traffic is not affected, is like a visual issue only...
 
Benik3
newbie
Posts: 46
Joined: Thu Apr 04, 2013 11:41 am

Re: v6.18

Tue Aug 26, 2014 7:00 pm

Does ver 5 help with the 100 % cpu issue? I cant access the thing running 4.17 some times... I know its slow, but, I should be able to configure it.. :-)
We have few RB133 and they works better with v5 then v4 :)

Otherwise I have 6.18 on one RB600 and it installed wrong - WebFig is not presented (upgraded from v4.17). Instead of WebFig, it show the old red site, but it's not possible to login.
The RB has damaged eth1, so I'm not able to reinstall it with netinstall :(

Who is online

Users browsing this forum: No registered users and 70 guests