Community discussions

 
jmginer
Member Candidate
Member Candidate
Topic Author
Posts: 115
Joined: Tue Dec 11, 2012 4:56 am

How to hide from traceroute

Tue Sep 16, 2014 11:35 am

Hello, I want hide from traceroutes the Mikrotik.
How can I do?

Thanks.
 
User avatar
cdiedrich
Forum Veteran
Forum Veteran
Posts: 928
Joined: Thu Feb 13, 2014 2:03 pm
Location: Basel, Switzerland // Bremen, Germany
Contact:

Re: How to hide from traceroute

Tue Sep 16, 2014 2:01 pm

ros code

/ip firewall filter add action=drop chain=input protocol=icmp
This will make your router not reply to pings either.

-Chris
Christopher Diedrich
MTCNA, MTCUME, MTCWE
Basel, Switzerland
Bremen, Germany

There are 10 types of people: Those who understand binary and those who don't.
There are two types of people: Those who can extrapolate from incomplete data
 
jmginer
Member Candidate
Member Candidate
Topic Author
Posts: 115
Joined: Tue Dec 11, 2012 4:56 am

Re: How to hide from traceroute

Tue Sep 16, 2014 2:25 pm

ros code

/ip firewall filter add action=drop chain=input protocol=icmp
This will make your router not reply to pings either.

-Chris
Thanks for your response, but don't solve my question, I have this rule active, but when I do a traceroute to some of the VPS servers hosted in a server that are connected to the CCR, the router hops are still visible.

I want hide completly the router/CCR.
 
User avatar
cdiedrich
Forum Veteran
Forum Veteran
Posts: 928
Joined: Thu Feb 13, 2014 2:03 pm
Location: Basel, Switzerland // Bremen, Germany
Contact:

Re: How to hide from traceroute

Tue Sep 16, 2014 2:30 pm

Now that's really surprising.
I just checked on a router myself and when using the input chain, it's really still visible.
I switched to the output chain and now the router is invisible (well, you see a hop, but requests just time out).
When switching to forward chain, you won't see anything behind the router's LAN interface...

-Chris
Christopher Diedrich
MTCNA, MTCUME, MTCWE
Basel, Switzerland
Bremen, Germany

There are 10 types of people: Those who understand binary and those who don't.
There are two types of people: Those who can extrapolate from incomplete data
 
jmginer
Member Candidate
Member Candidate
Topic Author
Posts: 115
Joined: Tue Dec 11, 2012 4:56 am

Re: How to hide from traceroute

Tue Sep 16, 2014 5:30 pm

Many thanks! Yes, now is solved :)
/ip firewall filter add action=drop chain=output protocol=icmp
And also blocking in Linux nodes:
iptables -A OUTPUT -p icmp --icmp-type any -j DROP
Regards!!
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: How to hide from traceroute

Tue Sep 16, 2014 5:45 pm

Will you be able to send ping from router itself?

Who is online

Users browsing this forum: MSN [Bot] and 72 guests