Community discussions

MikroTik App
 
shephajona
just joined
Topic Author
Posts: 1
Joined: Mon Sep 29, 2014 4:12 am

OpenDaylight and Openflow help v6.19

Mon Sep 29, 2014 4:18 am

(I hope this is in the right place)
Hello to anyone who can help some tertiary students with an opendaylight problem

We are currently running into issues using OpenDaylight and the openflow protocol (1.0) with a MikroTik routerboard running RouterOS v6.19

We are trying to adapt a load balancing application we have found from here: http://www.frank-durr.de/?p=126 and are having issues when the application tries to write the flows to the routerboards.
The routerboards return the error in opendaylight:
OFPET_FLOW_MOD_FAILED OFPFMFC_ALL_TABLES_FULL

The thing is, there are no flows in the flow table that we can see in the routerboard and as a result of this error nothing is written into the flow tables at all meaning our load balancing experiment isn’t working.

Any help would be greatly appreciated, thanks
 
User avatar
Paxy
just joined
Posts: 21
Joined: Mon May 26, 2008 8:28 pm

Re: OpenDaylight and Openflow

Tue Sep 01, 2015 12:07 pm

Same issue with 6.31.
When I try to insert flow that change Network layer addresses (src or dst IP) getting message OFPET_FLOW_MOD_FAILED OFPFMFC_ALL_TABLES_FULL.
Same action with OpenVStiwtch works correctly.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6048
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: OpenDaylight and Openflow help v6.19

Wed Sep 02, 2015 12:59 pm

Currently OFPAT_SET_NW_SRC, OFPAT_SET_NW_DST actions are not supported.
 
andrewmoses
just joined
Posts: 2
Joined: Mon Jan 18, 2016 2:35 pm

Re: OpenDaylight and Openflow help v6.19

Mon Jan 18, 2016 2:51 pm

(I hope this is in the right place)
Hello to anyone who can help some tertiary students with an opendaylight problem

We are currently running into issues using OpenDaylight and the openflow protocol (1.0) with a MikroTik routerboard running RouterOS v6.19

We are trying to adapt a load balancing application we have found from here: http://www.frank-durr.de/?p=126 and are having issues when the application tries to write the flows to the routerboards.
The routerboards return the error in opendaylight:
OFPET_FLOW_MOD_FAILED OFPFMFC_ALL_TABLES_FULL

The thing is, there are no flows in the flow table that we can see in the routerboard and as a result of this error nothing is written into the flow tables at all meaning our load balancing experiment isn’t working.

Any help would be greatly appreciated, thanks
Hi,
I'm trying to implement openflow protocol. I have routerboard rb750gl with routeros 6.32.3. To be frank I don't know where to start. I have tested my custom loadbalancing algo with pox controller in mininet. I trying to implement the same using the routerboard. thankyou in advance.

Who is online

Users browsing this forum: Google [Bot] and 84 guests