Community discussions

 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

v6.20 released!

Thu Oct 02, 2014 12:33 pm

What's new in 6.20 (2014-Oct-01 10:06):

*) cert scep - use fingerprints for transaction ids;
*) ipsec - support fqdn as my id;
*) fetch - allow fetching files larger than 4G;
*) fetch - fixed problem where files fetched over https were trimmed in size;
*) fixed problem - it was not possible to see %26 uninstall dude package;
*) stores are replaced with folders and disks are now managed under /disk menu;
*) added support for SMSC750x USB Gigabit Ethernet on x86;
*) ups - support selftest for smart and hid UPS;
*) pppoe client - increase connection timeout to make connection establishment
possible on busy pppoe server;
*) dhcp server - change default lease time from 3 days to 10 minutes
to avoid running out of IPs;
*) ipsec - allow binding modeconf address to username;
*) eoip/eoipv6/gre/gre6/ipip/ipipv6/6to4 tunnels have new features:
auto mtu (enabled by default for new tunnels);
dscp (inherit/specific value, inherit by default for new tunnels);
clamp-tcp-mss (yes by default for new tunnels);
*) eoip/gre/ipip/6to4 tunnels have dont-fragment option (inherit/no, no by default for new tunnels);
*) bridge has auto mtu feature (enabled by default for new bridges);
*) pppoe-server has auto mtu feature (enabled by default for new pppoe servers);

If you already run some RouterOS v6.x version, simply click “Check for updates” in QuickSet, Webfig or Winbox packages menu.

Others: http://www.mikrotik.com/download
 
zyzelis
Member Candidate
Member Candidate
Posts: 212
Joined: Sun Apr 08, 2012 9:25 pm

Re: v6.20 released!

Thu Oct 02, 2014 12:58 pm

What's new in 6.20 (2014-Oct-01 10:06):

*) cert scep - use fingerprints for transaction ids;
*) ipsec - support fqdn as my id;
*) fetch - allow fetching files larger than 4G;
*) fetch - fixed problem where files fetched over https were trimmed in size;
*) fixed problem - it was not possible to see %26 uninstall dude package;
*) stores are replaced with folders and disks are now managed under /disk menu;
*) added support for SMSC750x USB Gigabit Ethernet on x86;
*) ups - support selftest for smart and hid UPS;
*) pppoe client - increase connection timeout to make connection establishment
possible on busy pppoe server;
*) dhcp server - change default lease time from 3 days to 10 minutes
to avoid running out of IPs;
*) ipsec - allow binding modeconf address to username;
*) eoip/eoipv6/gre/gre6/ipip/ipipv6/6to4 tunnels have new features:
auto mtu (enabled by default for new tunnels);
dscp (inherit/specific value, inherit by default for new tunnels);
clamp-tcp-mss (yes by default for new tunnels);
*) eoip/gre/ipip/6to4 tunnels have dont-fragment option (inherit/no, no by default for new tunnels);
*) bridge has auto mtu feature (enabled by default for new bridges);
*) pppoe-server has auto mtu feature (enabled by default for new pppoe servers);

If you already run some RouterOS v6.x version, simply click “Check for updates” in QuickSet, Webfig or Winbox packages menu.

Others: http://www.mikrotik.com/download

No changes with wireless??
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v6.20 released!

Thu Oct 02, 2014 1:13 pm

zyzelis, what exact changes do you want to see for wireless?
 
infused
Member
Member
Posts: 305
Joined: Fri Dec 28, 2012 2:33 pm

Re: v6.20 released!

Thu Oct 02, 2014 1:18 pm

/me waits for people to upgrade their access point 100km away and have it fail then complain on the forums :D
 
User avatar
mishaM
Frequent Visitor
Frequent Visitor
Posts: 84
Joined: Sun Oct 25, 2009 1:48 pm
Location: Georgia

Re: v6.20 released!

Thu Oct 02, 2014 1:21 pm

hi sergejs


well be good if implement custom channel widths on C standart and MCS if be checkable manually
 
Basdno
Member Candidate
Member Candidate
Posts: 118
Joined: Wed Feb 17, 2010 10:11 pm

Re: v6.20 released!

Thu Oct 02, 2014 1:22 pm

/me waits for people to upgrade their access point 100km away and have it fail then complain on the forums :D


LOL

Maybe this is the time people learn to test in a Lab-setup first, then deploy to Production devices afterwards............ u never know! ;)


However, that said, I do like Mikrotiks new policy of offering the Release Candidates publicly on downloadsite for some time prior to main releases for the last couple of releases. I think this is a very good way forward, giving MT a lot more feedback PRIOR to release and thus probably making the stable versions even better and STABLE then before!

Hope they continue this way of working!

Keep up the good work Mikrotik!
Last edited by Basdno on Thu Oct 02, 2014 1:27 pm, edited 1 time in total.
 
meetriks2
newbie
Posts: 25
Joined: Wed May 07, 2014 12:18 am

Re: v6.20 released!

Thu Oct 02, 2014 1:23 pm

ros code

[admin@xxxx] /ppp active> print
Flags: R - radius 
 #   NAME         SERVICE CALLER-ID         ADDRESS         UPTIME   ENCODING  
 0   probe        sstp   x     0.0.0.0         57s      AES256-CBC
 1   probe        sstp   x     0.0.0.0         43s      AES256-CBC
 2   probe        sstp   x     0.0.0.0         42s      AES256-CBC
 3   probe        sstp   x     0.0.0.0         39s      AES256-CBC
 4   probe        sstp   x     0.0.0.0         38s      AES256-CBC
The address is not 0.0.0.0 but a valid adres. It all works, this is a cosmetic bug only.
On v6.19 forum i posted the configuration already.

Hope its getting fixed in v6.21

Cheers!
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

6.20 no microSDHC

Thu Oct 02, 2014 1:32 pm

RB433UAH

6.20 (6.21rc3) no micro-sd disk ( microSDHC Kingston 4GB) > downgrade 6.19 disk view

I already wrote here, but it was deleted. (20 days ago)
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v6.20 released!

Thu Oct 02, 2014 1:37 pm

meetriks2, thank you very much for the report.

napismizpravu, please provide us with support output file from your router (send to support@mikrotik.com).
 
zyzelis
Member Candidate
Member Candidate
Posts: 212
Joined: Sun Apr 08, 2012 9:25 pm

Re: v6.20 released!

Thu Oct 02, 2014 1:49 pm

zyzelis, what exact changes do you want to see for wireless?
Sergejs,
in changelog no word about wireless section, meanwile we know, that at least 6.20rc15 you have changed wireless to good side.

I thought, that changelog is for registering what was done with firmware(OS)
and for customers, who has updated to latest version and the if things are going not in expected way, to which version downgrade.
:lol:
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: v6.20 released!

Thu Oct 02, 2014 2:04 pm

napismizpravu, please provide us with support output file from your router (send to support@mikrotik.com).[/quote]

is it needed? (file repair folder - picture)


Another problem rename disk1 > usb1 (+reboot) = problem - picture
You do not have the required permissions to view the files attached to this post.
 
prawira
Trainer
Trainer
Posts: 280
Joined: Fri Feb 10, 2006 5:11 am

Re: v6.20 released!

Thu Oct 02, 2014 2:28 pm

any explanation and or example for this ?

*) cert scep - use fingerprints for transaction ids;

Tq

Paul
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: v6.20 released!

Thu Oct 02, 2014 3:20 pm

Why Wireless-fp package is still outside the the all-package bundle? The wireless package inside is still legacy wireless package?
 
k0st3k
just joined
Posts: 4
Joined: Mon Jul 09, 2012 12:10 pm

Re: v6.20 released!

Thu Oct 02, 2014 4:03 pm

Uploaded to rb711, reboot and.... no wireless config and wlan1 is disabled --like default
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v6.20 released!

Thu Oct 02, 2014 4:12 pm

jarda, wireless-fp package is included in the bundle. At 6.20 (not on rc releases) fp is included to bundle.
Please provide us with more information about your router, where wireless-fp is not included.


k0st3k,
make sure you have used the same wireless package before and after upgrade (for example wireless-fp was installed and now wireless is installed).
 
prawira
Trainer
Trainer
Posts: 280
Joined: Fri Feb 10, 2006 5:11 am

Re: v6.20 released!

Thu Oct 02, 2014 4:25 pm

i am using CRS...
when i click check for updates, it say System is already up to date
check 4 update.png
when i upgrade manually with upload the *npk file and reboot, the funny things happend.
after manual upgrade.png
what are wrong ?

P
You do not have the required permissions to view the files attached to this post.
 
prawira
Trainer
Trainer
Posts: 280
Joined: Fri Feb 10, 2006 5:11 am

Re: v6.20 released!

Thu Oct 02, 2014 4:30 pm

where is wireless-fp ??
all-packages-mipsbe-6.20.png
all the above files are from all-packages-mipsbe-6.20.zip

P
You do not have the required permissions to view the files attached to this post.
 
Thalid
newbie
Posts: 38
Joined: Sun Mar 31, 2013 11:33 pm

Re: v6.20 released!

Thu Oct 02, 2014 5:02 pm

where is wireless-fp ??
all-packages-mipsbe-6.20.png
all the above files are from all-packages-mipsbe-6.20.zip

P
happens when i check the package aswll

Torrent version for mipsbe contains it
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v6.20 released!

Thu Oct 02, 2014 5:03 pm

prawira
wireless-fp is included to all-in-one routerboard package and it is available for download as separate package,
http://download2.mikrotik.com/routeros/ ... mipsbe.npk


There might be some issues with check-for-latest version, as it was reported 6.19 version. Now it should work fine.
 
plisken
Forum Guru
Forum Guru
Posts: 2421
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: v6.20 released!

Thu Oct 02, 2014 5:47 pm

zyzelis, what exact changes do you want to see for wireless?
More stability for ac Nv2 :)

More tuning of the ac protocol
 
plisken
Forum Guru
Forum Guru
Posts: 2421
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: v6.20 released!

Thu Oct 02, 2014 5:50 pm

can Mikrotik make a clear and well illustrated presentation of fp?
This would be for many welcome and a greatfull help.
 
User avatar
avenn
Frequent Visitor
Frequent Visitor
Posts: 79
Joined: Fri Mar 14, 2014 11:59 pm
Location: Burnley UK
Contact:

Re: v6.20 released!

Thu Oct 02, 2014 5:51 pm

zyzelis, what exact changes do you want to see for wireless?
More stability for ac Nv2 :)

More tuning of the ac protocol

plus 1 from me
MTCRE - MTCNA - MTCTCE
 
mxmxmxmxmx
Frequent Visitor
Frequent Visitor
Posts: 69
Joined: Mon Aug 25, 2008 1:27 am

Re: v6.20 released!

Thu Oct 02, 2014 5:59 pm

What's new in 6.20 (2014-Oct-01 10:06):

*) fixed problem - it was not possible to see %26 uninstall dude package;
Maybe now I can see dude on package list, but it is not possible to login to dude.

down to 6.18 - OK. Up to 6.20 Login failed.
 
usx
newbie
Posts: 25
Joined: Sun Oct 27, 2013 7:30 pm

Re: v6.20 released!

Thu Oct 02, 2014 6:05 pm

Had no issues with the upgrade on a 2011UiAS-2HnD.

But on a RB450G all but one of the Queue Graphs lost their data (the graph curve started as if it just got set up). The one which didn't lose the data is now showing an erroneous date (Nov/08/2150).

The 2011UiAS-2HnD had no Queue Graphs, so I can't compare.

The RB450G (and the 2011UiAS-2HnD) have their primary NTP servers set to al local (inside the LAN) GPS-based NTP server. The clocks on both devices show the correct time.
You do not have the required permissions to view the files attached to this post.
 
Shiro
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Wed Sep 25, 2013 6:44 pm

Re: v6.20 released!

Thu Oct 02, 2014 7:16 pm

CCR1009-8G-1S-1S+ no longer detecting SD Cards. Tried two sd cards that worked before. Tried restart without success.
 
lucky79
Member Candidate
Member Candidate
Posts: 127
Joined: Sat Sep 27, 2014 1:24 pm
Location: Czech Republic

Re: v6.20 released!

Thu Oct 02, 2014 7:34 pm

RB922UAGS-5HPacD hanged after upgrade, needed power cycle to restore access.

minimum tx-power 6dBm, seriously guys? Current Tx power still shows 0dBm. Automatic Tx power based on antenna gain still not working. No manual noise floor threshold... No spectral scan... I guess I am holding the AC products until the wireless-fp will be ready for production. Its a shame I have already upgraded one PTP link with SXTacs which at the current state has lower performance and shitty CCQ (with R52n-M was perfect).
 
littlebill
Member Candidate
Member Candidate
Posts: 231
Joined: Sat Apr 30, 2011 3:11 am

Re: v6.20 released!

Thu Oct 02, 2014 8:48 pm

has all the sstp and pptp issues been resolved from the 6.8 debacle?
 
littlecake
just joined
Posts: 21
Joined: Sun Jun 04, 2006 8:56 pm

Re: v6.20 released!

Thu Oct 02, 2014 9:10 pm

Please how it works auto MTU function by pppoe?
 
k0st3k
just joined
Posts: 4
Joined: Mon Jul 09, 2012 12:10 pm

Re: v6.20 released!

Thu Oct 02, 2014 11:07 pm



k0st3k,
make sure you have used the same wireless package before and after upgrade (for example wireless-fp was installed and now wireless is installed).

5.26 > 6.20
 
tolkotov
just joined
Posts: 1
Joined: Wed Jun 04, 2014 1:47 pm

Re: v6.20 released!

Thu Oct 02, 2014 11:19 pm

when upgrading from 6.1 to 6.20 tik ccr1036 went in down :(.
sorry for my bad english.
 
eltopia
just joined
Posts: 13
Joined: Mon Jul 21, 2008 11:16 pm

Re: v6.20 released!

Fri Oct 03, 2014 4:29 am

I'm finding that going from 6.19 -> 6.20 breaks 6to4 tunnels on x86. Not sure on mips, though I could test if needed. (Running 6to4 between RB750GL and x86 VM)
 
plisken
Forum Guru
Forum Guru
Posts: 2421
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: v6.20 released!

Fri Oct 03, 2014 7:56 am

I have 2 EOIP-tunnels and working good after the upgrade.
This with omnitik and crs125-24G-1S-RM no problem
 
finalcutroot
newbie
Posts: 45
Joined: Sun Mar 09, 2014 9:36 pm

Re: v6.20 released!

Fri Oct 03, 2014 9:00 am

the latest update on hot spot was in version 6.0 the (login by mac cookies)
since then no updates

any way as i use MT for hotspot / update to 6.20 no problem

Thanks
 
msaxl
just joined
Posts: 6
Joined: Fri Oct 03, 2014 9:22 am

Re: v6.20 released!

Fri Oct 03, 2014 9:29 am

After I upgrade to v6.20 I have the problem that with v6.19 it was possible to set a my-user-fqdn also in psk main mode.
I know that this does not make much sense, but if you must connect to a juniper from behind a firewall, the my-id does not match the public ip address and the juniper ipsec does reject the connection when it first sees the "wrong" id. The workaround is setting the user-fqdn on both sides and binding the psk key on the public ip address on the juniper side.

But with version 6.20 setting user-fqdn or fqdn is rejected, so this is a showstopper for me
 
arturw
just joined
Posts: 10
Joined: Mon Dec 12, 2011 7:10 pm

Re: v6.20 released!

Fri Oct 03, 2014 12:42 pm

OVPN server "require-client-certificate" set and CRL option set is still not working.

my case number: [Ticket#2014082766000625]

I found that other people have the same problem.
http://forum.mikrotik.com/viewtopic.php ... 60#p449760
 
User avatar
a.devecerski
just joined
Posts: 22
Joined: Tue Jan 24, 2006 11:23 pm

Re: v6.20 released!

Fri Oct 03, 2014 12:50 pm

Winbox v2.x still works?
 
User avatar
skillful
Trainer
Trainer
Posts: 557
Joined: Wed Sep 06, 2006 1:42 pm
Location: Abuja, Nigeria
Contact:

Re: v6.20 released!

Fri Oct 03, 2014 1:25 pm

Winbox v2.x still works?
Yes, Winbox 2.2.18 still works.
 
fabiandr
just joined
Posts: 24
Joined: Tue Mar 03, 2009 10:28 pm

Re: v6.20 released!

Fri Oct 03, 2014 2:19 pm

Please how it works auto MTU function by pppoe?
 
steen
Member
Member
Posts: 469
Joined: Sat Oct 23, 2010 2:15 am
Location: Sweden
Contact:

Re: v6.20 released!

Fri Oct 03, 2014 3:13 pm

Hello Folks!

On each device we have upgraded (except RB411) from RoS6.19 to RoS6.20 we got alarms on DISK !?

There is no problem with disk, it is not full or damaged on any device.

What is this ?
 
rzirzi
Member
Member
Posts: 378
Joined: Mon Oct 09, 2006 2:33 pm

Re: v6.20 released!

Fri Oct 03, 2014 3:27 pm

changelog: pppoe-server has auto mtu feature (enabled by default for new pppoe servers)

Where is that feature? When I can enable/disable/set that feature? (Auto MTU for PPPoE server)
 
abis
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Fri Apr 11, 2014 9:32 pm
Location: Romania

Re: v6.20 released!

Fri Oct 03, 2014 3:40 pm

Hello,

after 6.19 -> 6.20 the monitor service disk for the dude doesn't work anymore...

p.s. *) stores are replaced with folders and disks are now managed under /disk menu;
I can create folders from winbox or i need to create via console?
Image Image
 
JanezFord
Member Candidate
Member Candidate
Posts: 263
Joined: Wed May 23, 2012 10:58 am

Re: v6.20 released!

Fri Oct 03, 2014 5:12 pm

After upgrade all of my static DHCP leases on CRS125 rack mount were lost ... on other devices upgrade went well and on dhcp leases were lost. Already contacted support.

JF.
 
plisken
Forum Guru
Forum Guru
Posts: 2421
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: v6.20 released!

Fri Oct 03, 2014 5:20 pm

I have update to with all-packages on crs125-24G-1S-RM
I don't lost my static ip's
 
User avatar
SiB
Member Candidate
Member Candidate
Posts: 169
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: v6.20 released!

Fri Oct 03, 2014 5:36 pm

topic about v6.19 was lock then I write in this place in my situation.

Upgrade from v6.4 to 6.19 at 27.09.2014. On calendar:
Image

all services are monitor by Nagios and TheDude - all stuff works by 3days.

My problem is on voip communication on small CallCenter (20 users 24/7) and rest voip phones (300users in 40branches in UE). NAT helper (ip firewall service-port) a SIP is always disable on all MikroTiks - voip was work perfect.

Problem:
On 1 at 10 calls have a missing voice in one direction - this was start after 3days. I try connect voip SIPTrunks to other ISP but it was even worst (90% RTP was as UDP unreply), remove connection from VoIP server to SIPTrunks is not work on long time.

Solution:
Today I must do downgrade to 6.4 and now >90% RTP of UDP are Assured status and all voip works perfect on v6.4.
It was my 3th to do upgrade to higer version then 6.4 :(.

SupOut files (before and after downgrade) and (day before) was send to MikroTik Support Team, I still wait for answers.
The same configuration was on v6.4 and on v6.19, v6.4 works "perfect" (without bugs like auto reboots by L2TP :) ).

For me, v6.19 isn't stable and v6.20 and v6.21RCx haven't any fix on this.
 
voxframe
Member Candidate
Member Candidate
Posts: 126
Joined: Thu Dec 16, 2010 2:51 pm

Re: v6.20 released!

Fri Oct 03, 2014 6:39 pm

I have also noticed problems starting with VOIP traversing NAT.

It worked fine, then as things were upgraded, it started to break. Give one way audio, etc.

Moving back down to very early firmware.
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1219
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6.20 released!

Fri Oct 03, 2014 6:58 pm

Reposted in Forwarding Protocols since it is not 9.20 specific.
http://forum.mikrotik.com/viewtopic.php?f=14&t=89893
Last edited by docmarius on Mon Oct 06, 2014 8:12 am, edited 13 times in total.
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: v6.20 released!

Fri Oct 03, 2014 6:59 pm

when upgrading from 6.1 to 6.20 tik ccr1036 went in down :(.
what exactly happened? Can you see in the Winbox by Layer2 connection?
Are you able to connect to the CCR via serial console?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: v6.20 released!

Fri Oct 03, 2014 7:04 pm

RB922UAGS-5HPacD hanged after upgrade, needed power cycle to restore access.

minimum tx-power 6dBm, seriously guys? Current Tx power still shows 0dBm. Automatic Tx power based on antenna gain still not working. No manual noise floor threshold... No spectral scan... I guess I am holding the AC products until the wireless-fp will be ready for production. Its a shame I have already upgraded one PTP link with SXTacs which at the current state has lower performance and shitty CCQ (with R52n-M was perfect).
Current-tx-power reading isn't made yet for the AC radios.
TX-power changing is working on the AC.
What signal you have on your SXT AC link?
If you set the band to the A/N on both sides do you get the same CCQ and performance like with the R52nM cards?
Try to reset the wireless interface configuration and check if the situation gets bettwe with default values.
 
User avatar
rmmccann
Member Candidate
Member Candidate
Posts: 182
Joined: Tue Sep 25, 2012 11:15 pm
Location: USA

Re: v6.20 released!

Fri Oct 03, 2014 7:28 pm

has all the sstp and pptp issues been resolved from the 6.8 debacle?
Would like to know as well. Have held at 6.7 because I need to maintain SSTP compatibility with Windows clients.
A common mistake that people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools. --Douglas Adams
 
steen
Member
Member
Posts: 469
Joined: Sat Oct 23, 2010 2:15 am
Location: Sweden
Contact:

Re: v6.20 released!

Fri Oct 03, 2014 11:15 pm

Hello,

after 6.19 -> 6.20 the monitor service disk for the dude doesn't work anymore...

p.s. *) stores are replaced with folders and disks are now managed under /disk menu;
I can create folders from winbox or i need to create via console?
Does this mean we soon now will se a new version of The Dude to ?
It is really needed a new The Dude version, a stable release, we have been using the same Dude for years now..
 
User avatar
avenn
Frequent Visitor
Frequent Visitor
Posts: 79
Joined: Fri Mar 14, 2014 11:59 pm
Location: Burnley UK
Contact:

Re: v6.20 released!

Sat Oct 04, 2014 4:14 pm

Random SXTac kernel failures still evident

Netinstall 6.20
Nv2
PtP SXTacSA to SXTac
100 metres
-49/50dBm
Very simple config
Very clean freg scan using airMAX

Works great at first then stops responding then kernel errors.

Switched to 802.11 rather than Nv2 equalled lost comma to SXTacSA.

Switching back to airMAX for external wireless for now. Customer is becoming unhappy.

Will try again in 6 to 12 months.
MTCRE - MTCNA - MTCTCE
 
poizzon
Member Candidate
Member Candidate
Posts: 113
Joined: Fri Jun 21, 2013 12:53 pm

Re: v6.20 released!

Sat Oct 04, 2014 7:14 pm

18:31:36 system,info verified ntp-6.20-mipsbe.npk
18:31:36 system,info verified ppp-6.20-mipsbe.npk
18:31:36 system,info verified security-6.20-mipsbe.npk
18:31:36 system,info verified advanced-tools-6.20-mipsbe.npk
18:31:36 system,info verified system-6.20-mipsbe.npk
18:31:36 system,info installed system-6.20
18:31:36 system,info installed advanced-tools-6.20
18:31:36 system,info installed security-6.20
18:31:36 system,info installed ppp-6.20
18:31:36 system,info installed ntp-6.20
18:31:36 system,info installed dhcp-6.20
18:31:55 interface,info ether1-gateway link up (speed 100M, full duplex)
18:31:55 interface,info ether2-master-local link up (speed 100M, full duplex)
18:32:05 l2tp,info first L2TP UDP packet received from AAA.BBB.CCC.DDD
18:32:06 l2tp,ppp,info,account NewYork logged in, 172.16.2.2
18:32:07 l2tp,ppp,info l2tp-NewYork: authenticated
18:32:07 l2tp,ppp,info l2tp-NewYork: connected
18:33:29 l2tp,info first L2TP UDP packet received from EEE.FFF.GGG.HHH
18:33:30 l2tp,ppp,info,account AmsTerDam logged in, 172.16.0.2
18:33:30 l2tp,ppp,info l2tp-AmsTerDam: authenticated
18:33:30 l2tp,ppp,info l2tp-AmsTerDam: connected
18:34:24 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.0.2[500] d3315d1866b8c332:0000000000000000
18:34:25 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 16586dd9987fdd61:0000000000000000
18:34:25 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.2.2[500] eb7dcfc791c0bee6:0000000000000000
18:35:20 system,info,account user poi logged in from xx.xx.xx.xx via winbox
18:35:25 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 093864a77ece5743:0000000000000000
18:36:25 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 4c4becbcae12daaf:0000000000000000
18:37:25 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 4f9ce96e1d5c59fc:0000000000000000
18:38:35 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] deb801af0ba9d6c9:0000000000000000
18:39:45 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 1dcfedef4e117603:0000000000000000
18:40:45 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] cd73a72de5a4bac4:0000000000000000
18:41:55 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 283e9d748f979c57:0000000000000000
18:43:05 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 1ec10de96c1e35d1:0000000000000000
18:44:05 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 5242da5b92f02b49:0000000000000000
18:45:15 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] af1788a953e26d08:0000000000000000
18:46:15 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] ff0ccd07cae83c2e:0000000000000000
18:47:15 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 808e73705a1348d8:0000000000000000
18:48:25 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 6035bc208336ee44:0000000000000000
18:49:35 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 01b1c837e087c94c:0000000000000000
18:50:35 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 981177407414de2b:0000000000000000
18:51:45 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 0dc357f7303910f6:0000000000000000
18:52:55 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 5f75d3969bcac9a1:0000000000000000
18:53:55 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] f788b880bcbb35af:0000000000000000
18:55:05 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] a70224a893e2dd19:0000000000000000
18:56:15 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] a18784aafea7ce3e:0000000000000000
18:57:15 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 600e0d1fcba18246:0000000000000000
18:58:25 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] aee578115f534004:0000000000000000
18:59:35 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 89f6b5acc9731f3a:0000000000000000
19:00:35 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 83cea2c786936e7c:0000000000000000
19:01:45 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] 58f4bf218c569a07:0000000000000000
19:02:55 ipsec,error phase1 negotiation failed due to time up XXX.YYY.ZZZ.XYZ[500]<=>172.16.3.2[500] acd4b68e28f0a7ff:0000000000000000
--
poi
 
poizzon
Member Candidate
Member Candidate
Posts: 113
Joined: Fri Jun 21, 2013 12:53 pm

Re: v6.20 released!

Sat Oct 04, 2014 7:31 pm

p.s.: after disabling inactive IPsec Peer - errors gone.
--
poi
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: v6.20 released!

Sat Oct 04, 2014 9:59 pm

I'm trying to install x86 on a fresh VirtualBox VM, and on the very first run of the ISO (i.e. before getting the installation dialog), I get this:
2014-10-04_21-56-27.png
after which the VM reboots, and the same thing happens again.

I have a suspicion some of the other things reported so far are related to this.


(6.19 installs fine on the same VM on the same host machine)
You do not have the required permissions to view the files attached to this post.
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
pitr
just joined
Posts: 4
Joined: Fri Mar 21, 2014 11:14 pm

Re: v6.20 released!

Sat Oct 04, 2014 10:20 pm

My 6to4 tunnel to tunnelbroker.net broke with 6.20. Can't even get them working again if I redo the configuration completely.
 
ponko
just joined
Posts: 3
Joined: Tue Nov 16, 2010 2:35 pm
Location: Palu, Indonesia

Re: 6.20 no microSDHC

Sun Oct 05, 2014 3:05 am

RB433UAH

6.20 (6.21rc3) no micro-sd disk ( microSDHC Kingston 4GB) > downgrade 6.19 disk view

I already wrote here, but it was deleted. (20 days ago)
same case here, and already sent support output file to support@mikrotik.com).
 
User avatar
Belgarion186
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Thu Jan 23, 2014 3:33 am

Re: v6.20 released!

Sun Oct 05, 2014 4:44 am

My 6to4 tunnel to tunnelbroker.net broke with 6.20. Can't even get them working again if I redo the configuration completely.
Thanks for the heads up.

I was too busy the past few days to upgrade mine to 6.20 (they're currently on 6.19). Guess I'll leave them at 6.19 till the problem is fixed.
 
lucky79
Member Candidate
Member Candidate
Posts: 127
Joined: Sat Sep 27, 2014 1:24 pm
Location: Czech Republic

Re: v6.20 released!

Sun Oct 05, 2014 11:48 am

RB922UAGS-5HPacD hanged after upgrade, needed power cycle to restore access.

minimum tx-power 6dBm, seriously guys? Current Tx power still shows 0dBm. Automatic Tx power based on antenna gain still not working. No manual noise floor threshold... No spectral scan... I guess I am holding the AC products until the wireless-fp will be ready for production. Its a shame I have already upgraded one PTP link with SXTacs which at the current state has lower performance and shitty CCQ (with R52n-M was perfect).
Current-tx-power reading isn't made yet for the AC radios.
TX-power changing is working on the AC.
What signal you have on your SXT AC link?
If you set the band to the A/N on both sides do you get the same CCQ and performance like with the R52nM cards?
Try to reset the wireless interface configuration and check if the situation gets bettwe with default values.
In 6.19 I could set manual tx-power to 0 but starting 6.20 the driver wont let me go below 6dBm (on Netmetal 5).... So apparently there is a change in wireless but its not in the changelog. Yes, manual tx-power works but not the automatic based on the antenna gain... at least it did not work the way I am used to from previous versions.

I have -57/-54 signal on the link with 0 tx-power (its 50m link across the road), I cannot get close to my previous setup with R52n-M and standard wireless package with 5.26... Even if I switch the SXTs to A/N its similar to AC.. lower CCQ, lower throughput (40MHz jumping between 100 and 170Mbps).

When I tried wireless-fp with R52n-M on another link some time ago (I guess it was 6.15) I have seen similar issues - lower CCQ and performance, so switched back to default wireless package = stable 99-100% CCQ and throughput
 
ditonet
Forum Veteran
Forum Veteran
Posts: 839
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: v6.20 released!

Sun Oct 05, 2014 6:33 pm

pitr wrote:
My 6to4 tunnel to tunnelbroker.net broke with 6.20. Can't even get them working again if I redo the configuration completely.


Thanks for the heads up.

I was too busy the past few days to upgrade mine to 6.20 (they're currently on 6.19). Guess I'll leave them at 6.19 till the problem is fixed.
My 6to4 tunnel to tunnelbroker.net works as expected after upgrade to 6.20.

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
newranman
just joined
Posts: 17
Joined: Mon Jan 10, 2011 10:53 pm

6.20 on RB450G kernel failure reboots

Mon Oct 06, 2014 1:21 am

I have had multiple kernel failures then reboots on my RB450G, submitted report to my account support. Ticket#2014100466000271, just sent another autosupout. Had to downgrade to 6.19

I don't recommend 6.20 at least for my setup.

Ran
:(
 
bjh21
just joined
Posts: 2
Joined: Mon Oct 06, 2014 1:19 am

Re: v6.20 released!

Mon Oct 06, 2014 1:37 am

My 6to4 connection failed too, when I upgraded from 6.13 to 6.20. I removed it all and followed the instructions at http://wiki.mikrotik.com/wiki/Setting_u ... l_via_6to4 with appropriate changes for the addressing on my network:
[admin@kattegat] > /interface 6to4 add mtu=1280 name=ipng-tunnel local-address=86.26.1.97 remote-address=192.88.99.1 disabled=no
[admin@kattegat] > /ipv6 address add address=2002:561a:0161::1/3 interface=ipng-tunnel
[admin@kattegat] > /ipv6 route add dst-address=2000::/3 gateway=::192.88.99.1%ipng-tunnel
But this leaves the routing table claiming that the interface is unreachable:
[admin@kattegat] > /ipv6 route print detail
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, o - ospf, b - bgp, U - unreachable 
 0 ADC  dst-address=2000::/3 gateway=ipng-tunnel 
        gateway-status=ipng-tunnel unreachable distance=0 scope=10 

 1   S  dst-address=2000::/3 gateway=::192.88.99.1%ipng-tunnel 
        gateway-status=::192.88.99.1%ipng-tunnel unreachable distance=1 
        scope=30 target-scope=10 

 2 ADC  dst-address=2002:561a:161:1::/64 gateway=ether2-master-local 
        gateway-status=ether2-master-local reachable distance=0 scope=10 

 3 ADC  dst-address=2002:561a:161:2::/64 gateway=wlan1 
        gateway-status=wlan1 reachable distance=0 scope=10 
 
Majklik
newbie
Posts: 35
Joined: Fri Dec 23, 2011 10:20 pm

Re: v6.20 released!

Mon Oct 06, 2014 9:53 am

[admin@kattegat] > /ipv6 address add address=2002:561a:0161::1/3 interface=ipng-tunnel
[admin@kattegat] > /ipv6 route add dst-address=2000::/3 gateway=::192.88.99.1%ipng-tunnel
This is not a probably OK. A maybe better:
/ipv6 address add address=2002:561a:0161::1/16 interface=ipng-tunnel
/ipv6 route add dst-address=::/0 gateway=::192.88.99.1%ipng-tunnel
My 6to4 tunnel to tunnelbroker.net broke with 6.20. Can't even get them working again if I redo the configuration completely.
Check how you have defined IPv6 address and default gateway on the tunnel. It looks that 6.20 is more strictly that previous version. The definition like this works with 6.20 OK:
/ipv6 address add address=2001:db8:1234:5678::2/64 advertise=no interface=wan6he
/ipv6 route add check-gateway=ping distance=1 gateway=2001:db8:1234:5678::1
The default gateway in this way do not (older ROS version probably accepts this):
/ipv6 route add distance=1 gateway=wan6he
 
MetUys
just joined
Posts: 18
Joined: Mon Mar 17, 2014 1:19 pm

Re: v6.20 released!

Mon Oct 06, 2014 10:34 am

Hi,

Upgraded RB751U-2HnD (v6.19 -> v6.20) = no problems as yet.
Upgraded RB2011UAS-2HnD (v6.19 -> v6.20) = IP Routes got lost, Queues also went missing and obviously the Graphs on the Queues were not linking correctly (no queue to link to).
I manually added back the routes and queues and fixed the graph links from an export done just before hand, and all is working again.
(no other noticeable issues as yet).

PS: Regarding the PPTP issues on v6.8 = I suffered from these but in the last few versions things have been good, no issues on our setups.

Conclusion: be careful on remote installs in case similar issues come through for you, as it did on my RB2011UAS-2HnD, in our case we had someone on the other end before we did the upgrade. (upgrade rollout planning is key :P)
 
ste
Forum Guru
Forum Guru
Posts: 1803
Joined: Sun Feb 13, 2005 11:21 pm

Re: v6.20 released!

Mon Oct 06, 2014 12:15 pm

Conclusion: be careful on remote installs in case similar issues come through for you, as it did on my RB2011UAS-2HnD, in our case we had someone on the other end before we did the upgrade. (upgrade rollout planning is key :P)
Conclusion: Wait for a stable release.
 
pitr
just joined
Posts: 4
Joined: Fri Mar 21, 2014 11:14 pm

Re: v6.20 released!

Mon Oct 06, 2014 1:28 pm

[admin@kattegat] > /ipv6 address add address=2002:561a:0161::1/3 interface=ipng-tunnel
[admin@kattegat] > /ipv6 route add dst-address=2000::/3 gateway=::192.88.99.1%ipng-tunnel
This is not a probably OK. A maybe better:
/ipv6 address add address=2002:561a:0161::1/16 interface=ipng-tunnel
/ipv6 route add dst-address=::/0 gateway=::192.88.99.1%ipng-tunnel
My 6to4 tunnel to tunnelbroker.net broke with 6.20. Can't even get them working again if I redo the configuration completely.
Check how you have defined IPv6 address and default gateway on the tunnel. It looks that 6.20 is more strictly that previous version. The definition like this works with 6.20 OK:
/ipv6 address add address=2001:db8:1234:5678::2/64 advertise=no interface=wan6he
/ipv6 route add check-gateway=ping distance=1 gateway=2001:db8:1234:5678::1
The default gateway in this way do not (older ROS version probably accepts this):
/ipv6 route add distance=1 gateway=wan6he
Ok, that fixed it. Thanks
 
User avatar
vadimbn
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Sun Aug 25, 2013 6:41 pm
Location: Russia, Berdsk
Contact:

Re: v6.20 released!

Mon Oct 06, 2014 3:15 pm

Dear developers, please see the attached screenshots. Can You explain, where are my disks? Before update to 6.20 i have two disks - internal and sd-card. After - nothing.
You do not have the required permissions to view the files attached to this post.
Veni. Vidi. Feci.
RBSXTLTE3-7, CRS326-24G-2S+RM, RB850Gx2, RBMRTG, RB1100AHx4, RB750Gr3, RBD52G-5HacD2HnD-TC, Woobm-USB
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24197
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.20 released!

Mon Oct 06, 2014 3:18 pm

Sorry about that, this is a confirmed bug, and we are already working on it. You can currently downgrade to v6.19 to see microSD cards
No answer to your question? How to write posts
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1407
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.20 released!

Mon Oct 06, 2014 3:34 pm

[admin@kattegat] > /ipv6 address add address=2002:561a:0161::1/3 interface=ipng-tunnel
[admin@kattegat] > /ipv6 route add dst-address=2000::/3 gateway=::192.88.99.1%ipng-tunnel
This is not a probably OK. A maybe better:
/ipv6 address add address=2002:561a:0161::1/16 interface=ipng-tunnel
/ipv6 route add dst-address=::/0 gateway=::192.88.99.1%ipng-tunnel
My 6to4 tunnel to tunnelbroker.net broke with 6.20. Can't even get them working again if I redo the configuration completely.
Check how you have defined IPv6 address and default gateway on the tunnel. It looks that 6.20 is more strictly that previous version. The definition like this works with 6.20 OK:
/ipv6 address add address=2001:db8:1234:5678::2/64 advertise=no interface=wan6he
/ipv6 route add check-gateway=ping distance=1 gateway=2001:db8:1234:5678::1
The default gateway in this way do not (older ROS version probably accepts this):
/ipv6 route add distance=1 gateway=wan6he
Ok, that fixed it. Thanks
We also managed to reproduce this issue which appears after upgrade. Please follow our changelog on download page and wait for version which will include fix for it.
http://www.mikrotik.com/download
 
lcrhea25
Member Candidate
Member Candidate
Posts: 114
Joined: Wed Nov 29, 2006 4:30 pm

Re: v6.20 released!

Mon Oct 06, 2014 4:38 pm

Normis anything on my Ticket#2014092966000638. Haven't heard anything back. Colocation of 3 120 degree 2.4 sectors. Problems when all three run nv2. Put 1 on channel 1 with nv2, 1 on channel 11 nv2 and 1 on channel 6 nv2 and problem goes away. Basically I am interfereing with myself when running nv2 5 channels away.
 
remojames
just joined
Posts: 3
Joined: Tue Apr 15, 2014 11:19 pm

Re: v6.20 released!

Mon Oct 06, 2014 7:50 pm

Somebody make firmware update from 3.18 to 3.19 ?
where can i find change log to this firmware?
 
ffernandes
Member Candidate
Member Candidate
Posts: 146
Joined: Mon Jun 23, 2008 11:20 pm

Re: v6.20 released!

Mon Oct 06, 2014 8:56 pm

it should be here: http://wiki.mikrotik.com/wiki/RouterBOOT_changelog

but its a little *outdated
Somebody make firmware update from 3.18 to 3.19 ?
where can i find change log to this firmware?
 
bjh21
just joined
Posts: 2
Joined: Mon Oct 06, 2014 1:19 am

Re: v6.20 released!

Mon Oct 06, 2014 10:42 pm

[admin@kattegat] > /ipv6 address add address=2002:561a:0161::1/3 interface=ipng-tunnel
[admin@kattegat] > /ipv6 route add dst-address=2000::/3 gateway=::192.88.99.1%ipng-tunnel
This is not a probably OK. A maybe better:
/ipv6 address add address=2002:561a:0161::1/16 interface=ipng-tunnel
/ipv6 route add dst-address=::/0 gateway=::192.88.99.1%ipng-tunnel
Thanks for the suggestion. That's actually the configuration I was using before the upgrade, and it has precisely the same problem:
[admin@kattegat] /ipv6 route> print detail
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, o - ospf, b - bgp, U - unreachable 
 0   S  dst-address=::/0 gateway=::192.88.99.1%ipng-tunnel 
        gateway-status=::192.88.99.1%ipng-tunnel unreachable distance=1 
        scope=30 target-scope=10 

 1 ADC  dst-address=2002::/16 gateway=ipng-tunnel 
        gateway-status=ipng-tunnel unreachable distance=0 scope=10 

 2 ADC  dst-address=2002:561a:161:1::/64 gateway=ether2-master-local 
        gateway-status=ether2-master-local reachable distance=0 scope=10 

 3 ADC  dst-address=2002:561a:161:2::/64 gateway=wlan1 
        gateway-status=wlan1 reachable distance=0 scope=10 
 
Ansy
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Mon Oct 17, 2011 1:32 pm
Location: Russia
Contact:

Profile

Tue Oct 07, 2014 9:33 am

0 items in Tools-->Profile on some upgraded devices :(
I can't realize what this issue depends of...
Image
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1407
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: Profile

Tue Oct 07, 2014 10:14 am

0 items in Tools-->Profile on some upgraded devices :(
I can't realize what this issue depends of...
Image

Thank you about this information. This issue is already reproduced and will be fixed.
 
User avatar
cdiedrich
Forum Veteran
Forum Veteran
Posts: 905
Joined: Thu Feb 13, 2014 2:03 pm
Location: Basel, Switzerland // Bremen, Germany
Contact:

Re: v6.20 released!

Tue Oct 07, 2014 11:39 am

Upgraded one of our 2011 yesterday from 6.12 to 6.20.
All IPsec installed SAs now show up with state=dying but are fully functional.
Expiration time is always more than 5min...

Since it's basically working, I consider this a cosmetic bug :-)
-Chris
Christopher Diedrich
MTCNA, MTCUME, MTCWE
Basel, Switzerland
Bremen, Germany

There are 10 types of people: Those who understand binary and those who don't.
There are two types of people: Those who can extrapolate from incomplete data
 
User avatar
24tammam
just joined
Posts: 4
Joined: Mon Oct 06, 2014 10:35 pm

Re: v6.20 released!

Tue Oct 07, 2014 8:58 pm

Dear developers, please see the attached screenshots. Can You explain, where are my disks? Before update to 6.20 i have two disks - internal and sd-card. After - nothing.

i have this :(

what i can to do ?
I do not want to return 6.19!
I want to repair the problem ؟
Islam is a religion of God for all people, a religion of forgiveness, science and morality
Do not believe what is being said .. until you learn about Islam
 
finnter
just joined
Posts: 1
Joined: Tue Oct 07, 2014 10:22 pm

Re: v6.20 released!

Tue Oct 07, 2014 10:29 pm

| fetch - fixed problem where files fetched over https were trimmed in size;

This doesn't appear to be fixed. Before files were being trimmed down to 1024 B, they are now being trimmed down to 4096 B.
 
levifig
just joined
Posts: 1
Joined: Tue Oct 07, 2014 11:57 pm

Re: v6.20 released!

Wed Oct 08, 2014 12:02 am

Upgraded a couple of 2011 and have had all sorts of trouble with the DHCP client, particularly on ETH1. No IP, or no default route, or no DNS, or nothing, even though other devices get DHCP just fine on the same physical cable. (RB2011UiAS)

Waiting for 6.21 now… :)
 
strokers
just joined
Posts: 3
Joined: Wed Oct 08, 2014 12:15 pm

Re: v6.20 released!

Wed Oct 08, 2014 2:22 pm

Hello

I found 2 bugs:
1) i use ppp tunel - when is one person connected by ppp to mikrotik all it's ok when the second person connecting after few minutes system is 100% cpu load and i must reboot (unplug 230v)

2) when i conneting by ppp from other network and i have in this network i have one address ip for ex. 192.168.1.200 now i diconnecting and connecting from other computer with other ip address for ex. 192.168.1.201 i cant connect - i must wait about 10-15 minutes and then i can connect.

the first problem is on 6.20 the second problem is now on 6.2 and on old software when i bought the 751U-2HnD (4.17)

Strokers
 
strokers
just joined
Posts: 3
Joined: Wed Oct 08, 2014 12:15 pm

Re: v6.20 released!

Wed Oct 08, 2014 2:24 pm

Hello

I found 2 bugs:
1) i use ppp tunel - when i use it - when i connect by ppp after few minutes system is 100% cpu load and i must reboot (unplug 230v)

2) when i conneting by ppp from other network and i have in this network i have one address ip for ex. 192.168.1.200 now i diconnecting and connecting from other computer with other ip address for ex. 192.168.1.201 i cant connect - i must wait about 10-15 minutes and then i can connect.

the first problem is on 6.20 the second problem is now on 6.2 and on old software when i bought the 751U-2HnD (4.17)

Strokers
 
zdiv
just joined
Posts: 6
Joined: Thu Sep 01, 2011 12:06 pm

Re: v6.20 released!

Wed Oct 08, 2014 2:35 pm

RB922UAGS-5HPacD hanged after upgrade, needed power cycle to restore access.

minimum tx-power 6dBm, seriously guys? Current Tx power still shows 0dBm. Automatic Tx power based on antenna gain still not working. No manual noise floor threshold... No spectral scan... I guess I am holding the AC products until the wireless-fp will be ready for production. Its a shame I have already upgraded one PTP link with SXTacs which at the current state has lower performance and shitty CCQ (with R52n-M was perfect).
Current-tx-power reading isn't made yet for the AC radios.
TX-power changing is working on the AC.
What signal you have on your SXT AC link?
If you set the band to the A/N on both sides do you get the same CCQ and performance like with the R52nM cards?
Try to reset the wireless interface configuration and check if the situation gets bettwe with default values.
In 6.19 I could set manual tx-power to 0 but starting 6.20 the driver wont let me go below 6dBm (on Netmetal 5).... So apparently there is a change in wireless but its not in the changelog. Yes, manual tx-power works but not the automatic based on the antenna gain... at least it did not work the way I am used to from previous versions.

I have -57/-54 signal on the link with 0 tx-power (its 50m link across the road), I cannot get close to my previous setup with R52n-M and standard wireless package with 5.26... Even if I switch the SXTs to A/N its similar to AC.. lower CCQ, lower throughput (40MHz jumping between 100 and 170Mbps).

When I tried wireless-fp with R52n-M on another link some time ago (I guess it was 6.15) I have seen similar issues - lower CCQ and performance, so switched back to default wireless package = stable 99-100% CCQ and throughput
Same here plus:
911G-5HPacD hanged after upgrade , needed power cycle to revive
SXT G-5HPacD upgrade process went ok
I am staying on 6.19 ... 6.20 seams to be unreliable with to much problems...
 
User avatar
Kickoleg
Member Candidate
Member Candidate
Posts: 127
Joined: Tue Mar 11, 2014 3:13 pm
Location: Yverdon-les-Bains, Suisse

Re: v6.20 released!

Wed Oct 08, 2014 5:02 pm

What is this "SIP Direct Media" ?
Where information about this new feature ?
You do not have the required permissions to view the files attached to this post.
MTCNA, MTCUME, MTCRE, MTCWE, MTCTCE certified
 
ditonet
Forum Veteran
Forum Veteran
Posts: 839
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: v6.20 released!

Wed Oct 08, 2014 6:00 pm

This 'new' option exists even in ROS 5.x and is described here:
http://wiki.mikrotik.com/wiki/Manual:IP ... vice_Ports

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
User avatar
zervan
Member
Member
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: v6.20 released!

Wed Oct 08, 2014 6:56 pm

has all the sstp and pptp issues been resolved from the 6.8 debacle?
Would like to know as well. Have held at 6.7 because I need to maintain SSTP compatibility with Windows clients.
I am using SSTP with 6.20 (and 6.19) with Windows clients and I didn't experienced troubles. What kind of issues should I check?
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
User avatar
rmmccann
Member Candidate
Member Candidate
Posts: 182
Joined: Tue Sep 25, 2012 11:15 pm
Location: USA

Re: v6.20 released!

Wed Oct 08, 2014 7:12 pm

has all the sstp and pptp issues been resolved from the 6.8 debacle?
Would like to know as well. Have held at 6.7 because I need to maintain SSTP compatibility with Windows clients.
I am using SSTP with 6.20 (and 6.19) with Windows clients and I didn't experienced troubles. What kind of issues should I check?
For a while there people were complaining about the inability to establish SSTP tunnels from Windows as well as stability issues with them from MT to MT.

I never could get a concrete yes or no from anyone using SSTP whether or not they had success with Windows clients since 6.7. Your response is encouraging.
A common mistake that people make when trying to design something completely foolproof is to underestimate the ingenuity of complete fools. --Douglas Adams
 
jondavy
Member Candidate
Member Candidate
Posts: 126
Joined: Tue May 12, 2009 11:14 pm
Location: Brasil

Re: v6.20 released!

Wed Oct 08, 2014 10:09 pm

In CloudCore in /system resources not appear the Status of:
Sector Writes Sice Reboot
Total Sector Wrires
Bad Blocks
 
User avatar
avenn
Frequent Visitor
Frequent Visitor
Posts: 79
Joined: Fri Mar 14, 2014 11:59 pm
Location: Burnley UK
Contact:

Re: v6.20 released!

Wed Oct 08, 2014 11:18 pm

has all the sstp and pptp issues been resolved from the 6.8 debacle?
Would like to know as well. Have held at 6.7 because I need to maintain SSTP compatibility with Windows clients.
SSTP to win7 clients is fine for me on 6.19
MTCRE - MTCNA - MTCTCE
 
User avatar
MTeeker
Frequent Visitor
Frequent Visitor
Posts: 75
Joined: Tue Jun 14, 2011 2:42 pm
Location: Australia

Re: v6.20 released!

Thu Oct 09, 2014 2:14 am

V6.20 minor bug?

Time, Date, CPU, Memory and Uptime indicators disappear when Winbox is next opened.

It's minor thing but if it can be fixed, it would be great.

I am running the latest version of Winbox. I don't think it works on the previous version of Winbox either.

Many thanks.
 
scampbell
Trainer
Trainer
Posts: 457
Joined: Thu Jun 22, 2006 5:20 am
Location: Wellington, NZ
Contact:

Re: v6.20 released!

Thu Oct 09, 2014 9:37 am

We have upgraded several RB951 series routers in a class situation. 2 or 3 of these have all exhibited odd firewall behavior when rules are disabled.

It shows a rule disabled in Winbox yet the rule continues to work, e.g a rule that logs traffic keeps logging even when disabled. We did not test this in CLI as time was tight.

A reboot fixes the issue.

Not all devices have shown this so perhaps user error - has anyone else seen this ?
 
User avatar
Kickoleg
Member Candidate
Member Candidate
Posts: 127
Joined: Tue Mar 11, 2014 3:13 pm
Location: Yverdon-les-Bains, Suisse

Re: v6.20 released!

Thu Oct 09, 2014 11:54 am

This 'new' option exists even in ROS 5.x and is described here:
http://wiki.mikrotik.com/wiki/Manual:IP ... vice_Ports

Regards,
SIP Direct Media appeared only in 6.20, You need more accurate read my question ...
And I interesting in how it work? What changes it made and etc...
MTCNA, MTCUME, MTCRE, MTCWE, MTCTCE certified
 
ditonet
Forum Veteran
Forum Veteran
Posts: 839
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: v6.20 released!

Thu Oct 09, 2014 3:46 pm

ros code

[grzegorz@Some_Gateway] /ip firewall service-port> export 
# oct/09/2014 13:38:06 by RouterOS 5.26
#
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061 sip-direct-media=no
set pptp disabled=no
All I wanted to say, is that 'sip-direct-media' option is not new feature introduced in ROS 6.20.
And I interesting in how it work
Just Google it...

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
mgob1985
newbie
Posts: 28
Joined: Wed Jun 18, 2014 3:02 pm

Re: v6.20 released!

Thu Oct 09, 2014 6:32 pm

We had an issue going from 6.15 to 6.20 on a CCR1009:

ros code

> /export compact  
# oct/09/2014 08:18:04 by RouterOS 6.20
#error exporting /ip ipsec mode-config
#error exporting /ip ipsec policy group
#error exporting /ip ipsec proposal
#error exporting /snmp community
#error exporting /certificate scep-server
#error exporting /certificate scep-server ra
#error exporting /ip ipsec peer
#error exporting /ip ipsec policy
#error exporting /ip ssh
#error exporting /routing bfd interface
#error exporting /snmp
#error exporting /tool e-mail
#error exporting /tool mac-server mac-winbox

> /snmp print 

error - contact MikroTik support and send a supout file (2)
I downgraded to 6.19 and everything worked again.... anyone else experience something like this?
 
Shiro
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Wed Sep 25, 2013 6:44 pm

Re: 6.20 no microSDHC

Thu Oct 09, 2014 9:48 pm

RB433UAH

6.20 (6.21rc3) no micro-sd disk ( microSDHC Kingston 4GB) > downgrade 6.19 disk view

I already wrote here, but it was deleted. (20 days ago)
same case here, and already sent support output file to support@mikrotik.com).
Same issue with CCR1009. I created a ticket to mt.
 
Shiro
Frequent Visitor
Frequent Visitor
Posts: 65
Joined: Wed Sep 25, 2013 6:44 pm

Re: v6.20 released!

Thu Oct 09, 2014 10:00 pm

What is this "SIP Direct Media" ?
Where information about this new feature ?
You can find more about this in iptables documentation. It's a helper that rewrite SIP Header if you using NAT.
 
robdeep
just joined
Posts: 8
Joined: Thu Oct 04, 2012 6:33 pm

Re: v6.20 released!

Fri Oct 10, 2014 4:22 am

Only issue I've noticed with 6.20 is with a bandwidth Queue I previously had defined in RouterOS but not enabled or applied to an interface. When I upgraded to 6.20, the queue became enabled and was being applied to the entire router, even though there was no "target" specified in the queue definition. So weird... I just disabled, it and all is good again. This was on a RB2011 btw.

Not a big deal for me, but I would be worried if I was a service provider and had a ton of customer queues setup, which I've used a lot in the past in my WISP days.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: v6.20 released!

Fri Oct 10, 2014 6:19 pm

We had an issue going from 6.15 to 6.20 on a CCR1009:

ros code

> /export compact  
# oct/09/2014 08:18:04 by RouterOS 6.20
#error exporting /ip ipsec mode-config
#error exporting /ip ipsec policy group
#error exporting /ip ipsec proposal
#error exporting /snmp community
#error exporting /certificate scep-server
#error exporting /certificate scep-server ra
#error exporting /ip ipsec peer
#error exporting /ip ipsec policy
#error exporting /ip ssh
#error exporting /routing bfd interface
#error exporting /snmp
#error exporting /tool e-mail
#error exporting /tool mac-server mac-winbox

> /snmp print 

error - contact MikroTik support and send a supout file (2)
I downgraded to 6.19 and everything worked again.... anyone else experience something like this?

try to do a /system check-installation

Could you make a support output file from 6.19 where it works ok and then upgrade to v6.20 where it doesn't work and make another file. Send both files to support@mikrotik.com
 
2dfx
just joined
Posts: 22
Joined: Tue Mar 05, 2013 6:30 pm

Re: v6.20 released!

Sat Oct 11, 2014 12:12 am

Hi!

I have error with lcd max-speed setup via winbox
Image

But i can set max-speed via terminal
Image

After set speed via terminal - winbox show error
Image
 
sisal
just joined
Posts: 5
Joined: Wed Jul 10, 2013 5:39 pm

webfig: </ip dhcp-server network> broken

Sat Oct 11, 2014 4:26 pm

I upgraded an RB2011 from 6.12 to 6.20. Now the configuration of networks for DHCP Server in webfig does not work anymore.

I create a network:
ros-620-dhcp-net-1.png
After saving it shows this:
ros-620-dhcp-net-2.png
[admin@MikroTik] /ip dhcp-server network> export
# oct/12/2014 00:20:22 by RouterOS 6.20
# software id = 6GM9-Z8QY
#
/ip dhcp-server network
add address=192.168.33.0/24
I can change the settings on the console, it works. Just missing the working webfig.
sisal
You do not have the required permissions to view the files attached to this post.
 
User avatar
Belgarion186
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Thu Jan 23, 2014 3:33 am

Re: webfig: </ip dhcp-server network> broken

Sun Oct 12, 2014 5:04 am

I upgraded an RB2011 from 6.12 to 6.20. Now the configuration of networks for DHCP Server in webfig does not work anymore.
Facing the same problem with Webfig on the RB850Gx2 too (ROS 6.20).

Had to use Winbox to configure DHCP Server - Networks.
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

6.21rcX crash

Sun Oct 12, 2014 2:23 pm

... other error RouterOS 6.21rc5 uptime 3d crash! RB433UAH


Dispose of version 6.20 and all 6.21rcX, again from 6.19

When you fix errors with USB Flash (drive) and microSDHC?


<Google Translator>

add error

router crash> power off/on > graf statistic all interfaces wireless lost, not in the menu (connection work
)....over time appeared
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2946
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.20 released!

Mon Oct 13, 2014 10:49 am

Again problems with user-manager.

6.18 on x86 with user manager, upgraded to 6.20 and user-manager stop working, not see the files of the database.

Revert back to 6.18 solve the problem.
I'm Italian, not English. Sorry for my imperfect grammar.
 
ste
Forum Guru
Forum Guru
Posts: 1803
Joined: Sun Feb 13, 2005 11:21 pm

Re: v6.20 released!

Mon Oct 13, 2014 11:17 am

Upgrading an SXT G-5HPacd from 6.19 worked but after upgrading
firmware to 3.18.1 device was no longer accessible.
Power Cycle helped.

:-(
 
aliereza
just joined
Posts: 2
Joined: Sat Oct 11, 2014 12:30 pm

Re: v6.20 released!

Mon Oct 13, 2014 6:38 pm

Upgraded NetMetal firmware to 3.18.1 and the device crashes every time that I use wireless scanner. Totally inaccessible, and it needs power cycle.
 
sirdir
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Tue Aug 27, 2013 8:17 pm

Re: v6.20 released!

Wed Oct 15, 2014 1:54 am

FYI, something seems to be broken with IPSEC. Sometimes the configuration just disappears. If you try to change anything in the submenu then that command just times out.
Rebooting fixes all issues for some time... suddenly the problems come back.

Regards
Patrick
 
alfonzz
just joined
Posts: 16
Joined: Wed Oct 15, 2014 12:16 pm
Location: CZ

Re: v6.20 released!

Wed Oct 15, 2014 12:26 pm

Upgraded NetMetal firmware to 3.18.1 and the device crashes every time that I use wireless scanner. Totally inaccessible, and it needs power cycle.

I agree, this hapens from v6.19, not only scan wireless, but snooper too.
in log is system reboot because watchdog timer, if you turned off timer, then system hangs and no response to anything, powercycle helped.
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

6.2x add error, why?

Wed Oct 15, 2014 1:28 pm

RB433UAH

Proč se objevila ve verzích 6.21rc7 a 6.21rc8 chyba v NTP klient?
Why has appeared in versions 6.21rc7 and 6.21rc8 error in NTP client?

still gain errors ...USB FLASH (drive); microSDHC; NTP, crash

Uvažuji, že se vrátím na verzi 6.19 a nový, ať si zkouší testeři.
I'll go back to version 6.19

Verze 6.19 mi běžela 19 dní a pak jsem jí aktualizoval na 6.20.
Version 6.19 uptime 19 days then update to 6.20.


Za překlad do angličtiny děkuji Google překladači.
The translation into English thanks to Google translator.
 
scampbell
Trainer
Trainer
Posts: 457
Joined: Thu Jun 22, 2006 5:20 am
Location: Wellington, NZ
Contact:

Re: v6.20 released!

Wed Oct 15, 2014 11:07 pm

Again problems with user-manager.

6.18 on x86 with user manager, upgraded to 6.20 and user-manager stop working, not see the files of the database.

Revert back to 6.18 solve the problem.
We are also seeing an issue with UM and WG500MP printers interfaced via API. Ticket for 1 Hour or 4 Hour print as 1 or 4 seconds. Printing was correct on RoS 6.17. Avccount still works for 1 or 4 hours though so only a "cosmetic" bug we hope....... :?
 
User avatar
noyo
Member Candidate
Member Candidate
Posts: 114
Joined: Sat Jan 28, 2012 12:25 am
Location: Mazury - Poland
Contact:

Re: v6.20 released!

Thu Oct 16, 2014 12:07 pm

Ticket # 2014091366000293
if you have taken any attempts to remove my problem?
Because the WATCHDOG-REBOOT becoming unbearable.
Unfortunately it has the network RB2011iL which I can not give you downgrade to 5.26 :(

Already three people with support wrote to me and no person has not solved it.
 
ste
Forum Guru
Forum Guru
Posts: 1803
Joined: Sun Feb 13, 2005 11:21 pm

Re: v6.20 released!

Thu Oct 16, 2014 3:41 pm

RB SXT G-5HPacd still rebooting due to kernel failure.
Same as with 6.19. supout.rif sent long ago and repeated.
No solution from Mikrotik.
FW: 3.18.1
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: v6.21rc11 _USB disk

Fri Oct 17, 2014 1:06 pm

What's new in 6.21rc11 (2014-Oct-17 10:55)
*) disks - fixed support for MMC/SD cards;


Zkoušel jsem a nefunguje, chyba nebyla opravena.
I tried and does not work, the error was not corrected.

upgrade 6.19 > 6.21rc11
rename disk1 >usb1, rename disk2 >usb2 ...reboot
images USB1 alias drive1 error 0 B free capacity, no name
power off/on
unchanged
downgrade 6.19

Došlo ve verzi 6.21rc11 ke zvýšení kapacity disků?
Increased capacity drives in 6.21.rc11? images usb2, microSDHC

<Google Translator>
You do not have the required permissions to view the files attached to this post.
 
pampi
newbie
Posts: 39
Joined: Mon Dec 26, 2005 7:28 pm
Location: Hungary / Pecs

Re: v6.20 released!

Fri Oct 17, 2014 4:41 pm

this "router was rebooted without proper shutdown by watchdog timer" problem solved?

I still have this issue from 6.7 to 6.19 mostly on all RB2011/ RB750G / RB911 / SXT Lite5 devices approx 70 pieces of our devices affected by this error.

Mostly all devices reboot between 1am to 3am. Devices that are affacted are not on the same location, (20-40km) all of them are running through uninterruptible power supply, so it could not be a power problem. At the same time, and on the same tower other devices which are not running Mikrotik 6.x version are still running.
 
User avatar
noyo
Member Candidate
Member Candidate
Posts: 114
Joined: Sat Jan 28, 2012 12:25 am
Location: Mazury - Poland
Contact:

Re: v6.20 released!

Fri Oct 17, 2014 4:58 pm

this "router was rebooted without proper shutdown by watchdog timer" problem solved?

I still have this issue from 6.7 to 6.19 mostly on all RB2011/ RB750G / RB911 / SXT Lite5 devices approx 70 pieces of our devices affected by this error.

Mostly all devices reboot between 1am to 3am. Devices that are affacted are not on the same location, (20-40km) all of them are running through uninterruptible power supply, so it could not be a power problem. At the same time, and on the same tower other devices which are not running Mikrotik 6.x version are still running.
I have the same problem
even sometimes when you try to generate or export supout.rif configure itself can perform a watchdog-reboot

This is simply fucking hate.
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2287
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: v6.20 released!

Fri Oct 17, 2014 5:52 pm

this "router was rebooted without proper shutdown by watchdog timer" problem solved?

I still have this issue from 6.7 to 6.19 mostly on all RB2011/ RB750G / RB911 / SXT Lite5 devices approx 70 pieces of our devices affected by this error.

Mostly all devices reboot between 1am to 3am. Devices that are affacted are not on the same location, (20-40km) all of them are running through uninterruptible power supply, so it could not be a power problem. At the same time, and on the same tower other devices which are not running Mikrotik 6.x version are still running.
I have the same problem
even sometimes when you try to generate or export supout.rif configure itself can perform a watchdog-reboot

This is simply fucking hate.
+1
LAN, FTTx, Wireless. ISP operator
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: v6.20 released!

Fri Oct 17, 2014 6:11 pm

It happens on 6.x when running on 32mb devices for me. Have you seen it also on other devices?
 
User avatar
noyo
Member Candidate
Member Candidate
Posts: 114
Joined: Sat Jan 28, 2012 12:25 am
Location: Mazury - Poland
Contact:

Re: v6.20 released!

Fri Oct 17, 2014 6:22 pm

It happens on 6.x when running on 32mb devices for me. Have you seen it also on other devices?
RB2011 has 60M
RB2011iL has 64M
RB SXT G-5HPnD r2 has 64M
and the same thing happens
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: v6.20 released!

Fri Oct 17, 2014 6:38 pm

Have you tried netinstall? I wasn't able to solve this problem only when there was not enough free memory.
I would like to see some effective memory management optimisation in the next ros release as 32mb devices really need it.
 
User avatar
noyo
Member Candidate
Member Candidate
Posts: 114
Joined: Sat Jan 28, 2012 12:25 am
Location: Mazury - Poland
Contact:

Re: v6.20 released!

Fri Oct 17, 2014 6:48 pm

Have you tried netinstall? I wasn't able to solve this problem only when there was not enough free memory.
I would like to see some effective memory management optimisation in the next ros release as 32mb devices really need it.
yes, mikrotik suggested execution netinsall, so I made for test on RB2011iL.
Nothing helped. Excluded api, snmp, ssh.
I included rstp across the network. did not help.

Already I wrote with support from S. Martins next Uldis next Janis B. None of these people has not helped.

by the underdeveloped software equivalent of good reviews about the company.

I do not understand how you can spend the AC equipment is not working properly, because the software is not worked out since the release of the first v6
 
User avatar
mandrade
Member Candidate
Member Candidate
Posts: 104
Joined: Fri Sep 08, 2006 12:35 pm
Location: Brazil
Contact:

Re: v6.20 released!

Sat Oct 18, 2014 4:07 pm

Any NEWS about Ticket#2014051266001345???
Any news on supporting LACP/802.3ad for trunking on CRS (without taxing the CPU)? We have just activated our 10GE link from our Data Center and the point where our radio trunk arrives in a 6+0 configuration. We're now obligated to keep a V1910 on site just for the aggregation of the radio links. On the remote site we have a similar situation, since our V1910 doesn't support 10GE.
 
byteman
just joined
Posts: 17
Joined: Tue May 29, 2007 11:38 pm

Re: v6.20 released!

Sat Oct 18, 2014 4:43 pm

We have issues with EoIPs after upgrade intermediate routers to 6.20 wich are doing routing. The tunnel is not broken, yo can make pings to internet, but no pings more than 1458 size and the clients can not surf to web. Example:

SXT Client (5.26)----wireless link----912G AP(5.26)__ether bridge__|RB935G(6.20)|__ether bridge__Sextant P2P (5.26)----wireless link---Sextant P2P (5.26)__ether bridge__ |CCR Core router 5.26|

with 6.13 version and same configuration in the RB935G router, the problem doesn't exist...

is this problem related with the news features like?:

*) bridge has auto mtu feature
*)...all non-ppp tunnel interfaces got optimized and common set of features..

what can we check?

Thks
 
steen
Member
Member
Posts: 469
Joined: Sat Oct 23, 2010 2:15 am
Location: Sweden
Contact:

Re: v6.20 released!

Sat Oct 18, 2014 10:32 pm

Hello Folks!

Regarding the routing marks for policy based routing, it seems like that problem is solved now.
I just upgraded from RoS6.7 to RoS6.20 on one of our routers that make use of it.

I am still in doubt, because one of the routes did not work directly, it took about 3 hours, then it started to work by itself by unknown reason. It means in my world it can stop woring at any time to.

I will go on and update one more router and see what happens.
.
.
.
And it was successful to, same effect one route took some time till it started working.

Now remains l2tp vpn tunnels, they were severely broken after 6.7 to, whole our vpn network (which is large) collapsed, a few megabyte could be sent through a link before it went down and took the whole router with it down the drain to.
Eventually it will be tested tomorrow, depends on the business.
 
thanxes
just joined
Posts: 1
Joined: Mon Apr 25, 2011 7:22 pm

Re: v6.20 released!

Sun Oct 19, 2014 12:54 am

Hello, I also have 6to4 tunnel problem. In my case it seems obvious that it is due to missing autogenerated link-local ipv6 address on tunnel interface. In version 6.19 and lower it was there as Dynamic&Link-local fe80::<last 4 bytes of ipv6 net>/64
My ISP (netbox.cz) provides me with only one /64 IPv6 space, therefore I have no address to spare in the tunnel itself when I run ipv6 in autoconfiguration. They suggest this kind of configuration.
 
User avatar
noyo
Member Candidate
Member Candidate
Posts: 114
Joined: Sat Jan 28, 2012 12:25 am
Location: Mazury - Poland
Contact:

Re: v6.20 released!

Sun Oct 19, 2014 6:55 pm

Ticket#2014091366000293

In September RB2011iL MTv6.19 was hooked like this:
x86 MTv5.26 (server-pppoe,nat) ---> RB2011LS MTv5.26 ---> UBNT NanoBridge ---> UBNT NanoBridge ---> RB2011iL MTv6.19 ---> ...
and at some time had a watchdog-reboot.
RB2011iL MTv6.19 swapped for RB450GL MTv5.26 because I could not wait until I flee customers by defective v.6.xx :(


Now the same RB2011iL MTv6.19 strapped so
x86 MTv5.26 (server-pppoe,nat) ---> RB2011LS MTv5.26 ---> RB711G-5HnD MTv5.26 --->
---> RB Lite5 MTv5.26 ---> RB2011L MTv5.26 ---> RB711GA-5HnD MTv5.26 ---> RB SXT G-5HPacD MTv6.20 ---> RB2011iL MTv6.20 ---> ... my house
and the problem disappeared. RB2011iL no longer watchdog-reboot. Uptime 16 day


I also hooked up two more RB2011iL MTv6.20 and they watchdog-reboot
x86 MTv5.26 (server-pppoe,nat) ---> RB2011LS MTv5.26 ---> RB711G-5HnD MTv5.26 --->
---> RB Lite5 MTv5.26 ---> RB2011L MTv5.26 ---> RB711G-5HnD MTv5.26 ---> RB Lite5 MTv5.26 ---> RB2011iL MTv6.20 --->
---> RB Lite5 MTv5.26 ---> RB Lite5 MTv5.26 ---> RB450GL MTv5.26 ---> UBNT NanoBeam ---> UBNT NanoBeam ---> RB2011iL MTv6.20 ---> ...
and all the RB2011iL MTv6.20 is watchdog-reboot.

is all network is bridge

NO RB v5.26 no such problems


What's going on? :(
 
ste
Forum Guru
Forum Guru
Posts: 1803
Joined: Sun Feb 13, 2005 11:21 pm

Re: v6.20 released!

Mon Oct 20, 2014 8:07 am

Upgraded a link to 6.20 with both sides doing OSPF/MPLS. After 2 days a IP subnet on one side of the link was no longer reachable.
Routes are there but packets do not pass. Reboot resolved the issue.

6.20 is a release to avoid. Things do not get better they get worse.
 
User avatar
skyfx
just joined
Posts: 11
Joined: Mon Sep 15, 2008 2:53 pm
Location: Bulgaria
Contact:

Re: v6.20 released!

Mon Oct 20, 2014 3:41 pm

I found this:
in 6.20 does not show the correct values ​​for the data rates and current transmit power
You do not have the required permissions to view the files attached to this post.
 
plisken
Forum Guru
Forum Guru
Posts: 2421
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: v6.20 released!

Mon Oct 20, 2014 11:32 pm

What's new in 6.20 (2014-Oct-01 10:06):

*) cert scep - use fingerprints for transaction ids;
*) ipsec - support fqdn as my id;
*) fetch - allow fetching files larger than 4G;
*) fetch - fixed problem where files fetched over https were trimmed in size;
*) fixed problem - it was not possible to see %26 uninstall dude package;
*) stores are replaced with folders and disks are now managed under /disk menu;
*) added support for SMSC750x USB Gigabit Ethernet on x86;
*) ups - support selftest for smart and hid UPS;
*) pppoe client - increase connection timeout to make connection establishment
possible on busy pppoe server;
*) dhcp server - change default lease time from 3 days to 10 minutes
to avoid running out of IPs;
*) ipsec - allow binding modeconf address to username;
*) eoip/eoipv6/gre/gre6/ipip/ipipv6/6to4 tunnels have new features:
auto mtu (enabled by default for new tunnels);
dscp (inherit/specific value, inherit by default for new tunnels);
clamp-tcp-mss (yes by default for new tunnels);
*) eoip/gre/ipip/6to4 tunnels have dont-fragment option (inherit/no, no by default for new tunnels);
*) bridge has auto mtu feature (enabled by default for new bridges);
*) pppoe-server has auto mtu feature (enabled by default for new pppoe servers);

If you already run some RouterOS v6.x version, simply click “Check for updates” in QuickSet, Webfig or Winbox packages menu.

Others: http://www.mikrotik.com/download


Why not wireless AC updates for a better performance?
I would appreciate that very much
 
zxdpxl
just joined
Posts: 2
Joined: Tue Oct 21, 2014 12:04 pm

Re: v6.20 released!

Tue Oct 21, 2014 12:53 pm

Hi
My family has a Mikrotik Router ,The Model is RB951G-2hnd, The current version of the OS is 6.20, My family is connected to internet via China-Telecom ADSL. At my router has a IPv6 tunnel, Hurricane Electric's provided this IPv6 tunnel. China-Telecom will reset the ADSL connection in 48 hours. The WAN IP will changed. I have to change WAN IP the tunnel to on Router setting and web settings in Hurricane Electric's. Then the router will automatically connect to IPv6 tunnel. 6.19 version of the RouterOS can automatically connect to the server. I upgrade the OS version to 6.20. Must manually disable this tunnel, and then enabled this tunnel. IPV6 server to connect. In previous versions have no such problem.

PS:I use this tunnel to access Youtube, Google, Facebook, China Network can't be used to directly access Google, Youtube, facebook.
 
leonix
newbie
Posts: 26
Joined: Fri Nov 26, 2010 4:13 pm

OSPF Problem! Re: v6.20 released!

Thu Oct 23, 2014 9:39 am

Upgraded a link to 6.20 with both sides doing OSPF/MPLS. After 2 days a IP subnet on one side of the link was no longer reachable.
Routes are there but packets do not pass. Reboot resolved the issue.
We have a similar OSPF problem. E.g. one system 6.19 the other one 6.20; OSPF does not work! (Doesnt find the OSPF router).
After going back to 6.19 - OSPF is working.

Leo.
 
onnoossendrijver
Member
Member
Posts: 418
Joined: Mon Jul 14, 2008 11:10 am
Location: The Netherlands

Re: v6.20 released!

Thu Oct 23, 2014 10:15 am

I have no problems with OSPF between 6.19 and 6.20 machines. Can you check all MTU settings on both devices? OSPF is very picky about wrong MTU sestings.
Linux/network engineer: ITIL, LPI1, CCNA R+S, CCNP R+S, JNCIA, JNCIS-SEC
 
nicolasmartinez
just joined
Posts: 2
Joined: Tue Oct 01, 2013 9:37 pm

Re: v6.20 released!

Thu Oct 23, 2014 6:24 pm

I can't seems to be able to configure anything on "/ip dhcp-server network" fields like default gateway after applying the new config gets reseted back to the previous values!!

Router model: RB2011iLS-IN
 
BenCo
just joined
Posts: 11
Joined: Sat Apr 19, 2014 11:51 pm
Location: Amsterdam

Re: v6.20 released!

Thu Oct 23, 2014 11:51 pm

*) stores are replaced with folders and disks are now managed under /disk menu;

Where can I add a folder instead of a store? Can't seem to find how to do it.
The manual still references the stores.
RB2011UiAS-2HnD-IN
 
User avatar
Stillhard
Frequent Visitor
Frequent Visitor
Posts: 82
Joined: Sun Jun 10, 2012 11:18 am
Location: Banten, Indonesia
Contact:

Re: v6.20 released!

Sun Oct 26, 2014 1:22 pm

Again problems with user-manager.

6.18 on x86 with user manager, upgraded to 6.20 and user-manager stop working, not see the files of the database.

Revert back to 6.18 solve the problem.
Check my reply here will solve it: http://forum.mikrotik.com/viewtopic.php ... 21#p452421
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2946
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.20 released!

Mon Oct 27, 2014 1:06 pm

Again problems with user-manager.

6.18 on x86 with user manager, upgraded to 6.20 and user-manager stop working, not see the files of the database.

Revert back to 6.18 solve the problem.
Check my reply here will solve it: http://forum.mikrotik.com/viewtopic.php ... 21#p452421
Thanks
I'm Italian, not English. Sorry for my imperfect grammar.
 
gustavomam
Trainer
Trainer
Posts: 289
Joined: Tue Jul 23, 2013 6:29 pm
Location: Spain
Contact:

Re: v6.20 released!

Tue Oct 28, 2014 4:27 pm

Scampbell it's happen to me too on 6.20.
I was teaching MTCNA and when a student disabled all firewall filter rules it didn't take changes until reboot.
-
Eng. Gustavo Angulo
Academy Xperts Spain
Mikrotik Certified Trainer
https://www.youtube.com/watch?v=Cbt2HVYwjYU
 
User avatar
apteixeira
Trainer
Trainer
Posts: 50
Joined: Fri Oct 05, 2012 5:54 pm

Re: v6.20 released!

Tue Oct 28, 2014 10:08 pm

We have upgraded several RB951 series routers in a class situation. 2 or 3 of these have all exhibited odd firewall behavior when rules are disabled.

It shows a rule disabled in Winbox yet the rule continues to work, e.g a rule that logs traffic keeps logging even when disabled. We did not test this in CLI as time was tight.

A reboot fixes the issue.

Not all devices have shown this so perhaps user error - has anyone else seen this ?
Hello,

I am experience the same problem. I made a video that shows the bug: http://www.youtube.com/watch?v=2umo6Kvd ... e=youtu.be

Best regards.
 
yozz
just joined
Posts: 15
Joined: Fri Jan 31, 2014 11:51 pm

Re: v6.20 released!

Tue Oct 28, 2014 11:09 pm

please update in RUSSIA NTP client!! our time in moscow http://www.vniiftri.ru/
GMT +3
 
scampbell
Trainer
Trainer
Posts: 457
Joined: Thu Jun 22, 2006 5:20 am
Location: Wellington, NZ
Contact:

Re: v6.20 released!

Wed Oct 29, 2014 7:13 am

We have upgraded several RB951 series routers in a class situation. 2 or 3 of these have all exhibited odd firewall behavior when rules are disabled.

It shows a rule disabled in Winbox yet the rule continues to work, e.g a rule that logs traffic keeps logging even when disabled. We did not test this in CLI as time was tight.

A reboot fixes the issue.

Not all devices have shown this so perhaps user error - has anyone else seen this ?
Hello,

I am experience the same problem. I made a video that shows the bug: http://www.youtube.com/watch?v=2umo6Kvd ... e=youtu.be

Best regards.
That confirms that one :-)
 
coylh
Member Candidate
Member Candidate
Posts: 160
Joined: Tue Jul 12, 2011 12:11 am

Re: v6.20 released!

Wed Oct 29, 2014 9:42 pm

I found this:
in 6.20 does not show the correct values ​​for the data rates and current transmit power
I've run into something similar.
You do not have the required permissions to view the files attached to this post.
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2287
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: v6.20 released!

Thu Oct 30, 2014 7:29 pm

LAN, FTTx, Wireless. ISP operator
 
spacemind
Member Candidate
Member Candidate
Posts: 111
Joined: Mon Jul 07, 2008 8:33 pm

Re: v6.20 released!

Thu Oct 30, 2014 9:21 pm

Attention:

Mikrotik 6.21 bricked 3 rb951-G after upgrade.

Beep and lights looping.

Mikrotik upgrade failed rb951-G 6.21: http://youtu.be/O0kJacEIdh0

How to fix? RMA?!

Ticket#2014103066001015

Thanks
Last edited by spacemind on Thu Oct 30, 2014 10:30 pm, edited 1 time in total.
 
staslabs
newbie
Posts: 38
Joined: Mon Feb 27, 2006 9:38 pm
Contact:

Re: v6.20 released!

Thu Oct 30, 2014 10:08 pm

Mikrotik 6.21 on CCR1036-12G-4S - so terrible!!!!! Restarts after some minutes of work. Again and again.
 
User avatar
heislerb
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Mon Sep 16, 2013 4:41 pm

Re: v6.20 released!

Thu Oct 30, 2014 10:36 pm

RB750G 6.20 upgraded to 6.21 by copying the npk file to the file list and rebooted.

Could not access RB750G. Downloaded and run netinstall. Was able to access the unit and downgrade to 6.20. All OK on 6.20.

I have upgraded many times form 6.5 and this was a real surprise.

edited to change 450 to 750
 
User avatar
heislerb
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Mon Sep 16, 2013 4:41 pm

Re: v6.20 released!

Fri Oct 31, 2014 1:13 am

RB750G ROS 6.20 upgraded to 6.21 (second try) and it looks good.

This is my test router. I lost a bit of code I was working on before the first try.

I would like to know why things went wrong the first time.
 
ffernandes
Member Candidate
Member Candidate
Posts: 146
Joined: Mon Jun 23, 2008 11:20 pm

Re: v6.20 released!

Fri Oct 31, 2014 1:15 am

tenta com netinstall.... se nao der... deita ao lixo :P
Attention:

Mikrotik 6.21 bricked 3 rb951-G after upgrade.

Beep and lights looping.

Mikrotik upgrade failed rb951-G 6.21: http://youtu.be/O0kJacEIdh0

How to fix? RMA?!

Ticket#2014103066001015

Thanks
 
spacemind
Member Candidate
Member Candidate
Posts: 111
Joined: Mon Jul 07, 2008 8:33 pm

Re: v6.20 released!

Fri Oct 31, 2014 2:17 am

tenta com netinstall.... se nao der... deita ao lixo :P
Attention:

Mikrotik 6.21 bricked 3 rb951-G after upgrade.

Beep and lights looping.

Mikrotik upgrade failed rb951-G 6.21: http://youtu.be/O0kJacEIdh0

How to fix? RMA?!

Ticket#2014103066001015

Thanks
I manage after a few tens of tries with netinstall to roll back to 6.20, but only in 1 951G.
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: v6.21 released USB FLASH problem

Fri Oct 31, 2014 4:19 am

RB433UAH RouterOS 6.21

still a problem USB FLASH disk Kingston DataTraveler 2.0 (4GB) from version 6.20rc1 drop compatibility in proxy? FTP transfers on disk function! ( in <6.19 works)


USB2 disk Kingston DataTraveler G3 works

edit:
after several format (ext3 and fat32) and eject the USB flash drive, reboot the routerboard now it works,stores data on disk function > do not rename the disk and use fat32

with a second disc such problems are not!

if a disk and the proxy will make mistakes, so I go back to version 6.19 where it works

<Google Translate>
Last edited by napismizpravu on Fri Oct 31, 2014 5:44 am, edited 1 time in total.
 
drusha
just joined
Posts: 14
Joined: Sun Mar 14, 2010 3:13 am

Re: v6.20 released!

Fri Oct 31, 2014 4:44 am

playing with 6.21 on my test x86
noticed a minor winbox bug, while trying to edit Hotspot Server Profile: window default minimal width is bigger than expected and cannot be made smaller

update: few hours later - window appears normally :D is it because I've enabled the hotspot?
You do not have the required permissions to view the files attached to this post.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v6.20 released!

Fri Oct 31, 2014 11:14 am

MikroTik RouterOS 6.21 is released.
http://forum.mikrotik.com/viewtopic.php?f=2&t=90792

Who is online

Users browsing this forum: MSN [Bot] and 102 guests