Community discussions

MUM Europe 2020
 
dbdom
just joined
Topic Author
Posts: 23
Joined: Sun Dec 09, 2012 9:51 pm

User Manager Crash after 6.19 to 6.20

Fri Oct 17, 2014 6:56 pm

After upgrade 6.19 to 6.20 on x86 my user-manager database "disappered". Can't login to userman via web, etc (now is over 20 min after restart). When I try to restore database I've got

> tool user-ma data load
name: User_Manager_2014_10_15_193359.tar
Restore user-manager database? [y/N]:
y
Loading user-manager database backup
Failed to load user-manager database backup
failed to open file for writing: No such file or directory
>tool user-ma data pri
database is not acceseble, yet
>

I've also removed and reinstalled userman package.
Any idea how to reinstall userman? It may be with empty database.
 
User avatar
Stillhard
Frequent Visitor
Frequent Visitor
Posts: 82
Joined: Sun Jun 10, 2012 11:18 am
Location: Banten, Indonesia
Contact:

Re: User Manager Crash after 6.19 to 6.20

Sun Oct 19, 2014 5:56 am

First check the db-path

ros code

/tool user-manager database print
If not exist

ros code

/tool user-manager database set db-path=/user-manager1
rebuild - downgrade to 6.19 - check if the database ok - re-upgrade to 6.20
 
User avatar
mahnet
Long time Member
Long time Member
Posts: 654
Joined: Tue Jul 07, 2009 9:11 pm

Re: User Manager Crash after 6.19 to 6.20

Sun Oct 19, 2014 12:30 pm

same thing happened with me and these guys say to restore the backup. but it says no backup file found even though the backup exists. i tried downgrade and restore but nothing happened.

Mikrotik always comes up with a new set of bugs and they even said that they are not focusing on any development wrt the user manager.
The only way to get user-manager working is to system reset ur x86
 
dbdom
just joined
Topic Author
Posts: 23
Joined: Sun Dec 09, 2012 9:51 pm

Re: User Manager Crash after 6.19 to 6.20

Sun Oct 19, 2014 10:42 pm

Stillhard -> thanks a lot ! It helps. I didn't know "set db-path=" option. After "set db-path=user-manager1" the "user-manager1.old" directory appered in "Files ". So I set db-path this .old dir, rebuilt db (because it did not show old session and something else) and now I have my old database fully accessible!
 
User avatar
Stillhard
Frequent Visitor
Frequent Visitor
Posts: 82
Joined: Sun Jun 10, 2012 11:18 am
Location: Banten, Indonesia
Contact:

Re: User Manager Crash after 6.19 to 6.20

Mon Oct 20, 2014 5:24 pm

You're welcome :D i know, i just cheated their undocumented document(s) :lol:

Who is online

Users browsing this forum: No registered users and 68 guests