Community discussions

 
MMorris
newbie
Topic Author
Posts: 40
Joined: Sun May 06, 2007 7:42 pm

route to device without default gateway??

Fri Oct 24, 2014 9:34 pm

Im not sure if anyone has and idea or if its possible but!!!

I have a controller that is a static ip address of 192.168.16.254 and an app on my phone that connects directly to it! But my issue is my phone disconnects from it and connects to my main wifi because of no internet.

I was thinking if i could source nat the deivce or something

I would like to either have my phone on my 172.27.1.x subnet (MAIN NETWORK) and have it route to the 192.168.16.x network but my issue is i cant add a default gateway on the controller so i dont see how i can route it? The app is programed to look for that address!!!!

My other thought was to create another network for the controller and phone and set my phone to use the router as its default gateway so it can connect to the controller on the same subnet but the phone would have default gateway to get to the ineternet. I would prefer the fist option so i can route it over the internet!


Hope this make some sense!
 
Petzl
Member Candidate
Member Candidate
Posts: 207
Joined: Sun Jun 30, 2013 12:14 pm

Re: route to device without default gateway??

Sat Oct 25, 2014 7:29 am

what does the device if you use dhcp ? (you can make this static)

does it then accept a default gateway?
 
abasit
just joined
Posts: 4
Joined: Fri Oct 24, 2014 9:00 am

Re: route to device without default gateway??

Sat Oct 25, 2014 7:44 am

Hi,

I think it will be much more easy for you if you give the static IP to controller from the same Subnet as your phone is getting for internet access. You will have a local access to you controller without needing any routable accesspoint which forward you data to the controller and don't nat it for that address.

Best Regards
Abdul Basit
 
MMorris
newbie
Topic Author
Posts: 40
Joined: Sun May 06, 2007 7:42 pm

Re: route to device without default gateway??

Wed Oct 29, 2014 4:30 pm

I was able to figure it out with source nat and some routing its working!!

Who is online

Users browsing this forum: No registered users and 163 guests