Community discussions

MikroTik App
 
oriondotnet
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 65
Joined: Tue Jan 17, 2006 9:27 pm

v2.9.26 released..

Thu Jun 15, 2006 5:28 pm

What's new in 2.9.26:

*) removed support for MMS connection tracking - it did not work as it should;
*) fixed unsetting of ppp secret local and remote addresses;
*) added ping option to ppp active sessions in WinBox;
*) added total statistics for Torch in WinBox;
*) fixed problem with static ARP entries not added after reboot
on the bridge interface;
*) dns cache max tll setting did not apply to negative records;
*) fixed some memory leaks in dns cache;
*) fixed BGP bugs in routing-test;
*) fixed RIP bugs in routing-test;
*) fixed bug - some stale PPPoE, PPTP and L2TP dynamic interfaces were not removed;
*) added logging of ups events;
*) added support for more then 2 USB serial ports;
*) fixed to save system logging echo messages every 30s and not immediately;
*) fixed scrolling in WinBox;
*) fixed bug - command output executed directly through ssh sometimes got
trimmed;
*) user manager - customer page added
*) user manager - active session page added
*) user manager - report performace improved
*) user manager - GUI improved

Anyone can help me test the bgp & ospf please.. :) want to put this 1 into our production router
 
advantz
Member Candidate
Member Candidate
Posts: 187
Joined: Thu Jul 08, 2004 4:11 am

Re: v2.9.26 released..

Thu Jun 15, 2006 8:12 pm

What's new in 2.9.26:

*) removed support for MMS connection tracking - it did not work as it should;
*) fixed unsetting of ppp secret local and remote addresses;
*) added ping option to ppp active sessions in WinBox;
*) added total statistics for Torch in WinBox;
*) fixed problem with static ARP entries not added after reboot
on the bridge interface;
*) dns cache max tll setting did not apply to negative records;
*) fixed some memory leaks in dns cache;
*) fixed BGP bugs in routing-test;
*) fixed RIP bugs in routing-test;
*) fixed bug - some stale PPPoE, PPTP and L2TP dynamic interfaces were not removed;
*) added logging of ups events;
*) added support for more then 2 USB serial ports;
*) fixed to save system logging echo messages every 30s and not immediately;
*) fixed scrolling in WinBox;
*) fixed bug - command output executed directly through ssh sometimes got
trimmed;
*) user manager - customer page added
*) user manager - active session page added
*) user manager - report performace improved
*) user manager - GUI improved

Anyone can help me test the bgp & ospf please.. :) want to put this 1 into our production router
OK I'll try this version because it's FIXED(?) BGP, see ya
 
alex_rhys-hurn
Member
Member
Posts: 325
Joined: Mon Jun 05, 2006 8:26 pm
Location: Kenya
Contact:

kernel panic when upgrading from 2.9.25 to 2.9.26

Thu Jun 15, 2006 11:50 pm

Download Packages: routeros-x86
verify file sizes and descriptions.
Upload to Router.
Reboot Router
Then:

Loading System with Initrd
Uncompressing linux....
Execve: 00000002
Kernel Panic: Attempted to Kill Init

Does anyone have any ideas?

How do I reinstall this without screwing up my license?
 
pekr
Member Candidate
Member Candidate
Posts: 138
Joined: Tue Feb 22, 2005 9:05 pm
Location: Czech Republic
Contact:

Fri Jun 16, 2006 12:06 am

Better wait for some guru to confirm, but IIRC we just burned image to CD, and installed once again. All settings and license were ok ...

good luck,
Petr
 
alex_rhys-hurn
Member
Member
Posts: 325
Joined: Mon Jun 05, 2006 8:26 pm
Location: Kenya
Contact:

Fri Jun 16, 2006 12:13 am

Thanks for sitting up and keeping me company....


well do I burn the .26 image or do I put back the .25 image

If its the .25 image, do you have one cos I dont see it on the mt site anymore.....

Its s demo box so I am going to try the .26 image.

Cheers

Alex
 
User avatar
Mitak
newbie
Posts: 42
Joined: Wed Jun 07, 2006 10:12 am
Location: Bulgaria
Contact:

reinstall

Fri Jun 16, 2006 12:27 am

I think taht when you reinstall /or upgrade/ MT your license key & configuration will be NOT touched?
 
alex_rhys-hurn
Member
Member
Posts: 325
Joined: Mon Jun 05, 2006 8:26 pm
Location: Kenya
Contact:

Fri Jun 16, 2006 12:43 am

Just like you said.

Burn the .26 image to cd, reboot install and remember to KEEP THE OLD SETTINGS....

Worked fine.

Thanks
 
advantz
Member Candidate
Member Candidate
Posts: 187
Joined: Thu Jul 08, 2004 4:11 am

Re: kernel panic when upgrading from 2.9.25 to 2.9.26

Fri Jun 16, 2006 3:52 am

Download Packages: routeros-x86
verify file sizes and descriptions.
Upload to Router.
Reboot Router
Then:

Loading System with Initrd
Uncompressing linux....
Execve: 00000002
Kernel Panic: Attempted to Kill Init

Does anyone have any ideas?

How do I reinstall this without screwing up my license?
Anyone can confirm if this "kernel panic" occures in x86 system?
Because I'm running 15km remote router, don't want to screw up the router.
thank you
 
cdemers
Member Candidate
Member Candidate
Posts: 189
Joined: Sun Feb 26, 2006 3:32 pm
Location: Canada
Contact:

Fri Jun 16, 2006 5:21 am

I have experienced no kernel panics on my upgraded test routers, both x86 and rb500 units. I have a few more to do that are not critical and will be testing further before upgrades to primary routers.
 
Gotmoh
newbie
Posts: 38
Joined: Fri Jul 15, 2005 8:56 am

Sat Jun 17, 2006 8:47 am

I did upgrades on two routers. Some away from me and some high ;-) . Previous both was 2.9.24. No problems with both routers.
 
Beccara
Long time Member
Long time Member
Posts: 606
Joined: Fri Apr 08, 2005 3:13 am

Sat Jun 17, 2006 9:02 am

Upgraded All non-core system - Upgraded Fine, BGP/NStream Wifi Setup's with nothing really special running and they are all humming along, another day and core systems will be upgraded
 
nikhil
Member Candidate
Member Candidate
Posts: 262
Joined: Wed Dec 22, 2004 5:04 pm
Location: US

Sat Jun 17, 2006 11:22 am

2.9.25 -> 2.9.26 upgrade , bgp , policy routes etc all working. Intel NIC problem still exists already mailed MT for it.
 
believewireless
Member Candidate
Member Candidate
Posts: 231
Joined: Wed Jul 06, 2005 6:30 pm

Sat Jun 17, 2006 4:57 pm

2.9.26 with web proxy and BGP seems to be eating memory and crashing on us. 2.9.25 was fine.
 
nikhil
Member Candidate
Member Candidate
Posts: 262
Joined: Wed Dec 22, 2004 5:04 pm
Location: US

Sat Jun 17, 2006 7:49 pm

2.9.26 with web proxy and BGP seems to be eating memory and crashing on us. 2.9.25 was fine.
quickly send a supout.rif to MT
 
User avatar
Alessio Garavano
Member
Member
Posts: 304
Joined: Sat May 29, 2004 12:49 am
Location: Corrientes, Argentina
Contact:

Sat Jun 17, 2006 8:49 pm

2 MTs x86(webproxy, hotspot, dhcp, bridge rstp, NAT, QoS) and 4 RB512 and RB532(AP, bridge, WDS, bridge rstp, QoS, Atheros Cards) upgraded without problem, all work fine and best...
Good work guys! :wink:
Regards!
Alessio
Alessio Garavano
http://www.isparg.com.ar
 
jarosoup
Long time Member
Long time Member
Posts: 600
Joined: Sun Aug 22, 2004 9:02 am

Sat Jun 17, 2006 9:45 pm

I've upgraded one Hotspot router which seems to be doing fine right now. Still waiting to see if the DNS cache holds up, but here's to hoping! Thanks for addressing this problem Mikrotik :)
 
oriondotnet
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 65
Joined: Tue Jan 17, 2006 9:27 pm

Sun Jun 18, 2006 9:00 am

Looks like this version is stable.. anyone can confirm the ospf is working fine ?

Thanks
 
nikhil
Member Candidate
Member Candidate
Posts: 262
Joined: Wed Dec 22, 2004 5:04 pm
Location: US

Sun Jun 18, 2006 9:14 am

Looks like this version is stable.. anyone can confirm the ospf is working fine ?

Thanks
Uptime 2d 10:46:13

looks stable, use bgp but i had to disable routes taken in through filters because of 100% cpu utilization if both peers send routes. IF i do one peer its fine but 2 bgp in and its dead slow.
 
cdemers
Member Candidate
Member Candidate
Posts: 189
Joined: Sun Feb 26, 2006 3:32 pm
Location: Canada
Contact:

Sun Jun 18, 2006 4:56 pm

Just finished upgrades to our primary routers and everything went fine, no problems anywhere. :D Now time to go break it lol :twisted:
 
oriondotnet
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 65
Joined: Tue Jan 17, 2006 9:27 pm

Sun Jun 18, 2006 5:27 pm

Well.. already try to upgrade to v2.9.26 Is is normal is CPU load go to 100% when receiving route information ?

Thanks
 
changeip
Forum Guru
Forum Guru
Posts: 3820
Joined: Fri May 28, 2004 5:22 pm

Sun Jun 18, 2006 5:31 pm

It is normal to get 100% cpu while receiving BGP routes, but it shouldn't stay at 100% forever. Typically when the routing table is sucking in 180,000+ routes it will be 100% cpu for 30 seconds on a super fast computer. If you run a p3 1000 or something it might be a few minutes. You will notice that 100% cpu doesn't mean you are dropping packets and no longer routing, those functions seem unaffected by 100% cpu for some reason. I did have a dev router with 230,000 routes (2 bgp peers using ibgp) nad it hit 100% cpu for 4 hours, but did come back eventually... not sure why that took so long. The CLI functions do seem to timeout while this is happening which is not so great.

Sam
 
nikhil
Member Candidate
Member Candidate
Posts: 262
Joined: Wed Dec 22, 2004 5:04 pm
Location: US

Mon Jun 19, 2006 7:51 am

Which version took up 4 hours ?
I have a p4 3ghz 1gig memory still i see 100% for hours. Also any changes in policy routes results in 100% cpu for hours + I have seen unresponsiveness to CLI as well as winbox, then there were sudden reboots as well after it staid for 100% for some time. 2.9.26 runnign ok so far with reject routes.
It is normal to get 100% cpu while receiving BGP routes, but it shouldn't stay at 100% forever. Typically when the routing table is sucking in 180,000+ routes it will be 100% cpu for 30 seconds on a super fast computer. If you run a p3 1000 or something it might be a few minutes. You will notice that 100% cpu doesn't mean you are dropping packets and no longer routing, those functions seem unaffected by 100% cpu for some reason. I did have a dev router with 230,000 routes (2 bgp peers using ibgp) nad it hit 100% cpu for 4 hours, but did come back eventually... not sure why that took so long. The CLI functions do seem to timeout while this is happening which is not so great.

Sam
 
advantz
Member Candidate
Member Candidate
Posts: 187
Joined: Thu Jul 08, 2004 4:11 am

Wed Jun 21, 2006 4:39 am

2.9.26 w/ routing test is fast but didn't work in my sytem, buggy,
having ethernet,bgp(still) problems with this version, going back to 2.9.24 w/ r-t

already sent supout.rif
 
nikhil
Member Candidate
Member Candidate
Posts: 262
Joined: Wed Dec 22, 2004 5:04 pm
Location: US

Thu Jun 22, 2006 10:05 am

 
krugmartin
Trainer
Trainer
Posts: 5
Joined: Sat May 27, 2006 3:23 pm

Customer problem

Sat Jun 24, 2006 5:47 pm

Hello,

we had 2.9.24 with trafic marking and tree quees afeter upgrade to .26 the system we got problem with customers, some of them are working fine 5 from 30 and all others can't get annything.

Have someone simmilar problem ? I tried to lok arround in forums but got no luck to solve this problem.

I disabled all markings and all queues an right now we are running on backup - simple queue.

Martin.
 
User avatar
jager
Trainer
Trainer
Posts: 296
Joined: Mon Oct 31, 2005 2:44 am
Location: Sierra Leone
Contact:

Sun Jun 25, 2006 9:03 am

I was a little nervous during 40 km away RB upgrade from 2.9.12 to 2.9.26 but everything went fine :)
Succesfully upgraded 12 pcs of RB532 and 112! Good work!

Who is online

Users browsing this forum: Google [Bot], hazar, krisjanisj, Majestic-12 [Bot], mrz, xvo and 102 guests