Page 1 of 1

Unreachable IP within reachable network

Posted: Sat Jan 10, 2015 3:32 pm
by WirelessRudy
Sometimes an dhcp-server assigned (to CPE antenna "D") can't be reached were routing tells all ip's in certain network can be reached.
route to (=.193 <-> .254)
Assigned IP that CAN be reached;
Assigned IP that CANNOT be reached;
Assigned IP that CAN be reached;

IP above and below this specific IP can be reached but that specific .216 can not....
Tell dhcp-server to assign an other IP in range to this CPE unit CAN be reached. (for instance .218) So CPE works fine. Routing works fine.
Set this .216 IP on another CPE in the same network (same AP client network) and suddenly that CPE cannot be reached any more!
So it looks like that specific .216 IP cannot be reached or is un routable.

But .216 IP can be pinged from any other directly attached (in same network) router. For instance the dhcp-server can ping and traceroute the unit and the AP itself can open the CPE with a telnet session to .216. So IP works....

But from a more distant (some nodes/routers) away that .216 IP cannot be reached. Where .215 and .217 don't give any problem.

Can't find nowhere any specific firewall or dsn-nat or src-nat rule that might prevent that specific IP to be reached.

I have had this problem now a couple of times over the last year. Sometimes I have to give given CPE just another IP and everything works again. Than sometimes weeks or months later I can use the once 'unreachable IP' to a new CPE (when a new client hooks up) and that new CPE is completely fine. No more issue!

Sometimes I also just had to reboot the main router that sits in between the path towards unreachable IP and monitor system device and after reboot the IP suddenly becomes reachable again..... So what happened before??

The issue happens on several different ROS versions, so I can't say its related to any version. Presently I am on 6.24.

In the early years when I had a pure routed network I never had such issues.
But since about 2 years I work with several vlans and that is also since when the issue submerges at times....

I also don't know if it is an issue on my network. I had two instances where a client was assigned a public IP that suddenly stopped working. I had to give it another public IP and client could reach the internet. In one instance I could just give this public IP to another client and it worked. Gave new public IP to problem client and it also worked! ???
In another instance I just had to reboot the main border router and it worked..... not a single change made before the reboot.

What strange behaviour is this??