Community discussions

 
lambert
Long time Member
Long time Member
Topic Author
Posts: 532
Joined: Fri Jul 23, 2010 1:09 am

Issue with DHCP and PPPoE servers on the same bridge?

Fri Jan 23, 2015 10:38 am

We have a WISP with several towers. There are multiple APs per tower. All of the APs are in one bridge with port horizon and / or bridge filters to keep the users from speaking to one another. We use DHCP + RADIUS auth to hand IPs to the customer. It works. But we are missing the accounting records we get from PPPoE on the DSL side.

So, I'm trying to bring up PPPoE on the same bridge with the DHCP clients for a smooth, gradual transition. I tried first on the work bench at the office where we connect the virus infected machines that come in for repair. We didn't actually build that config to test this situation. We test routers with PPPoE WAN interfaces from DSL customers having issues on that LAN as well, so we needed a PPPoE server. I haven't noticed any issues with that setup in the last year. That MikroTik runs RouterOS 5.25. We keep it at that version because it also terminates VPN connections and the VPN users were about to kill me during the RouterOS 6.7 - 6.15 period. I'm not brave enough to move it forward yet.

Today I tried a small tower with 5 clients, one is an employee. There is one AP and a directly connected customer at the base of the tower, so two connected ports in the bridge. The MikroTik is running RouterOS 6.24. Everything appeared to work. The employee has a MikroTik and I setup his DHCP client to use 100 for the gateway metric. Then I added a PPPoE client and got him connected with that. It seemed to work well. He was able to pass traffic and do everything he needed. It is a small tower, so there wasn't much other traffic, but there was some. Looked okay.

On that success, I tried the same thing on another tower where we have two employees with whom I could experiment... This tower has 5 APs connected on different interfaces in the bridge. The MikroTik is running RouterOS 6.18. These employees have Ubiquiti AirRouters. I configured one to use PPPoE and ... It worked! Except that while the PPPoE session is active, no other traffic flows on the bridge. We should have 30 - 40 Mbps of traffic on that bridge. We were seeing less than 100 Kbps. I kicked the PPPoE session off and during the 30 seconds it took the AirRouter to notice and reconnect, we passed 30Mbps of traffic. When the AirRouter reconnected, there was no traffic on the bridge. I repeated the experiment a few times with the same results. Any time there is an active PPPoE session on the PPPoE server configured on the bridge, no traffic flows, except in the PPPoE session.

Once I noticed that, I went back to the 5 client tower and looked at the traffic. There was 3 Mbps of traffic on the directly connected client at the bottom of the tower. But there wasn't much going on across the AP connected interface. That is not unusual on this tower, so it may not be a useful datapoint. I killed the PPPoE server and there still wasn't much traffic. I left PPPoE disabled to be safe.

I have not rolled RouterOS 6.24 to the bigger tower yet because we have had DHCP problems post 6.18 and were forced to roll everything back to 6.18 when 6.21.1 was current. The problem we were seeing is listed as repaired in the later change logs. But, with MikroTik's tendency to add new features to the "stable" 6.x release chain, ... We are being cautious.

So, I don't know if there is a bug I am seeing in 6.18, if there is something deeper which causes this issue across multiple versions, or if I just made a mistake in my configuration. I haven't had time to gather more data, yet. I've been searching the forums but the search terms I am choosing aren't turning up useful threads for me.

Does anyone have experience with this type of configuration? Does it normally work or does it normally fail?

Who is online

Users browsing this forum: No registered users and 111 guests