Page 1 of 1

Throughput issue on several routerboards. Help/Advice needed!

Posted: Thu Feb 12, 2015 7:00 pm
by WirelessRudy
One router (either SXT.lite, Sextant or QRT) used as CPE and connected by wireless to AP.
AP is connected via several links to border router where connection to internet is made.

Basic test:
Laptop with ethernet cat5e connected to ethernet interface of said board.
Radio of said board connects with a 802.11an NV2 link to AP where more units are associated.
CPE is routed. LAN has own IP as gateway and IP are hand out to connected devices.
WAN (=radio) is dhcp-client, and get IP plus dns and gw from AP.
Traffic from AP towards border router and internet is plain routed network.

Laptop is loaded with several bandwidth test programs.
Laptop can make a test from itself towards the routerboard; Up or Download is about 80-90Mbps. Combined is roughly 45 on both directions (I would expect both to be around 80-90 again since the status shows "duplex" But heho.)
CPU on both laptop or routerboard is not reaching 80% or more. Ethernet cable connection rate ("auto") shows full duplex and 100Mbps. Used cable is shielded Cat6.

So far, cable show plenty of capacity for test.

Next, run bandwidth test from within routerboard (QRT) towards AP (rb800), towards border router (CCR) and towards internet. (3 different test performed each separately)
Speeds depending on other users consumption anywhere between 20 and 40Mbps download or 10-20Mbps upload.
Combined some 8Mb down while 3-6Mb up, relatively stable. (This is in real AP network with 20+ clients associated with all kinds of MCS conn. rates)
Internet speed is less since simple queue in border router only permits 10Mb max.
While perfoming tests run ping with 200ms timeout and 1500byte package. Ample lost packages....

This shows the network from routerboard over my network towards the internet works fine and has plenty capacity to serve this routerboard with its 10Mb permitted download speed.

Now, run bandwidth speed test (either MT test or any other) from the laptop towards AP, Border router or internet and maximum obtainable is 2.5, 3, sometimes 4Mb download. Upload is something similar but slightly less. Combined shows sort of same for both direction. So this is a test perform "through" the router.

Why is the delay in the routerboard happening?

This is with CPE in router mode (srcnat LAN to WAN), no firewall filter nor mangle. 802.11an and NV2. Wireless fp package and both ethernet as wireless have 'hardware queue only' selected.

Tried to make CPE as a bridge. Removed the srcnat and made sure bridge has rstp enabled and fastpath selected. No difference.
Set the interface queues back to their 'old' type defaults. No difference.

MTU of interface is 1500 but increased them to 1550. No difference. (Well, to be expected. Ping runs during all these test to my border router with 1500byte package, 'no defrag' selected and 200ms timeout set. Hardly ever fails).

CPU of CPE shows only 5-15% while test is done from laptop, where done from CPE it shows 80-100% (Depending on direction and much more speed!)

Also tested the laptop. Connected to the CCR and could easy generate 300-400Mbps to and from it. So its not the laptop.

Tried older v.6.x ROS. All the same. Yesterday uploaded v6.27 to CPE. No solution. (Always have latest firmware uploaded too)

Tried several units now. SXT, Sextant, QRT. All the same.

While running the test from the laptop I monitor the traffic over the ethernet and wireless interface. Ethernet traffic on the ethernet falls back to "0" if bandwidth test is stopped. So no other traffic is generated. Only test traffic if it runs.
While running bandwidth test from laptop (generates some 3Mb of traffic) I can start the bandwidth test in the CPE at the same time and it immediately it consumes the rest of the available network capacity. Some 15 to 25Mbs!

The bottleneck is imho definitely in the routerboard. Why can I not run more data over the routerboard?

I am clueless on what to test more.

Any suggestions?