Community discussions

MikroTik App
 
User avatar
azurtem
Trainer
Trainer
Topic Author
Posts: 217
Joined: Mon May 16, 2011 5:35 pm
Location: Nice, France
Contact:

VoIP loses registration with ADSL

Fri Feb 20, 2015 4:29 pm

Hi

My client has eleven agencies in the West Indies, and each is equipped with an RB951G-2HnD

Each router has two uplinks, an SDSL and an ADSL link

The VoIP phones are Yealink SIP-T41P and DECT W52P

When connected via the ADSL link the phones frequently lose their registration status and can't be reached

I have to connect to the RB951G and remove their tracked connections in the Firewall tab to resolve

For now I have scheduled a script to reset the connections to port 5060 every ten minutes

Is this a RouterOS issue ? A RouterOS/ADSL issue ? Or some other issue ?

Any ideas ?.

thanks
yann
 
pants6000
Frequent Visitor
Frequent Visitor
Posts: 67
Joined: Fri Sep 26, 2014 5:30 am

Re: VoIP loses registration with ADSL

Wed Feb 25, 2015 8:48 am

Are your ADSL modems also routers or are they just bridges?
 
marrold
Member
Member
Posts: 417
Joined: Wed Sep 04, 2013 10:45 am

Re: VoIP loses registration with ADSL

Wed Feb 25, 2015 9:04 am

Try enabling/disabling the SIP helper-
/ IP firewall service-port
What phones are you using? What's the registration interval?
I'm a SIP / VoIP engineer. Feel free to ask questions...
 
User avatar
azurtem
Trainer
Trainer
Topic Author
Posts: 217
Joined: Mon May 16, 2011 5:35 pm
Location: Nice, France
Contact:

Re: VoIP loses registration with ADSL

Wed Feb 25, 2015 9:41 am

Are your ADSL modems also routers or are they just bridges?
The TP-Link 8616 modems are simple bridges, the RB912 is configured with a PPPoE client interface
 
User avatar
azurtem
Trainer
Trainer
Topic Author
Posts: 217
Joined: Mon May 16, 2011 5:35 pm
Location: Nice, France
Contact:

Re: VoIP loses registration with ADSL

Wed Feb 25, 2015 9:50 am

Try enabling/disabling the SIP helper-
/ IP firewall service-port
What phones are you using? What's the registration interval?
The phone models were specifically mentioned in my post
The SIP helper won't help here: previously tested and ruled out

After further research this seems to be an ADSL issue rather than a modem or router issue
This week in fact we have reduced, as per recommendations perused elsewhere, the "Subscribe Period"
(also known as "Session Timer" or "Login Expire") from 1800secs to 240secs
Some even recommend a more aggressive setting of 120secs

So far no more disconnections, but it has only been three days
 
marrold
Member
Member
Posts: 417
Joined: Wed Sep 04, 2013 10:45 am

Re: VoIP loses registration with ADSL

Wed Feb 25, 2015 12:00 pm

Ok, hopefully that's solved it. If they start losing registration again it might be worth getting a packet capture. I'd be happy to take a look.
I'm a SIP / VoIP engineer. Feel free to ask questions...

Who is online

Users browsing this forum: andya, Bing [Bot], Google [Bot], markos222, wispvt and 182 guests