Community discussions

MUM Europe 2020
 
IngoPlath
just joined
Topic Author
Posts: 1
Joined: Tue Feb 24, 2015 9:36 am

Huawei E3531s-2 USB LTE Stick & RB750UP

Thu Feb 26, 2015 1:06 pm

Hello all,
For Test i have here a RB750UP Routerboard which should be working with the Huawei E3531s-2 LTE USB Stick.

The LTE Stick should establish a Internet Connection and share it to some PC´s behind the Routerboard and the RB should make some connection test to other devices over the internet connection.

The Stick is already in the list of supported devices but it have no serial interface so PPP settings, which works with other USB Internet devices, does not match to this device.

Have anyone here experience with this USB LTE device on a RB?
 
frittentheke
newbie
Posts: 28
Joined: Mon Dec 24, 2012 1:12 am
Location: Germany

Re: Huawei E3531s-2 USB LTE Stick & RB750UP

Sun Nov 22, 2015 11:33 pm

I have a Swisscom USB stick, which is labeled:
HUAWEI E3531
Model: E3531s - 2
The RB751G-2HnD I tried does only recognize a USB device, but no ports (count = 0).

Is there any debugging I could do?
 
frittentheke
newbie
Posts: 28
Joined: Mon Dec 24, 2012 1:12 am
Location: Germany

Re: Huawei E3531s-2 USB LTE Stick & RB750UP

Sun Nov 22, 2015 11:42 pm

Maybe it's because the stick has a mass storage mode and does not switch to modem mode?

https://bugs.launchpad.net/ubuntu/+sour ... ug/1308895
 
User avatar
vixxant
newbie
Posts: 38
Joined: Thu Mar 17, 2011 7:36 pm
Contact:

Re: Huawei E3531s-2 USB LTE Stick & RB750UP

Mon Nov 23, 2015 2:05 pm

http://forum.mikrotik.com/viewtopic.php?t=57494

you will have to connect to the stick using terminal . like putty. and execute the command .

check these links as reference

https://content.konekt.io/blog/using-at ... awei-e303/

http://www.3g-modem-wiki.com/page/Huawei+AT-commands
 
frittentheke
newbie
Posts: 28
Joined: Mon Dec 24, 2012 1:12 am
Location: Germany

Re: Huawei E3531s-2 USB LTE Stick & RB750UP

Wed Nov 25, 2015 2:38 am

Thanks for the quick response. Likely the mode is the issue here. But I tried various AT commands to swtich the USB device to a modem only mode.
Strangely AT^U2DIAG=0 does only give me an error, but

AT^SETPORT? - show current mode
AT^SETPORT=? - show available modes
AT^SETPORT="A1,A2;1,2,3" - set "only modem" mode.

did make a change.

But whatever I tried, SETPORT or not, the Mikrotik RB does not recognise any ports. So I cannot even do a serial communication with the device over the RB:
[admin@751g] /system resource usb> print
 # DEVICE VENDOR                   NAME                  SPEED
 0 1:1    Linux 3.3.5 ehci_hcd     RB400 EHCI            480 Mbps
 1 1:4    HUAWEI                   HUAWEI Mobile         480 Mbps

[admin@751g] /port> print
Flags: I - inactive
 #   DEVICE NAME                    CHANNELS USED-BY                  BAUD-RATE

The web interface reports Vendor ID 0x12d1 and Device ID 0x15d2, but again, shows "Ports 0".


Am I missing anything? On the linux PC the device works fine. Windows and Linux (usb_switchmode)
 
cedzop
just joined
Posts: 2
Joined: Wed May 16, 2018 1:07 am

Re: Huawei E3531s-2 USB LTE Stick & RB750UP

Wed May 16, 2018 1:12 am

Any updates on this dongle? Looks like im facing the same issue.
Just got the E3531S-2
 
foraster
just joined
Posts: 13
Joined: Tue Oct 01, 2019 5:31 pm

Re: Huawei E3531s-2 USB LTE Stick & RB750UP

Tue Nov 05, 2019 3:05 pm

I was using an old huawei 3G USB stick with my mikrotik router, but it has stopped working after a power outage.
Looking for a replacement I find the Huawei E3531i-2 quite cheap and with enough capabilities for being used as a backup wan.
Did anyone make it work with a mikrotik router?

Thanks!

Who is online

Users browsing this forum: No registered users and 109 guests