Community discussions

 
User avatar
PCNetworks
newbie
Topic Author
Posts: 35
Joined: Tue Feb 19, 2013 7:57 am
Location: California

DHCP Options Not Seen @ Client

Sat Mar 28, 2015 8:25 pm

After looking over: http://wiki.mikrotik.com/wiki/Manual:IP/DHCP_Server
I have configured the following DHCP options:
 # NAME                  CODE VALUE                  RAW-VALUE                 
 0 Network Owner           54 'Saini'        5043204e6574776f726b696e67
 1 Time Zone Offset         2 '-0800'                fffffce0                  
 2 NTP Server              42 '64.6.144.6'           40069006   
I also set Network to utilize all 3 options.

When a client interface is refreshed are these options set into their interface?

Are options pushed by the DHCP Server to the client by default OR must options be requested by the client interface?

Any input into understanding this a little better would be great.

Thank you
 
User avatar
shahbazian
Trainer
Trainer
Posts: 166
Joined: Fri Sep 09, 2011 6:22 pm
Location: Iran
Contact:

Re: DHCP Options Not Seen @ Client

Sat Mar 28, 2015 9:03 pm

Do you set that options in
/ip dhcp-server network
Learn MikroTik to improve your network.
( MTCNA, MTCRE, MTCWE, MTCTCE, MTCUME, MTCIPv6E, MTCINE )
MikroTik Certified Trainer & Consultant
RIPE NCC Trainer
 
User avatar
PCNetworks
newbie
Topic Author
Posts: 35
Joined: Tue Feb 19, 2013 7:57 am
Location: California

Re: DHCP Options Not Seen @ Client

Sat Mar 28, 2015 9:56 pm

Do you set that options in
/ip dhcp-server network
Thank you for the reply shahbazian...

Yes, that is correct; examples
set 0 dhcp-option="NTP Server"
set 0 dhcp-option="Time Offset"
For each option, I also test Option Sets to try and run them as a set without success.
 
User avatar
ZeroByte
Forum Guru
Forum Guru
Posts: 4051
Joined: Wed May 11, 2011 6:08 pm

Re: DHCP Options Not Seen @ Client

Sun Mar 29, 2015 4:05 am

There is a built-in option for time servers already. Did you try using that one?
You may want to try making an option group, and setting the network to send the option group.
If you use wireshark, you should be able to see the options in the reply.
When given a spoon,
you should not cling to your fork.
The soup will get cold.
 
User avatar
PCNetworks
newbie
Topic Author
Posts: 35
Joined: Tue Feb 19, 2013 7:57 am
Location: California

Re: DHCP Options Not Seen @ Client

Sun Mar 29, 2015 7:06 am

There is a built-in option for time servers already. Did you try using that one?
You may want to try making an option group, and setting the network to send the option group.
If you use wireshark, you should be able to see the options in the reply.
Thank you for the reply zerobyte...
Yes I did see the NTP option, I am merely trying to see if any options at all, even if an option is redundant can be set in the client adapter.

When you refer to
option groups
... might you be referring to option sets?
If so I a have also created an
option set
and set it as the source for options to the DHCP.
According to the DHCP protocol, a parameter is returned to the DHCP client only if it requests this parameter, specifying the respective code in DHCP request Parameter-List (code 55) attribute. If the code is not included in Parameter-List attribute, DHCP server will not send it to the DHCP client.
Is this indicating the the DHCP server will "not" return options unless they are requested by the client?

Thank you once again for the reply zerobyte
 
User avatar
ZeroByte
Forum Guru
Forum Guru
Posts: 4051
Joined: Wed May 11, 2011 6:08 pm

Re: DHCP Options Not Seen @ Client

Sun Mar 29, 2015 4:39 pm

Is this indicating the the DHCP server will "not" return options unless they are requested by the client?
You know, I wouldn't "swear on the bible" either way - the more I think about it, the more I seem to recall an ability for clients to request certain options. I would have said the server just sends everything according to its configuration. (i.e. you can make some options just for certain hosts, groups of hosts, etc.)

Wireshark will be the ultimate way to answer this.
When given a spoon,
you should not cling to your fork.
The soup will get cold.
 
dvin
just joined
Posts: 1
Joined: Tue Mar 31, 2015 12:37 pm

Re: DHCP Options Not Seen @ Client

Tue Mar 31, 2015 6:00 pm

Hello. I have this problem too. :(

RouterOS 6.27, Software id = 05D5-NCBF
/ip dhcp-server option
add code=48 name=font-servers value=0x04AC1601CE

/ip dhcp-server network
add address=172.22.1.0/24 comment="default configuration" dhcp-option=font-servers dns-server=172.22.1.1 gateway=172.22.1.1 netmask=24
Value is
  • * 0x04 — 4 octets (one ip address)
    * AC1601CE — ip address 172.22.1.206
http://tools.ietf.org/html/rfc2132#section-8.9
8.9. X Window System Font Server Option

This option specifies a list of X Window System [21] Font servers
available to the client. Servers SHOULD be listed in order of
preference.

The code for this option is 48. The minimum length of this option is
4 octets, and the length MUST be a multiple of 4.

Code Len Address 1 Address 2
+-----+-----+-----+-----+-----+-----+-----+-----+---
| 48 | n | a1 | a2 | a3 | a4 | a1 | a2 | ...
+-----+-----+-----+-----+-----+-----+-----+-----+---
Device requested XFS, but my router don't receive 48 option:
0.0.0.0.68 > 255.255.255.255.67: [no cksum] BOOTP/DHCP, Request from 00:60:35:17:a4:c1, length 255, xid 0x5c0e0000,
 Flags [none] (0x0000)
          Client-Ethernet-Address 00:60:35:17:a4:c1
          Vendor-rfc1048 Extensions
            Magic Cookie 0x63825363
            DHCP-Message Option 53, length 1: Discover
            Parameter-Request Option 55, length 7: 
              Subnet-Mask, Default-Gateway, Domain-Name-Server, XFS
              Lease-Time, RN, RB
 
User avatar
PCNetworks
newbie
Topic Author
Posts: 35
Joined: Tue Feb 19, 2013 7:57 am
Location: California

Re: DHCP Options Not Seen @ Client

Wed Apr 01, 2015 4:17 am

Is this indicating the the DHCP server will "not" return options unless they are requested by the client?
You know, I wouldn't "swear on the bible" either way - the more I think about it, the more I seem to recall an ability for clients to request certain options. I would have said the server just sends everything according to its configuration. (i.e. you can make some options just for certain hosts, groups of hosts, etc.)

Wireshark will be the ultimate way to answer this.

I apologize for the long delay ZeroByte...

I will get back to working on this task again and I will run WS against it to see what exactly comes from the server.
Yeah, after already having had submitted this question at the MT forum I went and re-read the section Options in: http://wiki.mikrotik.com/wiki/Manual:IP ... CP_Options

The second paragraph under Manual: IP/DHCP Server > Options
According to the DHCP protocol, a parameter is returned to the DHCP client only if it requests this parameter, specifying the respective code in DHCP request Parameter-List (code 55) attribute. If the code is not included in Parameter-List attribute, DHCP server will not send it to the DHCP client.
Have a great day - the very best day you are able to have

Best Regards

Who is online

Users browsing this forum: Google [Bot] and 132 guests