Community discussions

MikroTik App
 
ahlai
newbie
Topic Author
Posts: 29
Joined: Sat May 27, 2006 8:07 am

how to limit the connection number of client

Sun Jul 09, 2006 1:33 am

In my lan ,there are only 9 computer,
but always have 3000 connections,/ip/firewall/connection/print,i can see.
how to limit the connection number of each client?
thanks
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6681
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Sun Jul 09, 2006 9:11 am

/ip firewall filter add chain=forward protocol=tcp tcp-flags=syn connection-limit=101,32 action=drop

This rule will allow 100 TCP simultaneous connection per network user.
 
zong
newbie
Posts: 27
Joined: Thu Sep 29, 2005 2:13 pm

Mon Jul 10, 2006 8:06 am

Hii....
I am using MT 2.9.6
using this rule but client can open more than 5 connections per Ip address.
/ip firewall filter add chain=forward protocol=tcp tcp-flags=syn connection-limit=4,24 action=drop

here my config
local : 192.168.168.200 netmask : 255.255.255.0
public : 10.97.20.200 netmask : 255.255.0.0
ip firewall nat> add chain=srcnat action=masquerade out-interface=Public

pls assist
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6681
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Mon Jul 10, 2006 8:08 am

1) Upgrade your router to the latest MikroTik RouterOS version.

2) your rule allows 3 connections per network.
4 - is allowed connections, 24 - subnet mask.
Change connection-limit configuration.
 
zong
newbie
Posts: 27
Joined: Thu Sep 29, 2005 2:13 pm

Mon Jul 10, 2006 8:18 am

so if using this ver 2.9.6 can not limit connection per ip address ?
mhhh :shock:
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6681
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Mon Jul 10, 2006 9:02 am

It should work, however it's recommended to ugprade.
Note, given rule will limit TCP connections.
 
zong
newbie
Posts: 27
Joined: Thu Sep 29, 2005 2:13 pm

Mon Jul 10, 2006 12:20 pm

what the correct rule for MT 2.9.6 ?

thx
:lol:
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 25288
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Mon Jul 10, 2006 12:23 pm

you should consider upgrading if something doesn't work for you

Who is online

Users browsing this forum: Baidu [Spider], Bokous, Rebel1 and 31 guests