Community discussions

 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

6.30 RC final fixes before release

Fri Jun 26, 2015 4:54 pm

Please test the latest 6.30 rc and let us know if there are any unsolved issues remaining. We have solved all the problems that were reported, and only minor polishing remains.

Here is the newest changelog:

What's new in 6.30rc22 (2015-Jun-19 10:41):

*) ipsec - fail ph2 negitioation when initiator proposed key length does not match proposal configuration;
*) ssh - added option '/ip ssh stong-crypto'
*) wireless - improve ac radio coexistence with other wireless clients;
*) console - values of S~.id~, S~.nextid~ and S~.dead~ are avaliable for
use in 'print where' expressions;
*) console - ':execute' command now accepts 'file=' parameter and
writes script output to scpecified file;
*) console - ':execute' command now accepts script source in ~{}~ braces,
like '/system scripts add source=' does;
*) console - ':execute' command now returns internal number of running job,
that can be used to check and stop execution. For example:
:local j [:execute {/interface print follow where [:log info ~Sname~]}]
:delay 10s
:do { /system script job remove Sj } on-error={}
*) console - firewall 'print' commands now show all entries including
dynamic, 'all' argument now has no effect;
*) ipsec - increase replay window to 128;
*) fixed file transfer on devices with large RAM memory;
*) pptp - fixed ~encryption got out of sync~ problem;
*) ppp - disable vj tcp header compression;
*) api - reduce api tcp connection keepalive delay to 30 seconds,
will timeout idle connections in about 5 minutes;
*) pptp & l2tp & sstp client: support the case were server issues its tunnel ip address the
same as its public one;
*) removed wireless package from routeros bundle package, new wireless-fp is left in place;
*) pptp & l2tp client: when adding default route, add special exception route for
a tunnel itself (no need to add it manually anymore);
*) improved connection list: added connection packet/byte counters, added separate counters
for fasttrack, added current rate display, added flag wheather
connection is fasttracked/srcnated/dstnated, removed 2048 connection entry limit;
*) tunnels - eoip,eoipv6,gre,gre6,ipip,ipipv6,6to4 tunnels have new property - ipsec-secret - for easy setup of ipsec encryption and authentication;
*) firewall - added ipsec-policy matcher to check wheather packet was/will be ipsec processed or not;
*) possibility to disable route cache - improves DDOS attack handling performance up to 2x (note that ipv4 fastpath depends on route cache);
*) fasttrack - added dummy firewall rule in filter and mangle tables to show packets/bytes that get processed in fasttrack and bypass firewall;
*) fastpath - vlan interfaces support fastpath;
*) fastpath - partial support for bonding interfaces (rx only);
*) fastpath - vrrp interfaces support fastpath;
No answer to your question? How to write posts
 
planetcoop
Member Candidate
Member Candidate
Posts: 115
Joined: Thu May 15, 2014 2:32 pm
Location: Sacramento, CA

Re: 6.30 RC final fixes before release

Fri Jun 26, 2015 6:59 pm

+1 on the fastpath and l2tp with ipsec, tested on ccr1016/ccr1036/x86 platforms.
 
rzirzi
Member
Member
Posts: 378
Joined: Mon Oct 09, 2006 2:33 pm

Re: 6.30 RC final fixes before release

Fri Jun 26, 2015 7:32 pm

"wireless - improve ac radio coexistence with other wireless clients" - what does it mean exactly?
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Fri Jun 26, 2015 8:12 pm

Why there are dummy firewall rules for fasttrack statistics instead showing correct values on real fasttracking rules? I don't understand it. Please, show the values where they belong to.
 
105547111
Member Candidate
Member Candidate
Posts: 132
Joined: Fri Jun 22, 2012 9:46 pm

Re: 6.30 RC final fixes before release

Sat Jun 27, 2015 8:56 am

It's all good, I've only got a ticket about random ether cycles on a CRS226.

But my random reboots on a CCR are fixed in rc22
 
IntrusDave
Forum Guru
Forum Guru
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: 6.30 RC final fixes before release

Sat Jun 27, 2015 10:32 am

I think I'm good. My issues were fixed with this last build. Thank you.
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
Beone
Member Candidate
Member Candidate
Posts: 243
Joined: Fri Feb 11, 2011 1:11 pm

Re: 6.30 RC final fixes before release

Sat Jun 27, 2015 11:39 am

Are below also fixed? As there is no mentioning in the release notes

Ticket#2015061266000441 - Hotspot SSL error on sudden reboot
Ticket#2015060366000681 - Router does not send RADIUS-Stop messages on admin-reboot when internet uplink is of type pppoe/pptp
Re: V6.x Status/logoff linklogin wrongfully to HTTP even if HTTPS is selected

PS, we saw a memleak on v6.30rc19; hopefully this is fixed as well
 
RafZielak
just joined
Posts: 5
Joined: Thu Jun 18, 2015 4:19 pm

Re: 6.30 RC final fixes before release

Sat Jun 27, 2015 6:28 pm

Hi All,

If we are talking about current beta release ...
As it was written several times on many forums, scheduler is not working.
http://forum.mikrotik.com/viewtopic.php?f=1&t=98052
http://forum.mikrotik.com/viewtopic.php?f=1&t=97731

Brgds
RafZielak
 
rocknight13
newbie
Posts: 45
Joined: Sun Dec 25, 2011 8:08 pm
Location: Iraq
Contact:

Re: 6.30 RC final fixes before release

Sat Jun 27, 2015 9:35 pm

Dear normis,
Please your comment for topic http://forum.mikrotik.com/viewtopic.php?f=1&t=98053
is this bug ? or there are mistake in command
regards
 
cegner
just joined
Posts: 15
Joined: Thu Sep 22, 2005 2:34 pm

Re: 6.30 RC final fixes before release

Sun Jun 28, 2015 4:45 pm

What about #2015042966000618?
It was supposed to be addressed in 6.30.
 
mindlesstux
just joined
Posts: 14
Joined: Tue Mar 17, 2009 3:20 pm
Location: Charlotte, NC, USA
Contact:

Re: 6.30 RC final fixes before release

Sun Jun 28, 2015 7:01 pm

I had a issue with going from 6.30rc19 to 6.30rc22. My bridges disappeared. They came back after a edit and reboot though.

Also wireless-cm2 was not in the all arch zip for tile. Had to use:
http://www.mikrotik.com/download/share/ ... t-tile.npk
 
solaoxo
Frequent Visitor
Frequent Visitor
Posts: 94
Joined: Sun Oct 20, 2013 8:38 pm

Re: 6.30 RC final fixes before release

Sun Jun 28, 2015 9:05 pm

scheduler is not working.
 
kez
newbie
Posts: 39
Joined: Tue Jul 05, 2005 4:13 am

Re: 6.30 RC final fixes before release

Sun Jun 28, 2015 10:54 pm

scheduler is not working.
I could see the same thing on a "startup" script. It didn't work as well.
But I'm not sure if the whole scheduler is not working or just with the "startup" as start time.
Tested on PPC.
 
LAD75
just joined
Posts: 6
Joined: Sun Jun 28, 2015 7:32 pm

Re: 6.30 RC final fixes before release

Mon Jun 29, 2015 11:31 am

I confirm, scheduler is not working.
i try to use dyndns update script and it not working.
But manual start of the script is working properly.
 
newtonek
just joined
Posts: 12
Joined: Sat Mar 11, 2006 9:20 am

Re: 6.30 RC final fixes before release

Mon Jun 29, 2015 1:44 pm

/ip settings
set route-cache=no tcp-syncookies=yes

/ip route cache print
cache-size: 2
max-cache-size: 16384


Is it normal? Route cache "disabled", but it still works? Or I'm missing something?
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Mon Jun 29, 2015 1:49 pm

rc23 should fix scheduler, it is in the download page already
No answer to your question? How to write posts
 
LAD75
just joined
Posts: 6
Joined: Sun Jun 28, 2015 7:32 pm

Re: 6.30 RC final fixes before release

Mon Jun 29, 2015 2:38 pm

try simply script: ":log info message="TEST";"
and sheduler: "/system script run script1" 1/min

not working for me :(
 
RafZielak
just joined
Posts: 5
Joined: Thu Jun 18, 2015 4:19 pm

Re: 6.30 RC final fixes before release

Mon Jun 29, 2015 4:13 pm

Update 6.30rc23 downloaded/installed and ... unfortunately ... scheduler is not working still.
 
User avatar
emils
MikroTik Support
MikroTik Support
Posts: 507
Joined: Thu Dec 11, 2014 8:53 am

Re: 6.30 RC final fixes before release

Mon Jun 29, 2015 4:24 pm

Fix for scheduler will be in rc24, not rc23.
 
RafZielak
just joined
Posts: 5
Joined: Thu Jun 18, 2015 4:19 pm

Re: 6.30 RC final fixes before release

Mon Jun 29, 2015 4:44 pm

@emils
Thank you for your update but ...
When should we expect the newest version rc24?
 
upower3
Member
Member
Posts: 384
Joined: Thu May 07, 2015 11:46 am

Re: 6.30 RC final fixes before release

Mon Jun 29, 2015 5:06 pm

No changelog for 6.30rc23, so waiting for rc24 and final.

May I please ask to highlight changes per RC in changelog (like it was before for versions)?

And, if it is possible at all, to set Content-Disposition for http://www.mikrotik.com/download/share/ ... evnote.txt to something that permits open it as plain text file? I hate to have other program to open simple text file.
 
User avatar
G2Dolphin
Member Candidate
Member Candidate
Posts: 157
Joined: Sun May 17, 2015 6:03 pm
Location: Moscow, Russia

Re: 6.30 RC final fixes before release

Mon Jun 29, 2015 5:10 pm

Please, add a checkbox for turning off these dummy statistic rules for FastTrack. I don't understand, why do we need them, since we have this counter on IP - Settings.
Home: RB3011UiAS-IN (2011 case+3011-RM), hAP ac, mAP2n/mAP2nD, GrooveA-52HPn, hEX (r3), hAP lite, RB951G-2HnD
Work: RB2011UiAS-RM / UiAS-2HnD-IN, RB951G-2HnD, hEX (r3), CRS125-24G-1S-2HnD-IN, CCR1009-8G-1S-1S+
 
pbr3000
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Fri Jan 08, 2010 7:31 am

Re: 6.30 RC final fixes before release

Tue Jun 30, 2015 3:21 am

Please, add a checkbox for turning off these dummy statistic rules for FastTrack. I don't understand, why do we need them, since we have this counter on IP - Settings.
Yes. Let us choose to turn it on or off.
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Tue Jun 30, 2015 6:55 am

Why even those dummy rules? Put the values to the real rules correctly !
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re:

Tue Jun 30, 2015 9:39 am

Why even those dummy rules? Put the values to the real rules correctly !
I find them very useful. Imagine situation when you need to connect to some unknown router and configure mangle and queue tree, you start mangling, but rules doesn't see the traffic, you have no idea why, cause you can see traffic on interface ....

Now you open mangle and you see that there are something - a rule that counting traffic - "aaaa, so there are my traffic".. It really avoids lots of potential confusion. I had several e-mails from our customers already about this, after everyone enabled fasttrack.

Initial implementation had some bugs, but as far as i can see latest RC adressed that.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
slav0nic
just joined
Posts: 7
Joined: Sun Oct 26, 2014 10:14 am

Re: 6.30 RC final fixes before release

Tue Jun 30, 2015 11:18 am

fasttrack for pppoe-client still not supported?
 
infused
Member
Member
Posts: 305
Joined: Fri Dec 28, 2012 2:33 pm

Re: 6.30 RC final fixes before release

Tue Jun 30, 2015 12:51 pm

Is the queue tree bug fixed from 29? The one where if you make constant changes the queues stop working?
 
Ansy
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Mon Oct 17, 2011 1:32 pm
Location: Russia
Contact:

Re: 6.30 RC final fixes before release

Tue Jun 30, 2015 3:09 pm

What about broken Simple Queues in Bridge configuration? 6.30rc22 (from 6.29, 6.30rc19,...)
http://forum.mikrotik.com/viewtopic.php ... 00#p488000
http://forum.mikrotik.com/viewtopic.php ... 90#p487990
It seems completely NO firewall, but IP Firewall box in Bridge Settings checked (screenshots).
All features worked OK until 6.27 .
 
slackR
newbie
Posts: 32
Joined: Sat May 23, 2009 1:46 pm
Location: Buffalo, New York, USA
Contact:

Re: 6.30 RC final fixes before release

Tue Jun 30, 2015 9:01 pm

rc23 should fix scheduler, it is in the download page already
I also saw issues with scheduled scripts not running and Netwatch scripts not executing on down/up. Has anyone else had this problem? I'm using rc23
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: 6.30 RC final fixes before release

Tue Jun 30, 2015 9:06 pm

What about broken Simple Queues in Bridge configuration? 6.30rc22 (from 6.29, 6.30rc19,...)
http://forum.mikrotik.com/viewtopic.php ... 00#p488000
http://forum.mikrotik.com/viewtopic.php ... 90#p487990
It seems completely NO firewall, but IP Firewall box in Bridge Settings checked (screenshots).
All features worked OK until 6.27 .
did you wrote an email to support like i suggested in othre topic?
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
mindlesstux
just joined
Posts: 14
Joined: Tue Mar 17, 2009 3:20 pm
Location: Charlotte, NC, USA
Contact:

Re: 6.30 RC final fixes before release

Tue Jun 30, 2015 11:16 pm

MikroTik RouterOS 6.30rc22 (c) 1999-2015 http://www.mikrotik.com/

jun/30/2015 11:49:08 ppp,error,critical pptp-vypervpn: Encryption got out of sync - disabling
jun/30/2015 11:58:38 ppp,error,critical pptp-vypervpn: Encryption got out of sync - disabling
jun/30/2015 13:58:10 ppp,error,critical pptp-vypervpn: Encryption got out of sync - disabling
jun/30/2015 15:35:52 ppp,error,critical pptp-vypervpn: Encryption got out of sync - disabling


Not sure if the Encryption out of sync is fixed yet...
 
pbr3000
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Fri Jan 08, 2010 7:31 am

Re: 6.30 RC final fixes before release

Wed Jul 01, 2015 5:10 am

MikroTik RouterOS 6.30rc22 (c) 1999-2015 http://www.mikrotik.com/

jun/30/2015 11:49:08 ppp,error,critical pptp-vypervpn: Encryption got out of sync - disabling
jun/30/2015 11:58:38 ppp,error,critical pptp-vypervpn: Encryption got out of sync - disabling
jun/30/2015 13:58:10 ppp,error,critical pptp-vypervpn: Encryption got out of sync - disabling
jun/30/2015 15:35:52 ppp,error,critical pptp-vypervpn: Encryption got out of sync - disabling


Not sure if the Encryption out of sync is fixed yet...
It's not. I saw this error until rc23. The test client is a macbook pro with gigabit wired connection to pptp server. On debian server there is no problem.
 
IntrusDave
Forum Guru
Forum Guru
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: 6.30 RC final fixes before release

Wed Jul 01, 2015 7:33 am

I hate to point out the obvious, but PLEASE fix the Leap Second crash on the TILE platform. I can not afford to have them all lock up like they did today.
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
LAD75
just joined
Posts: 6
Joined: Sun Jun 28, 2015 7:32 pm

Re: 6.30 RC final fixes before release

Wed Jul 01, 2015 8:09 am

i setup external storage of log
setup type remote: 192.168.1.11, port 514
setup rules for remote (error, firewall, info, script,system, warning, l2tp), byt to all of them transfer to external storage

i have next lines of logs
Jul  1 11:07:11 router.domain.com dns,packet <1.2.3.4.in-addr.arpa:PTR:2981=host1234*.omkc.ru>
Jul  1 11:07:11 router.domain.com dns,packet --- got query from 192.168.1.11:33391:
Jul  1 11:07:11 router.domain.com dns,packet id:5e68 rd:1 tc:0 aa:0 qr:0 ra:0 QUERY 'no error'
and nothin from setup type of logs
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Wed Jul 01, 2015 9:22 am

Of course, 6.30 will not be released until NTP package problem with Leap Second on CCR will be fixed.
No answer to your question? How to write posts
 
User avatar
emils
MikroTik Support
MikroTik Support
Posts: 507
Joined: Thu Dec 11, 2014 8:53 am

Re: 6.30 RC final fixes before release

Wed Jul 01, 2015 10:45 am

@emils
Thank you for your update but ...
When should we expect the newest version rc24?
v6.30rc24 is available now.
 
giannello
just joined
Posts: 2
Joined: Thu Jun 25, 2015 11:08 pm

Re: 6.30 RC final fixes before release

Wed Jul 01, 2015 11:09 am

Of course, 6.30 will not be released until NTP package problem with Leap Second on CCR will be fixed.
Does this mean that 6.29 has a known bug with leap second? That might explain why both our CCR crashed tonight.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Wed Jul 01, 2015 11:24 am

Of course, 6.30 will not be released until NTP package problem with Leap Second on CCR will be fixed.
Does this mean that 6.29 has a known bug with leap second? That might explain why both our CCR crashed tonight.
yes, all RouterOS versions are affected if you use NTP package and CCR.
No answer to your question? How to write posts
 
paulsa
newbie
Posts: 34
Joined: Tue Oct 29, 2013 10:24 am

Re: 6.30 RC final fixes before release

Wed Jul 01, 2015 12:01 pm

Trafficflow fix? 6.29 broke it, no egress + ingress netflows.
 
LAD75
just joined
Posts: 6
Joined: Sun Jun 28, 2015 7:32 pm

Re: 6.30 RC final fixes before release

Wed Jul 01, 2015 12:56 pm

scripts is worked on RC24!
 
User avatar
Bernardo
newbie
Posts: 27
Joined: Wed Nov 02, 2011 12:05 pm

Re: 6.30 RC final fixes before release

Wed Jul 01, 2015 2:25 pm

Trafficflow fix? 6.29 broke it, no egress + ingress netflows.
+1
 
Lupin
Member Candidate
Member Candidate
Posts: 265
Joined: Mon Feb 16, 2009 10:22 pm
Location: Italy

Re: 6.30 RC final fixes before release

Wed Jul 01, 2015 11:40 pm

"wireless - improve ac radio coexistence with other wireless clients" - what does it mean exactly?
What exactly did you improve?
Improve performance or latency when both N and AC clients are connected?

It also improves with Nstreme and NV2 protocol?

How much?
 
NicK
just joined
Posts: 4
Joined: Thu Jul 02, 2015 9:43 pm

Re: 6.30 RC final fixes before release

Thu Jul 02, 2015 9:46 pm

Image
Bug RB 750 (6.30 rc26): Sending packages to the port that is only connected but unused.

This began in version 6.29
 
Abdock
Member Candidate
Member Candidate
Posts: 252
Joined: Sun Sep 25, 2005 10:50 pm

Re: 6.30 RC final fixes before release

Thu Jul 02, 2015 10:43 pm

Has the issue of VPLS, MPLS, BGP, OSPF, which crashed the router in 6.28 fixed ? as i have 6.29.1 and i have to reboot the router every second day, some routes just dont work and power reboot is the only option on ccr. Anybody else having such issue ? my network was stable till 6.27 after that rebooting every other day.
 
zinkpad
just joined
Posts: 16
Joined: Fri Jun 26, 2015 11:24 pm

Re: 6.30 RC final fixes before release

Fri Jul 03, 2015 12:54 am

Hi,

I updated my RB951G to 6.30rc26 and now my DynDNS script fails,...I'm a beginner with Mikrotik, but debugging the script I saw that the /tool fetch command always return "Error 400 bad request".

I downgraded to 6.29.1 and works fine with the same script.

Regards!
Software developer
GitHub profile: https://github.com/zinkpad
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Fri Jul 03, 2015 10:31 am

Hi,

I updated my RB951G to 6.30rc26 and now my DynDNS script fails,...I'm a beginner with Mikrotik, but debugging the script I saw that the /tool fetch command always return "Error 400 bad request".

I downgraded to 6.29.1 and works fine with the same script.

Regards!
maybe post your script in a new topic, 400 bad request is server telling your that the request is malformed.
No answer to your question? How to write posts
 
User avatar
miasik
just joined
Posts: 18
Joined: Sun Mar 18, 2012 10:15 am
Location: Donetsk, Ukraine
Contact:

Re: 6.30 RC final fixes before release

Fri Jul 03, 2015 11:59 am

Hi, I updated my RB951G to 6.30rc26 and now my DynDNS script fails,...I'm a beginner with Mikrotik, but debugging the script I saw that the /tool fetch command always return "Error 400 bad request". I downgraded to 6.29.1 and works fine with the same script. Regards!
maybe post your script in a new topic, 400 bad request is server telling your that the request is malformed.
May be developers trying to fix my [Ticket#2015063066000237] Fetch error on IPv6 url.
Sorry for my English, i'm from Ukraine and my native language is Russian.
 
zinkpad
just joined
Posts: 16
Joined: Fri Jun 26, 2015 11:24 pm

Re: 6.30 RC final fixes before release

Fri Jul 03, 2015 2:17 pm

My script is the same that are in the Wiki:DynDns for RouterOS 6.x section.
Software developer
GitHub profile: https://github.com/zinkpad
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Fri Jul 03, 2015 2:21 pm

My script is the same that are in the Wiki:DynDns for RouterOS 6.x section.
It is not made by MikroTik, so I can't say if it should work or not. The article is made by one of the forum users. I suggest to make a new thread, and maybe some Dyn user could help improve the script to be more compatible
No answer to your question? How to write posts
 
User avatar
Bernardo
newbie
Posts: 27
Joined: Wed Nov 02, 2011 12:05 pm

Re: 6.30 RC final fixes before release

Fri Jul 03, 2015 8:34 pm

My script is the same that are in the Wiki:DynDns for RouterOS 6.x section.
It is not made by MikroTik, so I can't say if it should work or not. The article is made by one of the forum users. I suggest to make a new thread, and maybe some Dyn user could help improve the script to be more compatible
Now come on Normis....

it always is the users fault, isn´t it?

We too had problems with scripts.
Updating about 15 RB2011 from 6.29 (buggy as hell), to 6.30rc20, rc24 and later to rc26 (still buggy as hell), on all of them, the scripts stopped working.
On earlier versions, those ran without a problem for years.
Something clearly has changed.

saludos
Bernardo
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2946
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: 6.30 RC final fixes before release

Fri Jul 03, 2015 10:14 pm

The driver for ethernet on new 9xx ac board (random ether driver crash and restart only after reboot)
and the S-RJ01 are fixed???

http://forum.mikrotik.com/viewtopic.php ... 00#p485204

kernel crash on base box are fixed? i'm not the only user that report that

http://forum.mikrotik.com/viewtopic.php ... 00#p485633
I'm Italian, not English. Sorry for my imperfect grammar.
 
PtDragon
Frequent Visitor
Frequent Visitor
Posts: 77
Joined: Sun Apr 26, 2009 8:52 pm

Re: 6.30 RC final fixes before release

Sat Jul 04, 2015 4:37 am

My script is the same that are in the Wiki:DynDns for RouterOS 6.x section.
It is not made by MikroTik, so I can't say if it should work or not. The article is made by one of the forum users. I suggest to make a new thread, and maybe some Dyn user could help improve the script to be more compatible
Now come on Normis....

it always is the users fault, isn´t it?

We too had problems with scripts.
Updating about 15 RB2011 from 6.29 (buggy as hell), to 6.30rc20, rc24 and later to rc26 (still buggy as hell), on all of them, the scripts stopped working.
On earlier versions, those ran without a problem for years.
Something clearly has changed.

saludos
Bernardo
Yeah, in 6.30RCs scripts do not work.
I really use them constantly (in scheduler) so please fix them.
It even did not import back exported config hanging on each line.
CCR1036-12G-4S +6x100Mbit ^_^
 
zinkpad
just joined
Posts: 16
Joined: Fri Jun 26, 2015 11:24 pm

Re: 6.30 RC final fixes before release

Sat Jul 04, 2015 2:06 pm

Okay, I think that I found the "bug" with "/tool fetch" command. In my initial script working on 6.29.1 I have the following command:
/tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser \
         password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
The above command doesn't works on 6.30rc28... then, I changed it for:
/tool fetch url=("http://members.dyndns.org".$str)  user=$ddnsuser mode=http  \
         password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
...and now it seems works on 6.30rc28 :D

I don't know if there are any problem with the "address" and "src-path" parameters on 6.30rcX...

Regards!
Software developer
GitHub profile: https://github.com/zinkpad
 
kez
newbie
Posts: 39
Joined: Tue Jul 05, 2005 4:13 am

Re: 6.30 RC final fixes before release

Sun Jul 05, 2015 9:46 pm

Sorry, but I guess it's time for Mikrotik think about to integrate a native DDNS client. Look, it's already there for IP Cloud. Developers can say "it's hard to maintain a large number of DDNS services", so look at OpenWRT solution and leave IP check and update URLs strings as variables, so users can change them. It could be done on RAM memory, so it would decrease the number of NAND writes.
It's not so hard, just allow us to use what it is already there.
 
Lupin
Member Candidate
Member Candidate
Posts: 265
Joined: Mon Feb 16, 2009 10:22 pm
Location: Italy

Re: 6.30 RC final fixes before release

Mon Jul 06, 2015 9:34 pm

"wireless - improve ac radio coexistence with other wireless clients" - what does it mean exactly?
What exactly did you improve?
Improve performance or latency when both N and AC clients are connected?

It also improves with Nstreme and NV2 protocol?

How much?
Normis any info about this changelog??
 
ibm
Member
Member
Posts: 301
Joined: Mon May 12, 2014 5:16 pm

Re: 6.30 RC final fixes before release

Mon Jul 06, 2015 9:56 pm

"wireless - improve ac radio coexistence with other wireless clients" - what does it mean exactly?
What exactly did you improve?
Improve performance or latency when both N and AC clients are connected?

It also improves with Nstreme and NV2 protocol?

How much?
Normis any info about this changelog??
+1
 
Ansy
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Mon Oct 17, 2011 1:32 pm
Location: Russia
Contact:

Re: 6.30 RC final fixes before release

Tue Jul 07, 2015 1:46 pm

6.30rc29
Got "CPU overload by management process" issue returned :(
http://forum.mikrotik.com/viewtopic.php ... 36#p485836

Now I need to control my RB750UP only via telnet console again. Lists become empty too.
Using Winbox hangs device to reboot by watchdog not pinging default gateway.
But Bridge + Simple Queues + Firewall are working now.

It seems we are walking in circles...
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Tue Jul 07, 2015 1:52 pm

What exactly did you improve?
Improve performance or latency when both N and AC clients are connected?

It also improves with Nstreme and NV2 protocol?

How much?
Normis any info about this changelog??
Neither!
It doesn't say anything about Nv2 or Nstreme, so you should not expect these changes.
Like the line says, 802.11ac previously was more agressive (interference wise, not bandwidth or latency) towards other devices. This has been reduced.
No answer to your question? How to write posts
 
User avatar
BartoszP
Forum Guru
Forum Guru
Posts: 1719
Joined: Mon Jun 16, 2014 1:13 pm
Location: Poland

Re: 6.30 RC final fixes before release

Tue Jul 07, 2015 2:04 pm

Normis:
Your explanation should be a part of changelog.
The word "coexistence" has so broad meaning that it tells nothing particular what was changed.
Real admins use real keyboards.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Tue Jul 07, 2015 2:05 pm

leave IP check and update URLs strings as variables
one post above yours shows how you can already do this
No answer to your question? How to write posts
 
apathy
just joined
Posts: 6
Joined: Tue Apr 15, 2014 12:16 pm

Re: 6.30 RC final fixes before release

Tue Jul 07, 2015 6:50 pm

Trafficflow fix? 6.29 broke it, no egress + ingress netflows.
+
 
User avatar
miasik
just joined
Posts: 18
Joined: Sun Mar 18, 2012 10:15 am
Location: Donetsk, Ukraine
Contact:

Re: 6.30 RC final fixes before release

Tue Jul 07, 2015 11:10 pm

Released 6.30 in Latest?
Sorry for my English, i'm from Ukraine and my native language is Russian.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 9:24 am

New build every few hours, RC is now removed, nearly ready to release. Any comments?
No answer to your question? How to write posts
 
cheeze
Member Candidate
Member Candidate
Posts: 146
Joined: Tue Jul 31, 2012 7:44 am

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 9:49 am

I would say, please release an RC-Final candidate file.

If people do not have any issues with it, then rename it and re-release it as 6.30.0 with no change other than the name.

That way whatever bugs are found are squashed before 6.30.0, and said backlash doesn't hit Mikrotik nearly as badly.

Other than that, what's the current changelog?
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 9:50 am

I would say, please release an RC-Final candidate file.

If people do not have any issues with it, then rename it and re-release it as 6.30.0 with no change other than the name.

That way whatever bugs are found are squashed before 6.30.0, and said backlash doesn't hit Mikrotik nearly as badly.

Other than that, what's the current changelog?
we have released RC versions every day for a few weeks already.
it has been on our main download page all this time.
No answer to your question? How to write posts
 
User avatar
eworm
Member
Member
Posts: 407
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 11:52 am

New build every few hours, RC is now removed, nearly ready to release. Any comments?
Just wondering... When RC is removed from version string... Is there any way to see it is not the final build? Perhaps adding a package property with incrementing build id would be of help.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 11:53 am

New build every few hours, RC is now removed, nearly ready to release. Any comments?
Just wondering... When RC is removed from version string... Is there any way to see it is not the final build? Perhaps adding a package property with incrementing build id would be of help.
build time can be compared in "system packages". but yes, for the RC releases, currently we are not showing the build time, we will implement it for the download page
No answer to your question? How to write posts
 
P2k1
just joined
Posts: 13
Joined: Wed Nov 23, 2011 1:49 pm

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 2:45 pm

where is wireless cm2 package for 6.30?

regards
 
User avatar
eworm
Member
Member
Posts: 407
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 2:49 pm

where is wireless cm2 package for 6.30?
Probably it is there. But server gives "403 Forbidden", so looks file permissions are borked.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 2:58 pm

hold on please, release procedure script went crazy
No answer to your question? How to write posts
 
User avatar
eworm
Member
Member
Posts: 407
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 3:02 pm

Oh, just another note... Why does the ZIP archive (all_packages-mipsbe-6.30.zip) miss the capsman package (wireless-cm2-6.30-mipsbe.npk)?
Has always been this way, though. So this is not a regression.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
User avatar
bajodel
Long time Member
Long time Member
Posts: 545
Joined: Sun Nov 24, 2013 8:30 am
Location: Italy

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 3:25 pm

hold on please, release procedure script went crazy
normis ..just a note: extra packages for x86 are missing
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 3:27 pm

I know, see above :) Sorry about that. This is why official topic doesn't exist yet.
No answer to your question? How to write posts
 
gabeselig
just joined
Posts: 9
Joined: Tue May 08, 2012 3:52 am

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 3:39 pm

Could you post the changelog for the updated RouterBOOT?

The URL Here: http://wiki.mikrotik.com/wiki/RouterBOOT_changelog

It only goes up to 3.22 but I am seeing 3.24 on the RB450G boards now.

Thank you,
Gabe
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2294
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 3:41 pm

As normis usualy say: Support for new products...
LAN, FTTx, Wireless. ISP operator
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 3:43 pm

This time, also small fix for reset-lock package.
No answer to your question? How to write posts
 
DmitriiP
just joined
Posts: 18
Joined: Sat Mar 09, 2013 9:42 pm

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 3:45 pm

Where:

wireless-cm2-6.30-mipsbe.npk
wireless-cm2-6.30-smips.npk

and others http://www.mikrotik.com/download ????

CAPsMANv2 only for ccr?

Check for updates:
ERROR: missing wireless-cm2-6.30-mipsbe.npk
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 3:49 pm

Where:
Dmitry, please read above posts before posting something.
No answer to your question? How to write posts
 
DmitriiP
just joined
Posts: 18
Joined: Sat Mar 09, 2013 9:42 pm

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 3:58 pm

Sorry, was very busy by trying to update AP's unsuccessfuly ;)
 
ste
Forum Guru
Forum Guru
Posts: 1815
Joined: Sun Feb 13, 2005 11:21 pm

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 4:04 pm

New build every few hours, RC is now removed, nearly ready to release. Any comments?
We had MPLS/LDP-Problems with 6.29.1. /32 Routes did not work.

Ticket#2015070266000681

We cant go back to the errorstate to send supout of not working condition as this would screw our network. No further feedback so I guess it is not solved.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 4:17 pm

We had MPLS/LDP-Problems with 6.29.1. /32 Routes did not work.
We have several customers who have working MPLS/LDP and it works for us too. My colleagues are at a loss, since we are unable to repeat any problems, and you have not provided us with any clear information, at least the supout.rif file would help.
No answer to your question? How to write posts
 
PtDragon
Frequent Visitor
Frequent Visitor
Posts: 77
Joined: Sun Apr 26, 2009 8:52 pm

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 4:36 pm

Normis, please fix scripts on 6.30!
for example this one from scheduler dows not work in 6.30 but works in 6.29:
:local i 0;
:if ([/ip firewall mangle get [find comment="wan0"] disabled]=false) do {
:set i 0; {:do {:set i ($i + 1)} while (($i < 5) && ([/ping 209.244.0.5 interval=500ms interface=ether1 count=1]=0))};
  :if ($i=5 && [/ip firewall mangle get [find comment="wan0"] disabled]=false) do={:log info "wan0 down";
   /ip firewall mangle set [find comment="wan0"] disabled=yes;
   execute beeperdown}}
:if ([/ip firewall mangle get [find comment="wan0"] disabled]=true) do={
:set i 0; {:do {:set i ($i + 1)} while (($i < 5) && ([/ping  209.244.0.5 interval=500ms interface=ether1 count=1]=1))};
   :if ($i=5 && [/ip firewall mangle get [find comment="wan0"] disabled]=true) do={:log info "wan0 up";
   /ip firewall mangle set [find comment="wan0"] disabled=no;
   execute beeperup}}
CCR1036-12G-4S +6x100Mbit ^_^
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5943
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 4:44 pm

What exactly is not working in that script?
 
PtDragon
Frequent Visitor
Frequent Visitor
Posts: 77
Joined: Sun Apr 26, 2009 8:52 pm

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 5:06 pm

What exactly is not working in that script?
On 6.29 it disables/enables rule in mangle(where i do load balancing) and gives sound+log message when uplink stops working/starts working again.
On 6.30 it does not do that at all(no rule changes and no sound, did not check if it sends pings but it does not do its job on 6.30).
CCR1036-12G-4S +6x100Mbit ^_^
 
ste
Forum Guru
Forum Guru
Posts: 1815
Joined: Sun Feb 13, 2005 11:21 pm

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 5:12 pm

We had MPLS/LDP-Problems with 6.29.1. /32 Routes did not work.
We have several customers who have working MPLS/LDP and it works for us too. My colleagues are at a loss, since we are unable to repeat any problems, and you have not provided us with any clear information, at least the supout.rif file would help.
Maris informed me now. Thanks. I sent supout.rifs of the working routers after downgrading. I cant risk to upgrade again to provide supout of the problematic state. May be the problem is with mixed 6.15/6.29.1 routers. Dont know. But for sure there is a problem. The downgrade to 6.15 solved the problem and disabling LDP solved the problem, too.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5943
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 5:14 pm

But what exactly is not working in the code? You have to debug your script to find an error.

I added your script on my router and it shows syntax error at execute beeperdown. What exactly is beeperdown?
 
PtDragon
Frequent Visitor
Frequent Visitor
Posts: 77
Joined: Sun Apr 26, 2009 8:52 pm

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 5:37 pm

But what exactly is not working in the code? You have to debug your script to find an error.

I added your script on my router and it shows syntax error at execute beeperdown. What exactly is beeperdown?
beeperdown
beeperup
They are sound scripts (in system->script)
You can remove them for debug, they aren't important.
If you wish have exactly same scripts for debug:

beeperdown
 :for i from=4000 to=2000 step=-500 do={
   :beep frequency=$i length=50ms;
   :delay 50ms;
 }
beeperup
 :for i from=2000 to=4000 step=500 do={
   :beep frequency=$i length=50ms;
   :delay 50ms;
 }
CCR1036-12G-4S +6x100Mbit ^_^
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5943
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 5:46 pm

is that beeperdown script loaded as variable?

Otherwise :execute beeperdown is a syntax error and then of course the whole script is not going to run at all.

:execute command accepts "script" parameter which should be script source code not an unknown name.
 
PtDragon
Frequent Visitor
Frequent Visitor
Posts: 77
Joined: Sun Apr 26, 2009 8:52 pm

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 6:11 pm

is that beeperdown script loaded as variable?

Otherwise :execute beeperdown is a syntax error and then of course the whole script is not going to run at all.

:execute command accepts "script" parameter which should be script source code not an unknown name.
I replaced
execute
with
/system script run
and it works now.
You should warn about syntax changes on update(at first line) and give workarounds ;)
Thanks for help :)
CCR1036-12G-4S +6x100Mbit ^_^
 
User avatar
bajodel
Long time Member
Long time Member
Posts: 545
Joined: Sun Nov 24, 2013 8:30 am
Location: Italy

Re: 6.30 RC final fixes before release

Wed Jul 08, 2015 9:02 pm

I know, see above :) Sorry about that. This is why official topic doesn't exist yet.
Now official topic exists ..6.30 is out ..but Extra Packages for x86 item is not on download page.
 
dadoremix
Member Candidate
Member Candidate
Posts: 118
Joined: Sat May 14, 2011 11:31 am

Re: 6.30 RC final fixes before release

Sun Jul 12, 2015 1:12 pm

Okay, I think that I found the "bug" with "/tool fetch" command. In my initial script working on 6.29.1 I have the following command:
/tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser \
         password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
The above command doesn't works on 6.30rc28... then, I changed it for:
/tool fetch url=("http://members.dyndns.org".$str)  user=$ddnsuser mode=http  \
         password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
...and now it seems works on 6.30rc28 :D

I don't know if there are any problem with the "address" and "src-path" parameters on 6.30rcX...

Regards!

can you post full script ?
i try find and replace code but not working

# Set needed variables
:local username yyyy
:local password xxxxx
:local hostname xxxx.dyndns.tv

:global dyndnsForce
:global previousIP 

# print some debug info
:log info ("UpdateDynDNS: username = $username")
:log info ("UpdateDynDNS: password = $password")
:log info ("UpdateDynDNS: hostname = $hostname")
:log info ("UpdateDynDNS: previousIP = $previousIP")

# get the current IP address from the internet (in case of double-nat)
/tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
:delay 1
:local result [/file get dyndns.checkip.html contents]

# parse the current IP result
:local resultLen [:len $result]
:local startLoc [:find $result ": " -1]
:set startLoc ($startLoc + 2)
:local endLoc [:find $result "</body>" -1]
:local currentIP [:pick $result $startLoc $endLoc]
:log info "UpdateDynDNS: currentIP = $currentIP"

# Remove the # on next line to force an update every single time - useful for debugging,
# but you could end up getting blacklisted by DynDNS!

#:set dyndnsForce true

# Determine if dyndns update is needed
# more dyndns updater request details http://www.dyndns.com/developers/specs/syntax.html

:if (($currentIP != $previousIP) || ($dyndnsForce = true)) do={
   :set dyndnsForce false
   :set previousIP $currentIP
   :log info "$currentIP or $previousIP"
   /tool fetch user=$username password=$password mode=http address="members.dyndns.org" \
      src-path="nic/update?system=dyndns&hostname=$hostname&myip=$currentIP&wildcard=no" \
      dst-path="/dyndns.txt"
   :delay 1
   :local result [/file get dyndns.txt contents]
   :log info ("UpdateDynDNS: Dyndns update needed")
   :log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
   :put ("Dyndns Update Result: ".$result)
} else={
   :log info ("UpdateDynDNS: No dyndns update needed")
}
that script i use
 
paulsa
newbie
Posts: 34
Joined: Tue Oct 29, 2013 10:24 am

Re: 6.30 RC final fixes before release

Mon Jul 13, 2015 1:25 pm

Trafficflow fix? 6.29 broke it, no egress + ingress netflows.
+
Any news? Anyone experiencing the issues that were in 6.29 and 6.29.1?
 
zinkpad
just joined
Posts: 16
Joined: Fri Jun 26, 2015 11:24 pm

Re: 6.30 RC final fixes before release

Wed Jul 15, 2015 7:27 pm

Okay, I think that I found the "bug" with "/tool fetch" command. In my initial script working on 6.29.1 I have the following command:
/tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser \
         password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
The above command doesn't works on 6.30rc28... then, I changed it for:
/tool fetch url=("http://members.dyndns.org".$str)  user=$ddnsuser mode=http  \
         password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
...and now it seems works on 6.30rc28 :D

I don't know if there are any problem with the "address" and "src-path" parameters on 6.30rcX...

Regards!

can you post full script ?
i try find and replace code but not working

# Set needed variables
:local username yyyy
:local password xxxxx
:local hostname xxxx.dyndns.tv

:global dyndnsForce
:global previousIP 

# print some debug info
:log info ("UpdateDynDNS: username = $username")
:log info ("UpdateDynDNS: password = $password")
:log info ("UpdateDynDNS: hostname = $hostname")
:log info ("UpdateDynDNS: previousIP = $previousIP")

# get the current IP address from the internet (in case of double-nat)
/tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
:delay 1
:local result [/file get dyndns.checkip.html contents]

# parse the current IP result
:local resultLen [:len $result]
:local startLoc [:find $result ": " -1]
:set startLoc ($startLoc + 2)
:local endLoc [:find $result "</body>" -1]
:local currentIP [:pick $result $startLoc $endLoc]
:log info "UpdateDynDNS: currentIP = $currentIP"

# Remove the # on next line to force an update every single time - useful for debugging,
# but you could end up getting blacklisted by DynDNS!

#:set dyndnsForce true

# Determine if dyndns update is needed
# more dyndns updater request details http://www.dyndns.com/developers/specs/syntax.html

:if (($currentIP != $previousIP) || ($dyndnsForce = true)) do={
   :set dyndnsForce false
   :set previousIP $currentIP
   :log info "$currentIP or $previousIP"
   /tool fetch user=$username password=$password mode=http address="members.dyndns.org" \
      src-path="nic/update?system=dyndns&hostname=$hostname&myip=$currentIP&wildcard=no" \
      dst-path="/dyndns.txt"
   :delay 1
   :local result [/file get dyndns.txt contents]
   :log info ("UpdateDynDNS: Dyndns update needed")
   :log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
   :put ("Dyndns Update Result: ".$result)
} else={
   :log info ("UpdateDynDNS: No dyndns update needed")
}
that script i use
Hi,

This is my script:
:global ddnsuser "theddnsusername"
:global ddnspass "theddnspassword"
:global theinterface "interfacename"
:global ddnshost blabla.dyndns.org
:global ipddns [:resolve $ddnshost];
:global ipfresh [ /ip address get [/ip address find interface=$theinterface ] address ]
:if ([ :typeof $ipfresh ] = nil ) do={
   :log info ("DynDNS: No ip address on $theinterface .")
} else={
   :for i from=( [:len $ipfresh] - 1) to=0 do={ 
      :if ( [:pick $ipfresh $i] = "/") do={ 
    :set ipfresh [:pick $ipfresh 0 $i];
      } 
}
 
:if ($ipddns != $ipfresh) do={
    :log info ("DynDNS: IP-DynDNS = $ipddns")
    :log info ("DynDNS: IP-Fresh = $ipfresh")
   :log info "DynDNS: Update IP needed, Sending UPDATE...!"
   :global str "/nic/update\?hostname=$ddnshost&myip=$ipfresh&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
   /tool fetch url=("http://members.dyndns.org".$str)  user=$ddnsuser mode=http  \
         password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
    :delay 1
    :log info "DynDNS: Data sent!"
    :global str [/file find name="DynDNS.$ddnshost"];
    /file remove $str
    :global ipddns $ipfresh
  :log info "DynDNS: IP updated to $ipfresh!"
    } else={
     :log info "DynDNS: dont need changes";
    }
} 
Software developer
GitHub profile: https://github.com/zinkpad
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 778
Joined: Mon May 14, 2012 9:30 pm

Re: 6.30 RC final fixes before release

Mon Jul 20, 2015 11:42 am

So in the dyn scripts we have been using...

? Breaks the script so that line needs to be changed from
\?
/tool fetch user=$username password=$password mode=http address="members.dyndns.org" \
src-path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/dyndns.txt"
to
/tool fetch user=$username password=$password mode=http address="members.dyndns.org" \
src-path="/nic/update\?hostname=$hostname&myip=$currentIP" dst-path="/dyndns.txt"

Then I get Error 400 for bad request.

Kind of stuck at the moment.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Mon Jul 20, 2015 11:46 am

gotsprings - one post above yours is a working script. why not use that one ?
No answer to your question? How to write posts
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 778
Joined: Mon May 14, 2012 9:30 pm

Re: 6.30 RC final fixes before release

Mon Jul 20, 2015 12:16 pm

gotsprings - one post above yours is a working script. why not use that one ?
2 reasons.

1. it's pretty different from what we have used for years.
2. is not written to take double NAT.

So I would prefer find the "break" in what we are used to an edit accordingly.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24280
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.30 RC final fixes before release

Mon Jul 20, 2015 12:28 pm

No answer to your question? How to write posts

Who is online

Users browsing this forum: No registered users and 75 guests