Page 1 of 1

6.30 RC final fixes before release

Posted: Fri Jun 26, 2015 4:54 pm
by normis
Please test the latest 6.30 rc and let us know if there are any unsolved issues remaining. We have solved all the problems that were reported, and only minor polishing remains.

Here is the newest changelog:

What's new in 6.30rc22 (2015-Jun-19 10:41):

*) ipsec - fail ph2 negitioation when initiator proposed key length does not match proposal configuration;
*) ssh - added option '/ip ssh stong-crypto'
*) wireless - improve ac radio coexistence with other wireless clients;
*) console - values of S~.id~, S~.nextid~ and S~.dead~ are avaliable for
use in 'print where' expressions;
*) console - ':execute' command now accepts 'file=' parameter and
writes script output to scpecified file;
*) console - ':execute' command now accepts script source in ~{}~ braces,
like '/system scripts add source=' does;
*) console - ':execute' command now returns internal number of running job,
that can be used to check and stop execution. For example:
:local j [:execute {/interface print follow where [:log info ~Sname~]}]
:delay 10s
:do { /system script job remove Sj } on-error={}
*) console - firewall 'print' commands now show all entries including
dynamic, 'all' argument now has no effect;
*) ipsec - increase replay window to 128;
*) fixed file transfer on devices with large RAM memory;
*) pptp - fixed ~encryption got out of sync~ problem;
*) ppp - disable vj tcp header compression;
*) api - reduce api tcp connection keepalive delay to 30 seconds,
will timeout idle connections in about 5 minutes;
*) pptp & l2tp & sstp client: support the case were server issues its tunnel ip address the
same as its public one;
*) removed wireless package from routeros bundle package, new wireless-fp is left in place;
*) pptp & l2tp client: when adding default route, add special exception route for
a tunnel itself (no need to add it manually anymore);
*) improved connection list: added connection packet/byte counters, added separate counters
for fasttrack, added current rate display, added flag wheather
connection is fasttracked/srcnated/dstnated, removed 2048 connection entry limit;
*) tunnels - eoip,eoipv6,gre,gre6,ipip,ipipv6,6to4 tunnels have new property - ipsec-secret - for easy setup of ipsec encryption and authentication;
*) firewall - added ipsec-policy matcher to check wheather packet was/will be ipsec processed or not;
*) possibility to disable route cache - improves DDOS attack handling performance up to 2x (note that ipv4 fastpath depends on route cache);
*) fasttrack - added dummy firewall rule in filter and mangle tables to show packets/bytes that get processed in fasttrack and bypass firewall;
*) fastpath - vlan interfaces support fastpath;
*) fastpath - partial support for bonding interfaces (rx only);
*) fastpath - vrrp interfaces support fastpath;

Re: 6.30 RC final fixes before release

Posted: Fri Jun 26, 2015 6:59 pm
by planetcoop
+1 on the fastpath and l2tp with ipsec, tested on ccr1016/ccr1036/x86 platforms.

Re: 6.30 RC final fixes before release

Posted: Fri Jun 26, 2015 7:32 pm
by rzirzi
"wireless - improve ac radio coexistence with other wireless clients" - what does it mean exactly?

Posted: Fri Jun 26, 2015 8:12 pm
by jarda
Why there are dummy firewall rules for fasttrack statistics instead showing correct values on real fasttracking rules? I don't understand it. Please, show the values where they belong to.

Re: 6.30 RC final fixes before release

Posted: Sat Jun 27, 2015 8:56 am
by 105547111
It's all good, I've only got a ticket about random ether cycles on a CRS226.

But my random reboots on a CCR are fixed in rc22

Re: 6.30 RC final fixes before release

Posted: Sat Jun 27, 2015 10:32 am
by IntrusDave
I think I'm good. My issues were fixed with this last build. Thank you.

Re: 6.30 RC final fixes before release

Posted: Sat Jun 27, 2015 11:39 am
by Beone
Are below also fixed? As there is no mentioning in the release notes

Ticket#2015061266000441 - Hotspot SSL error on sudden reboot
Ticket#2015060366000681 - Router does not send RADIUS-Stop messages on admin-reboot when internet uplink is of type pppoe/pptp
Re: V6.x Status/logoff linklogin wrongfully to HTTP even if HTTPS is selected

PS, we saw a memleak on v6.30rc19; hopefully this is fixed as well

Re: 6.30 RC final fixes before release

Posted: Sat Jun 27, 2015 6:28 pm
by RafZielak
Hi All,

If we are talking about current beta release ...
As it was written several times on many forums, scheduler is not working.
http://forum.mikrotik.com/viewtopic.php?f=1&t=98052
http://forum.mikrotik.com/viewtopic.php?f=1&t=97731

Brgds
RafZielak

Re: 6.30 RC final fixes before release

Posted: Sat Jun 27, 2015 9:35 pm
by rocknight13
Dear normis,
Please your comment for topic http://forum.mikrotik.com/viewtopic.php?f=1&t=98053
is this bug ? or there are mistake in command
regards

Re: 6.30 RC final fixes before release

Posted: Sun Jun 28, 2015 4:45 pm
by cegner
What about #2015042966000618?
It was supposed to be addressed in 6.30.

Re: 6.30 RC final fixes before release

Posted: Sun Jun 28, 2015 7:01 pm
by mindlesstux
I had a issue with going from 6.30rc19 to 6.30rc22. My bridges disappeared. They came back after a edit and reboot though.

Also wireless-cm2 was not in the all arch zip for tile. Had to use:
http://www.mikrotik.com/download/share/ ... t-tile.npk

Re: 6.30 RC final fixes before release

Posted: Sun Jun 28, 2015 9:05 pm
by solaoxo
scheduler is not working.

Re: 6.30 RC final fixes before release

Posted: Sun Jun 28, 2015 10:54 pm
by kez
scheduler is not working.
I could see the same thing on a "startup" script. It didn't work as well.
But I'm not sure if the whole scheduler is not working or just with the "startup" as start time.
Tested on PPC.

Re: 6.30 RC final fixes before release

Posted: Mon Jun 29, 2015 11:31 am
by LAD75
I confirm, scheduler is not working.
i try to use dyndns update script and it not working.
But manual start of the script is working properly.

Re: 6.30 RC final fixes before release

Posted: Mon Jun 29, 2015 1:44 pm
by newtonek
/ip settings
set route-cache=no tcp-syncookies=yes

/ip route cache print
cache-size: 2
max-cache-size: 16384


Is it normal? Route cache "disabled", but it still works? Or I'm missing something?

Re: 6.30 RC final fixes before release

Posted: Mon Jun 29, 2015 1:49 pm
by normis
rc23 should fix scheduler, it is in the download page already

Re: 6.30 RC final fixes before release

Posted: Mon Jun 29, 2015 2:38 pm
by LAD75
try simply script: ":log info message="TEST";"
and sheduler: "/system script run script1" 1/min

not working for me :(

Re: 6.30 RC final fixes before release

Posted: Mon Jun 29, 2015 4:13 pm
by RafZielak
Update 6.30rc23 downloaded/installed and ... unfortunately ... scheduler is not working still.

Re: 6.30 RC final fixes before release

Posted: Mon Jun 29, 2015 4:24 pm
by emils
Fix for scheduler will be in rc24, not rc23.

Re: 6.30 RC final fixes before release

Posted: Mon Jun 29, 2015 4:44 pm
by RafZielak
@emils
Thank you for your update but ...
When should we expect the newest version rc24?

Re: 6.30 RC final fixes before release

Posted: Mon Jun 29, 2015 5:06 pm
by upower3
No changelog for 6.30rc23, so waiting for rc24 and final.

May I please ask to highlight changes per RC in changelog (like it was before for versions)?

And, if it is possible at all, to set Content-Disposition for http://www.mikrotik.com/download/share/ ... evnote.txt to something that permits open it as plain text file? I hate to have other program to open simple text file.

Re: 6.30 RC final fixes before release

Posted: Mon Jun 29, 2015 5:10 pm
by G2Dolphin
Please, add a checkbox for turning off these dummy statistic rules for FastTrack. I don't understand, why do we need them, since we have this counter on IP - Settings.

Re: 6.30 RC final fixes before release

Posted: Tue Jun 30, 2015 3:21 am
by pbr3000
Please, add a checkbox for turning off these dummy statistic rules for FastTrack. I don't understand, why do we need them, since we have this counter on IP - Settings.
Yes. Let us choose to turn it on or off.

Posted: Tue Jun 30, 2015 6:55 am
by jarda
Why even those dummy rules? Put the values to the real rules correctly !

Re:

Posted: Tue Jun 30, 2015 9:39 am
by macgaiver
Why even those dummy rules? Put the values to the real rules correctly !
I find them very useful. Imagine situation when you need to connect to some unknown router and configure mangle and queue tree, you start mangling, but rules doesn't see the traffic, you have no idea why, cause you can see traffic on interface ....

Now you open mangle and you see that there are something - a rule that counting traffic - "aaaa, so there are my traffic".. It really avoids lots of potential confusion. I had several e-mails from our customers already about this, after everyone enabled fasttrack.

Initial implementation had some bugs, but as far as i can see latest RC adressed that.

Re: 6.30 RC final fixes before release

Posted: Tue Jun 30, 2015 11:18 am
by slav0nic
fasttrack for pppoe-client still not supported?

Re: 6.30 RC final fixes before release

Posted: Tue Jun 30, 2015 12:51 pm
by infused
Is the queue tree bug fixed from 29? The one where if you make constant changes the queues stop working?

Re: 6.30 RC final fixes before release

Posted: Tue Jun 30, 2015 3:09 pm
by Ansy
What about broken Simple Queues in Bridge configuration? 6.30rc22 (from 6.29, 6.30rc19,...)
http://forum.mikrotik.com/viewtopic.php ... 00#p488000
http://forum.mikrotik.com/viewtopic.php ... 90#p487990
It seems completely NO firewall, but IP Firewall box in Bridge Settings checked (screenshots).
All features worked OK until 6.27 .

Re: 6.30 RC final fixes before release

Posted: Tue Jun 30, 2015 9:01 pm
by slackR
rc23 should fix scheduler, it is in the download page already
I also saw issues with scheduled scripts not running and Netwatch scripts not executing on down/up. Has anyone else had this problem? I'm using rc23

Re: 6.30 RC final fixes before release

Posted: Tue Jun 30, 2015 9:06 pm
by macgaiver
What about broken Simple Queues in Bridge configuration? 6.30rc22 (from 6.29, 6.30rc19,...)
http://forum.mikrotik.com/viewtopic.php ... 00#p488000
http://forum.mikrotik.com/viewtopic.php ... 90#p487990
It seems completely NO firewall, but IP Firewall box in Bridge Settings checked (screenshots).
All features worked OK until 6.27 .
did you wrote an email to support like i suggested in othre topic?

Re: 6.30 RC final fixes before release

Posted: Tue Jun 30, 2015 11:16 pm
by mindlesstux
MikroTik RouterOS 6.30rc22 (c) 1999-2015 http://www.mikrotik.com/

jun/30/2015 11:49:08 ppp,error,critical pptp-vypervpn: Encryption got out of sync - disabling
jun/30/2015 11:58:38 ppp,error,critical pptp-vypervpn: Encryption got out of sync - disabling
jun/30/2015 13:58:10 ppp,error,critical pptp-vypervpn: Encryption got out of sync - disabling
jun/30/2015 15:35:52 ppp,error,critical pptp-vypervpn: Encryption got out of sync - disabling


Not sure if the Encryption out of sync is fixed yet...

Re: 6.30 RC final fixes before release

Posted: Wed Jul 01, 2015 5:10 am
by pbr3000
MikroTik RouterOS 6.30rc22 (c) 1999-2015 http://www.mikrotik.com/

jun/30/2015 11:49:08 ppp,error,critical pptp-vypervpn: Encryption got out of sync - disabling
jun/30/2015 11:58:38 ppp,error,critical pptp-vypervpn: Encryption got out of sync - disabling
jun/30/2015 13:58:10 ppp,error,critical pptp-vypervpn: Encryption got out of sync - disabling
jun/30/2015 15:35:52 ppp,error,critical pptp-vypervpn: Encryption got out of sync - disabling


Not sure if the Encryption out of sync is fixed yet...
It's not. I saw this error until rc23. The test client is a macbook pro with gigabit wired connection to pptp server. On debian server there is no problem.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 01, 2015 7:33 am
by IntrusDave
I hate to point out the obvious, but PLEASE fix the Leap Second crash on the TILE platform. I can not afford to have them all lock up like they did today.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 01, 2015 8:09 am
by LAD75
i setup external storage of log
setup type remote: 192.168.1.11, port 514
setup rules for remote (error, firewall, info, script,system, warning, l2tp), byt to all of them transfer to external storage

i have next lines of logs
Jul  1 11:07:11 router.domain.com dns,packet <1.2.3.4.in-addr.arpa:PTR:2981=host1234*.omkc.ru>
Jul  1 11:07:11 router.domain.com dns,packet --- got query from 192.168.1.11:33391:
Jul  1 11:07:11 router.domain.com dns,packet id:5e68 rd:1 tc:0 aa:0 qr:0 ra:0 QUERY 'no error'
and nothin from setup type of logs

Re: 6.30 RC final fixes before release

Posted: Wed Jul 01, 2015 9:22 am
by normis
Of course, 6.30 will not be released until NTP package problem with Leap Second on CCR will be fixed.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 01, 2015 10:45 am
by emils
@emils
Thank you for your update but ...
When should we expect the newest version rc24?
v6.30rc24 is available now.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 01, 2015 11:09 am
by giannello
Of course, 6.30 will not be released until NTP package problem with Leap Second on CCR will be fixed.
Does this mean that 6.29 has a known bug with leap second? That might explain why both our CCR crashed tonight.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 01, 2015 11:24 am
by normis
Of course, 6.30 will not be released until NTP package problem with Leap Second on CCR will be fixed.
Does this mean that 6.29 has a known bug with leap second? That might explain why both our CCR crashed tonight.
yes, all RouterOS versions are affected if you use NTP package and CCR.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 01, 2015 12:01 pm
by paulsa
Trafficflow fix? 6.29 broke it, no egress + ingress netflows.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 01, 2015 12:56 pm
by LAD75
scripts is worked on RC24!

Re: 6.30 RC final fixes before release

Posted: Wed Jul 01, 2015 2:25 pm
by Bernardo
Trafficflow fix? 6.29 broke it, no egress + ingress netflows.
+1

Re: 6.30 RC final fixes before release

Posted: Wed Jul 01, 2015 11:40 pm
by Lupin
"wireless - improve ac radio coexistence with other wireless clients" - what does it mean exactly?
What exactly did you improve?
Improve performance or latency when both N and AC clients are connected?

It also improves with Nstreme and NV2 protocol?

How much?

Re: 6.30 RC final fixes before release

Posted: Thu Jul 02, 2015 9:46 pm
by NicK
Image
Bug RB 750 (6.30 rc26): Sending packages to the port that is only connected but unused.

This began in version 6.29

Re: 6.30 RC final fixes before release

Posted: Thu Jul 02, 2015 10:43 pm
by Abdock
Has the issue of VPLS, MPLS, BGP, OSPF, which crashed the router in 6.28 fixed ? as i have 6.29.1 and i have to reboot the router every second day, some routes just dont work and power reboot is the only option on ccr. Anybody else having such issue ? my network was stable till 6.27 after that rebooting every other day.

Re: 6.30 RC final fixes before release

Posted: Fri Jul 03, 2015 12:54 am
by zinkpad
Hi,

I updated my RB951G to 6.30rc26 and now my DynDNS script fails,...I'm a beginner with Mikrotik, but debugging the script I saw that the /tool fetch command always return "Error 400 bad request".

I downgraded to 6.29.1 and works fine with the same script.

Regards!

Re: 6.30 RC final fixes before release

Posted: Fri Jul 03, 2015 10:31 am
by normis
Hi,

I updated my RB951G to 6.30rc26 and now my DynDNS script fails,...I'm a beginner with Mikrotik, but debugging the script I saw that the /tool fetch command always return "Error 400 bad request".

I downgraded to 6.29.1 and works fine with the same script.

Regards!
maybe post your script in a new topic, 400 bad request is server telling your that the request is malformed.

Re: 6.30 RC final fixes before release

Posted: Fri Jul 03, 2015 11:59 am
by miasik
Hi, I updated my RB951G to 6.30rc26 and now my DynDNS script fails,...I'm a beginner with Mikrotik, but debugging the script I saw that the /tool fetch command always return "Error 400 bad request". I downgraded to 6.29.1 and works fine with the same script. Regards!
maybe post your script in a new topic, 400 bad request is server telling your that the request is malformed.
May be developers trying to fix my [Ticket#2015063066000237] Fetch error on IPv6 url.

Re: 6.30 RC final fixes before release

Posted: Fri Jul 03, 2015 2:17 pm
by zinkpad
My script is the same that are in the Wiki:DynDns for RouterOS 6.x section.

Re: 6.30 RC final fixes before release

Posted: Fri Jul 03, 2015 2:21 pm
by normis
My script is the same that are in the Wiki:DynDns for RouterOS 6.x section.
It is not made by MikroTik, so I can't say if it should work or not. The article is made by one of the forum users. I suggest to make a new thread, and maybe some Dyn user could help improve the script to be more compatible

Re: 6.30 RC final fixes before release

Posted: Fri Jul 03, 2015 8:34 pm
by Bernardo
My script is the same that are in the Wiki:DynDns for RouterOS 6.x section.
It is not made by MikroTik, so I can't say if it should work or not. The article is made by one of the forum users. I suggest to make a new thread, and maybe some Dyn user could help improve the script to be more compatible
Now come on Normis....

it always is the users fault, isn´t it?

We too had problems with scripts.
Updating about 15 RB2011 from 6.29 (buggy as hell), to 6.30rc20, rc24 and later to rc26 (still buggy as hell), on all of them, the scripts stopped working.
On earlier versions, those ran without a problem for years.
Something clearly has changed.

saludos
Bernardo

Re: 6.30 RC final fixes before release

Posted: Fri Jul 03, 2015 10:14 pm
by rextended
The driver for ethernet on new 9xx ac board (random ether driver crash and restart only after reboot)
and the S-RJ01 are fixed???

http://forum.mikrotik.com/viewtopic.php ... 00#p485204

kernel crash on base box are fixed? i'm not the only user that report that

http://forum.mikrotik.com/viewtopic.php ... 00#p485633

Re: 6.30 RC final fixes before release

Posted: Sat Jul 04, 2015 4:37 am
by PtDragon
My script is the same that are in the Wiki:DynDns for RouterOS 6.x section.
It is not made by MikroTik, so I can't say if it should work or not. The article is made by one of the forum users. I suggest to make a new thread, and maybe some Dyn user could help improve the script to be more compatible
Now come on Normis....

it always is the users fault, isn´t it?

We too had problems with scripts.
Updating about 15 RB2011 from 6.29 (buggy as hell), to 6.30rc20, rc24 and later to rc26 (still buggy as hell), on all of them, the scripts stopped working.
On earlier versions, those ran without a problem for years.
Something clearly has changed.

saludos
Bernardo
Yeah, in 6.30RCs scripts do not work.
I really use them constantly (in scheduler) so please fix them.
It even did not import back exported config hanging on each line.

Re: 6.30 RC final fixes before release

Posted: Sat Jul 04, 2015 2:06 pm
by zinkpad
Okay, I think that I found the "bug" with "/tool fetch" command. In my initial script working on 6.29.1 I have the following command:
/tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser \
         password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
The above command doesn't works on 6.30rc28... then, I changed it for:
/tool fetch url=("http://members.dyndns.org".$str)  user=$ddnsuser mode=http  \
         password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
...and now it seems works on 6.30rc28 :D

I don't know if there are any problem with the "address" and "src-path" parameters on 6.30rcX...

Regards!

Re: 6.30 RC final fixes before release

Posted: Sun Jul 05, 2015 9:46 pm
by kez
Sorry, but I guess it's time for Mikrotik think about to integrate a native DDNS client. Look, it's already there for IP Cloud. Developers can say "it's hard to maintain a large number of DDNS services", so look at OpenWRT solution and leave IP check and update URLs strings as variables, so users can change them. It could be done on RAM memory, so it would decrease the number of NAND writes.
It's not so hard, just allow us to use what it is already there.

Re: 6.30 RC final fixes before release

Posted: Mon Jul 06, 2015 9:34 pm
by Lupin
"wireless - improve ac radio coexistence with other wireless clients" - what does it mean exactly?
What exactly did you improve?
Improve performance or latency when both N and AC clients are connected?

It also improves with Nstreme and NV2 protocol?

How much?
Normis any info about this changelog??

Re: 6.30 RC final fixes before release

Posted: Mon Jul 06, 2015 9:56 pm
by ibm
"wireless - improve ac radio coexistence with other wireless clients" - what does it mean exactly?
What exactly did you improve?
Improve performance or latency when both N and AC clients are connected?

It also improves with Nstreme and NV2 protocol?

How much?
Normis any info about this changelog??
+1

Re: 6.30 RC final fixes before release

Posted: Tue Jul 07, 2015 1:46 pm
by Ansy
6.30rc29
Got "CPU overload by management process" issue returned :(
http://forum.mikrotik.com/viewtopic.php ... 36#p485836

Now I need to control my RB750UP only via telnet console again. Lists become empty too.
Using Winbox hangs device to reboot by watchdog not pinging default gateway.
But Bridge + Simple Queues + Firewall are working now.

It seems we are walking in circles...

Re: 6.30 RC final fixes before release

Posted: Tue Jul 07, 2015 1:52 pm
by normis
What exactly did you improve?
Improve performance or latency when both N and AC clients are connected?

It also improves with Nstreme and NV2 protocol?

How much?
Normis any info about this changelog??
Neither!
It doesn't say anything about Nv2 or Nstreme, so you should not expect these changes.
Like the line says, 802.11ac previously was more agressive (interference wise, not bandwidth or latency) towards other devices. This has been reduced.

Re: 6.30 RC final fixes before release

Posted: Tue Jul 07, 2015 2:04 pm
by BartoszP
Normis:
Your explanation should be a part of changelog.
The word "coexistence" has so broad meaning that it tells nothing particular what was changed.

Re: 6.30 RC final fixes before release

Posted: Tue Jul 07, 2015 2:05 pm
by normis
leave IP check and update URLs strings as variables
one post above yours shows how you can already do this

Re: 6.30 RC final fixes before release

Posted: Tue Jul 07, 2015 6:50 pm
by apathy
Trafficflow fix? 6.29 broke it, no egress + ingress netflows.
+

Re: 6.30 RC final fixes before release

Posted: Tue Jul 07, 2015 11:10 pm
by miasik
Released 6.30 in Latest?

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 9:24 am
by normis
New build every few hours, RC is now removed, nearly ready to release. Any comments?

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 9:49 am
by cheeze
I would say, please release an RC-Final candidate file.

If people do not have any issues with it, then rename it and re-release it as 6.30.0 with no change other than the name.

That way whatever bugs are found are squashed before 6.30.0, and said backlash doesn't hit Mikrotik nearly as badly.

Other than that, what's the current changelog?

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 9:50 am
by normis
I would say, please release an RC-Final candidate file.

If people do not have any issues with it, then rename it and re-release it as 6.30.0 with no change other than the name.

That way whatever bugs are found are squashed before 6.30.0, and said backlash doesn't hit Mikrotik nearly as badly.

Other than that, what's the current changelog?
we have released RC versions every day for a few weeks already.
it has been on our main download page all this time.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 11:52 am
by eworm
New build every few hours, RC is now removed, nearly ready to release. Any comments?
Just wondering... When RC is removed from version string... Is there any way to see it is not the final build? Perhaps adding a package property with incrementing build id would be of help.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 11:53 am
by normis
New build every few hours, RC is now removed, nearly ready to release. Any comments?
Just wondering... When RC is removed from version string... Is there any way to see it is not the final build? Perhaps adding a package property with incrementing build id would be of help.
build time can be compared in "system packages". but yes, for the RC releases, currently we are not showing the build time, we will implement it for the download page

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 2:45 pm
by P2k1
where is wireless cm2 package for 6.30?

regards

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 2:49 pm
by eworm
where is wireless cm2 package for 6.30?
Probably it is there. But server gives "403 Forbidden", so looks file permissions are borked.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 2:58 pm
by normis
hold on please, release procedure script went crazy

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 3:02 pm
by eworm
Oh, just another note... Why does the ZIP archive (all_packages-mipsbe-6.30.zip) miss the capsman package (wireless-cm2-6.30-mipsbe.npk)?
Has always been this way, though. So this is not a regression.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 3:25 pm
by bajodel
hold on please, release procedure script went crazy
normis ..just a note: extra packages for x86 are missing

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 3:27 pm
by normis
I know, see above :) Sorry about that. This is why official topic doesn't exist yet.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 3:39 pm
by gabeselig
Could you post the changelog for the updated RouterBOOT?

The URL Here: http://wiki.mikrotik.com/wiki/RouterBOOT_changelog

It only goes up to 3.22 but I am seeing 3.24 on the RB450G boards now.

Thank you,
Gabe

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 3:41 pm
by honzam
As normis usualy say: Support for new products...

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 3:43 pm
by normis
This time, also small fix for reset-lock package.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 3:45 pm
by DmitriiP
Where:

wireless-cm2-6.30-mipsbe.npk
wireless-cm2-6.30-smips.npk

and others http://www.mikrotik.com/download ????

CAPsMANv2 only for ccr?

Check for updates:
ERROR: missing wireless-cm2-6.30-mipsbe.npk

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 3:49 pm
by normis
Where:
Dmitry, please read above posts before posting something.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 3:58 pm
by DmitriiP
Sorry, was very busy by trying to update AP's unsuccessfuly ;)

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 4:04 pm
by ste
New build every few hours, RC is now removed, nearly ready to release. Any comments?
We had MPLS/LDP-Problems with 6.29.1. /32 Routes did not work.

Ticket#2015070266000681

We cant go back to the errorstate to send supout of not working condition as this would screw our network. No further feedback so I guess it is not solved.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 4:17 pm
by normis
We had MPLS/LDP-Problems with 6.29.1. /32 Routes did not work.
We have several customers who have working MPLS/LDP and it works for us too. My colleagues are at a loss, since we are unable to repeat any problems, and you have not provided us with any clear information, at least the supout.rif file would help.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 4:36 pm
by PtDragon
Normis, please fix scripts on 6.30!
for example this one from scheduler dows not work in 6.30 but works in 6.29:
:local i 0;
:if ([/ip firewall mangle get [find comment="wan0"] disabled]=false) do {
:set i 0; {:do {:set i ($i + 1)} while (($i < 5) && ([/ping 209.244.0.5 interval=500ms interface=ether1 count=1]=0))};
  :if ($i=5 && [/ip firewall mangle get [find comment="wan0"] disabled]=false) do={:log info "wan0 down";
   /ip firewall mangle set [find comment="wan0"] disabled=yes;
   execute beeperdown}}
:if ([/ip firewall mangle get [find comment="wan0"] disabled]=true) do={
:set i 0; {:do {:set i ($i + 1)} while (($i < 5) && ([/ping  209.244.0.5 interval=500ms interface=ether1 count=1]=1))};
   :if ($i=5 && [/ip firewall mangle get [find comment="wan0"] disabled]=true) do={:log info "wan0 up";
   /ip firewall mangle set [find comment="wan0"] disabled=no;
   execute beeperup}}

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 4:44 pm
by mrz
What exactly is not working in that script?

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 5:06 pm
by PtDragon
What exactly is not working in that script?
On 6.29 it disables/enables rule in mangle(where i do load balancing) and gives sound+log message when uplink stops working/starts working again.
On 6.30 it does not do that at all(no rule changes and no sound, did not check if it sends pings but it does not do its job on 6.30).

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 5:12 pm
by ste
We had MPLS/LDP-Problems with 6.29.1. /32 Routes did not work.
We have several customers who have working MPLS/LDP and it works for us too. My colleagues are at a loss, since we are unable to repeat any problems, and you have not provided us with any clear information, at least the supout.rif file would help.
Maris informed me now. Thanks. I sent supout.rifs of the working routers after downgrading. I cant risk to upgrade again to provide supout of the problematic state. May be the problem is with mixed 6.15/6.29.1 routers. Dont know. But for sure there is a problem. The downgrade to 6.15 solved the problem and disabling LDP solved the problem, too.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 5:14 pm
by mrz
But what exactly is not working in the code? You have to debug your script to find an error.

I added your script on my router and it shows syntax error at execute beeperdown. What exactly is beeperdown?

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 5:37 pm
by PtDragon
But what exactly is not working in the code? You have to debug your script to find an error.

I added your script on my router and it shows syntax error at execute beeperdown. What exactly is beeperdown?
beeperdown
beeperup
They are sound scripts (in system->script)
You can remove them for debug, they aren't important.
If you wish have exactly same scripts for debug:

beeperdown
 :for i from=4000 to=2000 step=-500 do={
   :beep frequency=$i length=50ms;
   :delay 50ms;
 }
beeperup
 :for i from=2000 to=4000 step=500 do={
   :beep frequency=$i length=50ms;
   :delay 50ms;
 }

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 5:46 pm
by mrz
is that beeperdown script loaded as variable?

Otherwise :execute beeperdown is a syntax error and then of course the whole script is not going to run at all.

:execute command accepts "script" parameter which should be script source code not an unknown name.

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 6:11 pm
by PtDragon
is that beeperdown script loaded as variable?

Otherwise :execute beeperdown is a syntax error and then of course the whole script is not going to run at all.

:execute command accepts "script" parameter which should be script source code not an unknown name.
I replaced
execute
with
/system script run
and it works now.
You should warn about syntax changes on update(at first line) and give workarounds ;)
Thanks for help :)

Re: 6.30 RC final fixes before release

Posted: Wed Jul 08, 2015 9:02 pm
by bajodel
I know, see above :) Sorry about that. This is why official topic doesn't exist yet.
Now official topic exists ..6.30 is out ..but Extra Packages for x86 item is not on download page.

Re: 6.30 RC final fixes before release

Posted: Sun Jul 12, 2015 1:12 pm
by dadoremix
Okay, I think that I found the "bug" with "/tool fetch" command. In my initial script working on 6.29.1 I have the following command:
/tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser \
         password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
The above command doesn't works on 6.30rc28... then, I changed it for:
/tool fetch url=("http://members.dyndns.org".$str)  user=$ddnsuser mode=http  \
         password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
...and now it seems works on 6.30rc28 :D

I don't know if there are any problem with the "address" and "src-path" parameters on 6.30rcX...

Regards!

can you post full script ?
i try find and replace code but not working

# Set needed variables
:local username yyyy
:local password xxxxx
:local hostname xxxx.dyndns.tv

:global dyndnsForce
:global previousIP 

# print some debug info
:log info ("UpdateDynDNS: username = $username")
:log info ("UpdateDynDNS: password = $password")
:log info ("UpdateDynDNS: hostname = $hostname")
:log info ("UpdateDynDNS: previousIP = $previousIP")

# get the current IP address from the internet (in case of double-nat)
/tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
:delay 1
:local result [/file get dyndns.checkip.html contents]

# parse the current IP result
:local resultLen [:len $result]
:local startLoc [:find $result ": " -1]
:set startLoc ($startLoc + 2)
:local endLoc [:find $result "</body>" -1]
:local currentIP [:pick $result $startLoc $endLoc]
:log info "UpdateDynDNS: currentIP = $currentIP"

# Remove the # on next line to force an update every single time - useful for debugging,
# but you could end up getting blacklisted by DynDNS!

#:set dyndnsForce true

# Determine if dyndns update is needed
# more dyndns updater request details http://www.dyndns.com/developers/specs/syntax.html

:if (($currentIP != $previousIP) || ($dyndnsForce = true)) do={
   :set dyndnsForce false
   :set previousIP $currentIP
   :log info "$currentIP or $previousIP"
   /tool fetch user=$username password=$password mode=http address="members.dyndns.org" \
      src-path="nic/update?system=dyndns&hostname=$hostname&myip=$currentIP&wildcard=no" \
      dst-path="/dyndns.txt"
   :delay 1
   :local result [/file get dyndns.txt contents]
   :log info ("UpdateDynDNS: Dyndns update needed")
   :log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
   :put ("Dyndns Update Result: ".$result)
} else={
   :log info ("UpdateDynDNS: No dyndns update needed")
}
that script i use

Re: 6.30 RC final fixes before release

Posted: Mon Jul 13, 2015 1:25 pm
by paulsa
Trafficflow fix? 6.29 broke it, no egress + ingress netflows.
+
Any news? Anyone experiencing the issues that were in 6.29 and 6.29.1?

Re: 6.30 RC final fixes before release

Posted: Wed Jul 15, 2015 7:27 pm
by zinkpad
Okay, I think that I found the "bug" with "/tool fetch" command. In my initial script working on 6.29.1 I have the following command:
/tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser \
         password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
The above command doesn't works on 6.30rc28... then, I changed it for:
/tool fetch url=("http://members.dyndns.org".$str)  user=$ddnsuser mode=http  \
         password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
...and now it seems works on 6.30rc28 :D

I don't know if there are any problem with the "address" and "src-path" parameters on 6.30rcX...

Regards!

can you post full script ?
i try find and replace code but not working

# Set needed variables
:local username yyyy
:local password xxxxx
:local hostname xxxx.dyndns.tv

:global dyndnsForce
:global previousIP 

# print some debug info
:log info ("UpdateDynDNS: username = $username")
:log info ("UpdateDynDNS: password = $password")
:log info ("UpdateDynDNS: hostname = $hostname")
:log info ("UpdateDynDNS: previousIP = $previousIP")

# get the current IP address from the internet (in case of double-nat)
/tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
:delay 1
:local result [/file get dyndns.checkip.html contents]

# parse the current IP result
:local resultLen [:len $result]
:local startLoc [:find $result ": " -1]
:set startLoc ($startLoc + 2)
:local endLoc [:find $result "</body>" -1]
:local currentIP [:pick $result $startLoc $endLoc]
:log info "UpdateDynDNS: currentIP = $currentIP"

# Remove the # on next line to force an update every single time - useful for debugging,
# but you could end up getting blacklisted by DynDNS!

#:set dyndnsForce true

# Determine if dyndns update is needed
# more dyndns updater request details http://www.dyndns.com/developers/specs/syntax.html

:if (($currentIP != $previousIP) || ($dyndnsForce = true)) do={
   :set dyndnsForce false
   :set previousIP $currentIP
   :log info "$currentIP or $previousIP"
   /tool fetch user=$username password=$password mode=http address="members.dyndns.org" \
      src-path="nic/update?system=dyndns&hostname=$hostname&myip=$currentIP&wildcard=no" \
      dst-path="/dyndns.txt"
   :delay 1
   :local result [/file get dyndns.txt contents]
   :log info ("UpdateDynDNS: Dyndns update needed")
   :log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
   :put ("Dyndns Update Result: ".$result)
} else={
   :log info ("UpdateDynDNS: No dyndns update needed")
}
that script i use
Hi,

This is my script:
:global ddnsuser "theddnsusername"
:global ddnspass "theddnspassword"
:global theinterface "interfacename"
:global ddnshost blabla.dyndns.org
:global ipddns [:resolve $ddnshost];
:global ipfresh [ /ip address get [/ip address find interface=$theinterface ] address ]
:if ([ :typeof $ipfresh ] = nil ) do={
   :log info ("DynDNS: No ip address on $theinterface .")
} else={
   :for i from=( [:len $ipfresh] - 1) to=0 do={ 
      :if ( [:pick $ipfresh $i] = "/") do={ 
    :set ipfresh [:pick $ipfresh 0 $i];
      } 
}
 
:if ($ipddns != $ipfresh) do={
    :log info ("DynDNS: IP-DynDNS = $ipddns")
    :log info ("DynDNS: IP-Fresh = $ipfresh")
   :log info "DynDNS: Update IP needed, Sending UPDATE...!"
   :global str "/nic/update\?hostname=$ddnshost&myip=$ipfresh&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
   /tool fetch url=("http://members.dyndns.org".$str)  user=$ddnsuser mode=http  \
         password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
    :delay 1
    :log info "DynDNS: Data sent!"
    :global str [/file find name="DynDNS.$ddnshost"];
    /file remove $str
    :global ipddns $ipfresh
  :log info "DynDNS: IP updated to $ipfresh!"
    } else={
     :log info "DynDNS: dont need changes";
    }
} 

Re: 6.30 RC final fixes before release

Posted: Mon Jul 20, 2015 11:42 am
by gotsprings
So in the dyn scripts we have been using...

? Breaks the script so that line needs to be changed from
\?
/tool fetch user=$username password=$password mode=http address="members.dyndns.org" \
src-path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/dyndns.txt"
to
/tool fetch user=$username password=$password mode=http address="members.dyndns.org" \
src-path="/nic/update\?hostname=$hostname&myip=$currentIP" dst-path="/dyndns.txt"

Then I get Error 400 for bad request.

Kind of stuck at the moment.

Re: 6.30 RC final fixes before release

Posted: Mon Jul 20, 2015 11:46 am
by normis
gotsprings - one post above yours is a working script. why not use that one ?

Re: 6.30 RC final fixes before release

Posted: Mon Jul 20, 2015 12:16 pm
by gotsprings
gotsprings - one post above yours is a working script. why not use that one ?
2 reasons.

1. it's pretty different from what we have used for years.
2. is not written to take double NAT.

So I would prefer find the "break" in what we are used to an edit accordingly.

Re: 6.30 RC final fixes before release

Posted: Mon Jul 20, 2015 12:28 pm
by normis