Community discussions

 
mrb
just joined
Topic Author
Posts: 11
Joined: Wed Feb 06, 2013 12:12 pm

IP/Cloud doesn't perform auto-update

Sun Jul 26, 2015 2:02 pm

I have enabled IP > Cloud, and I expected it would auto-update given dns-name when my public IP address changes, based on reading relevant documentation. Quote:
ddns-enabled (yes | no)

If set to "yes" then router will send an encrypted message to the MikroTik cloud server. Server will then decrypt the message and verify that sender is an authentic Mikrotik router. If all is OK then server will create a DDNS record for this router and send response to the router. Every minute the cloud service on the router will check if external IP address matches the one sent to server and will send encrypted update to cloud server if IP address changes.
Bolded part is what I am having issue with. My public IP changed several times, since my cable-based ISP forces DHCP lease expiration every several days. This feature was enabled for more than a several weeks now, and it never did self-update. Forcing update by issuing /ip cloud force-update works as expected. Of course, I could script it to run frequently via scheduler, but I doubt that would be the right solution.

Here's the relevant configuration of my router.
[admin@HomeMT] > /ip cloud export verbose
# jul/26/2015 12:49:19 by RouterOS 6.29
# software id = UWXX-ZKXX
#
/ip cloud
set ddns-enabled=yes update-time=yes
/ip cloud advanced
set use-local-address=no

[admin@HomeMT] > /ip cloud print
    ddns-enabled: yes
     update-time: yes
  public-address: 188.2.xx.xx
        dns-name: 2fxx02dfxxxx.sn.mynetname.net
          status: updated
         warning: DDNS server received request from IP 188.2.xx.xx but your local IP was 192.168.0.10;
                  DDNS service might not work.
Last edited by mrb on Sun Jul 26, 2015 3:04 pm, edited 2 times in total.
 
jebz
Member Candidate
Member Candidate
Posts: 238
Joined: Sun May 01, 2011 12:03 pm
Location: Australia

Re: IP/Cloud doesn't perform auto-update

Sun Jul 26, 2015 2:56 pm


[admin@HomeMT] > /ip cloud print
ddns-enabled: yes
update-time: yes
public-address: 188.2.xx.xx
dns-name: 2fxx02dfxxxx.sn.mynetname.net
status: updated
warning: DDNS server received request from IP 188.2.xx.xx but your local IP was 192.168.0.10; DDNS service might
not work.
[/code]

The warning above is always present and it is self-explanatory. If I may suggest something: remove this warning when /ip cloud advanced use-local-address=no as it is redundant when local mode is disabled.
The warning
but your local IP was 192.168.0.10
indicates your router isn't obtaining a route-able internet address on it's WAN port. i.e. You router is behind another router with the WAN address of 188.2.xx.xx .
 
mrb
just joined
Topic Author
Posts: 11
Joined: Wed Feb 06, 2013 12:12 pm

Re: IP/Cloud doesn't perform auto-update

Sun Jul 26, 2015 3:03 pm

The warning
but your local IP was 192.168.0.10
indicates your router isn't obtaining a route-able internet address on it's WAN port. i.e. You router is behind another router with the WAN address of 188.2.xx.xx .
jebz, oh, that's right, I forgot about my local network configuration. 192.168.0.10 is indeed assigned to my router by upstream DHCP on the cable modem, that holds actual WAN address. I will edit original question to remove suggestion about the warning.

Anyhow, my question still stands. Any ideas as to why Cloud isn't auto-updating as advertised?
 
jebz
Member Candidate
Member Candidate
Posts: 238
Joined: Sun May 01, 2011 12:03 pm
Location: Australia

Re: IP/Cloud doesn't perform auto-update

Sun Jul 26, 2015 4:12 pm

The warning
but your local IP was 192.168.0.10
indicates your router isn't obtaining a route-able internet address on it's WAN port. i.e. You router is behind another router with the WAN address of 188.2.xx.xx .
jebz, oh, that's right, I forgot about my local network configuration. 192.168.0.10 is indeed assigned to my router by upstream DHCP on the cable modem, that holds actual WAN address. I will edit original question to remove suggestion about the warning.

Anyhow, my question still stands. Any ideas as to why Cloud isn't auto-updating as advertised?
Because the WAN address of your router isn't changing. It's staying the same, 192.168.0.10 .

Reconfigure your cable modem to do WAN bypass and operate as a modem only not a combination modem/router.
 
mrb
just joined
Topic Author
Posts: 11
Joined: Wed Feb 06, 2013 12:12 pm

Re: IP/Cloud doesn't perform auto-update

Sun Jul 26, 2015 4:28 pm

Anyhow, my question still stands. Any ideas as to why Cloud isn't auto-updating as advertised?
Because the WAN address of your router isn't changing. It's staying the same, 192.168.0.10 .

Reconfigure your cable modem to do WAN bypass and operate as a modem only not a combination modem/router.
I am not sure that is how it is supposed to work. Besides, that's exactly the case where use-local-address=yes option would come in handy, right? Let me quote the documentation again:
Every minute the cloud service on the router will check if external IP address matches the one sent to server [...]
This pretty clearly says that a publicly visible IP will be compared to the IP previously sent and saved in DDNS record. Dynamic DNS service serves the purpose of mapping a changing IP address to a fixed DNS, and although I can think of a scenario where I would actually want to map a dynamic local IP to a DDNS record, far more useful scenario is keeping a publicly visible IP mapped to a DDNS record, wherever in the routing chain that IP resides.

If I am forced to have a public IP address on my wan interface, that defeats the purpose and ease of use of the Cloud option. I can totally see many users in the same position as I, where they have a cable, an ADSL or another ISP-mandated device that provides connectivity to their home network, in front of their MikroTik router, without possibility to change internal routing options of said device.
Last edited by mrb on Sun Jul 26, 2015 10:24 pm, edited 1 time in total.
 
networkfudge
Trainer
Trainer
Posts: 130
Joined: Mon May 20, 2013 2:47 pm

Re: IP/Cloud doesn't perform auto-update

Sun Jul 26, 2015 10:13 pm

I am not sure that is how it is supposed to work. Besides, that's what use-local-address option is for, right? Let me quote the documentation again:
Every minute the cloud service on the router will check if external IP address matches the one sent to server [...]
+1

Yes it does sound like Mikrotik's logic/algorithm is flawed, I have the same network topology as mrb (uplink connection is behind nat) and cloud ip doesnt auto update despite having use-local-address option.
MTCNA MTCWE MTCRE MTCINE MTCTCE UWBS UWBA
 
networkfudge
Trainer
Trainer
Posts: 130
Joined: Mon May 20, 2013 2:47 pm

Re: IP/Cloud doesn't perform auto-update

Mon Jul 27, 2015 10:14 pm

Can anyone from Mikrotik comment on this?
MTCNA MTCWE MTCRE MTCINE MTCTCE UWBS UWBA
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24206
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: IP/Cloud doesn't perform auto-update

Tue Jul 28, 2015 9:34 am

This is most certainly not meant that way.

Your actual router must have the external IP. It will not detect changes on your gateways IP and we have no plans for such functionality.

You can send your LAN IP if you want, via the "use-local-address" option if you want, but detection still applies only to the address of the router.
No answer to your question? How to write posts
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

IP/Cloud doesn't perform auto-update

Wed Jul 29, 2015 9:30 am

I am maybe boring with this,but I have to say it again. Use normal dynamic dns service and appropriate script that will handle that.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24206
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: IP/Cloud doesn't perform auto-update

Wed Jul 29, 2015 9:41 am

Well yes, "ip cloud" offers basic features. Currently it does not offer more advanced stuff like custom names, detection of gateway IP changes etc.
No answer to your question? How to write posts
 
mrb
just joined
Topic Author
Posts: 11
Joined: Wed Feb 06, 2013 12:12 pm

Re: IP/Cloud doesn't perform auto-update

Thu Jul 30, 2015 12:09 am

Well yes, "ip cloud" offers basic features. Currently it does not offer more advanced stuff like custom names, detection of gateway IP changes etc.
Okay, thanks for the reply.

Can I ask you guys to please update docs to reflect this stance? I believe others can get confused as well, due to ambiguous wording in docs.
I am maybe boring with this,but I have to say it again. Use normal dynamic dns service and appropriate script that will handle that.
I am already using full-blown DynDNS script for this very purpose. I just was hoping (beyond hope, as it turns out) that things just got *much* simpler for MikroTik owners.

Regards
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Thu Jul 30, 2015 3:29 pm

No. Unfortunately it is not simplier in case you need things that ip cloud doesn't offer.
 
dattl
just joined
Posts: 10
Joined: Sun Sep 27, 2015 1:57 pm

Re: IP/Cloud doesn't perform auto-update

Mon Sep 28, 2015 8:41 pm

Hi,

I ran in the same Problem. I found out that it is much simpler to update through /ip cloud than other DDNS providers.
I posted this Script yesterday. It should do the trick:
http://forum.mikrotik.com/viewtopic.php ... me#p501271

-
Dattl
 
User avatar
usef
just joined
Posts: 2
Joined: Sun Jul 10, 2016 8:10 am

Re: IP/Cloud doesn't perform auto-update

Sun Jul 10, 2016 8:13 am

Hi,

I ran in the same Problem. I found out that it is much simpler to update through /ip cloud than other DDNS providers.
I posted this Script yesterday. It should do the trick:
http://forum.mikrotik.com/viewtopic.php ... me#p501271

-
Dattl
Hi
Great script. Thank you
 
User avatar
cszolee79
just joined
Posts: 18
Joined: Wed Mar 14, 2012 6:28 pm

Re: IP/Cloud doesn't perform auto-update

Fri Oct 07, 2016 1:06 pm

Just so you know, I had the same problem with Cloud update.

The ISP gave a device that we can't set as a simple ADSL modem, so we have DMZ to the Mikrotik behind it.
Unfortunately the ADSL is very bad, disconnects all the time, then the Mikrotik will not update the public IP for the Cloud.

So, solution:

1. new script
name: cloud
/ip cloud force-update

2. new schedule, every five minutes
event: cloud

And now we're happy, it forces update every 5 minutes.
You do not have the required permissions to view the files attached to this post.
One... Hundred... BILLION DOLLARS!
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: IP/Cloud doesn't perform auto-update

Fri Oct 07, 2016 2:26 pm

ok, changes the "external" to "WAN"

I hope that it makes it clear what router will look up - an IP address on its current WAN interface.
 
jo2jo
Forum Veteran
Forum Veteran
Posts: 958
Joined: Fri May 26, 2006 1:25 am

Re: IP/Cloud doesn't perform auto-update

Wed Jun 14, 2017 9:07 pm

This is most certainly not meant that way.

Your actual router must have the external IP. It will not detect changes on your gateways IP and we have no plans for such functionality.

You can send your LAN IP if you want, via the "use-local-address" option if you want, but detection still applies only to the address of the router.

This is partially flawed logic- one of the nice features MT has builtin to their Cloud side code is its ability to recognize where the request is coming from and use that public IP if ROS is infact sending a private IP as the interface's IP. <-- this is GREAT functionality / thinking on MTs part.

however,
This also is one of the core benefits of the DDNS part of /ip cloud . If the cloud side is smart enough to set the DDNS to a non private IP (ie use the "received request from IP") than the ROS side should be "smart" enough to run or force , force Update on some kind of schedule (even every 12h), just incase the user is not savey enough to know how to script and schedule a forced update. (and over recent years, clearly, MT has been making ROS / its Interface much easier so that the "non-tech" home users will adopt their great products - those users dont know how to script / schedule and frankly they also dont want to learn - unlike most of us.)
(btw, MT is doing this while still retaining+increasing all of the deeper power and functionality that we all love ROS for)

I understand MT / Normis ' reasons and position in this ( just use /force update on a schedule if you are "an exception to the way /ip cloud ddns was intended to function" , if you have a private IP on your GW interface) - but this just seems like stubbornness in place of helpful/easier functionality (with no downsides that i can think of).

tks
:beep :beep :beep
 
mpho1010
just joined
Posts: 2
Joined: Mon Jun 19, 2017 4:14 pm

Re: IP/Cloud doesn't perform auto-update

Mon Jun 19, 2017 4:43 pm

Hi

Please assist me with a script for No-IP portal. am currently on Version 6.39.2 (mipsbe)

Thanks
 
jo2jo
Forum Veteran
Forum Veteran
Posts: 958
Joined: Fri May 26, 2006 1:25 am

Re: IP/Cloud doesn't perform auto-update

Mon Jun 19, 2017 8:17 pm

Hi

Please assist me with a script for No-IP portal. am currently on Version 6.39.2 (mipsbe)

Thanks
A simple google search for: mikrotik ddns script
(or better yet i like to use on google : mikrotik ddns script site:forum.mikrotik.com )

will find your answer.

here are some links from that search:

viewtopic.php?t=81253
and
viewtopic.php?t=65013

Just be sure that whatever DDNS service you use, that your account stays valid on that service (ie some of them make you "check in" every X number of months, if you are on their free tier) -- i suggest using mikrotiks builtin "/ip cloud" service , if it works for your network setup (ie you dont have the issues we talk about in this thread)
:beep :beep :beep
 
jojoba2010
just joined
Posts: 1
Joined: Sun Apr 08, 2018 12:19 pm

Re: IP/Cloud doesn't perform auto-update

Sun Apr 08, 2018 1:05 pm

hi
i have the same problem.
DDNS server received request from IP 217.219.33.126 but your local IP was 172.20.10.79; DDNS service might not work.

what is the solution ?

Who is online

Users browsing this forum: No registered users and 87 guests