Community discussions

MikroTik App
 
remzalp
just joined
Topic Author
Posts: 5
Joined: Mon Jul 27, 2015 8:42 pm

DHCP bug (RB951G-2HnD) and failover?

Mon Aug 03, 2015 8:27 am

Working on failover with check gateway.
net.png
To the building comes 2 ISP- fiber optic and radio (backup).
LAN - 192.168.88.0/24

First question - Wi-Fi clients receiving network addresses of 192.168.1.0, the network is not 192.168.88.0. Net 192.168.1.0 have dhcp server too.

How to scatter Wi-Fi clients and the backup ISP into different network? Vlan?

Second question:
Used failover:
/ip route add gateway=fiberispppp check-gateway=ping
/ip route add gateway=192.168.1.1 distance=2

If fiber is down, switching occurs in about 5 minutes, but back with no switches.
Where is my mistake?

Fragments of config:
/interface ethernet
set [ find default-name=ether1 ] name=ether1-fiberisp
set [ find default-name=ether2 ] name=ether2-radioisp
set [ find default-name=ether3 ] name=ether3-master-local name=ether2-radioisp
UPD: ^^^^^^^ this fragment of config was buggy
set [ find default-name=ether4 ] master-port=ether3-master-local name=ether2-radioisp
set [ find default-name=ether5 ] master-port=ether3-master-local name=ether2-radioisp
/interface pppoe-client
add add-default-route=yes default-route-distance=1 disabled=no interface=ether1-gateway max-mru=1480 max-mtu=1480 mrru=512 name=fiberispppp service-name=fiberispppp user=... password=...

DHCP config:
/ip pool add name=dhcp ranges=192.168.88.100-192.168.88.254
/ip dhcp-server add address-pool=dhcp disabled=no interface=bridge-local lease-time=3d name=default

Bridge config:
/interface bridge port
add bridge=bridge-local interface=ether2-radioisp
add bridge=bridge-local interface=wlan1

IP addr:
/ip address
add address=192.168.1.2/24 interface=ether2-radioisp network=192.168.1.0
add address=192.168.88.1/24 interface=bridge-local network=192.168.88.0

Version - MikroTik RouterOS 6.30.1
You do not have the required permissions to view the files attached to this post.
Last edited by remzalp on Sun Aug 09, 2015 7:22 pm, edited 1 time in total.
 
remzalp
just joined
Topic Author
Posts: 5
Joined: Mon Jul 27, 2015 8:42 pm

Re: DHCP bug (RB951G-2HnD) and failover?

Sun Aug 09, 2015 6:59 pm

bug was in bridge.

At bridge connected ether2-radioisp with dhcp server, wlan1.

User connects by wlan1 received reply from dhcp server on ether2-radioisp.

other questions answered on russian https://toster.ru/q/237478

Who is online

Users browsing this forum: Baidu [Spider], codebreaker, Google Feedfetcher, muhlpaul, sindy and 31 guests