Page 1 of 1

SMTP problem, how?

Posted: Sat Jul 29, 2006 4:28 pm
by ropeba
Does anyne know how could I set sending only via SMTP server of my provider, and all others must be rejected. I did following, but it's not working

/ ip firewall filter
add chain=forward protocol=tcp dst-port=25 dst-address-list=SMTP action=drop comment="" disabled=no

/ ip firewall address-list
add list=SMTP address=PROVIDERIP/32 comment="ISP SMTP" disabled=no

Posted: Sat Jul 29, 2006 4:31 pm
by BurstNET
Order of the rules should probably be reversed, as you are rejecting everything before you are allowing what you want. Allow first, then reject the rest?

SMA

Posted: Sat Jul 29, 2006 4:38 pm
by ropeba
but can you tell me which order should I use?
how should I configure that?

thanks

Posted: Sat Jul 29, 2006 4:48 pm
by ropeba
I got it, first I add rule for forwarding of port 25 to Ip form provider, and then I add rule for blocking of all bandwith on port 25

Posted: Sat Jul 29, 2006 10:50 pm
by GotNet
Thiis type of thing is good in WinBox - just drag 'em where you want 'em.

Mike

Posted: Sun Jul 30, 2006 11:44 am
by savage
Why not just use one rule?
/ ip firewall filter 
add chain=forward protocol=tcp dst-port=25 dst-address-list=!SMTP action=drop comment="" disabled=no
Drop everything outgoing on port 25 *not* going to dst-address-list ? ;)