Community discussions

MUM Europe 2020
 
johnsilver
newbie
Topic Author
Posts: 32
Joined: Tue Aug 23, 2011 12:53 pm

DNS assign for L2TP/IPSEC... bug?

Mon Aug 10, 2015 5:14 pm

Hi.

When i set DNS server (in PPP -> Profiles) L2TP connection can't be established. When i clear DNS server parameter then i can connect. Is it normal behavior?

In L2TP logs from router i can see that client in first case asked for ms-dns parameters and didn't get it and then trying again multiple times and then stopped with error "No network protocols running". In second case ms-dns parameter recieved router's ip as ms-dns parameter and second ms-dns from IP -> DNS.

So i can't set my dns server in PPP profile. Is it normal behavior?
 
johnsilver
newbie
Topic Author
Posts: 32
Joined: Tue Aug 23, 2011 12:53 pm

Re: DNS assign for L2TP/IPSEC... bug?

Mon Aug 10, 2015 5:34 pm

Here is screenshot with ConfReq/ConfAck/ConfRef
ImageImage
 
johnsilver
newbie
Topic Author
Posts: 32
Joined: Tue Aug 23, 2011 12:53 pm

Re: DNS assign for L2TP/IPSEC... bug?

Tue Aug 11, 2015 9:29 am

So i guess this is a bug. If i put two DNS servers in PPP profile than everything works OK. If one then no connection at all.
 
SN2015
just joined
Posts: 1
Joined: Tue Aug 11, 2015 9:49 am

Re: DNS assign for L2TP/IPSEC... bug?

Tue Aug 11, 2015 11:29 am

L2tp over IPsec will not be able to receive DNS suffix.
 
johnsilver
newbie
Topic Author
Posts: 32
Joined: Tue Aug 23, 2011 12:53 pm

Re: DNS assign for L2TP/IPSEC... bug?

Thu Aug 13, 2015 10:53 am

Yes, I know. Thank you.

The bug described here fixed in 6.30.2 firmware upgrade.
What's new in 6.30.2 (2015-Jul-22 11:17):

*) pptp & l2tp - fixed problem where android client could not connect if
both dns names were not provided (was broken since v6.30);

Who is online

Users browsing this forum: No registered users and 69 guests