Page 1 of 1

PPPoE Server on Bridge, only one client works at a time

Posted: Wed Aug 12, 2015 8:45 am
by rwrocket
I have a PPPoE Setup I am testing

Previously I had 2 PPPoE clients and two PPPoE servers running on their vlan interfaces respectively all on mikrotik hardware.

I plan to deliver PPPoE using Radius to configure IP's etc so I thought I could create just one PPPoE Server on a bridge and bridge all my client networks/tunnels to it.

Here is the strange thing

If I have one PPPoE server running on a bridge with an IP assigned, The PPPoE Server has the same IP.
With both my client vlans connected to the bridge PPPoE doesn't connect, I get this in the PPPoE log on the client:

"sent PADI to XXXXXXXXXXX dropping PADI no service to offer"

If I disable the bridge port for one of the clients, voila it works and the other client connects.

I have tried changing ARP, turning off RSTP in the bridge, nothing works

My PPPoE server only works when only one client is connected.
And yes these are different usernames so I don't believe I need to untick Allow one session per host.

Re: PPPoE Server on Bridge, only one client works at a time

Posted: Thu Aug 13, 2015 12:47 pm
by magnavox
Helo!

If I understand, I have same problem.

I tried to setup PPPoE Server over a Bridge interface that contain multiple VLANs.
VLANs are in QinQ scenario (outer and inner).
So it's possible to have two or more VLANs (inner) into same VLAN (outer).
In this last case, only one a PPPoE Client go UP!

Where i wrong?
Need to add some Bridge Filter rules?

tnx

Re: PPPoE Server on Bridge, only one client works at a time

Posted: Mon Aug 17, 2015 4:59 am
by rwrocket
Well I am glad to know it is not only me

However I don't have QinQ, I am just adding VLANs to a bridge then putting a PPPoE Server on that bridge.

Re: PPPoE Server on Bridge, only one client works at a time

Posted: Tue Aug 18, 2015 9:23 am
by rwrocket
I have found out the solution to this problem myself

It is because my VLAN MAC Addresses are the same

In my case I had my vlans attached to an INTERFACE BOND so they all had the same MAC address

I am not sure the best way to get around this however

Doesn't seem like I can change the MAC address on the VLAN interfaces

Re: PPPoE Server on Bridge, only one client works at a time

Posted: Tue Aug 18, 2015 5:44 pm
by lenart
I have found out the solution to this problem myself

It is because my VLAN MAC Addresses are the same

In my case I had my vlans attached to an INTERFACE BOND so they all had the same MAC address

I am not sure the best way to get around this however

Doesn't seem like I can change the MAC address on the VLAN interfaces
I'm afraid I'm not much help when it comes to providing a clear-cut solution here. I can however tell you that a VLAN isn't an interface and therefore doesn't have a MAC address.

Is it an option to use virtual interfaces? That would allow you to set a separate MAC on each [vif] and attach a VLAN to that [vif]. These could then be added to the bridge.

Re: PPPoE Server on Bridge, only one client works at a time

Posted: Tue Aug 18, 2015 8:45 pm
by magnavox
I solved my issue...

Need prevent traffic intra-VLANs. So, you can add a filter bridge rule to drop forward packets, but best solution is use "Split Horizont" option, configuring same value "Horizont" on all bridge ports that you NOT want to exange traffic. All bridge ports whit same Horizont value NOT exange packets.

This can help you?

Re: PPPoE Server on Bridge, only one client works at a time

Posted: Wed Aug 19, 2015 2:38 am
by rwrocket
I will experiment with both of these solutions and get back to you both

thanks for your input

Re: PPPoE Server on Bridge, only one client works at a time

Posted: Wed Aug 19, 2015 3:48 am
by rwrocket
Split Horizon indeed does solve my issue, seems to be the most elegant solution also

thanks all

Re: PPPoE Server on Bridge, only one client works at a time

Posted: Wed Aug 19, 2015 10:54 am
by magnavox
Yes, use Split Horizont, bridge filter rule is poor solution... more CPU usage, problem whit more bridge....