Community discussions

 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

v6.41.2 [current]

Fri Feb 09, 2018 3:29 pm

RouterOS version 6.41.2 has been released in public "current" channel!

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 6.41.2 (2018-Feb-06 12:29):

*) bridge - fixed ARP settings on bridge interfaces (introduced v6.41);
*) discovery - fixed discovery interface list change;
*) disk - fixed disk related processes becoming unresponsive after unplugging used disk;
*) filesystem - fixed situations when "/flash" directory lost files after upgrade;
*) ppp - do not lose "/ppp profile" script configuration after other profile parameters are edited;
*) routerboard - properly report warnings under "/system routerboard" menu;
*) snmp - added w60g support;
*) w60g - fixed "/interface w60g reset-configuration";
*) webfig - fixed backup loading from Webfig on RouterBOARD running default configuration;
*) winbox - changed default bridge port PVID value to 1;
*) wireless - fixed wireless protocol mode restrictions if lockpack is installed and has limits for it;

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5730
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.41.2 [current]

Fri Feb 09, 2018 4:52 pm

Does it fix all the reported new 6.41.1 (vs 6.41) issues reported in the 6.41.1 topic?
It does not look like that in the changelog...
 
w0lt
Member
Member
Posts: 482
Joined: Wed Apr 02, 2008 2:12 pm
Location: Minnesota USA

Re: v6.41.2 [current]

Fri Feb 09, 2018 6:37 pm

Upgraded several 6.4.1 versions, no problems yet. 8)

-tp
MTCNA - 2011

" The Bitterness of Poor Quality Remains Long After the Sweetness of Low Price is Forgotten "
 
User avatar
ErfanDL
Member Candidate
Member Candidate
Posts: 274
Joined: Thu Sep 29, 2016 9:13 am
Location: IRAN
Contact:

Re: v6.41.2 [current]

Fri Feb 09, 2018 6:53 pm

After upgrade to 6.41.2 bridge mac address changed :|

Sent from my C6833 using Tapatalk


 
lisek
just joined
Posts: 1
Joined: Fri Feb 09, 2018 4:48 pm
Location: Poland
Contact:

Re: v6.41.2 [current]

Fri Feb 09, 2018 7:09 pm

Thank goodness WEBFIG dude works on the server in the web interface, and there is access to information. Difficult but it is.
 
drees
just joined
Posts: 22
Joined: Tue Sep 20, 2016 9:39 pm

Re: v6.41.2 [current]

Fri Feb 09, 2018 7:19 pm

I noticed that starting with v6.41.1 (and v6.41.2) that the routerboard-firmware versioning has changed to match the RouterOS version.

This is fine, but with these last two versions, there were firmware updates for my 951G-2HnD and 941-2nD.

Problem is that there's no real indication that a firmware update is available when updating RouterOS, so a firmware update is easy to miss - it's also impossible to tell what changes are in the firmware and how important it might be to apply those firmware updates.

On a similar note, after pressing the Upgrade button on the Routerboard firmware upgrade page, some sort of simple message saying that you should reboot when the firmware is updated should be presented. Right now I usually go to the Log file to verify that the firmware updated before rebooting.
 
jackx
just joined
Posts: 4
Joined: Wed Feb 07, 2018 6:33 pm

Re: v6.41.2 [current]

Fri Feb 09, 2018 9:14 pm

After upgrade to 6.41.2 bridge mac address changed :|
I suspect the changes in the bridge settings and behavior caused my hAP lite bridges to become unresponsive. I'd like to upgrade for the hardware offloading features but I'm afraid my devices will lock up again.
 
User avatar
LucZWFM
Member Candidate
Member Candidate
Posts: 127
Joined: Tue Dec 26, 2017 10:47 pm
Location: Bergen op Zoom, The Netherlands

Re: v6.41.2 [current]

Fri Feb 09, 2018 9:31 pm

After upgrading my only just 3 months old 2011iL-RM got stuck in a bootloop and
I am not able to recover it, what ever I try..

:(
Volunteer Techie @ZuidWest FM / ZuidWest TV, Stichting Repeater Bergen op Zoom & WRLP CB Repeater
 
PashaT
just joined
Posts: 15
Joined: Sat Feb 01, 2014 1:10 am
Location: Zhytomyr, Ukraine

Re: v6.41.2 [current]

Fri Feb 09, 2018 11:02 pm

interface,warning ether3: bridge port received packet with own address as source address (#MAC), probably loop

hap-ac-lite(port3) connected to the hap-lite(port1).
hap-lite configured as bridge.

Reproduced with 6.41, 6.41.1, 6.41.2.

[Ticket#2018020922005437]

What's new in 6.41.1 (2018-Jan-30 10:26):
*) bridge - fixed situation when packet could be sent with local MAC as dst-mac;
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Sat Feb 10, 2018 12:38 am

pe1chl - Which specific fix are you looking for;
drees - Thank you for suggestion. Yes, at the moment you can see warning on CLI and System/RouterBOARD/Settings menu but do not see any warning pop-up;
jackx - Please do not assume that if someone did upgrade model X device to specific version and it did not boot up that there is some version related problem with particular model device. It is possible, but usually it is false alarm. In most cases, when router becomes unavailable after upgrade, problem is caused due to configuration changes (affected by upgrade - admin did not see changes in changelog) or there was a problem during upgrade (upgrade happens on old version, not the one which you install);
LucZWFM - Have you tried to Netinstall device? From which version did you upgrade your router? Can you install same version, same configuration and try to upgrade once more and reproduce the same problem;
PashaT - This has nothing to do with the fix which you referenced. Are you sure that there is no actual loop in your network? Are you sure that there is no other device in network with same MAC address as this routers ether3 interface;
 
i4ko
just joined
Posts: 14
Joined: Sat Sep 26, 2015 9:23 pm

Re: v6.41.2 [current]

Sat Feb 10, 2018 5:42 am

None of my 941-2nDs are able to upgrade. I have no files in files menu in winbox besides the regular ones. Yet the available space is only 6.9mb. The winbox will not start downloading the update, nor it is possible to upload a complete update file manually. I've tried recreating the flash folder and the flash/pub and flash/skins sub folders - no go. Please advise.
 
105547111
Member Candidate
Member Candidate
Posts: 131
Joined: Fri Jun 22, 2012 9:46 pm

Re: v6.41.2 [current]

Sat Feb 10, 2018 5:58 am

The special dummy rule in filters, mangle and raw to show fasttrack is 0, but my own fasttrack rules are working and counting packets.

Actually they are counting but I see only 11 packets after 2 hours. My own fasttrack on fwd that is more restrictive shows 4 million and increasing.

Checked connections using fasttrack yes and no and indeed 2/3 of the traffic is fasttrack

Another new bug?
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 1364
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Randburg
Contact:

Re: v6.41.2 [current]

Sat Feb 10, 2018 7:22 am

None of my 941-2nDs are able to upgrade. I have no files in files menu in winbox besides the regular ones. Yet the available space is only 6.9mb. The winbox will not start downloading the update, nor it is possible to upload a complete update file manually. I've tried recreating the flash folder and the flash/pub and flash/skins sub folders - no go. Please advise.
Provide results for:

/file print

/system package print
MTCNA, MTCTCE, MTCRE & MTCINE
 
User avatar
LucZWFM
Member Candidate
Member Candidate
Posts: 127
Joined: Tue Dec 26, 2017 10:47 pm
Location: Bergen op Zoom, The Netherlands

Re: v6.41.2 [current]

Sat Feb 10, 2018 10:47 am

Still stuck in bootloop... no matter what I try...
Last edited by LucZWFM on Sat Feb 10, 2018 10:50 am, edited 1 time in total.
Volunteer Techie @ZuidWest FM / ZuidWest TV, Stichting Repeater Bergen op Zoom & WRLP CB Repeater
 
User avatar
LucZWFM
Member Candidate
Member Candidate
Posts: 127
Joined: Tue Dec 26, 2017 10:47 pm
Location: Bergen op Zoom, The Netherlands

Re: v6.41.2 [current]

Sat Feb 10, 2018 10:48 am

LucZWFM - Have you tried to Netinstall device? From which version did you upgrade your router? Can you install same version, same configuration and try to upgrade once more and reproduce the same problem;

The board refuses to appear in netinstall, tried on 3 computers now...
This make me unable to try anything...

I upgraded from 6.41.1.
Volunteer Techie @ZuidWest FM / ZuidWest TV, Stichting Repeater Bergen op Zoom & WRLP CB Repeater
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Sat Feb 10, 2018 11:40 am

i4ko - Which RouterOS packages you have installed on your device;
105547111 - Most likely there are processes running on your router which stop FastTrack:
https://wiki.mikrotik.com/wiki/Manual:IP/Fasttrack
LucZWFM - Have you tried to Netinstall any other RouterBOARD to be sure that Netinstall is properly running?

Note: Netinstall is a tool which detects router running in Ether boot mode. Ether boot mode is started from firmware. RouterOS upgrade does not affect firmware. This clearly states that you simply can not upgrade RouterOS and suddenly Netinstall possibility would be broken. In 95% of cases there is a problem with Netinstall + computer + network configuration.
 
Lakis
Forum Veteran
Forum Veteran
Posts: 701
Joined: Wed Sep 23, 2009 7:52 pm

Re: v6.41.2 [current]

Sat Feb 10, 2018 12:48 pm

*) crs317 - improved transmit performance between 10G and 1G ports;
yes its fixed

but on 960PGS transmit performance between 1G and 100mbit not fixed (when hw offload enable)
 
User avatar
zervan
Member
Member
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: v6.41.2 [current]

Sat Feb 10, 2018 5:30 pm

Somebody using CRS112-8G-4S? I have 2 SFP modules on it. It is rebooting me each 2 minutes when I turn on IGMP Snooping. The same problem was with v6.41. Can't make supout, because not enough time to next reboot. Automatic Supout in Watchdog is not working (don't know why). No problem with CRS109-8G-1S-2HnD (and no SFP module).
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
PashaT
just joined
Posts: 15
Joined: Sat Feb 01, 2014 1:10 am
Location: Zhytomyr, Ukraine

Re: v6.41.2 [current]

Sat Feb 10, 2018 5:44 pm

1. [Ticket#2018021022001447]
Detect Internet not working on two different providers.

2. [Ticket#2018020922005437]
PashaT - This has nothing to do with the fix which you referenced. Are you sure that there is no actual loop in your network? Are you sure that there is no other device in network with same MAC address as this routers ether3 interface;
No other devices with same mac, only one PC connected.

Additional info:
hap-lite configured as bridge, DHCP client on the bridge.
I see two DHCP leases on the root router, one with bridge port MAC, second with ether1 port MAC address.

EDITED:
When Detect Internet is activated on the interface without the address - invisible DHCP client running on that interface. Ether1 was added to detect interface list.
Last edited by PashaT on Sun Feb 11, 2018 2:56 am, edited 7 times in total.
 
User avatar
GreySer
just joined
Posts: 19
Joined: Thu Apr 21, 2016 9:38 am
Location: Cheboksary

Re: v6.41.2 [current]

Sat Feb 10, 2018 6:19 pm

After upgrading my only just 3 months old 2011iL-RM got stuck in a bootloop and
I am not able to recover it, what ever I try..

:(
At RB3011 bootloop too.
 
AntonReviakin
just joined
Posts: 3
Joined: Sat Feb 10, 2018 6:22 pm

Re: v6.41.2 [current]

Sat Feb 10, 2018 6:28 pm

On Virtual of WLAN can't receive IP. Log: XX:XX:XX:XX:XX:XX@WLAN_VIRTUAL: disconnected, received deauth: sending station leaving (3)
 
jackx
just joined
Posts: 4
Joined: Wed Feb 07, 2018 6:33 pm

Re: v6.41.2 [current]

Sat Feb 10, 2018 7:08 pm

jackx - Please do not assume that if someone did upgrade model X device to specific version and it did not boot up that there is some version related problem with particular model device. It is possible, but usually it is false alarm. In most cases, when router becomes unavailable after upgrade, problem is caused due to configuration changes (affected by upgrade - admin did not see changes in changelog) or there was a problem during upgrade (upgrade happens on old version, not the one which you install);
Let me be clear: before the upgrade, each bridge had its own MAC address. After the upgrade, there were MAC address conflicts because some of the bridges had the same MAC address. This should never happen. This was on FACTORY DEFAULT firmware and settings.
 
mstead
Member Candidate
Member Candidate
Posts: 112
Joined: Sat Mar 04, 2006 2:41 am

Re: v6.41.2 [current]

Sat Feb 10, 2018 9:29 pm

The ping tool is broken and has been for many versions - I only noticed this tonight. The "timeout" option doesn't change the ping timeout but rather the interval between pings. So this is either a bug or a badly labelled "ping interval" option. However timeout is a crucial parameter for any ping tool.
 
i4ko
just joined
Posts: 14
Joined: Sat Sep 26, 2015 9:23 pm

Re: v6.41.2 [current]

Sat Feb 10, 2018 10:06 pm

None of my 941-2nDs are able to upgrade. I have no files in files menu in winbox besides the regular ones. Yet the available space is only 6.9mb. The winbox will not start downloading the update, nor it is possible to upload a complete update file manually. I've tried recreating the flash folder and the flash/pub and flash/skins sub folders - no go. Please advise.
Provide results for:

/file print

Code: Select all

[mkadm@MikroTik] > /file print
# NAME TYPE SIZE CREATION-TIME
0 flash directory feb/09/2018 20:46:43
1 flash/pub directory feb/09/2018 20:46:43
2 flash/skins directory feb/09/2018 20:46:43
[mkadm@MikroTik] >
/system package print

Code: Select all

[mkadm@MikroTik] > /system package print
Flags: X - disabled
# NAME VERSION SCHEDULED
0 routeros-smips 6.41.1
1 system 6.41.1
2 X ipv6 6.41.1
3 wireless 6.41.1
4 X hotspot 6.41.1
5 dhcp 6.41.1
6 X mpls 6.41.1
7 routing 6.41.1
8 X ppp 6.41.1
9 security 6.41.1
10 advanced-tools 6.41.1
[mkadm@MikroTik] >
[/quote]
And the relevant portion from /system resource print

Code: Select all

uptime: 16h14m40s
version: 6.41.1 (stable)
build-time: Jan/30/2018 10:26:14
free-memory: 6.0MiB
total-memory: 32.0MiB
cpu: MIPS 24Kc V7.4
cpu-count: 1
cpu-frequency: 650MHz
cpu-load: 9%
free-hdd-space: 7.0MiB
total-hdd-space: 16.0MiB
write-sect-since-reboot: 36352
write-sect-total: 39081061
bad-blocks: 0%
architecture-name: smips
board-name: hAP lite
platform: MikroTik
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Sun Feb 11, 2018 12:14 pm

Lakis, zervan, AntonReviakin - Please contact support@mikrotik.com regarding this issue. I assume that downgrade to 6.41.1 fix the problem and after upgrade to 6.41.2 again shows the same problem.
GreySer - What do you see on serial console? Did you try to Netinstall device?
jackx - If you did not have admin-mac configured, then bridge uses MAC address of first interface recognized by RouterOS. MAC can change between reboots, etc. I assume that downgrade to 6.41.1 fix the problem and after upgrade to 6.41.2 again shows the same problem?
mstead - This topic is created to find problems which were not in RouterOS in 6.41.1 and are in 6.41.2. Have you contacted support regarding this problem? We are not aware about such problem. Write to support@mikrotik.com regarding this problem.
i4ko - Have you had other RouterOS packages installed on the device in the past? If you reboot router is space freed up?
 
AntonReviakin
just joined
Posts: 3
Joined: Sat Feb 10, 2018 6:22 pm

Re: v6.41.2 [current]

Sun Feb 11, 2018 12:39 pm

Lakis, zervan, AntonReviakin - Please contact support@mikrotik.com regarding this issue. I assume that downgrade to 6.41.1 fix the problem and after upgrade to 6.41.2 again shows the same problem.
GreySer - What do you see on serial console? Did you try to Netinstall device?
jackx - If you did not have admin-mac configured, then bridge uses MAC address of first interface recognized by RouterOS. MAC can change between reboots, etc. I assume that downgrade to 6.41.1 fix the problem and after upgrade to 6.41.2 again shows the same problem?
mstead - This topic is created to find problems which were not in RouterOS in 6.41.1 and are in 6.41.2. Have you contacted support regarding this problem? We are not aware about such problem. Write to support@mikrotik.com regarding this problem.
i4ko - Have you had other RouterOS packages installed on the device in the past? If you reboot router is space freed up?
Thanks, it's works. In virtual WLAN dropdown "VLAN Mode" select "no tag" and reconnecting to both interfaces :-)
 
Mikhail73
just joined
Posts: 10
Joined: Wed Sep 21, 2016 8:31 pm

Re: v6.41.2 [current]

Sun Feb 11, 2018 12:41 pm

Just now upgraded my wAP AC from 6.41 to 6.41.2. With my MacBook Air '15 RX/TX was 585/526, became nearly 270/270.
P.S. On 6.42 results are much worse.
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 1364
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Randburg
Contact:

Re: v6.41.2 [current]

Sun Feb 11, 2018 2:42 pm

None of my 941-2nDs are able to upgrade. I have no files in files menu in winbox besides the regular ones. Yet the available space is only 6.9mb. The winbox will not start downloading the update, nor it is possible to upload a complete update file manually. I've tried recreating the flash folder and the flash/pub and flash/skins sub folders - no go. Please advise.
Provide results for:

/file print

Code: Select all

[mkadm@MikroTik] > /file print
# NAME TYPE SIZE CREATION-TIME
0 flash directory feb/09/2018 20:46:43
1 flash/pub directory feb/09/2018 20:46:43
2 flash/skins directory feb/09/2018 20:46:43
[mkadm@MikroTik] >
/system package print

Code: Select all

[mkadm@MikroTik] > /system package print
Flags: X - disabled
# NAME VERSION SCHEDULED
0 routeros-smips 6.41.1
1 system 6.41.1
2 X ipv6 6.41.1
3 wireless 6.41.1
4 X hotspot 6.41.1
5 dhcp 6.41.1
6 X mpls 6.41.1
7 routing 6.41.1
8 X ppp 6.41.1
9 security 6.41.1
10 advanced-tools 6.41.1
[mkadm@MikroTik] >
And the relevant portion from /system resource print

Code: Select all

uptime: 16h14m40s
version: 6.41.1 (stable)
build-time: Jan/30/2018 10:26:14
free-memory: 6.0MiB
total-memory: 32.0MiB
cpu: MIPS 24Kc V7.4
cpu-count: 1
cpu-frequency: 650MHz
cpu-load: 9%
free-hdd-space: 7.0MiB
total-hdd-space: 16.0MiB
write-sect-since-reboot: 36352
write-sect-total: 39081061
bad-blocks: 0%
architecture-name: smips
board-name: hAP lite
platform: MikroTik
[/quote]

Think only solution will be to export config, save this off the router, then use netinstall with 6.41.2 and import config again
MTCNA, MTCTCE, MTCRE & MTCINE
 
eifLZ9D8zSwW
just joined
Posts: 6
Joined: Sat May 30, 2015 10:26 am

Re: v6.41.2 [current]

Sun Feb 11, 2018 6:26 pm

Hi,
RB750Gr3 went to bootloap :-(
I upgraded from 6.41.1, routerboard 6.41.1. I did it via System -> packages -> check for updates.

I managed to fix it with, however I am not sure what was the solution-trigger:
1) poweroff
2) press reset button, power on
3) keep the reset button pressed for 300 seconds (I found this somewhere on this forum)
4) poweroff
5) do the Netinstall procedure. I used Netinstall v6.38.5. (for some reason 6.41.1 didnt work)
6) I loaded 6.38.5 Main package,
7) it looked like it didnt work but after some time mikrotik beeped and started working.
8) upgrade from 6.38.5 to 6.41.1

It has been working for 2 days without problem.
Cheers, good luck
 
Mikhail73
just joined
Posts: 10
Joined: Wed Sep 21, 2016 8:31 pm

Re: v6.41.2 [current]

Sun Feb 11, 2018 6:33 pm

I did an upgrad of RB750Gr3 from 6.41 to 6.41.2 - no problems.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Sun Feb 11, 2018 7:05 pm

Mikhail73 - Please send supout file from your router to support@mikrotik.com. In best case scenario provide two files - one from 6.41.2 and one from 6.41.1 where everything works just fine. This version does not have any wireless fixes;
CZFan - Does reboot free up some space on your router?
eifLZ9D8zSwW - You did - launch backup booter and reset router and bootloader configuration and then Netinstalled router. You could just skip the first part. However, if you had protected bootloader enabled (disabled reset button), then yes - you could not Netinstall router in any other way:
https://wiki.mikrotik.com/wiki/Manual:R ... bootloader

We do recommend to use protected bootloader only if you really need it and are aware how to recover device in case something goes wrong. If you simply decide to enable this feature without actually knowing what it does, most likely you will not be able to recover unit when something goes wrong and in the end will want to return device for warranty repair. However, there is no actual problem with the router.
 
i4ko
just joined
Posts: 14
Joined: Sat Sep 26, 2015 9:23 pm

Re: v6.41.2 [current]

Sun Feb 11, 2018 7:30 pm

i4ko - Have you had other RouterOS packages installed on the device in the past? If you reboot router is space freed up?
No and No
What I noticed is that config backup usually used to take shy of 500kb. After the 6.41.1 upgrade, the config backup right now takes shy of 700kb, and there isn't that much config on them either - address lists with about 940 IPs total (some of it is dynamic entries), 630 static dns entries, and 1 script that has 30 lines.
Some of the device had issues updating to 6.41.1 in the first place as well - they did not update via winbox, but I was able to upload the file and reboot them and they took it (which was unusual - normally it worked the other way around). It seems my last option is netupdate but these are all at remote sites, so not easy to schedule and do and I would like to avoid it. Would downgrade to 6.39.3 and upgrade to 6.41.2 directly if it wasn't for bridge config changes.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Sun Feb 11, 2018 7:35 pm

i4ko - Most likely you will need to re-install devices by using Netinstall. However, I recommend that you send supout file from one of your routers to support. We might see in supout file what is filling up the space.
 
wmiguel
just joined
Posts: 7
Joined: Mon Feb 12, 2018 12:13 am
Location: Spain

Re: v6.41.2 [current]

Mon Feb 12, 2018 12:33 am

Hi.
I just upgrade my RB750Gr3 to version 6.41.2, and The Dude 6.41.2 server (on RB750Gr3) and the surprise when I try to connect to this system with The Dude client (other times the application itself upgrades downloading directly from MikroTik) is that NOT WORKS. More accurately, the client cannot connect the server because The client 6.41.2 WAS NOT RELEASED YET, and the applicaion complete DOES NOT WORK.

I also try to downgrade to 6.41.1, but the router does not accept it.

Why MikrotiK release only partiallly his software, making impossible the management? I don't understand nothing.

I hope that Mikrotik releases quickly the new client. At a moment, more than 250 devices of my network cannot be managed. It is a very strange thing.
Best regards.

Miguel
P.D. NOTE: I just made the downgrade from 6.41.2 to 6.41.1. This was an mistake from my part. Sorry. I will expect MikroTik releases all needed sofware before trying to upgrade.
Regards. M.
Last edited by wmiguel on Mon Feb 12, 2018 1:39 am, edited 1 time in total.
 
User avatar
rmonteiraum
just joined
Posts: 3
Joined: Tue Oct 24, 2017 11:03 pm
Location: Vila Velha, Brazil
Contact:

Re: v6.41.2 [current]

Mon Feb 12, 2018 12:58 am

After upgrading from version 6.39.3 [BugFix] to 6.41.1 and then to 6.41.2, my device [RB751U-2HnD] presented wireless connectivity problems.

I also upgraded the firmware, leaving it equivalent to the ROS.

The causes of the problem could not be identified in the logs.

Even after resetting and redoing all the settings one by one, it was not possible to keep the wireless connection stable.
 
skuykend
Member Candidate
Member Candidate
Posts: 270
Joined: Tue Oct 06, 2015 7:28 am

Re: v6.41.2 [current]

Mon Feb 12, 2018 3:48 am

Upgraded all devices from 6.41.1 to 6.41.2.

Went well, but then after some time my CRS317 lost management DHCP client lease from my CCR1009 (log message via serial on 317 indicates lost lease). Using trunked VLANS.

Haven't noticed any other devices losing connectivity yet.

edit: Other traffic was still being switched normally. Noticed I was still on 6.41.1 routerboard firmware on the 317. Updated the firmware via serial console (couldn't connect via MAC either) and rebooted. Connectivity restored via IP and MAC winbox. Will reply again if connectivity lost.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Mon Feb 12, 2018 6:52 am

rmonteiraum - Please send supout file from your device to support@mikrotik.com. Send two supout files - one from old version where everything is working properly and one from latest version where it is not. Generate file after you have experienced disconnects;
 
User avatar
seventh
just joined
Posts: 22
Joined: Fri Nov 20, 2009 11:26 am
Location: Russia, Belgorod

Re: v6.41.2 [current]

Mon Feb 12, 2018 8:28 am

Can't connect to Dude server after upgrade.
Dude client update stopped with error "bad http response from cloud".
Dude server is on router os 6.41.2.
Sorry for my English
 
User avatar
seventh
just joined
Posts: 22
Joined: Fri Nov 20, 2009 11:26 am
Location: Russia, Belgorod

Re: v6.41.2 [current]

Mon Feb 12, 2018 9:25 am

Hi this ver not work in Windows system. Do not download from mikrotik.com. Info from Dude client:

bad http response from cloud
Hi, could you solve the problem?
There's no way to workaround the bug. We need a new RouterOS release or the dude client 6.41.2 which is not available now. I suspect it's not available because they know it's bugged and so last resource is to wait for next RouterOS release. Hope soon.


Hm. I just change version number in standart download link https://download2.mikrotik.com/routeros ... 6.41.2.exe and download dude-client. Looks like it work.
Last edited by seventh on Mon Feb 12, 2018 9:32 am, edited 1 time in total.
Sorry for my English
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: v6.41.2 [current]

Mon Feb 12, 2018 9:28 am

After upgrading from version 6.39.3 [BugFix] to 6.41.1 and then to 6.41.2, my device [RB751U-2HnD] presented wireless connectivity problems.

I also upgraded the firmware, leaving it equivalent to the ROS.

The causes of the problem could not be identified in the logs.

Even after resetting and redoing all the settings one by one, it was not possible to keep the wireless connection stable.
Please write more detailed what kind of wireless connectivity problems you see.
 
Clauu
Member Candidate
Member Candidate
Posts: 205
Joined: Fri Mar 21, 2014 8:27 pm
Location: RO

Re: v6.41.2 [current]

Mon Feb 12, 2018 9:29 am

Ova for chr - 404 not found..
https://www.mikrotik.com/chr-6.41.2.ova
Isn't anyone from the team checking this basics stuff? We always have to report such trivial issues.
Having fun with RB850Gx2, RB2011UiAS-2HnD, RB260GSP, RB751U-2HnD, CRS112, RB3011UiAS, hAP ac, cAP ac and hAP ac². More others on the way :-)
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24157
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Mon Feb 12, 2018 10:17 am

Ova for chr - 404 not found..
https://www.mikrotik.com/chr-6.41.2.ova
Isn't anyone from the team checking this basics stuff? We always have to report such trivial issues.
Where did you get that link? Download page shows correct and working link:
https://download2.mikrotik.com/routeros ... 6.41.2.ova
No answer to your question? How to write posts
 
Note
newbie
Posts: 49
Joined: Fri Jun 03, 2016 12:39 pm

Re: v6.41.2 [current]

Mon Feb 12, 2018 10:25 am

Ill post it here and i hope all u mikrotik engineers will take a look at that comment. We need u to introduce codel algorithm, it is the best working feature this time we speak in routers.
 
User avatar
LucZWFM
Member Candidate
Member Candidate
Posts: 127
Joined: Tue Dec 26, 2017 10:47 pm
Location: Bergen op Zoom, The Netherlands

Re: v6.41.2 [current]

Mon Feb 12, 2018 10:48 am

LucZWFM - Have you tried to Netinstall device? From which version did you upgrade your router? Can you install same version, same configuration and try to upgrade once more and reproduce the same problem;

The board refuses to appear in netinstall, tried on 3 computers now...
This make me unable to try anything...

I upgraded from 6.41.1.

Connecting the board via a switch did it...
Windows didn't bring up the NIC when there is no link...
Volunteer Techie @ZuidWest FM / ZuidWest TV, Stichting Repeater Bergen op Zoom & WRLP CB Repeater
 
Clauu
Member Candidate
Member Candidate
Posts: 205
Joined: Fri Mar 21, 2014 8:27 pm
Location: RO

Re: v6.41.2 [current]

Mon Feb 12, 2018 10:55 am

Ova for chr - 404 not found..
https://www.mikrotik.com/chr-6.41.2.ova
Isn't anyone from the team checking this basics stuff? We always have to report such trivial issues.
Where did you get that link? Download page shows correct and working link:
https://download2.mikrotik.com/routeros ... 6.41.2.ova
Hi normis, from here - https://mikrotik.com/download
Now as i can see links were updated because it points correctly so yes, after my report now it;s fine.
P.S i'm not using any caching proxy etc
Having fun with RB850Gx2, RB2011UiAS-2HnD, RB260GSP, RB751U-2HnD, CRS112, RB3011UiAS, hAP ac, cAP ac and hAP ac². More others on the way :-)
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24157
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Mon Feb 12, 2018 11:06 am

The link might be wrong when release is not yet completed, just reload the page if some link doesn't work.
No answer to your question? How to write posts
 
eifLZ9D8zSwW
just joined
Posts: 6
Joined: Sat May 30, 2015 10:26 am

Re: v6.41.2 [current]

Mon Feb 12, 2018 11:38 am

Mikhail73 - Please send supout file from your router to support@mikrotik.com. In best case scenario provide two files - one from 6.41.2 and one from 6.41.1 where everything works just fine. This version does not have any wireless fixes;
CZFan - Does reboot free up some space on your router?
eifLZ9D8zSwW - You did - launch backup booter and reset router and bootloader configuration and then Netinstalled router. You could just skip the first part. However, if you had protected bootloader enabled (disabled reset button), then yes - you could not Netinstall router in any other way:
https://wiki.mikrotik.com/wiki/Manual:R ... bootloader

We do recommend to use protected bootloader only if you really need it and are aware how to recover device in case something goes wrong. If you simply decide to enable this feature without actually knowing what it does, most likely you will not be able to recover unit when something goes wrong and in the end will want to return device for warranty repair. However, there is no actual problem with the router.

Hi,
I forgot to mention that I didn't use protected-bootloader. But if I had used, the 300s reset would have erased mikoritk even with protected-bootloader?
thx
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Mon Feb 12, 2018 11:52 am

eifLZ9D8zSwW - Are you sure that you did not enable feature by accident? Or simply enabled it without knowing what it does? Wiki page will explain how it works. Your solution would work only if these 500 seconds are between min/max timeout values. Wiki page should explain how long you have to hold that button pressed if feature is enabled.

Again - we strongly recommend to NOT use this feature if you are not aware about how it works. If you will not know min/max settings, then you will not be able to recover device in any way.
 
Airell
just joined
Posts: 7
Joined: Fri Mar 25, 2016 3:40 pm

Re: v6.41.2 [current]

Mon Feb 12, 2018 12:14 pm

bridge - fixed ARP settings on bridge interfaces (introduced v6.41);
Would this actually fix the issue I had in the start post of this topic?
It sounds it could: viewtopic.php?f=2&t=130581
 
mszru
just joined
Posts: 18
Joined: Wed Aug 10, 2016 10:42 am

Re: v6.41.2 [current]

Mon Feb 12, 2018 3:25 pm

I found a couple of strange entries in the routing table after the upgrade on my hAP ac. The upgrade path was the following: 6.40.5 > 6.41 > 6.41.1 > 6.41.2. Not sure when it happened exactly.

Image
 
Mikhail73
just joined
Posts: 10
Joined: Wed Sep 21, 2016 8:31 pm

Re: v6.41.2 [current]

Mon Feb 12, 2018 3:31 pm

Mikhail73 - Please send supout file from your router to support@mikrotik.com. In best case scenario provide two files - one from 6.41.2 and one from 6.41.1 where everything works just fine. This version does not have any wireless fixes;
Done. Upgrade was from 6.41, not 6.41.1.
Do i need to downgrade also routerboard firmware from 6.41.2 to 6.41 now?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5921
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.41.2 [current]

Mon Feb 12, 2018 4:08 pm

I found a couple of strange entries in the routing table after the upgrade on my hAP ac.
What exactly is considered strange there?
 
mszru
just joined
Posts: 18
Joined: Wed Aug 10, 2016 10:42 am

Re: v6.41.2 [current]

Mon Feb 12, 2018 4:41 pm

I found a couple of strange entries in the routing table after the upgrade on my hAP ac.
What exactly is considered strange there?
The new routes to 0.0.0.0/32 in the list which were not there before.
According to the RFC 3330 it is kind of special address, and I cannot understand if it was added on purpose or by mistake during the upgrade.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5921
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.41.2 [current]

Mon Feb 12, 2018 5:02 pm

Can you generate supout file from 6.41.2 downgrade and generate another file from older version and send both files to support?
 
fabifri
just joined
Posts: 8
Joined: Thu Dec 11, 2014 12:25 am

Re: v6.41.2 [current]

Mon Feb 12, 2018 5:10 pm

Boot loop on RB750Gr3 too. :-(
Datacenter offline. Night shift incomming. Thanks!
 
Rule47
just joined
Posts: 2
Joined: Sun Jan 17, 2016 11:15 pm

Re: v6.41.2 [current]

Mon Feb 12, 2018 10:24 pm

I've got trouble connecting older devices such as Android 4.0, iPhone 4 or Blackberry probably since Rel. 6.41 to access points using CAPsMAN. I downgraded to Rel. 6.35.4, which works well with these devices. Newer devices work (tested: iPhone 6, iPhone 8).

Currently installed on all devices: Rel. 6.41.2. The error I get is: "received deauth: class 3 frame received (7)".

Does someone have a clue, what to do. Users are complaining heavily.

Jo
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 1297
Joined: Sat Dec 24, 2016 11:17 am
Location: jo.overland at gmail.com

Re: v6.41.2 [current]

Tue Feb 13, 2018 1:11 am

Boot loop on RB750Gr3 too. :-(
Datacenter offline. Night shift incomming. Thanks!
RB750Gr3 is a low cost product ment for home and small offices.
Running a whole datasenter behind it seems for me some strange.
 
How to use Splunk to monitor your MikroTik Router

MikroTik->Splunk
 
 
i4ko
just joined
Posts: 14
Joined: Sat Sep 26, 2015 9:23 pm

Re: v6.41.2 [current]

Tue Feb 13, 2018 6:18 am

After upgrading from version 6.39.3 [BugFix] to 6.41.1 and then to 6.41.2, my device [RB751U-2HnD] presented wireless connectivity problems.

I also upgraded the firmware, leaving it equivalent to the ROS.

The causes of the problem could not be identified in the logs.

Even after resetting and redoing all the settings one by one, it was not possible to keep the wireless connection stable.
Please write more detailed what kind of wireless connectivity problems you see.
I have seen a wireless issue on two of the RB941-2nD I have. I don't know if it is the same or not.
Initially it started with wireless devices intermittently dropping. Later on it progressed to more severe intermittent connectivity - about 50 percent of the time there will be no devices connected. Logs would show key exchange timeout and drop the wireless devices about every 30 minutes, then it changed to about every 2 minutes. It progressed further onto the wireless devices not being able to hold stable connection for more than 2-3 seconds, it would not matter if the frequency was set to auto or set frequency. Initially devices tried to connect frequently, then connection attempt became more rare, until almost no connection attempts would be made. Every time the router kicked out the device for unicast key exchange timeout. But it became even worse - the devices were not trying to connect because they could not see the SSID. Those two devices now (no longer at customer) do not advertise SSID no matter what, I can't see it even with kismet. It seems like the radio RF portion just gradually and eventually died after the 6.41.1 upgrade. Multiple resets, and power off/power on did not make any difference.
Needless to say I had to replace these two. Initially they did not have the 6.41.1 firmware installed when they started being weird. When I got the issues, I installed the 6.41.1 firmware which made things worse and ultimately the WIFI portion just does not seem to work at all. The whole degradation from a fully stable working router to fully non-discoverable wifi (even on scans) started about a month after the 6.41.0 upgrade, and tool like 3-4 days with a 6.41.1 upgrade in the middle.
Regular AP bridge, no CAPsMAN, 2GHz-N-only band, 20Mhz channel, 802.11 protocol, WPS disabled, Hide SSID not set. Frequency - regulatory domain, Country - United States, Data rates - Default, Distance - indoors, Preamble - long/both

Hmm, tried setting the country to something else - Latvia - it would make the SSID temporarily discoverable (for about 5-10 seconds) and then it will die again. At the same time the status will claim it is running, at -112dBm noise floor and 2427/20/gn(20dBm) channel (sometimes 2422).
Nothing informative in the logs, even if wireless is on debug
 
Clauu
Member Candidate
Member Candidate
Posts: 205
Joined: Fri Mar 21, 2014 8:27 pm
Location: RO

Re: v6.41.2 [current]

Tue Feb 13, 2018 8:18 am

About firewall new feature 'tls-host' i cannot make use of it no matter what sites i try, i'm i missing something or this feature is broken?
/ip firewall filter add chain=forward dst-port=443 protocol=tcp tls-host=*google.com action=drop
Having fun with RB850Gx2, RB2011UiAS-2HnD, RB260GSP, RB751U-2HnD, CRS112, RB3011UiAS, hAP ac, cAP ac and hAP ac². More others on the way :-)
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Tue Feb 13, 2018 8:35 am

Clauu - Such rule should be working. Most likely some other firewall rule matches such traffic before this one. Are you using FastTrack?
 
Clauu
Member Candidate
Member Candidate
Posts: 205
Joined: Fri Mar 21, 2014 8:27 pm
Location: RO

Re: v6.41.2 [current]

Tue Feb 13, 2018 8:53 am

Hi strods, i'm not using fastrack and tls rule was in top of all other forward chain rules.
Hm as i can see there is a fix for this feature in latest rc
What's new in 6.42rc24 (2018-Feb-08 09:42):
*) firewall - fixed "tls-host" firewall feature (introduced v6.41);
Is this related to my issue?
L.E: tested again and now it's working.. odd.
Having fun with RB850Gx2, RB2011UiAS-2HnD, RB260GSP, RB751U-2HnD, CRS112, RB3011UiAS, hAP ac, cAP ac and hAP ac². More others on the way :-)
 
tangram
Member Candidate
Member Candidate
Posts: 131
Joined: Wed Nov 16, 2016 9:55 pm

Re: v6.41.2 [current]

Tue Feb 13, 2018 4:43 pm

Hi,

I don't know if it's a winbox or routeros bug, but it's easy to reproduce. Connected with winbox, if you have a script open for editing and you delete that script from script list the session is dropped.
Oh and it generates autosupout :)
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5921
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.41.2 [current]

Tue Feb 13, 2018 4:46 pm

Do you use latest winbox version?
 
ksteink
newbie
Posts: 38
Joined: Thu Mar 31, 2016 6:54 pm

Re: v6.41.2 [current]

Tue Feb 13, 2018 9:42 pm

I upgraded my RB2011UiAS-2HnD-IN with no major issues. All my basic connection features worked fine (OVPN, IPv6 and VLANs). I did noticed that after the upgrade the LED on the router was constantly ON even in my setting I have it by default on OFF. I did turned ON and OFF again and it finally turn it off.

I have been working all day with it and no issues. I still want to revisit the configuration changes on the HW off-loading but from the end user experience no services have been impacted.
 
aaronw
just joined
Posts: 11
Joined: Thu Feb 26, 2009 7:30 am

Re: v6.41.2 [current]

Wed Feb 14, 2018 2:47 am

Never mind. I switched to a different laptop and disabled the firewall and I was able to recover the system. I still do not know why the initial update failed. Using netinstall I was able to boot the new system and install it.

This update appears to have broken an RB850GX2 router. After the update the router never recovered and failed to boot. I have since tried to get it to boot using netinstall and that fails.

Here is the output when booting from NAND:
RouterBOOT booter 3.24

RouterBoard 850Gx2

CPU frequency: 533 MHz
Memory size: 512 MiB
NAND size: 512 MiB

Press any key within 2 seconds to enter setup..

loading kernel from nand... OK
setting up elf image... OK
jumping to kernel code
Starting...
Starting services...
connect failed (errno=2)
died with signal 6 on Thu Jan 1 00:00:12 1970

Aborted
connect failed (errno=2)
Aborted

Here is the output when I attempt to use netinstall and boot over Ethernet:
RouterBOOT booter 3.24

RouterBoard 850Gx2

CPU frequency: 533 MHz
Memory size: 512 MiB
NAND size: 512 MiB

Press any key within 2 seconds to enter setup..
trying bootp protocol.... OK
Got IP address: 192.168.0.100
resolved mac address 3C:97:0E:24:41:BC
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
********************falling back to small packet size
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
********************kernel loading failed
Basically it bricked the Routerboard. I have also cleared the configuration from the bootloader and that did not help. It seems to pass the memory test.

Everything was working fine until the update. The update process completed then the box showing the progress just hung (obviously because it could not reboot).

Any suggestions?

-Aaron
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Wed Feb 14, 2018 6:35 am

Seems that either there is some issue with link between computer and router or there is another device in the path (switch, for example) causing this problem. Router starts to communicate with Netinstall, however, they both are not being able to make stable connection in order to start Netinstall process.
 
i4ko
just joined
Posts: 14
Joined: Sat Sep 26, 2015 9:23 pm

Re: v6.41.2 [current]

Wed Feb 14, 2018 6:46 am

i4ko - Most likely you will need to re-install devices by using Netinstall. However, I recommend that you send supout file from one of your routers to support. We might see in supout file what is filling up the space.
Finally manged to update remotely. While on 6.41.1 disabled all packages except for system, dhcp and wireless, and uploaded the same from the 6.41.2 all packages file to the router (those were all i had room for), then rebooted, all in one go. Now I no longer have any packages besides these (routeros-smips is also gone) but everything is working fine. This also dropped 1.5mb in disk usage, I'll add some of the other packages where I need them.
 
osmoticzest
just joined
Posts: 8
Joined: Wed Jan 03, 2018 2:55 pm

Re: v6.41.2 [current]

Wed Feb 14, 2018 9:35 am

Spotted the following on Superuser today, and it accurately describes what I’m seeing on the last couple of releases (potentially since 6.41.0) – the WiFi interface will just ‘stop’ at random, nothing in registration table, 0/0 tx/rx. Restarting the interface or doing something like using the ‘Scanner’ will bring things back to life. Same behaviour on both APs here.

https://superuser.com/questions/1293579 ... -is-restar

951G-2HnD + RB941-2nD
frequency-mode=regulatory-domain country=united kingdom
Last edited by osmoticzest on Wed Feb 14, 2018 1:45 pm, edited 2 times in total.
 
Nuubo
just joined
Posts: 5
Joined: Wed Jan 03, 2018 12:38 pm

Re: v6.41.2 [current]

Wed Feb 14, 2018 9:37 am

Unfortunately my fears were true: bridging is still working bad because ARP is not fixed.
I am wondering why did Mikrotik eliminate master/slave options using switching?, since I am using Mikrotik I just use bridges to link wifi / ethernet interfaces but when the other day I upgraded to 6.41.2 it was impossible to keep the network running, the old master/slave interfaces of same switch were wrong, the old master interface loosing packets continuosly and the slave interface just not populate MAC addreses connected.

Please, consider my option: back to the old status, master slave is a much better option using switiching, if someone wants bridging, use bridging, but I think it is much worse.

Thanks.
 
tangram
Member Candidate
Member Candidate
Posts: 131
Joined: Wed Nov 16, 2016 9:55 pm

Re: v6.41.2 [current]

Wed Feb 14, 2018 10:20 am

Do you use latest winbox version?
Thank you, I was using 3.11. In 3.12 problem is fixed.
 
R1st0
just joined
Posts: 6
Joined: Wed Feb 14, 2018 10:08 am

Re: v6.41.2 [current]

Wed Feb 14, 2018 10:23 am

I have problem with neighbor discovery on CRS106. My intention is to allow neighbor discovery only on uplink port (sfp5).
When using configuration:
/interface list
add name=clients
/interface list member
add interface=sfp1 list=clients
add interface=sfp2 list=clients
add interface=sfp3 list=clients
add interface=sfp4 list=clients
/ip neighbor discovery-settings
set discover-interface-list=!clients
It works, but when exporting the config "!" mark disappears: /ip neighbor discovery-settings set discover-interface-list=clients. When I use "/ip neighbor discovery-settings pr" the "!" is there.
To reduce lines I tried similar configuration, but this one doesn´t work (no discovery on sfp5):
/interface list
add name=uplink
/interface list member
add interface=sfp5 list=uplink
/ip neighbor discovery-settings
set discover-interface-list=uplink
 
eddieb
Member Candidate
Member Candidate
Posts: 135
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: v6.41.2 [current]

Wed Feb 14, 2018 2:05 pm

updated my RB2011UAS from 6.40.5 to 6.41.2 ...
everything went smooth.
2 IPSEC site-to-site tunnels
DHCP and DNS server
PPPOE on wan

look fine here
Running 6.45.6 (stable) on :
CCR1009-8G-1S (2x ipsec/l2tp site-to-site, ipsec/l2tp roadwarrior, dhcpd, dns), CRS125-24G-1S, RB1100, RB962UiGS-5HacT2HnT (10pc), RB931-2nD, RB951, RB750GL ,RB2011UAS-RM, CHR running dude (CHR running in VirtualBox on OSX)
 
LIV2
newbie
Posts: 31
Joined: Sat Jan 23, 2016 7:42 am

Re: v6.41.2 [current]

Thu Feb 15, 2018 2:29 am

After upgrading my mAP2n to 6.41.2 I've found that doing /system reset-configuration no-defaults=no results in an empty configuration, and I can only connect to the router via mac-telnet
Same result when using the reset button to do a config reset, even on 6.42rc24 it also doesn't work
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Thu Feb 15, 2018 6:52 am

osmoticzest - Provide supout file from your router to support@mikrotik.com
Nuubo - Please provide precise problem description and supout files to support@mikrotik.com. From which version with what exact configuration did you upgrade this device and did you upgrade directly to 6.41.2 release;
R1st0 - We will resolve this export command problem in upcoming RouterOS releases;
LIV2 - Have you tried to Netinstall your device and reset it only after that? Seems that default configuration has been changed to something else by using configuration script on Netinstall.
 
LIV2
newbie
Posts: 31
Joined: Sat Jan 23, 2016 7:42 am

Re: v6.41.2 [current]

Thu Feb 15, 2018 9:56 am

LIV2 - Have you tried to Netinstall your device and reset it only after that? Seems that default configuration has been changed to something else by using configuration script on Netinstall.
I've tried Netinstall ensuring "Apply Default Config" is ticked with various versions with the following results
6.42rc20 - No default config
6.41.1 - No default config
6.41 - No default config
6.40.5 - Default config works
6.39.3 - Default config works
 
Nuubo
just joined
Posts: 5
Joined: Wed Jan 03, 2018 12:38 pm

Re: v6.41.2 [current]

Fri Feb 16, 2018 10:50 am

Nuubo - Please provide precise problem description and supout files to support@mikrotik.com. From which version with what exact configuration did you upgrade this device and did you upgrade directly to 6.41.2 release;

I am sorry but I did the change to my configuration with a new subnet just for one computer. I thought it was some upgrade problem (I did it from 6.41 directly) I deleted the bridge and I recreated it with same results, there was no MAC address in ARP table and continuous interruptions of network traffic. I just want ask you in future releases the recover of master/slave option, I can not understand why did you eliminate the use of switching, it is much better since it is flexible and instant.
 
buzzdee
newbie
Posts: 35
Joined: Mon Apr 22, 2013 1:22 pm

Re: v6.41.2 [current] - scripting and terminal "no such item"

Fri Feb 16, 2018 7:24 pm

Hi,

seems the issue described here

viewtopic.php?f=21&t=128915&p=637801&hi ... em#p637801

still persists. When enabling/disabling ppp-devices from terminal or script, I get "no such item (4)" the first time I run the command, but it works when I run it again. Have a couple of 411U's and 912's with 3G modems, would be nice if I could use my scripts to reset those modems would work again.
 
User avatar
macsrwe
Long time Member
Long time Member
Posts: 647
Joined: Mon Apr 02, 2007 5:43 am
Location: Arizona, USA
Contact:

Re: v6.41.2 [current]

Fri Feb 16, 2018 10:57 pm

Again - we strongly recommend to NOT use this feature if you are not aware about how it works. If you will not know min/max settings, then you will not be able to recover device in any way.
I suspect there are many routers out there where this value is set to arbitrary garbage due to recent (still current?) bug in Winbox where calling up /system routerboard settings always populates this value as 00:00:00 -- in red since zero is an invalid value -- and then demands the user set it to something nonzero before they can make the unrelated change they originally wished to make.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Sat Feb 17, 2018 10:58 am

buzzdee - First of all, please do not post version u relafed issues within new release topic. Your problem has nothing to do with release and even ia not a bug. Do not use ID in scripts or run print first.

For example:
1) will not work
/interface ethernet set 1 name=test
2) will work
/interface ethernet set ether2 name=test
3) will work
/interface ethernet print
/interface ethernet set 1 name

On #1 script does not know which interface is 1 and that is why you see such error.
 
buzzdee
newbie
Posts: 35
Joined: Mon Apr 22, 2013 1:22 pm

Re: v6.41.2 [current]

Sat Feb 17, 2018 11:48 am

Hi strods, thanks for the quick reply.
First of all, please do not post version u relafed issues within new release topic
Sorry, I should have been more precise - what I experienced was on 6.41.2.

Heres is a snippet from the script. I'm not using ID's but the interfaces name:
# Set UMTS Interface name
:global WanName "ppp-out1"
# get its ID number #
:local WanID [/interface ppp-client find name=$WanName];
# Change the data channel setting
/interface ppp-client set data-channel="3" $WanID
If I get you right, interface should come before set-command in the last line:
/interface ppp-client $WanID set data-channel="3"
Does this also apply when using interface names instead of ID's?

Thanks, BuzzDee.
 
sindy
Forum Guru
Forum Guru
Posts: 3806
Joined: Mon Dec 04, 2017 9:19 pm

Re: v6.41.2 [current]

Sat Feb 17, 2018 12:26 pm

If I get you right, interface should come before set-command in the last line:
/interface ppp-client $WanID set data-channel="3"
Does this also apply when using interface names instead of ID's?

Thanks, BuzzDee.
No, the order is less obvious, 1. set 2. in which item 3. which attribute:
/interface ppp-client set $WanID data-channel="3"
You can abbreviate your example into
/interface ppp-client set [find name=$WanName] data-channel="3"
And yes, you can replace the number(s) in the set, remove, unset etc. by "find" referring to any attribute.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
Institor
just joined
Posts: 9
Joined: Sat Apr 29, 2017 3:28 pm

Re: v6.41.2 [current]

Sat Feb 17, 2018 1:38 pm

Bridge on RB750Gr3 (6.41.2) seems to be broken.
1) No HW offload on ethernet interfaces after upgrade from 6.41.1:
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 #     INTERFACE                      BRIDGE                      HW  PVID PRIORITY  PATH-COST INTERNAL-PATH-COST    HORIZON
 0     eth2                           bridge_local                yes    1     0x80         10                 10       none
 1     eth3                           bridge_local                yes    1     0x80         10                 10       none
 2 I   eth4                           bridge_local                yes    1     0x80         10                 10       none
 3 I   eth5                           bridge_local                yes    1     0x80         10                 10       none
 
interface bridge port print detail
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 0     interface=eth2 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 1     interface=eth3 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 2 I   interface=eth4 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 3 I   interface=eth5 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no
2) Bridge settings freezes constantly (for example, after trying to check/uncheck "igmp snooping", bridge completely shuts down and remain disabled for approx. 1 minute).

It's slightly annoying....
 
GARCIADOEGOGERMAN
just joined
Posts: 23
Joined: Fri Aug 18, 2017 2:05 pm

Re: v6.41.2 [current]

Sat Feb 17, 2018 5:37 pm

Bridge on RB750Gr3 (6.41.2) seems to be broken.
1) No HW offload on ethernet interfaces after upgrade from 6.41.1:
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 #     INTERFACE                      BRIDGE                      HW  PVID PRIORITY  PATH-COST INTERNAL-PATH-COST    HORIZON
 0     eth2                           bridge_local                yes    1     0x80         10                 10       none
 1     eth3                           bridge_local                yes    1     0x80         10                 10       none
 2 I   eth4                           bridge_local                yes    1     0x80         10                 10       none
 3 I   eth5                           bridge_local                yes    1     0x80         10                 10       none
 
interface bridge port print detail
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 0     interface=eth2 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 1     interface=eth3 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 2 I   interface=eth4 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 3 I   interface=eth5 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no
2) Bridge settings freezes constantly (for example, after trying to check/uncheck "igmp snooping", bridge completely shuts down and remain disabled for approx. 1 minute).

It's slightly annoying....
In my RB750GR3 the same thing happens ... looking for more info I found this that seems to be the reason why what happens is what happens.

Release 6.41.1 2018-02-02
What's new in 6.41.1 (2018-Jan-30 10:26):

*) bridge - fixed hw-offload disabling for Mediatek and Realtek switches when STP / RSTP configured;
*) bridge - fixed hw-offload disabling when adding a port with "horizon" set;

This will have to do with what you mention ???

Regards!!!
 
mpadmin
just joined
Posts: 18
Joined: Sun May 22, 2016 3:48 pm

Re: v6.41.2 [current]

Sat Feb 17, 2018 10:32 pm

Bridge on RB750Gr3 (6.41.2) seems to be broken.
1) No HW offload on ethernet interfaces after upgrade from 6.41.1:
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 #     INTERFACE                      BRIDGE                      HW  PVID PRIORITY  PATH-COST INTERNAL-PATH-COST    HORIZON
 0     eth2                           bridge_local                yes    1     0x80         10                 10       none
 1     eth3                           bridge_local                yes    1     0x80         10                 10       none
 2 I   eth4                           bridge_local                yes    1     0x80         10                 10       none
 3 I   eth5                           bridge_local                yes    1     0x80         10                 10       none
 
interface bridge port print detail
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 0     interface=eth2 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 1     interface=eth3 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 2 I   interface=eth4 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 3 I   interface=eth5 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no
2) Bridge settings freezes constantly (for example, after trying to check/uncheck "igmp snooping", bridge completely shuts down and remain disabled for approx. 1 minute).

It's slightly annoying....


I have 750Gr3 and HW offload works, but you need to set Protocol Mode to "none".
/interface bridge
add name=bridge-internal protocol-mode=none
 
GARCIADOEGOGERMAN
just joined
Posts: 23
Joined: Fri Aug 18, 2017 2:05 pm

Re: v6.41.2 [current]

Sun Feb 18, 2018 2:53 am

Bridge on RB750Gr3 (6.41.2) seems to be broken.
1) No HW offload on ethernet interfaces after upgrade from 6.41.1:
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 #     INTERFACE                      BRIDGE                      HW  PVID PRIORITY  PATH-COST INTERNAL-PATH-COST    HORIZON
 0     eth2                           bridge_local                yes    1     0x80         10                 10       none
 1     eth3                           bridge_local                yes    1     0x80         10                 10       none
 2 I   eth4                           bridge_local                yes    1     0x80         10                 10       none
 3 I   eth5                           bridge_local                yes    1     0x80         10                 10       none
 
interface bridge port print detail
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 0     interface=eth2 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 1     interface=eth3 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 2 I   interface=eth4 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 3 I   interface=eth5 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no
2) Bridge settings freezes constantly (for example, after trying to check/uncheck "igmp snooping", bridge completely shuts down and remain disabled for approx. 1 minute).

It's slightly annoying....


I have 750Gr3 and HW offload works, but you need to set Protocol Mode to "none".
/interface bridge
add name=bridge-internal protocol-mode=none
Then because the script of the default configuration of the RB750GR3 has set "protocol-mode = rstp" ??? It would be a problem to solve by Mikrotik support, since being in RSTP mode will never use HW OFF ...
 
Institor
just joined
Posts: 9
Joined: Sat Apr 29, 2017 3:28 pm

Re: v6.41.2 [current]

Sun Feb 18, 2018 5:31 am

Yes, rstp was enabled on bridge...
However, disabling rstp took about 3-4 minutes, i think that's a little too slow... Changing other settings (like "fast forward") also freezes the bridge for several minutes.
 
kuzma2000
just joined
Posts: 16
Joined: Wed Nov 20, 2013 11:57 am
Location: Kiev, Ukraine

Re: v6.41.2 [current]

Sun Feb 18, 2018 8:57 pm

Hi!
I successfully updated through Dude all my rb941 (2 pieces) ccr1009 (2 pieces) and RB WAP G-5hact2hnd from 6.41.1 to 6.41.2.
But I couldn't update any rb962.
Also, I tried to update rb962 via Winbox.
The reason is: there is not enough space.
rb962 have only 16 MB, of which only 20-30% is available.
Last time I altering them through NetInstall/
What to do now?
 
ATROX
newbie
Posts: 44
Joined: Mon Oct 14, 2013 2:10 pm

Re: v6.41.2 [current]

Mon Feb 19, 2018 11:01 am

ap - cAP ac (RouterBOARD cAP Gi-5acD2nD)
ARP table - empty
Current Tx Power 2GHz - empty

OS - 6.41.2

Image
Image

Image
Real IPQ4019 ???
In specification - IPQ4018.
Image
 
tigro11
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Tue Feb 20, 2018 12:31 am

Re: v6.41.2 [current]

Tue Feb 20, 2018 12:40 am

hi guys, on my rb750Gr3 with firmware 6.42rc28 I wanted to mount a hotspot for a job. I can not install the user-manager package.
Are there any solutions?
thank you all

Valerio
 
ATROX
newbie
Posts: 44
Joined: Mon Oct 14, 2013 2:10 pm

Re: v6.41.2 [current]

Tue Feb 20, 2018 7:28 am

ap - cAP ac (RouterBOARD cAP Gi-5acD2nD)
OS - 6.41.2

Some clients are disconnected from the point here with such an error:
disconnected, extensive data loss
and
disconnected, received disassoc: sending station leaving (8)
I settings many MicroTick AP.
The settings are the same everywhere, it's on this, new such problems.

Image

For example, this client is sitting on the spot, does not run around the office.

Well, here's a look at what the rest are doing ...
Image
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1218
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6.41.2 [current]

Tue Feb 20, 2018 8:50 am

...
Current Tx Power 2GHz - empty
...
FYI: 0 dBm does not mean "empty"/zero power. It is a valid value and means 1 mW. Still odd though, if it changed by itself.
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
buzzdee
newbie
Posts: 35
Joined: Mon Apr 22, 2013 1:22 pm

Re: v6.41.2 [current]

Tue Feb 20, 2018 6:06 pm

@sindy

Thanks for pointing out which order to use in scripting. I must have been lucky that my scripts worked in earlier versions without paying that much attention to the order.
 
ATROX
newbie
Posts: 44
Joined: Mon Oct 14, 2013 2:10 pm

Re: v6.41.2 [current]

Wed Feb 21, 2018 10:50 am

ap - cAP ac (RouterBOARD cAP Gi-5acD2nD)
ARP table - empty
Current Tx Power 2GHz - empty

OS - 6.41.2

The new chips have a new method of obtaining power data. not yet supported Route OS.
MikroTik support answered
 
HiroZA
just joined
Posts: 2
Joined: Wed Feb 21, 2018 3:46 pm

Re: v6.41.2 [current]

Wed Feb 21, 2018 6:55 pm

My current router was ISP supplied and has all the default config on it. If i download this update and install it, will this setup be overwritten? Will i have issues due to PPPoE settings being factory reset ?
 
sindy
Forum Guru
Forum Guru
Posts: 3806
Joined: Mon Dec 04, 2017 9:19 pm

Re: v6.41.2 [current]

Wed Feb 21, 2018 8:12 pm

My current router was ISP supplied and has all the default config on it. If i download this update and install it, will this setup be overwritten? Will i have issues due to PPPoE settings being factory reset ?
Even if you upgrade between stable versions, you should always backup the configuration and download the backup file from the router. Exporting it in the text form into another file (using "/export file=backup_version_today") is also a good practice because the "binary" backups from older versions are not always readable by newer versions. And noting down any credentials (in your case, especially those related to the PPPoE account) is also a good idea.

I assume that your ISP doesn't mind you to do the upgrade as they've given you administrator rights to the router.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
coliflower
just joined
Posts: 18
Joined: Mon Aug 21, 2017 1:10 pm

Re: v6.41.2 [current]

Wed Feb 21, 2018 9:03 pm

I am sorry but I am still confused with the new bridge implementation :-(

I updaten one of my wAP-ac to 6.41.2 and created a bridge - this bridge has an IP 10.0.100.4/24 and PVID1 because the AP itself is a part of the administrative-VLAN1-un-tagged (Internet-Cable-Modem to Firewall to Switch to wAP-ac via TRUNKs).

Connected to the bridge via PORT is the only one available ether1 - this port has a PVID1 as well because if I understood the brief explanation of MikroTik, it is need for the un-tagged ingress (from ether-cable to port-ether1 / port-ether1 to the bridge) traffic ... On this PORT there is a cable with Trunk (vlan1-un-tagged, vlan10-tagged, vlan20-tagged, etc.).
Frame-Types = admit all ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

The next PORT to the bridge is the physical WLAN-chip (not vAP) - this port also has PVID1 because the SSID of the WLAN-chip is the administrative-VLAN1-un-tagged.
Frame-Types = admit all ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

Now the vAP's ... e.g. vAP10, vAP20, vAP30, etc.
For example: vAP10 has PVID10
Frame-Types = admit only VLAN tagged ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

Next is interface / bridge / VLAN:

I created VLAN ID = 1
Tagged = empty ... correct / why ?
Untagged = bridge, vlan1, wAP-2GHz, wAP5GHz ... correct / why ?

I created VLAN ID = 10
Tagged = bridge, vlan10 ... correct / why ?
Untagged = vAP10 ... correct / why ?

At the end I activated VLAN-Filtering under /interface bridge

One additional question ... is it needed to create the VLANs under /interface VLAN, too ?

As you see there are some puzzle-brickets I know but I am not able to make a picture of them :-(

Any help is highly appreciated - especially with explanation :-)
 
sindy
Forum Guru
Forum Guru
Posts: 3806
Joined: Mon Dec 04, 2017 9:19 pm

Re: v6.41.2 [current]

Wed Feb 21, 2018 9:18 pm

I am sorry but I am still confused with the new bridge implementation :-(

I updaten one of my wAP-ac to 6.41.2 and created a bridge - this bridge has an IP 10.0.100.4/24 and PVID1 because the AP itself is a part of the administrative-VLAN1-un-tagged (Internet-Cable-Modem to Firewall to Switch to wAP-ac via TRUNKs).

Connected to the bridge via PORT is the only one available ether1 - this port has a PVID1 as well because if I understood the brief explanation of MikroTik, it is need for the un-tagged ingress (from ether-cable to port-ether1 / port-ether1 to the bridge) traffic ... On this PORT there is a cable with Trunk (vlan1-un-tagged, vlan10-tagged, vlan20-tagged, etc.).
Frame-Types = admit all ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

The next PORT to the bridge is the physical WLAN-chip (not vAP) - this port also has PVID1 because the SSID of the WLAN-chip is the administrative-VLAN1-un-tagged.
Frame-Types = admit all ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

Now the vAP's ... e.g. vAP10, vAP20, vAP30, etc.
For example: vAP10 has PVID10
Frame-Types = admit only VLAN tagged ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

Next is interface / bridge / VLAN:

I created VLAN ID = 1
Tagged = empty ... correct / why ?
Untagged = bridge, vlan1, wAP-2GHz, wAP5GHz ... correct / why ?

I created VLAN ID = 10
Tagged = bridge, vlan10 ... correct / why ?
Untagged = vAP10 ... correct / why ?

At the end I activated VLAN-Filtering under /interface bridge

One additional question ... is it needed to create the VLANs under /interface VLAN, too ?

As you see there are some puzzle-brickets I know but I am not able to make a picture of them :-(

Any help is highly appreciated - especially with explanation :-)
I'd suggest you to either join this topic or create a new one.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
coliflower
just joined
Posts: 18
Joined: Mon Aug 21, 2017 1:10 pm

Re: v6.41.2 [current]

Wed Feb 21, 2018 9:49 pm

I did, but I am still confused :( Maybe because of the WLAN-aspect ?
And I opened one here - but I found other issues in between ... viewtopic.php?f=7&t=130734
 
davidv
just joined
Posts: 1
Joined: Sun Feb 04, 2018 3:25 pm

Re: v6.41.2 [current]

Thu Feb 22, 2018 12:01 am

LHG´s AC 6.41.2
After the restarts it shows:
memory; system, error, critical; kernel failure in previous boot.
in the shutdown of the system only reboots

any solution?
Thank
.......................................................................................................
reset when you change the configuration and the connection wlan falls
problem coment: viewtopic.php?f=7&t=128916
Last edited by davidv on Mon Feb 26, 2018 4:33 pm, edited 1 time in total.
 
aforster
just joined
Posts: 7
Joined: Thu May 05, 2016 2:44 pm

Re: v6.41.2 [current]

Thu Feb 22, 2018 3:42 am

Folks,

I tried twice to move from 6.40.3 to other streams, but a few weeks after the upgrade, the router started going slow, and after a reboot, the same problem happened, exactly the same the two times: it lost part of the new bridge configurations. Even with reboots or reloading the configs, it would not fix it.. very, very strange.

It was a real pain to download the old 6.40.3 code using my cell phone as internet access to upload it to the router and restore old config.

Anyone had the same problem?

Now, Im back to 6.40.x.. just moved to 6.40.6 to see how that one is.. otherwise, will downgrade to 6.40.3 again.
 
jaytcsd
Member Candidate
Member Candidate
Posts: 286
Joined: Wed Dec 29, 2004 9:50 am
Location: Pittsboro IN
Contact:

Re: v6.41.2 [current]

Thu Feb 22, 2018 8:28 am

My hAPlite locked up after upgrading from 6.3 something using quickset to download and install.

I upgraded winbox through the tool option first, it crashed.
It worked when I restarted it and I got into the router to run quickset.
It rebooted OK, I got in and was looking at the log when it died.
I've done 3 power cycles and it still won't respond to pings.

Will netinstall preserve any supout data? I think that is my only recourse to help troubleshoot what happened.
My 10+ year old RB532 is working fine, otherwise this would be a letter.
 
minhcoi
just joined
Posts: 5
Joined: Wed Jan 17, 2018 4:53 pm

Re: v6.41.2 [current]

Sat Feb 24, 2018 6:16 am

I was upgrade my 951ui-2hnd from 6.40 to 6.41 and then i deleted all files in router... Now my 951ui become continually reset... I tried Netinstall but it cant see my router...
How can i fix this?
 
xtcinmymind
just joined
Posts: 2
Joined: Sun Feb 25, 2018 1:39 pm

Re: v6.41.2 [current]

Sun Feb 25, 2018 1:44 pm

Hello

great job with the latest firmware work so fast and more reliable .I just wonder to know about bonding .
before i used to uncheck master port on ether1 or 2 to be able to create bonding .
Now i cant do that cos it say ether1 or 2 already on brigde1 .
Can someone tell me how to create bonding easy way on the firmware 6.41.2

thnx
 
sindy
Forum Guru
Forum Guru
Posts: 3806
Joined: Mon Dec 04, 2017 9:19 pm

Re: v6.41.2 [current]

Sun Feb 25, 2018 2:42 pm

Now i cant do that cos it say ether1 or 2 already on brigde1 .
Can someone tell me how to create bonding easy way on the firmware 6.41.2
Go to Bridge -> Ports, remove ether1 and ether2 from the list, go to Interfaces -> Add new -> Bonding, set ether1 and ether2 as slaves, then maybe make the new bonding interface a member of that bridge from which you've removed ether1 and ether2. Done.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
xtcinmymind
just joined
Posts: 2
Joined: Sun Feb 25, 2018 1:39 pm

Re: v6.41.2 [current]

Sun Feb 25, 2018 3:43 pm

Now i cant do that cos it say ether1 or 2 already on brigde1 .
Can someone tell me how to create bonding easy way on the firmware 6.41.2
Go to Bridge -> Ports, remove ether1 and ether2 from the list, go to Interfaces -> Add new -> Bonding, set ether1 and ether2 as slaves, then maybe make the new bonding interface a member of that bridge from which you've removed ether1 and ether2. Done.
Yes thnx was easy way .also in the end have to add ports with the bond created and brigde ..thnxxx again
 
weldox
just joined
Posts: 10
Joined: Mon Mar 06, 2017 2:35 pm

Re: v6.41.2 [current]

Tue Feb 27, 2018 12:46 pm

I have my 7 milkrotik devices all stick to 6.38.5 and I am really scared in try to upgrade. I see a lot of problems in this thread....
Is it really so dangerous?
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: v6.41.2 [current]

Tue Feb 27, 2018 2:57 pm

Don't update anything if it scares you. Read the release notes that describe version differences. If you think there is a change you would like to have, make your own tests with backup devices before you decide to roll out the new version to your production ones.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5730
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.41.2 [current]

Tue Feb 27, 2018 5:36 pm

Also, when you want to be conservative set the update channel to "bugfix only" and you can update to 6.40.6 which does not
have this new style bridge instead of the existing bridge master-port setup. That should avoid a lot of problems when you
have a complicated configuration with VLAN and switching.
 
weldox
just joined
Posts: 10
Joined: Mon Mar 06, 2017 2:35 pm

Re: v6.41.2 [current]

Tue Feb 27, 2018 5:39 pm

Thank You very much!
 
bbs2web
Member Candidate
Member Candidate
Posts: 197
Joined: Sun Apr 22, 2012 6:25 pm
Location: Johannesburg, South Africa
Contact:

Re: v6.41.2 [current]

Wed Feb 28, 2018 12:25 am

We've had several instances of CCR routers losing bridge ports after upgrading from 6.41 to 6.41.2.

We run rancid as a configuration revision management system and reviewed logs after scheduling upgrades at 3am, ports simply missing.

Example:
/interface bridge port
add bridge=bridge-hosting interface=xxx-vlan12
missing after upgrade:

add bridge=bridge-nat interface=sfp11
add bridge=bridge-nat interface=xxx-vlan13
add bridge=bridge-management interface=xxx-vlan11
add bridge=bridge-management interface=sfp10
add bridge=bridge-hosting interface=sfp7
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5921
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.41.2 [current]

Wed Feb 28, 2018 11:29 am

Did you have any of bridge ports disabled?
 
lukas2511
just joined
Posts: 7
Joined: Sat Jan 07, 2017 1:19 pm

Re: v6.41.2 [current]

Thu Mar 01, 2018 12:16 am

I upgraded a RouterBoard hEX from 6.41 to 6.41.2 and had bridge ports disappearing too.

ether1 and ether2 were no longer part of any bridges (which was kinda unfortunate as those were my uplink and local-network ports)
 
bbs2web
Member Candidate
Member Candidate
Posts: 197
Joined: Sun Apr 22, 2012 6:25 pm
Location: Johannesburg, South Africa
Contact:

Re: v6.41.2 [current]

Thu Mar 01, 2018 12:26 am

No, they were active and working perfectly. This occurred on another CCR where I subsequently connected via mac telnet and simply dumped all bridge ports back again, any that already existed we skipped.

I'll book a maintenance window for next weekend (10th March) and take a supout before and after upgrading.

I initially thought that it may relate to large number of bridge ports but the example above occurred on a router with 3 bridges, each with pairs...
Did you have any of bridge ports disabled?
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1218
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6.41.2 [current]

Thu Mar 01, 2018 9:00 am

On my CCR1009 this version is unstable.
After an unpredictable time, the DHCP server stops responding, and routing seems to go amok (routes are there, but it is like connection tracking is not working). A reboot restores functionality for a time (from minutes up to a day).
Downgrading to 6.40.6 "cures" this behavior. I do not remember seeing this on 6.41.1. This could be the beginning of a beautiful friendship with 6.40.6 :lol:
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
b2fshen
just joined
Posts: 1
Joined: Sat Mar 03, 2018 8:17 pm

Re: v6.41.2 [current]

Sun Mar 04, 2018 6:21 am

Hi!
I am having trouble sending AT commands to LTE interface. After entering of ANY AT command like "interface lte at-chat lte1 input="ATI"" I receive: "action timed out - try again, if error continues contact MikroTik support and send a supout file (13)" reply.
My board is hAP (RB951ui-2nD) running 6.41.2. I tried it with USB modems ZTE MF730M and Huawei e3372 with the same result.
From Windows PC I can
Does anybody had same issues?
 
kasana825
just joined
Posts: 6
Joined: Sun Dec 04, 2016 7:27 pm

Re: v6.41.2 [current]

Sun Mar 04, 2018 7:41 pm

Hello,
I have routerboard and I configure 1 as WAN and 2,3 Bridge with WAN and I have set bandwidth limit on ethernet port 3, see attached file please

but today I bought rb1100ahx4
there is no option to set bandwidth limit on interface
but there is no option to set bandwidth limit
 
nimbo78
Frequent Visitor
Frequent Visitor
Posts: 71
Joined: Tue Jan 14, 2014 9:09 pm

Re: v6.41.2 [current]

Mon Mar 05, 2018 2:33 pm

FR:
plz add ICCID to lte info. needed to identify what SIM is now installed into the LTE kit. physically difficult to take out SIM from LTE kit and insert it back to the routerboard every time when we need to see ICCID.
 
scrarfussi
just joined
Posts: 7
Joined: Tue Sep 27, 2016 1:10 am

Re: v6.41.2 [current]

Mon Mar 05, 2018 7:52 pm

i upgraded my rb750gr2 to 6.41.2 and i lost internet access
i can ping on the router
but devices connected to it have no internet access
 
bbs2web
Member Candidate
Member Candidate
Posts: 197
Joined: Sun Apr 22, 2012 6:25 pm
Location: Johannesburg, South Africa
Contact:

Re: v6.41.2 [current]

Tue Mar 06, 2018 6:01 pm

I've sent supout files for a CHR instance before and after upgrading (6.41 to 6.41.2) where bridge ports disappear after upgrading. This problem has occurred on CCR, CHS and 750Gr3 routers, one of which only had 3 bridges with 6 bridge ports...
I'll book a maintenance window for next weekend (10th March) and take a supout before and after upgrading.

I initially thought that it may relate to large number of bridge ports but the example above occurred on a router with 3 bridges, each with pairs...
 
ok1mgj
just joined
Posts: 4
Joined: Wed Jan 24, 2018 9:13 am

Re: v6.41.2 [current]

Wed Mar 07, 2018 12:06 am

Hi all.

i`v upgraded 2 routerboards and on both of them i get into troubles with wireless.
RB751U-2HnD and RB751G-2HnD - both of them were on some 6.3x.x versions.

after upgrade to 6.41.2 (and corresponding firmware version) was RB unstable, after reboot and when wireless was enabled routerboard goes into booting loop.
configuration reset is unusable, because in default config is wifi enabled => booting loop.
next step was netinstall - yes, it helped. but after enabling wifi it was in booting loop again
i`v used netinstall again, did some tests and things were fine until i`v enabled wifi. Welcome to booting loop.
on 751U i`v tried 6.42rc37 - and after enabling wifi -> whooo, booting loop.
OK, something went wrong.
netinstall with older version (some 6.39.x) - and after enabling wifi..... voila, booting loop.

I have these RBs on very simple configuration - only one bridge across all ports including wifi - RBs acts only as AP for home usage.
So, now these routerboards is in stable config, but with disabled wireless.

Any idea how to solve this issue?
 
pe1chl
Forum Guru
Forum Guru
Posts: 5730
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.41.2 [current]

Wed Mar 07, 2018 11:28 am

Save your configuration and do a completely new netinstall.
In the past there have been changes to the wireless and at that time it already was tricky to update past that release,
it would not surprise me when it again causes problems when you still had the wireless package from before that change.
 
ok1mgj
just joined
Posts: 4
Joined: Wed Jan 24, 2018 9:13 am

Re: v6.41.2 [current]

Wed Mar 07, 2018 1:18 pm

Hi,
after netinstall is configuration clear, so it is not about configuration.

edit: on RB951G-2HnD is all OK and working properly.
 
ok1mgj
just joined
Posts: 4
Joined: Wed Jan 24, 2018 9:13 am

Re: v6.41.2 [current]

Wed Mar 07, 2018 9:22 pm

guys, please, don`t panic (..and thanks for all the fish)

after a few hours of tests with other pices of routerboards (i have many RBs of many types) i have found, where trouble is located.

and this was: power adapter.

so, i`m very sorry to all the people.
 
JanezFord
Member Candidate
Member Candidate
Posts: 263
Joined: Wed May 23, 2012 10:58 am

Re: v6.41.2 [current]

Thu Mar 08, 2018 1:28 pm

We've had several instances of CCR routers losing bridge ports after upgrading from 6.41 to 6.41.2.
I can also confirm that. CCR lost about half of bridge ports for no apparent reason after upgrading from 6.41 to 6.41.2. I also had to netinstall one hAP-AC with very simple config (simple CAP with all ports bridget + dhcp on bridge) which went into reboot loop after upgrade.

JF.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5730
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.41.2 [current]

Thu Mar 08, 2018 2:07 pm

A not so widely know feature of the "older" routers (this was lost in the recent low-end models that have only 16MB of flash) is the
possibility to divide the flash in two partitions that can be copied over and one can be activated. On a CCR you can copy the existing
firmware+config to the inactive partition, upgrade, reboot and when is not troublefree you can activate the second partition and reboot again to
fall back to the previous situation (without the issue that an upgrade could have modified the configuration).
You probably already know this but I bet not every admin does.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Mon Mar 12, 2018 10:01 am

Version 6.41.3 has been released in current channel:
viewtopic.php?f=21&t=131810

Who is online

Users browsing this forum: No registered users and 6 guests