Community discussions

 
Mikhail73
just joined
Posts: 6
Joined: Wed Sep 21, 2016 8:31 pm

Re: v6.41.2 [current]

Mon Feb 12, 2018 3:31 pm

Mikhail73 - Please send supout file from your router to support@mikrotik.com. In best case scenario provide two files - one from 6.41.2 and one from 6.41.1 where everything works just fine. This version does not have any wireless fixes;
Done. Upgrade was from 6.41, not 6.41.1.
Do i need to downgrade also routerboard firmware from 6.41.2 to 6.41 now?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5479
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.41.2 [current]

Mon Feb 12, 2018 4:08 pm

I found a couple of strange entries in the routing table after the upgrade on my hAP ac.
What exactly is considered strange there?
 
mszru
just joined
Posts: 9
Joined: Wed Aug 10, 2016 10:42 am

Re: v6.41.2 [current]

Mon Feb 12, 2018 4:41 pm

I found a couple of strange entries in the routing table after the upgrade on my hAP ac.
What exactly is considered strange there?
The new routes to 0.0.0.0/32 in the list which were not there before.
According to the RFC 3330 it is kind of special address, and I cannot understand if it was added on purpose or by mistake during the upgrade.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5479
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.41.2 [current]

Mon Feb 12, 2018 5:02 pm

Can you generate supout file from 6.41.2 downgrade and generate another file from older version and send both files to support?
 
fabifri
just joined
Posts: 8
Joined: Thu Dec 11, 2014 12:25 am

Re: v6.41.2 [current]

Mon Feb 12, 2018 5:10 pm

Boot loop on RB750Gr3 too. :-(
Datacenter offline. Night shift incomming. Thanks!
 
Rule47
just joined
Posts: 2
Joined: Sun Jan 17, 2016 11:15 pm

Re: v6.41.2 [current]

Mon Feb 12, 2018 10:24 pm

I've got trouble connecting older devices such as Android 4.0, iPhone 4 or Blackberry probably since Rel. 6.41 to access points using CAPsMAN. I downgraded to Rel. 6.35.4, which works well with these devices. Newer devices work (tested: iPhone 6, iPhone 8).

Currently installed on all devices: Rel. 6.41.2. The error I get is: "received deauth: class 3 frame received (7)".

Does someone have a clue, what to do. Users are complaining heavily.

Jo
 
User avatar
Jotne
Member Candidate
Member Candidate
Posts: 224
Joined: Sat Dec 24, 2016 11:17 am

Re: v6.41.2 [current]

Tue Feb 13, 2018 1:11 am

Boot loop on RB750Gr3 too. :-(
Datacenter offline. Night shift incomming. Thanks!
RB750Gr3 is a low cost product ment for home and small offices.
Running a whole datasenter behind it seems for me some strange.
 
i4ko
just joined
Posts: 9
Joined: Sat Sep 26, 2015 9:23 pm

Re: v6.41.2 [current]

Tue Feb 13, 2018 6:18 am

After upgrading from version 6.39.3 [BugFix] to 6.41.1 and then to 6.41.2, my device [RB751U-2HnD] presented wireless connectivity problems.

I also upgraded the firmware, leaving it equivalent to the ROS.

The causes of the problem could not be identified in the logs.

Even after resetting and redoing all the settings one by one, it was not possible to keep the wireless connection stable.
Please write more detailed what kind of wireless connectivity problems you see.
I have seen a wireless issue on two of the RB941-2nD I have. I don't know if it is the same or not.
Initially it started with wireless devices intermittently dropping. Later on it progressed to more severe intermittent connectivity - about 50 percent of the time there will be no devices connected. Logs would show key exchange timeout and drop the wireless devices about every 30 minutes, then it changed to about every 2 minutes. It progressed further onto the wireless devices not being able to hold stable connection for more than 2-3 seconds, it would not matter if the frequency was set to auto or set frequency. Initially devices tried to connect frequently, then connection attempt became more rare, until almost no connection attempts would be made. Every time the router kicked out the device for unicast key exchange timeout. But it became even worse - the devices were not trying to connect because they could not see the SSID. Those two devices now (no longer at customer) do not advertise SSID no matter what, I can't see it even with kismet. It seems like the radio RF portion just gradually and eventually died after the 6.41.1 upgrade. Multiple resets, and power off/power on did not make any difference.
Needless to say I had to replace these two. Initially they did not have the 6.41.1 firmware installed when they started being weird. When I got the issues, I installed the 6.41.1 firmware which made things worse and ultimately the WIFI portion just does not seem to work at all. The whole degradation from a fully stable working router to fully non-discoverable wifi (even on scans) started about a month after the 6.41.0 upgrade, and tool like 3-4 days with a 6.41.1 upgrade in the middle.
Regular AP bridge, no CAPsMAN, 2GHz-N-only band, 20Mhz channel, 802.11 protocol, WPS disabled, Hide SSID not set. Frequency - regulatory domain, Country - United States, Data rates - Default, Distance - indoors, Preamble - long/both

Hmm, tried setting the country to something else - Latvia - it would make the SSID temporarily discoverable (for about 5-10 seconds) and then it will die again. At the same time the status will claim it is running, at -112dBm noise floor and 2427/20/gn(20dBm) channel (sometimes 2422).
Nothing informative in the logs, even if wireless is on debug
 
Clauu
Member Candidate
Member Candidate
Posts: 202
Joined: Fri Mar 21, 2014 8:27 pm
Location: RO

Re: v6.41.2 [current]

Tue Feb 13, 2018 8:18 am

About firewall new feature 'tls-host' i cannot make use of it no matter what sites i try, i'm i missing something or this feature is broken?
/ip firewall filter add chain=forward dst-port=443 protocol=tcp tls-host=*google.com action=drop
Having fun with RB850Gx2, RB2011UiAS-2HnD, RB260GSP, RB751U-2HnD, CRS112, RB3011UiAS, hAP ac, cAP ac and hAP ac². More others on the way :-)
 
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1245
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Tue Feb 13, 2018 8:35 am

Clauu - Such rule should be working. Most likely some other firewall rule matches such traffic before this one. Are you using FastTrack?
 
Clauu
Member Candidate
Member Candidate
Posts: 202
Joined: Fri Mar 21, 2014 8:27 pm
Location: RO

Re: v6.41.2 [current]

Tue Feb 13, 2018 8:53 am

Hi strods, i'm not using fastrack and tls rule was in top of all other forward chain rules.
Hm as i can see there is a fix for this feature in latest rc
What's new in 6.42rc24 (2018-Feb-08 09:42):
*) firewall - fixed "tls-host" firewall feature (introduced v6.41);
Is this related to my issue?
L.E: tested again and now it's working.. odd.
Having fun with RB850Gx2, RB2011UiAS-2HnD, RB260GSP, RB751U-2HnD, CRS112, RB3011UiAS, hAP ac, cAP ac and hAP ac². More others on the way :-)
 
tangram
Frequent Visitor
Frequent Visitor
Posts: 99
Joined: Wed Nov 16, 2016 9:55 pm

Re: v6.41.2 [current]

Tue Feb 13, 2018 4:43 pm

Hi,

I don't know if it's a winbox or routeros bug, but it's easy to reproduce. Connected with winbox, if you have a script open for editing and you delete that script from script list the session is dropped.
Oh and it generates autosupout :)
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5479
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.41.2 [current]

Tue Feb 13, 2018 4:46 pm

Do you use latest winbox version?
 
ksteink
just joined
Posts: 13
Joined: Thu Mar 31, 2016 6:54 pm

Re: v6.41.2 [current]

Tue Feb 13, 2018 9:42 pm

I upgraded my RB2011UiAS-2HnD-IN with no major issues. All my basic connection features worked fine (OVPN, IPv6 and VLANs). I did noticed that after the upgrade the LED on the router was constantly ON even in my setting I have it by default on OFF. I did turned ON and OFF again and it finally turn it off.

I have been working all day with it and no issues. I still want to revisit the configuration changes on the HW off-loading but from the end user experience no services have been impacted.
 
aaronw
just joined
Posts: 9
Joined: Thu Feb 26, 2009 7:30 am

Re: v6.41.2 [current]

Wed Feb 14, 2018 2:47 am

Never mind. I switched to a different laptop and disabled the firewall and I was able to recover the system. I still do not know why the initial update failed. Using netinstall I was able to boot the new system and install it.

This update appears to have broken an RB850GX2 router. After the update the router never recovered and failed to boot. I have since tried to get it to boot using netinstall and that fails.

Here is the output when booting from NAND:
RouterBOOT booter 3.24

RouterBoard 850Gx2

CPU frequency: 533 MHz
Memory size: 512 MiB
NAND size: 512 MiB

Press any key within 2 seconds to enter setup..

loading kernel from nand... OK
setting up elf image... OK
jumping to kernel code
Starting...
Starting services...
connect failed (errno=2)
died with signal 6 on Thu Jan 1 00:00:12 1970

Aborted
connect failed (errno=2)
Aborted

Here is the output when I attempt to use netinstall and boot over Ethernet:
RouterBOOT booter 3.24

RouterBoard 850Gx2

CPU frequency: 533 MHz
Memory size: 512 MiB
NAND size: 512 MiB

Press any key within 2 seconds to enter setup..
trying bootp protocol.... OK
Got IP address: 192.168.0.100
resolved mac address 3C:97:0E:24:41:BC
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
********************falling back to small packet size
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
********************kernel loading failed
Basically it bricked the Routerboard. I have also cleared the configuration from the bootloader and that did not help. It seems to pass the memory test.

Everything was working fine until the update. The update process completed then the box showing the progress just hung (obviously because it could not reboot).

Any suggestions?

-Aaron
 
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1245
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Wed Feb 14, 2018 6:35 am

Seems that either there is some issue with link between computer and router or there is another device in the path (switch, for example) causing this problem. Router starts to communicate with Netinstall, however, they both are not being able to make stable connection in order to start Netinstall process.
 
i4ko
just joined
Posts: 9
Joined: Sat Sep 26, 2015 9:23 pm

Re: v6.41.2 [current]

Wed Feb 14, 2018 6:46 am

i4ko - Most likely you will need to re-install devices by using Netinstall. However, I recommend that you send supout file from one of your routers to support. We might see in supout file what is filling up the space.
Finally manged to update remotely. While on 6.41.1 disabled all packages except for system, dhcp and wireless, and uploaded the same from the 6.41.2 all packages file to the router (those were all i had room for), then rebooted, all in one go. Now I no longer have any packages besides these (routeros-smips is also gone) but everything is working fine. This also dropped 1.5mb in disk usage, I'll add some of the other packages where I need them.
 
osmoticzest
just joined
Posts: 3
Joined: Wed Jan 03, 2018 2:55 pm

Re: v6.41.2 [current]

Wed Feb 14, 2018 9:35 am

Spotted the following on Superuser today, and it accurately describes what I’m seeing on the last couple of releases (potentially since 6.41.0) – the WiFi interface will just ‘stop’ at random, nothing in registration table, 0/0 tx/rx. Restarting the interface or doing something like using the ‘Scanner’ will bring things back to life. Same behaviour on both APs here.

https://superuser.com/questions/1293579 ... -is-restar

951G-2HnD + RB941-2nD
frequency-mode=regulatory-domain country=united kingdom
Last edited by osmoticzest on Wed Feb 14, 2018 1:45 pm, edited 2 times in total.
 
Nuubo
just joined
Posts: 5
Joined: Wed Jan 03, 2018 12:38 pm

Re: v6.41.2 [current]

Wed Feb 14, 2018 9:37 am

Unfortunately my fears were true: bridging is still working bad because ARP is not fixed.
I am wondering why did Mikrotik eliminate master/slave options using switching?, since I am using Mikrotik I just use bridges to link wifi / ethernet interfaces but when the other day I upgraded to 6.41.2 it was impossible to keep the network running, the old master/slave interfaces of same switch were wrong, the old master interface loosing packets continuosly and the slave interface just not populate MAC addreses connected.

Please, consider my option: back to the old status, master slave is a much better option using switiching, if someone wants bridging, use bridging, but I think it is much worse.

Thanks.
 
tangram
Frequent Visitor
Frequent Visitor
Posts: 99
Joined: Wed Nov 16, 2016 9:55 pm

Re: v6.41.2 [current]

Wed Feb 14, 2018 10:20 am

Do you use latest winbox version?
Thank you, I was using 3.11. In 3.12 problem is fixed.
 
R1st0
just joined
Posts: 3
Joined: Wed Feb 14, 2018 10:08 am

Re: v6.41.2 [current]

Wed Feb 14, 2018 10:23 am

I have problem with neighbor discovery on CRS106. My intention is to allow neighbor discovery only on uplink port (sfp5).
When using configuration:
/interface list
add name=clients
/interface list member
add interface=sfp1 list=clients
add interface=sfp2 list=clients
add interface=sfp3 list=clients
add interface=sfp4 list=clients
/ip neighbor discovery-settings
set discover-interface-list=!clients
It works, but when exporting the config "!" mark disappears: /ip neighbor discovery-settings set discover-interface-list=clients. When I use "/ip neighbor discovery-settings pr" the "!" is there.
To reduce lines I tried similar configuration, but this one doesn´t work (no discovery on sfp5):
/interface list
add name=uplink
/interface list member
add interface=sfp5 list=uplink
/ip neighbor discovery-settings
set discover-interface-list=uplink
 
eddieb
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: v6.41.2 [current]

Wed Feb 14, 2018 2:05 pm

updated my RB2011UAS from 6.40.5 to 6.41.2 ...
everything went smooth.
2 IPSEC site-to-site tunnels
DHCP and DNS server
PPPOE on wan

look fine here
 
LIV2
just joined
Posts: 24
Joined: Sat Jan 23, 2016 7:42 am

Re: v6.41.2 [current]

Thu Feb 15, 2018 2:29 am

After upgrading my mAP2n to 6.41.2 I've found that doing /system reset-configuration no-defaults=no results in an empty configuration, and I can only connect to the router via mac-telnet
Same result when using the reset button to do a config reset, even on 6.42rc24 it also doesn't work
 
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1245
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Thu Feb 15, 2018 6:52 am

osmoticzest - Provide supout file from your router to support@mikrotik.com
Nuubo - Please provide precise problem description and supout files to support@mikrotik.com. From which version with what exact configuration did you upgrade this device and did you upgrade directly to 6.41.2 release;
R1st0 - We will resolve this export command problem in upcoming RouterOS releases;
LIV2 - Have you tried to Netinstall your device and reset it only after that? Seems that default configuration has been changed to something else by using configuration script on Netinstall.
 
LIV2
just joined
Posts: 24
Joined: Sat Jan 23, 2016 7:42 am

Re: v6.41.2 [current]

Thu Feb 15, 2018 9:56 am

LIV2 - Have you tried to Netinstall your device and reset it only after that? Seems that default configuration has been changed to something else by using configuration script on Netinstall.
I've tried Netinstall ensuring "Apply Default Config" is ticked with various versions with the following results
6.42rc20 - No default config
6.41.1 - No default config
6.41 - No default config
6.40.5 - Default config works
6.39.3 - Default config works
 
Nuubo
just joined
Posts: 5
Joined: Wed Jan 03, 2018 12:38 pm

Re: v6.41.2 [current]

Fri Feb 16, 2018 10:50 am

Nuubo - Please provide precise problem description and supout files to support@mikrotik.com. From which version with what exact configuration did you upgrade this device and did you upgrade directly to 6.41.2 release;

I am sorry but I did the change to my configuration with a new subnet just for one computer. I thought it was some upgrade problem (I did it from 6.41 directly) I deleted the bridge and I recreated it with same results, there was no MAC address in ARP table and continuous interruptions of network traffic. I just want ask you in future releases the recover of master/slave option, I can not understand why did you eliminate the use of switching, it is much better since it is flexible and instant.
 
buzzdee
newbie
Posts: 34
Joined: Mon Apr 22, 2013 1:22 pm

Re: v6.41.2 [current] - scripting and terminal "no such item"

Fri Feb 16, 2018 7:24 pm

Hi,

seems the issue described here

viewtopic.php?f=21&t=128915&p=637801&hi ... em#p637801

still persists. When enabling/disabling ppp-devices from terminal or script, I get "no such item (4)" the first time I run the command, but it works when I run it again. Have a couple of 411U's and 912's with 3G modems, would be nice if I could use my scripts to reset those modems would work again.
 
User avatar
macsrwe
Long time Member
Long time Member
Posts: 584
Joined: Mon Apr 02, 2007 5:43 am
Location: Arizona, USA
Contact:

Re: v6.41.2 [current]

Fri Feb 16, 2018 10:57 pm

Again - we strongly recommend to NOT use this feature if you are not aware about how it works. If you will not know min/max settings, then you will not be able to recover device in any way.
I suspect there are many routers out there where this value is set to arbitrary garbage due to recent (still current?) bug in Winbox where calling up /system routerboard settings always populates this value as 00:00:00 -- in red since zero is an invalid value -- and then demands the user set it to something nonzero before they can make the unrelated change they originally wished to make.
 
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1245
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.2 [current]

Sat Feb 17, 2018 10:58 am

buzzdee - First of all, please do not post version u relafed issues within new release topic. Your problem has nothing to do with release and even ia not a bug. Do not use ID in scripts or run print first.

For example:
1) will not work
/interface ethernet set 1 name=test
2) will work
/interface ethernet set ether2 name=test
3) will work
/interface ethernet print
/interface ethernet set 1 name

On #1 script does not know which interface is 1 and that is why you see such error.
 
buzzdee
newbie
Posts: 34
Joined: Mon Apr 22, 2013 1:22 pm

Re: v6.41.2 [current]

Sat Feb 17, 2018 11:48 am

Hi strods, thanks for the quick reply.
First of all, please do not post version u relafed issues within new release topic
Sorry, I should have been more precise - what I experienced was on 6.41.2.

Heres is a snippet from the script. I'm not using ID's but the interfaces name:
# Set UMTS Interface name
:global WanName "ppp-out1"
# get its ID number #
:local WanID [/interface ppp-client find name=$WanName];
# Change the data channel setting
/interface ppp-client set data-channel="3" $WanID
If I get you right, interface should come before set-command in the last line:
/interface ppp-client $WanID set data-channel="3"
Does this also apply when using interface names instead of ID's?

Thanks, BuzzDee.
 
sindy
Forum Guru
Forum Guru
Posts: 1182
Joined: Mon Dec 04, 2017 9:19 pm

Re: v6.41.2 [current]

Sat Feb 17, 2018 12:26 pm

If I get you right, interface should come before set-command in the last line:
/interface ppp-client $WanID set data-channel="3"
Does this also apply when using interface names instead of ID's?

Thanks, BuzzDee.
No, the order is less obvious, 1. set 2. in which item 3. which attribute:
/interface ppp-client set $WanID data-channel="3"
You can abbreviate your example into
/interface ppp-client set [find name=$WanName] data-channel="3"
And yes, you can replace the number(s) in the set, remove, unset etc. by "find" referring to any attribute.
 
Institor
just joined
Posts: 9
Joined: Sat Apr 29, 2017 3:28 pm

Re: v6.41.2 [current]

Sat Feb 17, 2018 1:38 pm

Bridge on RB750Gr3 (6.41.2) seems to be broken.
1) No HW offload on ethernet interfaces after upgrade from 6.41.1:
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 #     INTERFACE                      BRIDGE                      HW  PVID PRIORITY  PATH-COST INTERNAL-PATH-COST    HORIZON
 0     eth2                           bridge_local                yes    1     0x80         10                 10       none
 1     eth3                           bridge_local                yes    1     0x80         10                 10       none
 2 I   eth4                           bridge_local                yes    1     0x80         10                 10       none
 3 I   eth5                           bridge_local                yes    1     0x80         10                 10       none
 
interface bridge port print detail
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 0     interface=eth2 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 1     interface=eth3 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 2 I   interface=eth4 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 3 I   interface=eth5 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no
2) Bridge settings freezes constantly (for example, after trying to check/uncheck "igmp snooping", bridge completely shuts down and remain disabled for approx. 1 minute).

It's slightly annoying....
 
GARCIADOEGOGERMAN
just joined
Posts: 15
Joined: Fri Aug 18, 2017 2:05 pm

Re: v6.41.2 [current]

Sat Feb 17, 2018 5:37 pm

Bridge on RB750Gr3 (6.41.2) seems to be broken.
1) No HW offload on ethernet interfaces after upgrade from 6.41.1:
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 #     INTERFACE                      BRIDGE                      HW  PVID PRIORITY  PATH-COST INTERNAL-PATH-COST    HORIZON
 0     eth2                           bridge_local                yes    1     0x80         10                 10       none
 1     eth3                           bridge_local                yes    1     0x80         10                 10       none
 2 I   eth4                           bridge_local                yes    1     0x80         10                 10       none
 3 I   eth5                           bridge_local                yes    1     0x80         10                 10       none
 
interface bridge port print detail
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 0     interface=eth2 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 1     interface=eth3 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 2 I   interface=eth4 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 3 I   interface=eth5 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no
2) Bridge settings freezes constantly (for example, after trying to check/uncheck "igmp snooping", bridge completely shuts down and remain disabled for approx. 1 minute).

It's slightly annoying....
In my RB750GR3 the same thing happens ... looking for more info I found this that seems to be the reason why what happens is what happens.

Release 6.41.1 2018-02-02
What's new in 6.41.1 (2018-Jan-30 10:26):

*) bridge - fixed hw-offload disabling for Mediatek and Realtek switches when STP / RSTP configured;
*) bridge - fixed hw-offload disabling when adding a port with "horizon" set;

This will have to do with what you mention ???

Regards!!!
 
mpadmin
just joined
Posts: 7
Joined: Sun May 22, 2016 3:48 pm

Re: v6.41.2 [current]

Sat Feb 17, 2018 10:32 pm

Bridge on RB750Gr3 (6.41.2) seems to be broken.
1) No HW offload on ethernet interfaces after upgrade from 6.41.1:
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 #     INTERFACE                      BRIDGE                      HW  PVID PRIORITY  PATH-COST INTERNAL-PATH-COST    HORIZON
 0     eth2                           bridge_local                yes    1     0x80         10                 10       none
 1     eth3                           bridge_local                yes    1     0x80         10                 10       none
 2 I   eth4                           bridge_local                yes    1     0x80         10                 10       none
 3 I   eth5                           bridge_local                yes    1     0x80         10                 10       none
 
interface bridge port print detail
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 0     interface=eth2 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 1     interface=eth3 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 2 I   interface=eth4 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 3 I   interface=eth5 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no
2) Bridge settings freezes constantly (for example, after trying to check/uncheck "igmp snooping", bridge completely shuts down and remain disabled for approx. 1 minute).

It's slightly annoying....


I have 750Gr3 and HW offload works, but you need to set Protocol Mode to "none".
/interface bridge
add name=bridge-internal protocol-mode=none
 
GARCIADOEGOGERMAN
just joined
Posts: 15
Joined: Fri Aug 18, 2017 2:05 pm

Re: v6.41.2 [current]

Sun Feb 18, 2018 2:53 am

Bridge on RB750Gr3 (6.41.2) seems to be broken.
1) No HW offload on ethernet interfaces after upgrade from 6.41.1:
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 #     INTERFACE                      BRIDGE                      HW  PVID PRIORITY  PATH-COST INTERNAL-PATH-COST    HORIZON
 0     eth2                           bridge_local                yes    1     0x80         10                 10       none
 1     eth3                           bridge_local                yes    1     0x80         10                 10       none
 2 I   eth4                           bridge_local                yes    1     0x80         10                 10       none
 3 I   eth5                           bridge_local                yes    1     0x80         10                 10       none
 
interface bridge port print detail
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 0     interface=eth2 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 1     interface=eth3 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 2 I   interface=eth4 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 3 I   interface=eth5 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no
2) Bridge settings freezes constantly (for example, after trying to check/uncheck "igmp snooping", bridge completely shuts down and remain disabled for approx. 1 minute).

It's slightly annoying....


I have 750Gr3 and HW offload works, but you need to set Protocol Mode to "none".
/interface bridge
add name=bridge-internal protocol-mode=none
Then because the script of the default configuration of the RB750GR3 has set "protocol-mode = rstp" ??? It would be a problem to solve by Mikrotik support, since being in RSTP mode will never use HW OFF ...
 
Institor
just joined
Posts: 9
Joined: Sat Apr 29, 2017 3:28 pm

Re: v6.41.2 [current]

Sun Feb 18, 2018 5:31 am

Yes, rstp was enabled on bridge...
However, disabling rstp took about 3-4 minutes, i think that's a little too slow... Changing other settings (like "fast forward") also freezes the bridge for several minutes.
 
kuzma2000
just joined
Posts: 10
Joined: Wed Nov 20, 2013 11:57 am
Location: Kiev, Ukraine

Re: v6.41.2 [current]

Sun Feb 18, 2018 8:57 pm

Hi!
I successfully updated through Dude all my rb941 (2 pieces) ccr1009 (2 pieces) and RB WAP G-5hact2hnd from 6.41.1 to 6.41.2.
But I couldn't update any rb962.
Also, I tried to update rb962 via Winbox.
The reason is: there is not enough space.
rb962 have only 16 MB, of which only 20-30% is available.
Last time I altering them through NetInstall/
What to do now?
 
ATROX
newbie
Posts: 40
Joined: Mon Oct 14, 2013 2:10 pm

Re: v6.41.2 [current]

Mon Feb 19, 2018 11:01 am

ap - cAP ac (RouterBOARD cAP Gi-5acD2nD)
ARP table - empty
Current Tx Power 2GHz - empty

OS - 6.41.2

Image
Image

Image
Real IPQ4019 ???
In specification - IPQ4018.
Image
 
tigro11
just joined
Posts: 17
Joined: Tue Feb 20, 2018 12:31 am

Re: v6.41.2 [current]

Tue Feb 20, 2018 12:40 am

hi guys, on my rb750Gr3 with firmware 6.42rc28 I wanted to mount a hotspot for a job. I can not install the user-manager package.
Are there any solutions?
thank you all

Valerio
 
ATROX
newbie
Posts: 40
Joined: Mon Oct 14, 2013 2:10 pm

Re: v6.41.2 [current]

Tue Feb 20, 2018 7:28 am

ap - cAP ac (RouterBOARD cAP Gi-5acD2nD)
OS - 6.41.2

Some clients are disconnected from the point here with such an error:
disconnected, extensive data loss
and
disconnected, received disassoc: sending station leaving (8)
I settings many MicroTick AP.
The settings are the same everywhere, it's on this, new such problems.

Image

For example, this client is sitting on the spot, does not run around the office.

Well, here's a look at what the rest are doing ...
Image
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1178
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6.41.2 [current]

Tue Feb 20, 2018 8:50 am

...
Current Tx Power 2GHz - empty
...
FYI: 0 dBm does not mean "empty"/zero power. It is a valid value and means 1 mW. Still odd though, if it changed by itself.
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
buzzdee
newbie
Posts: 34
Joined: Mon Apr 22, 2013 1:22 pm

Re: v6.41.2 [current]

Tue Feb 20, 2018 6:06 pm

@sindy

Thanks for pointing out which order to use in scripting. I must have been lucky that my scripts worked in earlier versions without paying that much attention to the order.
 
ATROX
newbie
Posts: 40
Joined: Mon Oct 14, 2013 2:10 pm

Re: v6.41.2 [current]

Wed Feb 21, 2018 10:50 am

ap - cAP ac (RouterBOARD cAP Gi-5acD2nD)
ARP table - empty
Current Tx Power 2GHz - empty

OS - 6.41.2

The new chips have a new method of obtaining power data. not yet supported Route OS.
MikroTik support answered
 
HiroZA
just joined
Posts: 2
Joined: Wed Feb 21, 2018 3:46 pm

Re: v6.41.2 [current]

Wed Feb 21, 2018 6:55 pm

My current router was ISP supplied and has all the default config on it. If i download this update and install it, will this setup be overwritten? Will i have issues due to PPPoE settings being factory reset ?
 
sindy
Forum Guru
Forum Guru
Posts: 1182
Joined: Mon Dec 04, 2017 9:19 pm

Re: v6.41.2 [current]

Wed Feb 21, 2018 8:12 pm

My current router was ISP supplied and has all the default config on it. If i download this update and install it, will this setup be overwritten? Will i have issues due to PPPoE settings being factory reset ?
Even if you upgrade between stable versions, you should always backup the configuration and download the backup file from the router. Exporting it in the text form into another file (using "/export file=backup_version_today") is also a good practice because the "binary" backups from older versions are not always readable by newer versions. And noting down any credentials (in your case, especially those related to the PPPoE account) is also a good idea.

I assume that your ISP doesn't mind you to do the upgrade as they've given you administrator rights to the router.
 
coliflower
just joined
Posts: 18
Joined: Mon Aug 21, 2017 1:10 pm

Re: v6.41.2 [current]

Wed Feb 21, 2018 9:03 pm

I am sorry but I am still confused with the new bridge implementation :-(

I updaten one of my wAP-ac to 6.41.2 and created a bridge - this bridge has an IP 10.0.100.4/24 and PVID1 because the AP itself is a part of the administrative-VLAN1-un-tagged (Internet-Cable-Modem to Firewall to Switch to wAP-ac via TRUNKs).

Connected to the bridge via PORT is the only one available ether1 - this port has a PVID1 as well because if I understood the brief explanation of MikroTik, it is need for the un-tagged ingress (from ether-cable to port-ether1 / port-ether1 to the bridge) traffic ... On this PORT there is a cable with Trunk (vlan1-un-tagged, vlan10-tagged, vlan20-tagged, etc.).
Frame-Types = admit all ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

The next PORT to the bridge is the physical WLAN-chip (not vAP) - this port also has PVID1 because the SSID of the WLAN-chip is the administrative-VLAN1-un-tagged.
Frame-Types = admit all ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

Now the vAP's ... e.g. vAP10, vAP20, vAP30, etc.
For example: vAP10 has PVID10
Frame-Types = admit only VLAN tagged ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

Next is interface / bridge / VLAN:

I created VLAN ID = 1
Tagged = empty ... correct / why ?
Untagged = bridge, vlan1, wAP-2GHz, wAP5GHz ... correct / why ?

I created VLAN ID = 10
Tagged = bridge, vlan10 ... correct / why ?
Untagged = vAP10 ... correct / why ?

At the end I activated VLAN-Filtering under /interface bridge

One additional question ... is it needed to create the VLANs under /interface VLAN, too ?

As you see there are some puzzle-brickets I know but I am not able to make a picture of them :-(

Any help is highly appreciated - especially with explanation :-)
 
sindy
Forum Guru
Forum Guru
Posts: 1182
Joined: Mon Dec 04, 2017 9:19 pm

Re: v6.41.2 [current]

Wed Feb 21, 2018 9:18 pm

I am sorry but I am still confused with the new bridge implementation :-(

I updaten one of my wAP-ac to 6.41.2 and created a bridge - this bridge has an IP 10.0.100.4/24 and PVID1 because the AP itself is a part of the administrative-VLAN1-un-tagged (Internet-Cable-Modem to Firewall to Switch to wAP-ac via TRUNKs).

Connected to the bridge via PORT is the only one available ether1 - this port has a PVID1 as well because if I understood the brief explanation of MikroTik, it is need for the un-tagged ingress (from ether-cable to port-ether1 / port-ether1 to the bridge) traffic ... On this PORT there is a cable with Trunk (vlan1-un-tagged, vlan10-tagged, vlan20-tagged, etc.).
Frame-Types = admit all ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

The next PORT to the bridge is the physical WLAN-chip (not vAP) - this port also has PVID1 because the SSID of the WLAN-chip is the administrative-VLAN1-un-tagged.
Frame-Types = admit all ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

Now the vAP's ... e.g. vAP10, vAP20, vAP30, etc.
For example: vAP10 has PVID10
Frame-Types = admit only VLAN tagged ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

Next is interface / bridge / VLAN:

I created VLAN ID = 1
Tagged = empty ... correct / why ?
Untagged = bridge, vlan1, wAP-2GHz, wAP5GHz ... correct / why ?

I created VLAN ID = 10
Tagged = bridge, vlan10 ... correct / why ?
Untagged = vAP10 ... correct / why ?

At the end I activated VLAN-Filtering under /interface bridge

One additional question ... is it needed to create the VLANs under /interface VLAN, too ?

As you see there are some puzzle-brickets I know but I am not able to make a picture of them :-(

Any help is highly appreciated - especially with explanation :-)
I'd suggest you to either join this topic or create a new one.
 
coliflower
just joined
Posts: 18
Joined: Mon Aug 21, 2017 1:10 pm

Re: v6.41.2 [current]

Wed Feb 21, 2018 9:49 pm

I did, but I am still confused :( Maybe because of the WLAN-aspect ?
And I opened one here - but I found other issues in between ... viewtopic.php?f=7&t=130734
 
davidv
just joined
Posts: 1
Joined: Sun Feb 04, 2018 3:25 pm

Re: v6.41.2 [current]

Thu Feb 22, 2018 12:01 am

LHG´s AC 6.41.2
After the restarts it shows:
memory; system, error, critical; kernel failure in previous boot.
in the shutdown of the system only reboots

any solution?
Thank
.......................................................................................................
reset when you change the configuration and the connection wlan falls
problem coment: viewtopic.php?f=7&t=128916
Last edited by davidv on Mon Feb 26, 2018 4:33 pm, edited 1 time in total.
 
aforster
just joined
Posts: 7
Joined: Thu May 05, 2016 2:44 pm

Re: v6.41.2 [current]

Thu Feb 22, 2018 3:42 am

Folks,

I tried twice to move from 6.40.3 to other streams, but a few weeks after the upgrade, the router started going slow, and after a reboot, the same problem happened, exactly the same the two times: it lost part of the new bridge configurations. Even with reboots or reloading the configs, it would not fix it.. very, very strange.

It was a real pain to download the old 6.40.3 code using my cell phone as internet access to upload it to the router and restore old config.

Anyone had the same problem?

Now, Im back to 6.40.x.. just moved to 6.40.6 to see how that one is.. otherwise, will downgrade to 6.40.3 again.

Who is online

Users browsing this forum: emikrotik, r00t and 11 guests