Community discussions

MikroTik App
 
becs
MikroTik Support
MikroTik Support
Topic Author
Posts: 491
Joined: Thu Jul 07, 2011 8:26 am

SwOS version 2.13 released!

Thu Apr 29, 2021 8:55 am

SwOS version 2.13 released
http://www.mikrotik.com/download

What's new in v2.13:

*) added support for CRS354;
*) CRS328: fixed SFP status monitoring;
*) CRS328: fixed auto-negotiation on combo ports;
*) CRS326Q: fixed matching by ports in ACL;
*) CRS326Q: properly detect QSFP+ optical modules;
*) CRS326Q: properly detect QSFP+ DAC cable;
*) CRS326Q: fixed case where some deleted ACL rules were still active;
*) CRS305: make auto upgrade work;
*) CRS312: fixed 2.5G & 5G modes;
*) CRS312 & CRS326Q: fixed SNMP ifAdminStatus & ifOperStatus;
*) CRS312 & CRS326Q: do not freeze when showing Host tab with no entries;
*) CRS312 & CRS326Q & CRS309: fixed ingress rate limiter;
*) CSS106: added reset-counters to Statistics tab;
*) CSS106: make RSTP work with vlanMode=enabled or vlanMode=strict;
*) CSS106: fixed IGMP, PPPoE & DHCP snooping of VLAN tagged packets;
*) CSS106: make port isolation work when vlanMode=enabled or vlanMode=strict;
*) CRS318fi: make 1G ports link with other routerboards;
*) CRS309: fixed tx flow control;
*) CRS305: fixed traffic forwarding between SFP+ ports;
*) fixed ingress traffic port mirroring on first port;
*) fixed dst. & src. port matcher in ACL;
*) fixed redirect-to in ACL;
*) fixed storm rate limiter on SFP+ ports working in 1G mode;
*) fixed storm rate limiter on 40G links;
*) correctly recognize some copper SFP modules;
*) added name to VLAN entries;
*) fixed VLAN entry management when they were added unordered;
*) fixed IGMP snooping - stop forwarding multicast packets
if there are no more listeners;
*) added support for IGMP fast leave;
*) always forward link local IPv4 & IPV6 packets;
*) fixed password changing on Chrome and IE;
*) do not renew DHCP address and restart RSTP on any System tab change;
*) reset error & histogram counters separately from main ones;
*) report correct ifSpeed & ifHIghSpeed for ports with no active links;
*) fixed crash when receiving jumbo frames on management CPU;

To install SwOS v2.13 on CRS354 family devices, upgrade RouterOS to the latest stable version (6.48.2) and use "/system swos upgrade" command.
 
eddieb
Member Candidate
Member Candidate
Posts: 218
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: SwOS version 2.13 released!

Thu Apr 29, 2021 9:36 am

my 1st attempt to upgrade a RB260GS(CSS106-5G-1S) from 2.12 to 2.13 thru a browser failed.
Upgrade was visible and started, device prompted "upgrade failed" and did reset tot firmware 2.0 and lost normal settings ...
 
eddieb
Member Candidate
Member Candidate
Posts: 218
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: SwOS version 2.13 released!

Thu Apr 29, 2021 11:12 am

uploading firmware to the CSS106 also fails, device reboots into factory firmware.
after powercycle the swith is back in 2.12 ...
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 6843
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: SwOS version 2.13 released!

Thu Apr 29, 2021 1:33 pm

Of course, did you see on the list.? (rhetorical question)
-- fix the unstable SwoS upgrade process
 
biomesh
Member Candidate
Member Candidate
Posts: 257
Joined: Fri Feb 10, 2012 8:25 pm

Re: SwOS version 2.13 released!

Thu Apr 29, 2021 2:40 pm

My upgrade on a css106 from 2.11 went fine. It fixed my issues with rstp on 2.12.

I upgraded over 12 hours ago and have seen no issues.
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 6843
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: SwOS version 2.13 released!

Thu Apr 29, 2021 4:27 pm

My upgrade on a css106 from 2.11 went fine. It fixed my issues with rstp on 2.12.

I upgraded over 12 hours ago and have seen no issues.
Can you buy a lottery ticket for me!!
 
Railander
newbie
Posts: 35
Joined: Thu Jun 16, 2016 11:30 pm

Re: SwOS version 2.13 released!

Thu Apr 29, 2021 4:44 pm

my 1st attempt to upgrade a RB260GS(CSS106-5G-1S) from 2.12 to 2.13 thru a browser failed.
Upgrade was visible and started, device prompted "upgrade failed" and did reset tot firmware 2.0 and lost normal settings ...
we've had this exact problem for ages with these switches, not just this version in particular. sometimes upgrades fail with nothing happening, sometimes it reverts back to 2.0, and sometimes it works.
we just need to keep trying upgrading until it eventually works.
 
huntah
Member Candidate
Member Candidate
Posts: 280
Joined: Tue Sep 09, 2008 3:24 pm

Re: SwOS version 2.13 released!

Thu Apr 29, 2021 8:07 pm

*) CSS106: make RSTP work with vlanMode=enabled or vlanMode=strict;
CSS106 - RSTP issue is resolved

SwOS 2.11 and 2.13 - RSTP finds the correct Root Bridge

Did have a problem with RSTP root bridge pointed at it itself when I had UPLINK port (SFP) set to TAGGED ONLY!
Do not forget to set VLAN Recieve on Uplnik port to ANY

Dont know if this is intentional or a bug! It worked on tagged only frames on version 2.11!?

I also have problems if VLAN1 is not defined.. It calculates wrong ROOT (not itself both nevertheless wrong one!)..
This is also present on hAP-Lite and ROS and VLANs in Switch chip .. If you do not add VLAN1 it does not work!
 
Paternot
Forum Veteran
Forum Veteran
Posts: 831
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: SwOS version 2.13 released!

Fri Apr 30, 2021 12:57 am

uploading firmware to the CSS106 also fails, device reboots into factory firmware.
after powercycle the swith is back in 2.12 ...
Did You get the switch to download and install? Or did You download the file and installed manually? I have one CSS106-1G-4P-1S, and the upgrade went fine. The switch downloaded and installed the update.
 
User avatar
k6ccc
Long time Member
Long time Member
Posts: 673
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: SwOS version 2.13 released!

Fri Apr 30, 2021 7:30 am

Upgraded the following without incident via the "download & upgrade" button:
CRS326-24G-2S+ (running under SwitchOS)
CSS106-5G-1S
CSS106-1G-4P-1S

I'm holding off on my two CSS326-24G-2S+ main switches for a few days to make sure 2.13 is stable.
Last edited by k6ccc on Fri Apr 30, 2021 8:04 am, edited 1 time in total.
 
eddieb
Member Candidate
Member Candidate
Posts: 218
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: SwOS version 2.13 released!

Fri Apr 30, 2021 7:57 am

Did You get the switch to download and install? Or did You download the file and installed manually? I have one CSS106-1G-4P-1S, and the upgrade went fine. The switch downloaded and installed the update.
I tried both ways, downloading thru the switch starts and after a couple of seconds fails ... reboots in FW2.0. after a power cycle it gets back online in 2.12 with the working config ...
I also uploaded the FW file to the switch, same result.
 
EdPa
MikroTik Support
MikroTik Support
Posts: 87
Joined: Fri Sep 15, 2017 10:05 am
Location: Riga
Contact:

Re: SwOS version 2.13 released!

Fri Apr 30, 2021 10:10 am

If the upgrade fails on CSS106, try toggling the RSTP setting on the port you are connected to. If the switch still boots into an older (primary) version, try manually uploading the file in the "Upgrade" page. If the CSS106 still refuses to upgrade, follow this article - Cannot upgrade SwOS.
 
eddieb
Member Candidate
Member Candidate
Posts: 218
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: SwOS version 2.13 released!

Fri Apr 30, 2021 10:32 am

tnx for the suggestion @EdPa

the switch was running rstp and I disabled it. same result. The upload process starts and fails. devices reboots into FW2.0.
after power cycle it is back in 2.12 and running.
I tried to manually upload the new fw, same result. device reboots into FW2.0 ...
after power cycle it is back in 2.12 and running.

I can not access all switches power-supplies remotely, so doing the full reset thing will have to wait ...
 
bda
Member Candidate
Member Candidate
Posts: 188
Joined: Fri Sep 03, 2010 11:07 am
Location: Russia,Moscow

Re: SwOS version 2.13 released!

Fri Apr 30, 2021 2:24 pm

Problem with RSTP in vlan-strict, vlan-enabled - still exist

Update: RSTP working only with vlan-receive = any on uplink port. Earlier in 2.11, RSTP worked with vlan-receive = only-tagged.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1377
Joined: Mon Apr 08, 2019 1:16 am

Re: SwOS version 2.13 released!

Fri Apr 30, 2021 3:29 pm

uploading firmware to the CSS106 also fails, device reboots into factory firmware.
after powercycle the swith is back in 2.12 ...
Did You get the switch to download and install? Or did You download the file and installed manually? I have one CSS106-1G-4P-1S, and the upgrade went fine. The switch downloaded and installed the update.
Remember that CSS106 with SwOS cannot connect to the internet. There is no gateway/router defined. It cannot be set.
The IP routing mechanism is: answering to the IP address by using the source MAC of the request received. SwOS can answer an IP connection, but cannot initiate an IP connection.
It looks like as if SwOS is checking for an update, but it actually is your browser doing that. So don't move away from that browser page while download&upgrade.

The path to the CSS106 in my case is over a MT wifi bridge connection (AP bridge /-/ station bridge powered by the CSS106) and for one or other reason the download&upgrade failed.
Lost connection to the CSS106 after 3th attempt and had to physically power off/on to gain access again. Nothings seems to have changed.

EDIT.

Upgrade keeps failing.
- Manual download ... same problem
- local attached PC (independent from the power loss at the "station bridge" link) ... same problem
- disabled Windows defender ... same problem

What surprised me was that Windows 10 / Chrome browser had problems downloading the file. The download never completes.
Disabling the firewall (Windows defender) gave complete downloads. (no complains in windows)
By comparing the 2 files, they are identical. Upgrade problem persists.
Klembord-2.jpg
What is the meaning of "new CSS106" in the download page ???? Can we still find 2.12 SwOS for download?
You do not have the required permissions to view the files attached to this post.
 
han
just joined
Posts: 9
Joined: Fri Oct 30, 2020 11:30 am

Re: SwOS version 2.13 released!

Sat May 01, 2021 9:24 am

Upgrading my RB260GS (CSS106-5G-1S) went fine (from 2.12 and using Upgrade tab in SwOS).
 
eddieb
Member Candidate
Member Candidate
Posts: 218
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: SwOS version 2.13 released!

Sat May 01, 2021 9:40 am

Let me explain a little bit more ...
I am running vlan 99 on my uplink for management traffic. So the switches have an address in my management vlan.
I tried to upgrade from a W10 laptop connected to that vlan. The default gateway in that vlan has internet access.
Normal ROS devices can upgrade directly in that vlan.

Tried to upgrade SWOS within a browser, it says version 2.13 found, starts the upgrade procedure and fails. reboots in FW 2.0, need power-cycle to get back in FW 2.12 ...
Tried to upload the 2.13 to the switch, after uploading pressing the upgrade button starts somtihing and fails. reboots in FW 2.0, need power-cycle to get back in FW 2.12 ...

so far no luck
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1377
Joined: Mon Apr 08, 2019 1:16 am

Re: SwOS version 2.13 released!

Sat May 01, 2021 1:04 pm

I had the same experience. In the second attempt (manually downloaded file) the browser still mentioned "Waiting for upgrade.mikrotik.com" after pressing the upgrade button. The file was already local, and the reference to it was entered, so what is the connection to upgrade.mikrotik.com for ? The file field changed in that "sad looking square emoi".
Klembord-2.jpg
Klembord-3.jpg
You do not have the required permissions to view the files attached to this post.
 
User avatar
k6ccc
Long time Member
Long time Member
Posts: 673
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: SwOS version 2.13 released!

Sat May 01, 2021 8:11 pm

After running 2.13 on three of my minor switches for the past day and a half, I just updated my two main CSS326-24G-2S+ via the "Download & Upgrade" button. Both took the upgrade just fine with only one or two pings to 8.8.8.8 dropped on each one.
Everything appears to be working fine.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1377
Joined: Mon Apr 08, 2019 1:16 am

Re: SwOS version 2.13 released!

Sun May 02, 2021 12:54 am

In SwOS 2.12 on the Upgrade tab page the buttons "Download & Upgrade" and the "Upgrade" button seem to execute exactly the same code.
(Where the "Upgrade" button is supposed to use the local file, as indicated with "File for Upgrade", it just seems to ignore this and tries to download just as the other button)

As the "Download & Upgrade" fails, so does the "Upgrade" button.

In a standalone and an Internet-disconnected scenario for the Upgrade, with already downloaded firmware, there is no progress with the "Upgrade" button, as the browser keeps waiting for http://upgrade.mikrotik.com. Something in "engine.js" or identical definitions in the html page?
<a class="btn" draggable="false">Download &amp; Upgrade</a>
<a class="btn" draggable="false">Upgrade</a>
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1377
Joined: Mon Apr 08, 2019 1:16 am

Re: SwOS version 2.13 released!

Sun May 02, 2021 7:33 pm

So we can add this one: for upgrading from 2.12 to 2.13 make sure to turn RSTP on. With RSTP off the upgrade fails.
On-line "download&upgrade" worked fine with RSTP turned on.

viewtopic.php?f=21&t=163657&p=848903#p819200


I didn't care to do any test about manual download & upgrade.
 
User avatar
k6ccc
Long time Member
Long time Member
Posts: 673
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: SwOS version 2.13 released!

Sun May 02, 2021 8:47 pm

Of my two CSS106 switches (one CSS106-5G-1S, and one CSS106-1G-4P-1S), the POE version has RSTP turned on (only because it defaulted that way and I never turned it off) and the non-POE version has RSTP turned off for all ports - neither needs RSTP. Both upgraded just fine from 2.12 to 2.13 via the "Download & Upgrade" button. Additionally, neither of my two CSS326-24G-2S+, nor the one CRS326-24G-2S+ (running SwitchOS) have RSTP turned on for any ports. All upgraded fine.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 1377
Joined: Mon Apr 08, 2019 1:16 am

Re: SwOS version 2.13 released!

Mon May 03, 2021 12:59 am

It could all be time-dependent, as the problem was visible in the download or end of download , after contacting "upgrade.mikrotik.com". Even the local "Upgrade" button contacted the server and failed.
There is indeed almost a day difference between the trial to upgrade. So maybe any setting of RSTP did not even matter. It was just a hint given earlier in the 2.12 posts, and also here in the 2.13 posts by @EdPa (Mikrotik Support). Very bizar to many that the upgrade would depend on this.

I did not test with RSTP off, just before doing what the hints told me to try. So it remains a mystery what made it work and this could be a problem. I will not take the risk to upgrade any remote RB260GSP's as it needs a physical action if it fails.
 
eddieb
Member Candidate
Member Candidate
Posts: 218
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: SwOS version 2.13 released!

Mon May 03, 2021 10:47 am

stil no luck here...
I tried with and without rstp enabled.
right after power cycling, always the same result, the new version is detected and the process seems to start.
Failing after a couple of seconds ... (into FW2.0) and need to power-cycle to get back into FW2.12
 
User avatar
elel
just joined
Posts: 5
Joined: Thu Jun 11, 2020 11:40 am

Re: SwOS version 2.13 released!

Mon May 03, 2021 12:05 pm

Upgrading CRS354-48G-4S+2Q+ to SWOS went smooth.
The procedure as indicated in opening post. First upgrade to ROS 6.48.2 and from there upgrade to SWOS 2.13.
The only thing I noticed was fans working a bit more than in ROS.
 
eddieb
Member Candidate
Member Candidate
Posts: 218
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: SwOS version 2.13 released!

Mon May 03, 2021 6:18 pm

I managed to get my 4 CSS106 switches to upgrade to FW2.13 ...

the culprit seems that (at least mine) don't like to get upgraded while having allowing access only from VLAN 99 ...
during upgrade it somewhere looses the VLAN config and it wants to connect over default vlan ( 1 ) ...

disabling the access only from VLAN 99 made the upgrade working.
After rebooting and reenabling access only from VLAN 99 I am running latest on all switches.
 
User avatar
k6ccc
Long time Member
Long time Member
Posts: 673
Joined: Fri May 13, 2016 12:01 am
Location: Glendora, CA, USA (near Los Angeles)

Re: SwOS version 2.13 released!

Tue May 04, 2021 5:59 pm

I managed to get my 4 CSS106 switches to upgrade to FW2.13 ...

the culprit seems that (at least mine) don't like to get upgraded while having allowing access only from VLAN 99 ...
during upgrade it somewhere looses the VLAN config and it wants to connect over default vlan ( 1 ) ...

disabling the access only from VLAN 99 made the upgrade working.
After rebooting and reenabling access only from VLAN 99 I am running latest on all switches.
Beats me. All of my switches are set to allow access only on VLAN 201, and a limited number of ports.
 
svmk
just joined
Posts: 5
Joined: Mon Mar 26, 2018 1:52 am

Re: SwOS version 2.13 released!

Wed May 05, 2021 10:30 am

Successfully upgraded five CSS106-5G-1S in our network (via VPN remote access to our network). But during the update process there are problems:
1. Using Firefox could not update (including manual update)
2. Using Chrome I updated it, but in four cases out of five the firmware was updated only after 3-5 clicks Upgrade tab. On one device, the version changed first to 2.7p, and after another click - to 2.13
Management on all devices via SFP port untagged.
 
jefftee
Posts: 0
Joined: Thu Aug 27, 2020 8:43 am

Re: SwOS version 2.13 released!

Wed May 05, 2021 9:39 pm

I just upgraded my CRS309 to SWOS v2.13 and immediately running into issues with the GUI with "ERROR: Lost Connection" messages every few seconds as well as instability with all ports on the switch becoming unavailable for a few seconds and then coming back to life...

I've got a support request in for how to downgrade to v2.12.
 
User avatar
mbelanger
just joined
Posts: 13
Joined: Tue Jan 26, 2021 12:51 pm
Location: Bay Area, CA

Re: SwOS version 2.13 released!

Thu May 06, 2021 3:15 am

Found minor bug in 2.13 on CSS610-8G-2S+. The Identity field under the System tab is limited to 16 characters and truncates without warning or updating page without reload.

Wiki documentation also doesn't describe.

How do I go about filing a bug report?

Who is online

Users browsing this forum: No registered users and 15 guests