Community discussions

 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

6.33.2 version is released!

Tue Dec 01, 2015 10:16 am

We have released 6.33.2 version. Version includes only bug fixes compared with 6.33.1 and does not include new features. If you need new features, then test 6.34rc versions.

Version at the moment is released in current channel!

What's new in 6.33.2 (2015-Nov-27 15:00):

*) bridge - fixed power-cycle-ping for bridge ports (was affecting all bridge);
*) ethernet - fixed link resetting on power-cycle-ping value change;
*) ppp - fixed dynamic filter rule adding on some firewall filter configurations;
*) pppoe - improved MTU discovery compatibility with other vendors;
*) pppoe - made MTU discovery more robust;
*) pppoe - fixed compliance to RFC4638 (MTU larger than 1488) again;
*) vrrp - fix arp=reply-only;
*) vrrp - do not warn about version mismatch if VRID does not match;
*) vrrp - allow VRRP to work behind firewall and NAT rules;
*) vrrp - fixed on-backup script;
*) dhcpv4 server - fix kernel crash when restoring lease with queue for non-existent server;
*) dhcpv4-client - support /32 address assignment;
*) ssh - fix key exchange when first kex packet follows.
 
freemannnn
Long time Member
Long time Member
Posts: 669
Joined: Sun Oct 13, 2013 7:29 pm

Re: 6.33.2 version is released!

Tue Dec 01, 2015 10:21 am

so the 1492 mru-mtu pppoe bug in 6.33.1 is fixed?
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.33.2 version is released!

Tue Dec 01, 2015 10:24 am

freemannnn - Yes. It is fixed.
 
Trema
newbie
Posts: 36
Joined: Tue May 20, 2014 10:21 am
Location: The Netherlands

Re: 6.33.2 version is released!

Tue Dec 01, 2015 12:27 pm

Just a reminder that the export is still broken.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: 6.33.2 version is released!

Tue Dec 01, 2015 2:06 pm

Just a reminder that the export is still broken.
what's in export file?
[admin@Neighbours] > export file=test
[admin@Neighbours] > export file=test-v verbose 
[admin@Neighbours] > file print where name~"test"
 # NAME                    TYPE                         SIZE CREATION-TIME       
 0 test.rsc                script                    15.4KiB dec/01/2015 15:04:18
 1 test-v.rsc              script                    74.6KiB dec/01/2015 15:04:28
[admin@Neighbours] > :put [sys resource get version ]
6.33.2 (stable)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
Trema
newbie
Posts: 36
Joined: Tue May 20, 2014 10:21 am
Location: The Netherlands

Re: 6.33.2 version is released!

Tue Dec 01, 2015 2:26 pm

Arghh. My bad. I did /system export etc.
Should of course have been: /export etc.
My apologies to all.
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: 6.33.2 version samba crash routerboard

Tue Dec 01, 2015 2:52 pm

6.33.2 samba error, click direct link file in SMB routerboard freezes (bridge all interfaces, mipsle) power off/on repeated test freeze (Google translator)
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.33.2 version is released!

Tue Dec 01, 2015 4:09 pm

napismizpravu - I have connected to SMB, created file, deleted file, moved file and everything works correctly. Please write to support and explain exactly what you have done to crash SMB. Also send supout file.
 
User avatar
juanvi
Member Candidate
Member Candidate
Posts: 164
Joined: Mon May 05, 2014 6:55 pm
Location: SPAIN

Re: 6.33.2 version is released!

Tue Dec 01, 2015 4:31 pm

Can someone explain this? Updated CAP and CAPs and there is nothing new in sign-up form.
*) userman - added phone number support to signup form;

Thanks in advance
¡vʞvdnX puv ···SOɹǝʇnoɹ ʞıʇoɹʞıW oʇ sʞuvHʇ
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: 6.33.2 samba

Tue Dec 01, 2015 10:43 pm

napismizpravu - I have connected to SMB, created file, deleted file, moved file and everything works correctly. Please write to support and explain exactly what you have done to crash SMB. Also send supout file.
Why send supout? Simple setup RB133> IP assigned Bridge, all port add Bridge, + Wireless config,+ copy samba files


/interface bridge settings
set allow-fast-path=yes use-ip-firewall=no use-ip-firewall-for-pppoe=no use-ip-firewall-for-vlan=no

/ip smb
set allow-guests=yes comment=iptv domain=WORKGROUP enabled=yes interfaces=all
/ip smb shares
set [ find default=yes ] comment="default share" directory=/pub disabled=no max-sessions=10 name=pub
add comment="iptv vlc playlist" directory=/iptv disabled=no max-sessions=10 name=iptv
/ip smb users
set [ find default=yes ] disabled=no name=guest password="" read-only=yes
add disabled=no name=smb password=0123 read-only=no
create errors, crash RouterOS:
Google Chrome x64 (Windows 10) open link: \\192.168.1.22/pub/internet.html

RB133 crash (6.33.2)
RB433UAH (6.34rc11) works, no error
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.33.2 version is released!

Wed Dec 02, 2015 8:21 am

juanvi - Here is sign-up form with phone number
You do not have the required permissions to view the files attached to this post.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.33.2 version is released!

Wed Dec 02, 2015 8:47 am

napismizpravu - I have managed to reproduce some kind of SMB crash and it is now reported to our developers.
 
User avatar
juanvi
Member Candidate
Member Candidate
Posts: 164
Joined: Mon May 05, 2014 6:55 pm
Location: SPAIN

Re: 6.33.2 version is released!

Wed Dec 02, 2015 10:32 am

Must delete actual umfiles folder? or doing extra steps for enabling? Can't see phone field after upgrade and reboot.
juanvi - Here is sign-up form with phone number
¡vʞvdnX puv ···SOɹǝʇnoɹ ʞıʇoɹʞıW oʇ sʞuvHʇ
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.33.2 version is released!

Wed Dec 02, 2015 10:55 am

juanvi - Please first test with different browser and/or clear cache.
 
igb
just joined
Posts: 7
Joined: Fri Aug 29, 2014 7:05 pm

Re: 6.33.2 version is released!

Wed Dec 02, 2015 11:08 am

As a general point, 6.33.2 still for me has wildly incorrect dates on graphs within webfig (2151 to 2152). This has been the case for, oh, ages: in fact, I don't think I've ever had graphs this isn't true of.

"Monthly" is misspelt as "Montly" in the same screen.

Image
 
User avatar
juanvi
Member Candidate
Member Candidate
Posts: 164
Joined: Mon May 05, 2014 6:55 pm
Location: SPAIN

Re: 6.33.2 version is released!

Wed Dec 02, 2015 11:14 am

Tested and does not work. We have a modified sign-up page with our logo and favicon. Could be this?
juanvi - Please first test with different browser and/or clear cache.
¡vʞvdnX puv ···SOɹǝʇnoɹ ʞıʇoɹʞıW oʇ sʞuvHʇ
 
User avatar
basd
just joined
Posts: 6
Joined: Mon Sep 14, 2015 11:37 am

Re: 6.33.2 version is released!

Wed Dec 02, 2015 2:09 pm

After the upgrade my site to site tunnels stoped working.

I can ping but but thats all.
Can't make http or ssh sesion over the tunnel any more whats wrong ?
With kind regards,

Bas van den Dikkenberg
 
shifto
just joined
Posts: 13
Joined: Wed Jul 15, 2015 1:58 am

Re: 6.33.2 version is released!

Wed Dec 02, 2015 4:21 pm

Thanks for this bugfix, last release was dramatic with my PPPOE connection.
 
User avatar
Alessio Garavano
Member
Member
Posts: 304
Joined: Sat May 29, 2004 12:49 am
Location: Corrientes, Argentina
Contact:

Re: 6.33.2 version is released!

Wed Dec 02, 2015 8:09 pm

I CAN´T BELIEVE!!! tested on 2 NetMetal and continuously re.connect the ethernet... i tried in auto-negotiation and all the combinations of speed & duplex and nothing... i think the problem is in some bridge ping test or something about this... Any temporal workaround to enter the RB and fix? thanks!
Alessio Garavano
http://www.isparg.com.ar
 
spenczek
just joined
Posts: 2
Joined: Sat Jan 31, 2015 5:38 pm

Re: 6.33.2 version is released!

Wed Dec 02, 2015 8:20 pm

There is a problem with ethernet and 6.33.2 With 2 new RB911G-5HPacD I have tested, I could not connect at 100Mb with any device. 1G seems to work. Downgrade to 6.33 solves the problem.

Staszek
 
User avatar
Alessio Garavano
Member
Member
Posts: 304
Joined: Sat May 29, 2004 12:49 am
Location: Corrientes, Argentina
Contact:

Re: 6.33.2 version is released!

Wed Dec 02, 2015 8:36 pm

Yes... we need to down 1 of the Netmetal of the tower and now connected direct to the laptop at 1Gbps are connected perfectly...
Alessio Garavano
http://www.isparg.com.ar
 
User avatar
Alessio Garavano
Member
Member
Posts: 304
Joined: Sat May 29, 2004 12:49 am
Location: Corrientes, Argentina
Contact:

Re: 6.33.2 version is released!

Wed Dec 02, 2015 8:44 pm

Stable version with this problem??? mamita!
Alessio Garavano
http://www.isparg.com.ar
 
pbr3000
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Fri Jan 08, 2010 7:31 am

Re: 6.33.2 version is released!

Wed Dec 02, 2015 10:17 pm

There is a problem with ethernet and 6.33.2 With 2 new RB911G-5HPacD I have tested, I could not connect at 100Mb with any device. 1G seems to work. Downgrade to 6.33 solves the problem.

Staszek
I can confirm this too. We lost access to two netmetal on upgrade yesterday because the ethernet port where they was connected is 10/100mbps.
 
jahill70
just joined
Posts: 5
Joined: Thu Dec 03, 2015 3:38 am

Re: 6.33.2 version is released!

Thu Dec 03, 2015 3:46 am

I found the stable 6.33.2 broke PPPOE with my ISP reporting the wrong username/password combination was being used. The pre-release version 6.34 worked fine before moving to the 'stable' version and, moving back to the release candidate, all works fine again (re-entering the username/passwork combo made no difference). Of course it's not easy updating the firmware when your router can't connect to the internet!

Mentioning it here to try and prevent the bug re-appearing at a later date.

(I'm guessing this isn't the 100Mb ethernet connection bug mentioned above as the router appears to be able to talk to the modems, but not authenticate).
 
pbr3000
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Fri Jan 08, 2010 7:31 am

Re: 6.33.2 version is released!

Thu Dec 03, 2015 4:09 am

I saw the 100mbps ethernet bug in netmetal's only, until now... Email with supout already sent to support team.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.33.2 version is released!

Thu Dec 03, 2015 8:27 am

We are sorry for any inconvenience. After your reports we have managed to reproduce issue with ethernet link and are working on a fix.
 
PrSliCa
newbie
Posts: 27
Joined: Sun Feb 18, 2007 2:08 pm

Re: 6.33.2 version is released!

Thu Dec 03, 2015 8:59 am

We have found that SNMP is not working on 6.33.2 x86 after upgrade from 6.20.
optika-day.png
You do not have the required permissions to view the files attached to this post.
 
bcall
just joined
Posts: 15
Joined: Thu Dec 03, 2015 8:52 am

Re: 6.33.2 version is released!

Thu Dec 03, 2015 9:04 am

I upgraded a RB750gl from 6.33.1 was met with a semi-dead router. Upon reboot, the link lights flashed for a few seconds and then turned off entirely. Reseating the power had the same effect (tried multiple times). Unlike some other folks here, the devices in question were all 1G capable devices, so I don't believe I hit the 10/100 bug.

I was eventually able to reset the config to defaults and restore an outdated backup from mid-November. As soon as the router rebooted, it died again the same way.

After a few more resets to make sure I wasn't missing something stupid, I reset it again and downgraded it to 6.33.1. Once it was stable on 6.33.1 with a default config, I re-applied my backup.

It's back to normal now, but 6.33.2 definitely broke it badly.

I'm not looking for support, I just wanted to let you know it happened :)
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.33.2 version is released!

Thu Dec 03, 2015 9:11 am

jahill70 - Please run this command on your device:
"/system logging add topics=pppoe,debug"

After that try to connect again.

Now generate supout file and send it to support@mikrotik.com
http://wiki.mikrotik.com/wiki/Manual:Su ... utput_File
 
jmontero
just joined
Posts: 20
Joined: Fri May 22, 2015 8:58 pm

Re: 6.33.2 version is released!

Thu Dec 03, 2015 12:38 pm

Here 2 x Netmetal Ethernet link problem crashed!!

The first one I thought was my fault. The second time I came here... Luckly they were updated at the workshop before mounting into the tower....

Really a Stable version with this kind of bug?? :shock: Kind of joke..

Waiting for a bug-fix asap....
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.33.2 version is released!

Thu Dec 03, 2015 12:42 pm

Here 2 x Netmetal Ethernet link problem crashed!!

The first one I thought was my fault. The second time I came here... Luckly they were updated at the workshop before mounting into the tower....

Really a Stable version with this kind of bug?? :shock: Kind of joke..

Waiting for a bug-fix asap....
Please contact support with the output files, so we can see what causes it. It could be hardware related or something else too.
No answer to your question? How to write posts
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1219
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: 6.33.2 version is released!

Thu Dec 03, 2015 4:01 pm

We are sorry for any inconvenience. After your reports we have managed to reproduce issue with ethernet link and are working on a fix.
Please contact support with the output files, so we can see what causes it. It could be hardware related or something else too.
Isn't there a contradiction in those 2 statements somehow?
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.33.2 version is released!

Thu Dec 03, 2015 4:08 pm

We are sorry for any inconvenience. After your reports we have managed to reproduce issue with ethernet link and are working on a fix.
Please contact support with the output files, so we can see what causes it. It could be hardware related or something else too.
Isn't there a contradiction in those 2 statements somehow?
I replied to a much later post. It is unclear if that is even related. In any case, keep sending files to be sure
No answer to your question? How to write posts
 
User avatar
Alessio Garavano
Member
Member
Posts: 304
Joined: Sat May 29, 2004 12:49 am
Location: Corrientes, Argentina
Contact:

Re: 6.33.2 version is released!

Thu Dec 03, 2015 4:24 pm

IMHO... I think, to avoid more problems, you need to remove the 6.33.2 from the Current channel on the web and System Check-for-updates...
Alessio Garavano
http://www.isparg.com.ar
 
kentaur
just joined
Posts: 3
Joined: Thu Dec 03, 2015 5:16 pm

Re: 6.33.2 version is released!

Thu Dec 03, 2015 5:34 pm

I second that, please remove it from upgrade channel.
I have one dead STX G-5HPacD (SN: 4F7004980B72) because of the 6.33.2, ehternet port doesn't activate so I can't revive it with netinstall. I'm open to suggestions.
 
User avatar
Alessio Garavano
Member
Member
Posts: 304
Joined: Sat May 29, 2004 12:49 am
Location: Corrientes, Argentina
Contact:

Re: 6.33.2 version is released!

Thu Dec 03, 2015 5:43 pm

Hi Kentaur... i think the only option is by Netinstall... hold the RESET button when starting it until the LED light turns off, and the device will start to look for a Netinstall servers...
Alessio Garavano
http://www.isparg.com.ar
 
hzdrus
newbie
Posts: 40
Joined: Mon May 14, 2012 3:58 pm

Re: 6.33.2 version is released!

Thu Dec 03, 2015 6:26 pm

It seems that 6.33 has a regression in EoIP/VPLS performance. Details are in http://forum.mikrotik.com/viewtopic.php ... 79#p510079
 
jahill70
just joined
Posts: 5
Joined: Thu Dec 03, 2015 3:38 am

Re: 6.33.2 version is released!

Thu Dec 03, 2015 6:28 pm

jahill70 - Please run this command on your device:
"/system logging add topics=pppoe,debug"

After that try to connect again.

Now generate supout file and send it to support@mikrotik.com
http://wiki.mikrotik.com/wiki/Manual:Su ... utput_File
As mentioned above, I've moved back to the current rc mentioned above and all is well.

I'm afraid I'm not really in a position to retest the version that broke PPPOE as it took a while to to get the per-packet load sharing config working again (a reset was required to connect the Mikrotik to an alternative network to pick up the alternative firmware, then a complete reconfiguration as the original config file wouldn't load)!
 
krugmartin
Trainer
Trainer
Posts: 5
Joined: Sat May 27, 2006 3:23 pm

Re: 6.33.2 version is released!

Thu Dec 03, 2015 7:01 pm

There is a problem with a Gigabit devices powered with 100Mbps POE or POE switch ! it should be fixed in the 6.34rc release

beware to downgrade ! Mine RB911's failed after downgrade to 6.30 and I tried another to 6.28 booth routers are dead.
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2293
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: 6.33.2 version is released!

Thu Dec 03, 2015 8:30 pm

Remove 6.33.2 from download page until 6.33.3 is released
LAN, FTTx, Wireless. ISP operator
 
digicomtech
Frequent Visitor
Frequent Visitor
Posts: 75
Joined: Fri Apr 20, 2007 5:03 pm
Location: Alma, Qc, Canada
Contact:

Re: 6.33.2 version is released!

Thu Dec 03, 2015 10:01 pm

Also, Ethernet synchronisation problem on a Netmetal with a RB750UP.
I had to remove auto-negotiation on both side to make them link again...

Very annoying on a remote production site...

I had upgrade firmware from 3.22 to 3.24 and reactivate auto-negotiation now works !!!

Please made more test before release stable,
Michael
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: 6.33.2 version is released!

Fri Dec 04, 2015 10:40 am

Who is online

Users browsing this forum: No registered users and 8 guests