Page 1 of 1

6.33.2 version is released!

Posted: Tue Dec 01, 2015 10:16 am
by strods
We have released 6.33.2 version. Version includes only bug fixes compared with 6.33.1 and does not include new features. If you need new features, then test 6.34rc versions.

Version at the moment is released in current channel!

What's new in 6.33.2 (2015-Nov-27 15:00):

*) bridge - fixed power-cycle-ping for bridge ports (was affecting all bridge);
*) ethernet - fixed link resetting on power-cycle-ping value change;
*) ppp - fixed dynamic filter rule adding on some firewall filter configurations;
*) pppoe - improved MTU discovery compatibility with other vendors;
*) pppoe - made MTU discovery more robust;
*) pppoe - fixed compliance to RFC4638 (MTU larger than 1488) again;
*) vrrp - fix arp=reply-only;
*) vrrp - do not warn about version mismatch if VRID does not match;
*) vrrp - allow VRRP to work behind firewall and NAT rules;
*) vrrp - fixed on-backup script;
*) dhcpv4 server - fix kernel crash when restoring lease with queue for non-existent server;
*) dhcpv4-client - support /32 address assignment;
*) ssh - fix key exchange when first kex packet follows.

Re: 6.33.2 version is released!

Posted: Tue Dec 01, 2015 10:21 am
by freemannnn
so the 1492 mru-mtu pppoe bug in 6.33.1 is fixed?

Re: 6.33.2 version is released!

Posted: Tue Dec 01, 2015 10:24 am
by strods
freemannnn - Yes. It is fixed.

Re: 6.33.2 version is released!

Posted: Tue Dec 01, 2015 12:27 pm
by Trema
Just a reminder that the export is still broken.

Re: 6.33.2 version is released!

Posted: Tue Dec 01, 2015 2:06 pm
by Chupaka
Just a reminder that the export is still broken.
what's in export file?
[admin@Neighbours] > export file=test
[admin@Neighbours] > export file=test-v verbose 
[admin@Neighbours] > file print where name~"test"
 # NAME                    TYPE                         SIZE CREATION-TIME       
 0 test.rsc                script                    15.4KiB dec/01/2015 15:04:18
 1 test-v.rsc              script                    74.6KiB dec/01/2015 15:04:28
[admin@Neighbours] > :put [sys resource get version ]
6.33.2 (stable)

Re: 6.33.2 version is released!

Posted: Tue Dec 01, 2015 2:26 pm
by Trema
Arghh. My bad. I did /system export etc.
Should of course have been: /export etc.
My apologies to all.

Re: 6.33.2 version samba crash routerboard

Posted: Tue Dec 01, 2015 2:52 pm
by napismizpravu
6.33.2 samba error, click direct link file in SMB routerboard freezes (bridge all interfaces, mipsle) power off/on repeated test freeze (Google translator)

Re: 6.33.2 version is released!

Posted: Tue Dec 01, 2015 4:09 pm
by strods
napismizpravu - I have connected to SMB, created file, deleted file, moved file and everything works correctly. Please write to support and explain exactly what you have done to crash SMB. Also send supout file.

Re: 6.33.2 version is released!

Posted: Tue Dec 01, 2015 4:31 pm
by juanvi
Can someone explain this? Updated CAP and CAPs and there is nothing new in sign-up form.
*) userman - added phone number support to signup form;

Thanks in advance

Re: 6.33.2 samba

Posted: Tue Dec 01, 2015 10:43 pm
by napismizpravu
napismizpravu - I have connected to SMB, created file, deleted file, moved file and everything works correctly. Please write to support and explain exactly what you have done to crash SMB. Also send supout file.
Why send supout? Simple setup RB133> IP assigned Bridge, all port add Bridge, + Wireless config,+ copy samba files


/interface bridge settings
set allow-fast-path=yes use-ip-firewall=no use-ip-firewall-for-pppoe=no use-ip-firewall-for-vlan=no

/ip smb
set allow-guests=yes comment=iptv domain=WORKGROUP enabled=yes interfaces=all
/ip smb shares
set [ find default=yes ] comment="default share" directory=/pub disabled=no max-sessions=10 name=pub
add comment="iptv vlc playlist" directory=/iptv disabled=no max-sessions=10 name=iptv
/ip smb users
set [ find default=yes ] disabled=no name=guest password="" read-only=yes
add disabled=no name=smb password=0123 read-only=no
create errors, crash RouterOS:
Google Chrome x64 (Windows 10) open link: \\192.168.1.22/pub/internet.html

RB133 crash (6.33.2)
RB433UAH (6.34rc11) works, no error

Re: 6.33.2 version is released!

Posted: Wed Dec 02, 2015 8:21 am
by strods
juanvi - Here is sign-up form with phone number

Re: 6.33.2 version is released!

Posted: Wed Dec 02, 2015 8:47 am
by strods
napismizpravu - I have managed to reproduce some kind of SMB crash and it is now reported to our developers.

Re: 6.33.2 version is released!

Posted: Wed Dec 02, 2015 10:32 am
by juanvi
Must delete actual umfiles folder? or doing extra steps for enabling? Can't see phone field after upgrade and reboot.
juanvi - Here is sign-up form with phone number

Re: 6.33.2 version is released!

Posted: Wed Dec 02, 2015 10:55 am
by strods
juanvi - Please first test with different browser and/or clear cache.

Re: 6.33.2 version is released!

Posted: Wed Dec 02, 2015 11:08 am
by igb
As a general point, 6.33.2 still for me has wildly incorrect dates on graphs within webfig (2151 to 2152). This has been the case for, oh, ages: in fact, I don't think I've ever had graphs this isn't true of.

"Monthly" is misspelt as "Montly" in the same screen.

Image

Re: 6.33.2 version is released!

Posted: Wed Dec 02, 2015 11:14 am
by juanvi
Tested and does not work. We have a modified sign-up page with our logo and favicon. Could be this?
juanvi - Please first test with different browser and/or clear cache.

Re: 6.33.2 version is released!

Posted: Wed Dec 02, 2015 2:09 pm
by basd
After the upgrade my site to site tunnels stoped working.

I can ping but but thats all.
Can't make http or ssh sesion over the tunnel any more whats wrong ?

Re: 6.33.2 version is released!

Posted: Wed Dec 02, 2015 4:21 pm
by shifto
Thanks for this bugfix, last release was dramatic with my PPPOE connection.

Re: 6.33.2 version is released!

Posted: Wed Dec 02, 2015 8:09 pm
by Alessio Garavano
I CANĀ“T BELIEVE!!! tested on 2 NetMetal and continuously re.connect the ethernet... i tried in auto-negotiation and all the combinations of speed & duplex and nothing... i think the problem is in some bridge ping test or something about this... Any temporal workaround to enter the RB and fix? thanks!

Re: 6.33.2 version is released!

Posted: Wed Dec 02, 2015 8:20 pm
by spenczek
There is a problem with ethernet and 6.33.2 With 2 new RB911G-5HPacD I have tested, I could not connect at 100Mb with any device. 1G seems to work. Downgrade to 6.33 solves the problem.

Staszek

Re: 6.33.2 version is released!

Posted: Wed Dec 02, 2015 8:36 pm
by Alessio Garavano
Yes... we need to down 1 of the Netmetal of the tower and now connected direct to the laptop at 1Gbps are connected perfectly...

Re: 6.33.2 version is released!

Posted: Wed Dec 02, 2015 8:44 pm
by Alessio Garavano
Stable version with this problem??? mamita!

Re: 6.33.2 version is released!

Posted: Wed Dec 02, 2015 10:17 pm
by pbr3000
There is a problem with ethernet and 6.33.2 With 2 new RB911G-5HPacD I have tested, I could not connect at 100Mb with any device. 1G seems to work. Downgrade to 6.33 solves the problem.

Staszek
I can confirm this too. We lost access to two netmetal on upgrade yesterday because the ethernet port where they was connected is 10/100mbps.

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 3:46 am
by jahill70
I found the stable 6.33.2 broke PPPOE with my ISP reporting the wrong username/password combination was being used. The pre-release version 6.34 worked fine before moving to the 'stable' version and, moving back to the release candidate, all works fine again (re-entering the username/passwork combo made no difference). Of course it's not easy updating the firmware when your router can't connect to the internet!

Mentioning it here to try and prevent the bug re-appearing at a later date.

(I'm guessing this isn't the 100Mb ethernet connection bug mentioned above as the router appears to be able to talk to the modems, but not authenticate).

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 4:09 am
by pbr3000
I saw the 100mbps ethernet bug in netmetal's only, until now... Email with supout already sent to support team.

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 8:27 am
by strods
We are sorry for any inconvenience. After your reports we have managed to reproduce issue with ethernet link and are working on a fix.

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 8:59 am
by PrSliCa
We have found that SNMP is not working on 6.33.2 x86 after upgrade from 6.20.
optika-day.png

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 9:04 am
by bcall
I upgraded a RB750gl from 6.33.1 was met with a semi-dead router. Upon reboot, the link lights flashed for a few seconds and then turned off entirely. Reseating the power had the same effect (tried multiple times). Unlike some other folks here, the devices in question were all 1G capable devices, so I don't believe I hit the 10/100 bug.

I was eventually able to reset the config to defaults and restore an outdated backup from mid-November. As soon as the router rebooted, it died again the same way.

After a few more resets to make sure I wasn't missing something stupid, I reset it again and downgraded it to 6.33.1. Once it was stable on 6.33.1 with a default config, I re-applied my backup.

It's back to normal now, but 6.33.2 definitely broke it badly.

I'm not looking for support, I just wanted to let you know it happened :)

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 9:11 am
by strods
jahill70 - Please run this command on your device:
"/system logging add topics=pppoe,debug"

After that try to connect again.

Now generate supout file and send it to support@mikrotik.com
http://wiki.mikrotik.com/wiki/Manual:Su ... utput_File

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 12:38 pm
by jmontero
Here 2 x Netmetal Ethernet link problem crashed!!

The first one I thought was my fault. The second time I came here... Luckly they were updated at the workshop before mounting into the tower....

Really a Stable version with this kind of bug?? :shock: Kind of joke..

Waiting for a bug-fix asap....

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 12:42 pm
by normis
Here 2 x Netmetal Ethernet link problem crashed!!

The first one I thought was my fault. The second time I came here... Luckly they were updated at the workshop before mounting into the tower....

Really a Stable version with this kind of bug?? :shock: Kind of joke..

Waiting for a bug-fix asap....
Please contact support with the output files, so we can see what causes it. It could be hardware related or something else too.

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 4:01 pm
by docmarius
We are sorry for any inconvenience. After your reports we have managed to reproduce issue with ethernet link and are working on a fix.
Please contact support with the output files, so we can see what causes it. It could be hardware related or something else too.
Isn't there a contradiction in those 2 statements somehow?

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 4:08 pm
by normis
We are sorry for any inconvenience. After your reports we have managed to reproduce issue with ethernet link and are working on a fix.
Please contact support with the output files, so we can see what causes it. It could be hardware related or something else too.
Isn't there a contradiction in those 2 statements somehow?
I replied to a much later post. It is unclear if that is even related. In any case, keep sending files to be sure

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 4:24 pm
by Alessio Garavano
IMHO... I think, to avoid more problems, you need to remove the 6.33.2 from the Current channel on the web and System Check-for-updates...

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 5:34 pm
by kentaur
I second that, please remove it from upgrade channel.
I have one dead STX G-5HPacD (SN: 4F7004980B72) because of the 6.33.2, ehternet port doesn't activate so I can't revive it with netinstall. I'm open to suggestions.

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 5:43 pm
by Alessio Garavano
Hi Kentaur... i think the only option is by Netinstall... hold the RESET button when starting it until the LED light turns off, and the device will start to look for a Netinstall servers...

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 6:26 pm
by hzdrus
It seems that 6.33 has a regression in EoIP/VPLS performance. Details are in http://forum.mikrotik.com/viewtopic.php ... 79#p510079

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 6:28 pm
by jahill70
jahill70 - Please run this command on your device:
"/system logging add topics=pppoe,debug"

After that try to connect again.

Now generate supout file and send it to support@mikrotik.com
http://wiki.mikrotik.com/wiki/Manual:Su ... utput_File
As mentioned above, I've moved back to the current rc mentioned above and all is well.

I'm afraid I'm not really in a position to retest the version that broke PPPOE as it took a while to to get the per-packet load sharing config working again (a reset was required to connect the Mikrotik to an alternative network to pick up the alternative firmware, then a complete reconfiguration as the original config file wouldn't load)!

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 7:01 pm
by krugmartin
There is a problem with a Gigabit devices powered with 100Mbps POE or POE switch ! it should be fixed in the 6.34rc release

beware to downgrade ! Mine RB911's failed after downgrade to 6.30 and I tried another to 6.28 booth routers are dead.

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 8:30 pm
by honzam
Remove 6.33.2 from download page until 6.33.3 is released

Re: 6.33.2 version is released!

Posted: Thu Dec 03, 2015 10:01 pm
by digicomtech
Also, Ethernet synchronisation problem on a Netmetal with a RB750UP.
I had to remove auto-negotiation on both side to make them link again...

Very annoying on a remote production site...

I had upgrade firmware from 3.22 to 3.24 and reactivate auto-negotiation now works !!!

Please made more test before release stable,
Michael

Re: 6.33.2 version is released!

Posted: Fri Dec 04, 2015 10:40 am
by sergejs