Community discussions

MUM Europe 2020
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1425
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

v6.32.4 [bugfix] is released!

Wed Feb 10, 2016 11:39 am

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface within bugfix channel, or head to our download page: http://www.mikrotik.com/download

What's new in 6.32.4 (2016-Feb-09 09:17):

Contains all relevant fixes that was confirmed till v6.34 release.

*) address-list - properly remove unused address-lists from drop-downs;
*) arp - show incomplete ARP entries;
*) bridge - fixed power-cycle-ping for bridge ports (was affecting all bridge);
*) bridge firewall - fixed crash when jump rule points to disabled custom chain;
*) btest - fix potential crash after btest release;
*) btest - improve UDP tx rate precision;
*) crypto - fixed kernel failure in talitos HW encryption;
*) dhcpv6-client - fix DNS address assignement;
*) dhcpv6-client - set correct parameters when rapid commit is used
*) e-mail - do not reset server address after changing configuration;
*) email - make password field sensitive in console.
*) ethernet - fixed link resetting on power-cycle-ping value change;
*) fastpath - fixed possible kernel failure on multi core systems;
*) fastpath - show fp counters in /interface monitor aggregate;
*) fetch - added 30 second connection time-out;
*) fetch - fixed closure after 30 seconds;
*) hotspot - added missing favicon.ico in hotspot html pages;
*) hotspot - fixed missing image at login;
*) ipsec - fixed kernel failure after underlying tunnel has been disabled/enabled;
*) kernel - general improvement for core process scheduling;
*) lcd - fixed LCD crash on fast disable/enable;
*) lcd - refresh LCD after display command is executed;
*) led - add WLAN led to RB951Ui
*) log - log link up/down events only when link actually has changed its state;
*) log - reopen log file if deleted;
*) lte - improve support Sierra Wireless 320U;
*) lte - speed up first time connection to LTE network on SXT LTE;
*) net - apply slave config only if master config has been changed;
*) net - do not show L2MTU in VLAN compact export;
*) netinstall - fix branding pack parsing;
*) netwatch - make work with ping time-out more precise;
*) packages - show version tag when no bundle is installed.
*) packing - fix tcp/udp checksums when simple packing is used;
*) ppp - do not allow empty name ppp secrets;
*) ppp - fixed dynamic filter rule adding on some firewall filter configurations;
*) ppp - make PPP active print radius & !radius conditions work;
*) romon - allow to see device identity if it is longer than 31 character;
*) romon - do not accept multicast id;
*) romon - fixed crash on RoMON if fast-path was active;
*) smb - fix crash when changing user which has open session;
*) smb - fixed SMB share crash when connection was cancelled;
*) smb - show correct interface name in SMB debug logs;
*) ssh - avoid double session clean-up;
*) ssh - fix active user accounting;
*) ssh - fix key exchange when first kex packet follows.
*) ssh - fix session clean-up;
*) sshd - resolved shared secret mismatch issue;
*) tile - fix ipsec freeze after SA updates;
*) tile - fixed kernel failure on HW encryption;
*) upnp - fixed memory leak;
*) upnp - fixed missing in-interface option for dynamic dst-nat rules;
*) vrrp - allow VRRP to work behind firewall and NAT rules;
*) vrrp - do not warn about version mismatch if VRID does not match;
*) vrrp - fix arp=reply-only;
*) vrrp - fix enabling disabled vrrp interface when vrrp program has exited;
*) vrrp - fixed on-backup script;
*) vrrp - make sure that VRRP gets state on bootup;
*) webfig - didn't show zero values in CRS ingress/egress VLAN translation rules;
*) webfig - fixed firewall connection-bytes option;
*) webfig - show correctly SFP Tx/Rx;
*) winbox - added + & - to IGMP proxy MFC;
*) winbox - allow to specify traffic-monitor threshold in k & M units + specify that those are bits;
*) winbox - do not send any changes on OK button press if nothing has been changed;
*) winbox - fixed tab names to correspond to console;
*) winbox - fixed tab names to correspond to console;
*) winbox - renamed power-cycle-ping-interval to power-cycle-ping-timeout;
*) winbox - show dhcp server name in dhcp leases;
*) winbox - show fast-path per interface counters;
*) winbox - show only actual switch-cpu ports in switch setting combobox;
*) winbox - show properly route-distinguisher for bgp vpn4;
*) winbox/webfig - fixed version column ordering in ip neighbors list.

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
DjM
Member Candidate
Member Candidate
Posts: 111
Joined: Sun Dec 27, 2009 2:44 pm

Re: v6.32.4 [bugfix] is released!

Wed Feb 10, 2016 11:47 am

Hello MikroTik support team,

Is mipsle platform (RB5xx) supported by this version, please? Or the last supported version for this platform is 6.32.3.

Thank you
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1730
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.32.4 [bugfix] is released!

Wed Feb 10, 2016 12:18 pm

Hello MikroTik support team,

Is mipsle platform (RB5xx) supported by this version, please? Or the last supported version for this platform is 6.32.3.

Thank you
New download page explains that nicely.
and
What's new in 6.34 (2016-Jan-29 10:25):

*) mipsle - architecture support dropped (last fully supported version 6.32.x);
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
DjM
Member Candidate
Member Candidate
Posts: 111
Joined: Sun Dec 27, 2009 2:44 pm

Re: v6.32.4 [bugfix] is released!

Wed Feb 10, 2016 12:27 pm

Hello MikroTik support team,

Is mipsle platform (RB5xx) supported by this version, please? Or the last supported version for this platform is 6.32.3.

Thank you
New download page explains that nicely.
and
What's new in 6.34 (2016-Jan-29 10:25):

*) mipsle - architecture support dropped (last fully supported version 6.32.x);
Thank you for your answer, I'm aware about this statement.

The main reason for my question is, that from ROS 6.33 there was something changed inside the code which breaks the mipsle platform, so I would like to know, if the mentioned code is also implemented in 6.32.4.

Thank you
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2303
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: v6.32.4 [bugfix] is released!

Wed Feb 10, 2016 12:28 pm

It seems - mipsle is supported in this version
http://download2.mikrotik.com/routeros/ ... 6.32.4.npk
LAN, FTTx, Wireless. ISP operator
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1730
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.32.4 [bugfix] is released!

Wed Feb 10, 2016 12:35 pm

The main reason for my question is, that from ROS 6.33 there was something changed inside the code which breaks the mipsle platform, so I would like to know, if the mentioned code is also implemented in 6.32.4.
Thank you
If 6.32.4 compared to 6.32.3 have no new features only fixes, so you will be fine with every 6.32.x version.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Wed Feb 10, 2016 1:04 pm

Very impressive bugfix. Thank you.
 
DjM
Member Candidate
Member Candidate
Posts: 111
Joined: Sun Dec 27, 2009 2:44 pm

Re: v6.32.4 [bugfix] is released!

Wed Feb 10, 2016 1:19 pm

@honzam:
Good hint :-)

@macgaiver:
I hope the same, but I would like to have some official answer from MikroTik.

Finally I will have to do some internal testing, but it would be nice to have an official answer from support team.
 
Genkun
newbie
Posts: 33
Joined: Mon Jul 27, 2015 11:32 am

Re: v6.32.4 [bugfix] is released!

Wed Feb 10, 2016 2:19 pm

@honzam:
Good hint :-)

@macgaiver:
I hope the same, but I would like to have some official answer from MikroTik.

Finally I will have to do some internal testing, but it would be nice to have an official answer from support team.
You are one strange fellow.... Mipsle works of 6.32.4 as tested by a few of us.

I never used 6.33.x with mipsle due to the statement from support that they discontinued mipsle support for it on that version.

Thanks on a great bugfix release. These are lifesavers for the network.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1425
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.32.4 [bugfix] is released!

Wed Feb 10, 2016 4:02 pm

Official answer is that mipsle will work with 6.32.x versions.

Usually if you want to get official response, you should get in touch with support@mikrotik.com
 
DjM
Member Candidate
Member Candidate
Posts: 111
Joined: Sun Dec 27, 2009 2:44 pm

Re: v6.32.4 [bugfix] is released!

Wed Feb 10, 2016 4:17 pm

@strods:
Thank you for confirmation.
I'm aware about the official communication channel, but I have tried is also here to share this information also with community.

@Genkun:
Thank you for sharing the results of your tests.

@MikroTik:
Thank you for implementing bugfixes to this version :-)
 
User avatar
craigmitchell
just joined
Posts: 11
Joined: Sat Aug 18, 2012 6:30 pm

Re: v6.32.4 [bugfix] is released!

Thu Feb 11, 2016 8:25 pm

Short version: a system reset-config results in in zero configuration

Long version:

Hi team, I've used ROS v6.32.3 for a while now, and every time I've reset a device to factory settings I've been able to associate to the open WLAN MikroTik SSID.

After upgrading from v6.32.3 > v6.32.4 I would say the behaviour has changed

Regardless if you use winbox to reset: settings > Reset Configuration > Reset Configuration ..

..or if you enter in terminal:

[admin@MikroTik] > /system reset-configuration
Dangerous! Reset anyway? [y/N]:
y
system configuration will be reset


Upon reboot, the outcome is the same, the WLAN is disabled, in fact when you connect and are asked to confirm the configuration, then you end up with:
  MMM      MMM       KKK                          TTTTTTTTTTT      KKK
  MMMM    MMMM       KKK                          TTTTTTTTTTT      KKK
  MMM MMMM MMM  III  KKK  KKK  RRRRRR     OOOOOO      TTT     III  KKK  KKK
  MMM  MM  MMM  III  KKKKK     RRR  RRR  OOO  OOO     TTT     III  KKKKK
  MMM      MMM  III  KKK KKK   RRRRRR    OOO  OOO     TTT     III  KKK KKK
  MMM      MMM  III  KKK  KKK  RRR  RRR   OOOOOO      TTT     III  KKK  KKK

  MikroTik RouterOS 6.32.4 (c) 1999-2015       http://www.mikrotik.com/

[?]             Gives the list of available commands
command [?]     Gives help on the command and list of arguments

[Tab]           Completes the command/word. If the input is ambiguous,
                a second [Tab] gives possible options

/               Move up to base level
..              Move up one level
/command        Use command at the base level
The following default configuration has been installed on your router:
-------------------------------------------------------------------------------
RouterMode:
 * WAN port is protected by firewall and enabled DHCP client
 * Wireless interfaces are part of LAN bridge
 * WAN port is protected by firewall and enabled DHCP client
 * IP address 192.168.88.1/24 is set on LAN port
wlan1 Configuration:
    mode:          ap-bridge;
    band:          2ghz-b/g;
    ht-chains:     ;
    ht-extension:  20/40mhz-Ce;
LAN Configuration:
    DHCP Server: enabled;
    DNS: enabled;
WAN (gateway) Configuration:
    gateway:  ether1 ;
    firewall:  enabled;
    NAT:   enabled;

-------------------------------------------------------------------------------
You can type "v" to see the exact commands that are used to add and remove
this default configuration, or you can view them later with
'/system default-configuration print' command.
To remove this default configuration type "r" or hit any other key to continue.
If you are connected using the above IP and you remove it, you will be disconnected.

Confirming configuration
  
[admin@MikroTik] > 


..then if we're to check the configuration, we see....
export
# jan/02/1970 00:01:10 by RouterOS 6.32.4
# software id = EG3F-HRQJ
#
/system routerboard settings
set cpu-frequency=400MHz
I've so far reproduced on hAP lite, mAP-2n, RB951Ui-2HnD.
 
ilinal
just joined
Posts: 4
Joined: Mon Aug 03, 2015 10:45 pm

Re: v6.32.4 [bugfix] is released!

Tue Feb 16, 2016 6:08 am

Anyone experiencing frequent sector writes since 6.32.4? My 750r2 was working for 7 months and had 218.000 sector writes so far. Now with 6.32.4 i see 6-7k writes each day. In 10 days it will write ~ 1/4 of every write ever done in 7 months...


I dont freak out too much about flash wear, but in this case something is wrong. All logging is done to remote, no graphing, no proxy, no caches and dhcp is set to never store leases on disk.

Image
 
_saik0
Member Candidate
Member Candidate
Posts: 127
Joined: Sun Aug 26, 2007 11:18 pm

Re: v6.32.4 [bugfix] is released!

Sun Feb 21, 2016 4:22 pm

Uh where do you see sector writes?
Did the location change?

On my CCRs with 6.34.2 and RB2011 on 6.32.3 sector writes info is missing under /system resources.
On my old RB2011 on 5.24 sector writes are visible under resources
They are also visible on a x86 6.30.4.

I didn't even notice this until the above post.
 
hedele
Member
Member
Posts: 338
Joined: Tue Feb 24, 2009 11:23 pm

Re: v6.32.4 [bugfix] is released!

Mon Feb 22, 2016 10:38 am

For some reason, sector writes don't show up on tile architecture boards, I checked an old CCR I have lying around running 6.18 and it doesn't show them either. Seems to be a design decision I guess?
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1425
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.32.4 [bugfix] is released!

Mon Feb 22, 2016 11:40 am

On tile platform based devices you simply can not see these bad blocks. It is not something broken or a bug - it has been that way since beginning.
 
_saik0
Member Candidate
Member Candidate
Posts: 127
Joined: Sun Aug 26, 2007 11:18 pm

Re: v6.32.4 [bugfix] is released!

Mon Feb 22, 2016 9:05 pm

but what about RB2011?

There's clearly write sectors info on older ROS.
 
andriys
Forum Guru
Forum Guru
Posts: 1193
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: v6.32.4 [bugfix] is released!

Mon Feb 22, 2016 10:44 pm

but what about RB2011?

There's clearly write sectors info on older ROS.
I see nothing wrong with my RB2011UiAS-RM. Sector writes info was present before the upgrade to 6.32.4 and is still present after upgrade.
 
thasser
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Mon Sep 23, 2013 8:28 pm

Re: v6.32.4 [bugfix] is released!

Tue Feb 23, 2016 5:04 am

I am having issues with upgrading from 6.32.3 to 6.32.4 with both RB922UAGS-5HPacD and RBDynaDishG-5HacD.

Both are reporting looping errors, but the Dynadish does not have an IP, so the error does not make sense.

[XXXXXXXX@YYYYYYYYY] /ip address> print
Flags: X - disabled, I - invalid, D - dynamic
# ADDRESS NETWORK INTERFACE
[XXXXXXXX@YYYYYYYYY] /ip address> ..
[XXXXXXXX@YYYYYYYYY] /ip> ..
[XXXXXXXX@YYYYYYYYY] > log
[XXXXXXXX@YYYYYYYYY] /log> print
feb/22 20:24:50 system,error,critical router was rebooted without proper shutdown
feb/22 20:24:54 wireless,info [removed]@wlan1 established connection on
feb/22 20:24:55 interface,info ether1 link up (speed 1G, full duplex)
feb/22 20:24:58 interface,warning wlan1: bridge port received packet with own addr
ess as source address, probably loop
feb/22 20:25:07 interface,warning wlan1: bridge port received packet with own addr
ess as source address, probably loop
feb/22 20:25:22 interface,warning wlan1: bridge port received packet with own addr
ess as source address, probably loop
feb/22 20:25:32 interface,warning wlan1: bridge port received packet with own addr
ess as source address, probably loop
feb/22 20:25:44 interface,warning wlan1: bridge port received packet with own addr
ess as source address, probably loop
feb/22 20:25:58 interface,warning wlan1: bridge port received packet with own addr
ess as source address, probably loop



The RB922UAGS-5HPacD is reporting similar errors on it's ether1 interface, although it does have an IP address assigned to it's bridge. I have tried disable, enable to no avail. The RB2011 that the RB922UAGS-5HPacD is connected to also shows no connection on the LAN side. I am only able to access the RB2011 via a redundant connection
 
andriys
Forum Guru
Forum Guru
Posts: 1193
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: v6.32.4 [bugfix] is released!

Tue Feb 23, 2016 9:41 am

Both are reporting looping errors, but the Dynadish does not have an IP, so the error does not make sense.
I believe this error messages talks about MAC address, not IP.
 
pants6000
Frequent Visitor
Frequent Visitor
Posts: 67
Joined: Fri Sep 26, 2014 5:30 am

Re: v6.32.4 [bugfix] is released!

Wed Feb 24, 2016 3:08 am

FWIW, working beautifully on my 951Ui-2HnD at home. Don't see an inordinate number of sector writes, either.
 
thasser
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Mon Sep 23, 2013 8:28 pm

Re: v6.32.4 [bugfix] is released!

Wed Feb 24, 2016 3:21 pm

Ah ok, so identical MAC addresses. Has anyone else seen this issue? Has anyone else upgraded from 6.32.3 to 6.32.4 with SXT, 2011, Sextant, etc.? My RB951 took it like a champ, dynadish and RB922 both report looping errors and are inaccessible via ethernet. Showing no connection. I can use the netboot tool easily, but wanted to make sure someone else can verify this issue.
 
lukoramu
just joined
Posts: 18
Joined: Mon Jan 07, 2013 11:11 am

Re: v6.32.4 [bugfix] is released!

Thu Feb 25, 2016 4:53 pm

Short version: a system reset-config results in in zero configuration

[...]

I've so far reproduced on hAP lite, mAP-2n, RB951Ui-2HnD.
I had exactly the same experience on RB951-2n and hAP. That initial configuration script does not get executed ...
When I downgraded to 6.32.3, default config script was executed as expected ...
 
bergonz
just joined
Posts: 10
Joined: Fri Oct 16, 2015 3:01 pm

Re: v6.32.4 [bugfix] is released!

Fri Feb 26, 2016 10:50 am

I've so far reproduced on hAP lite, mAP-2n, RB951Ui-2HnD.
I had this same issue, with the same fix (downgrade to 6.32.3) with RB951G-2HnD. Powering it on with the reset button pressed gives the same result, empty config.

I saved the default configuration script with /system default-configuration and I attach it here. I have no experience with RouterOS scripts, so I didn't find the way to run it directly to see possible errors.

Best regards
You do not have the required permissions to view the files attached to this post.
 
leonset
Member Candidate
Member Candidate
Posts: 256
Joined: Wed Apr 01, 2009 9:09 pm

Re: v6.32.4 [bugfix] is released!

Thu Mar 03, 2016 10:06 am

If anyone has ethernet issues with 922/912/911 boards with firmware v6.32.4, check my post here to get access back:

http://forum.mikrotik.com/viewtopic.php?f=2&t=105324

Who is online

Users browsing this forum: alber, DenisPDA and 12 guests