Community discussions

 
palhaland
just joined
Posts: 10
Joined: Mon Aug 15, 2016 9:05 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Tue Aug 16, 2016 8:41 am

issues found on v6.27rc16 (running on mAP lite)

Love the new version with only one wireless package!

However I found some issues :)
Wireless interface
/interface wireless connect-list does not work on virtual station. (on mAP2nd) When running with logging the network is listed (correct frequency), but the wireless interface claim that there is no network that satisfy the connect list.

Scripting
This code works in command line but not in script;
{
:local $scanList "scanList.csv"
:local wlanInterface "wlan1"
:local j [:execute {/interface wireless scan [find name=$wlanInterface] background=yes duration=5 rounds=1 save-file=$scanList;}]
}
Where as this code works in both command line and script:
{
:local $scanList "scanList.csv"
:local wlanInterface [/interface wireless find name="wlan1"]
:local j [:execute {/interface wireless scan $wlanInterface background=yes duration=5 rounds=1 save-file=$scanList;}]
}
update 17.08.2016: there are no issues with scripting, the reason why it did not work was because the variables used was only in the local scope, it has to be in the global scope
Last edited by palhaland on Wed Aug 17, 2016 11:47 am, edited 1 time in total.
 
TonyJr
Member Candidate
Member Candidate
Posts: 198
Joined: Sat Nov 12, 2011 1:30 am
Location: UK
Contact:

Re: v6.37rc [release candidate] is released, only one wireless package!

Tue Aug 16, 2016 6:20 pm

*) sstp - fixed disconnects on transmit for multicore systems;

Thank you for this fix - site-to-site VPN is now stable between a CCR1009-8G-1S-1S+-PC and a CRS109-8G-1S-2HnD with 6.37rc16. I had thought the problem was with my configuration, until I saw the changelog. The connection would previously disconnect every few minutes if under any load - Link Downs would often have numbers in the thousands, now it is 0.

TonyJr
 
Ulypka
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Wed Jan 09, 2013 8:26 am

Re: v6.37rc [release candidate] is released, only one wireless package!

Wed Aug 17, 2016 2:22 pm

After upgrade from v6.37rc10 to v6.37rc16 openvpn server dosn't work.
 
User avatar
emils
MikroTik Support
MikroTik Support
Posts: 463
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.37rc [release candidate] is released, only one wireless package!

Wed Aug 17, 2016 2:38 pm

Ulypka, please send supout.rif file to support@mikrotik.com
 
Ulypka
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Wed Jan 09, 2013 8:26 am

Re: v6.37rc [release candidate] is released, only one wireless package!

Wed Aug 17, 2016 9:19 pm

emils, I'm so sorry it was my mistake unrelated to ovpn.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 18, 2016 2:11 pm

What's new in 6.37rc19 (2016-Aug-18 06:46):

--- IMPORTANT! WIRELESS PACKAGE CHANGES:

If you are not using "routeros" bundle package and have two wireless packages installed,
uninstall one wireless package before upgrade to 6.37. For other cases simply upgrade to
6.37 version.

There will be only one "wireless" package in RouterOS v6.37. If using bundle package to
upgrade, click "Check for updates" in your RouterOS configuration interface, or head to
our download page: http://www.mikrotik.com/download.

--- IMPORTANT! DFS MODE CHANGES:

DFS mode setting is removed, and by default becomes forced to "dfs=radar-detect" for all
devices that use radar frequencies. If your client devices use a scan list with a few
specific frequencies that could conflict with radar frequencies, you could lose the
connection. It is recommended to widen the scan list range, use default scan list, or
change the AP frequency

Changes since 6.37rc16:

*) arm - show cpu frequency under resources menu;
*) arp - fixed crash that caused Ethernet frames to go out via wrong interface;
*) dude - (changes discussed here: http://forum.mikrotik.com/viewtopic.php?f=8&t=110424);
*) pppoe - fixed kernel crash caused by dial-on-demand when used with fastpath;
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 18, 2016 3:41 pm

issues found on v6.27rc16 (running on mAP lite)

Love the new version with only one wireless package!

However I found some issues :)
Wireless interface
/interface wireless connect-list does not work on virtual station. (on mAP2nd) When running with logging the network is listed (correct frequency), but the wireless interface claim that there is no network that satisfy the connect list.
I was unable to reproduce this problem.
Please provide us more information on that and also the wireless debug logs. Also make sure you select the correct security-profile in the connect-list.
 
jarda
Forum Guru
Forum Guru
Posts: 7601
Joined: Mon Oct 22, 2012 4:46 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 18, 2016 3:46 pm

Is the [Ticket#2016081022001387] solved already in this rc?
 
Ciambot
Member Candidate
Member Candidate
Posts: 144
Joined: Thu Jan 22, 2009 5:22 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 18, 2016 3:50 pm

--- IMPORTANT! DFS MODE CHANGES:

DFS mode setting is removed, and by default becomes forced to "dfs=radar-detect" for all
devices that use radar frequencies. If your client devices use a scan list with a few
specific frequencies that could conflict with radar frequencies, you could lose the
connection. It is recommended to widen the scan list range, use default scan list, or
change the AP frequency

Oh my God!
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24077
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 18, 2016 3:52 pm

--- IMPORTANT! DFS MODE CHANGES:

DFS mode setting is removed, and by default becomes forced to "dfs=radar-detect" for all
devices that use radar frequencies. If your client devices use a scan list with a few
specific frequencies that could conflict with radar frequencies, you could lose the
connection. It is recommended to widen the scan list range, use default scan list, or
change the AP frequency

Oh my God!
If you are in some place where you can use the radar frequencies ... Use Superchannel mode and it won't matter
No answer to your question? How to write posts
 
pe1chl
Forum Guru
Forum Guru
Posts: 5565
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 18, 2016 3:59 pm

If you are in some place where you can use the radar frequencies ... Use Superchannel mode and it won't matter
The problem is not using the radar frequencies, the problem is the (mis?)detection of radar on other frequencies when
at a high site near to radar. Do you mean that when switching from "regulatory - domain" to "superchannel" you can
still turn off the DFS? And will this remain in place or will it be the next feature to go?

Fortunately we use separate routers and APs that are only bridge, so we can still update routers and keep APs on old firmware
until there is a good solution. As it is now, DFS does not work for us on SXT, Metal5 etc.
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 18, 2016 5:02 pm

6.37rc19 Do not use RB433UAH hide all interfaces wireless (winbox, web) ethernet random refresh, wireless no configuration (remembers previous settings, broadcasts), ....downgrade previous build 6.37rc15
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24077
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 18, 2016 5:04 pm

6.37rc19 Do not use RB433UAH hide all interfaces wireless (winbox, web) ethernet random refresh, wireless no configuration (remembers previous settings, broadcasts), ....downgrade previous build 6.37rc15
Most likely your wireless package got disabled, this can sometimes happen if you have installed multiple wireless packages. No need to downgrade, just need to re-enable correct wireless npk.
No answer to your question? How to write posts
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 18, 2016 5:21 pm

6.37rc19 Do not use RB433UAH hide all interfaces wireless (winbox, web) ethernet random refresh, wireless no configuration (remembers previous settings, broadcasts), ....downgrade previous build 6.37rc15
Most likely your wireless package got disabled, this can sometimes happen if you have installed multiple wireless packages. No need to downgrade, just need to re-enable correct wireless npk.

It's not this way
wireless packages activate build 6.37rc19 ( wireless AP view air)
build 6.37rc15 upgrade to 6.37rc19 > downgrade 6.37rc15 (works)
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1717
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 18, 2016 5:30 pm

It's not this way
wireless packages activate build 6.37rc19 ( wireless AP view air)
build 6.37rc15 upgrade to 6.37rc19 > downgrade 6.37rc15 (works)
You most definately need to send supout.rif file from rc19 to support@mikrotik.com
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 18, 2016 5:55 pm


You most definately need to send supout.rif file from rc19 to support@mikrotik.com

macgaiver: why he wrote it? post+1? your is spamer
 
palhaland
just joined
Posts: 10
Joined: Mon Aug 15, 2016 9:05 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 18, 2016 6:03 pm

issues found on v6.27rc16 (running on mAP lite)

Love the new version with only one wireless package!

However I found some issues :)
Wireless interface
/interface wireless connect-list does not work on virtual station. (on mAP2nd) When running with logging the network is listed (correct frequency), but the wireless interface claim that there is no network that satisfy the connect list.
I was unable to reproduce this problem.
Please provide us more information on that and also the wireless debug logs. Also make sure you select the correct security-profile in the connect-list.
This is with frequency set to auto on the ap-bridge
831	Aug/18/2016 16:38:04	memory	wireless, debug	wlan2: no network that satisfies connect-list, by default choose with strongest signal	
832	Aug/18/2016 16:38:04	memory	wireless, debug	wlan2: failed to select network	
833	Aug/18/2016 16:38:04	memory	wireless, debug	wlan2: must select network	
834	Aug/18/2016 16:38:04	memory	wireless, debug	empty
This is with frequency set to the correct frequency:
985	Aug/18/2016 16:41:21	memory	wireless, debug	<mac address>: on 2462 AP: yes SSID <correct network name> caps 0x1431 rates 0xCCK:11 OFDM:12-54 BW:1x SGI:1x HT:0-23 basic 0xCCK:11 MT: no	
986	Aug/18/2016 16:41:21	memory	wireless, debug	<mac address>: on 2462 AP: yes SSID <correct network name> caps 0x1431 rates 0xCCK:11 OFDM:12-54 BW:1x SGI:1x HT:0-23 basic 0xCCK:11 MT: no	
987	Aug/18/2016 16:41:21	memory	wireless, debug	<mac address>: on 2462 AP: yes SSID <different network name> caps 0x1431 rates 0xCCK:11 OFDM:12-54 BW:1x SGI:1x HT:0-23 basic 0xCCK:11 MT: no	
988	Aug/18/2016 16:41:21	memory	wireless, debug	<mac address>: on 2462 AP: yes SSID caps 0x1431 rates 0xCCK:11 OFDM:12-54 BW:1x SGI:1x HT:0-23 basic 0xCCK:11 MT: no	
989	Aug/18/2016 16:41:21	memory	wireless, debug	<mac address>: on 2462 AP: yes SSID caps 0x1431 rates 0xCCK:11 OFDM:12-54 BW:1x SGI:1x HT:0-23 basic 0xCCK:11 MT: no	
990	Aug/18/2016 16:41:21	memory	wireless, debug	wlan2: no network that satisfies connect-list, by default choose with strongest signal	
991	Aug/18/2016 16:41:21	memory	wireless, debug	wlan2: failed to select network	
992	Aug/18/2016 16:41:22	memory	wireless, debug	wlan2: must select network	
# aug/18/2016 16:46:13 by RouterOS 6.37rc16
# software id = G2LP-VRHH
#
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-eC \
    disabled=no distance=indoors frequency=2462 mode=ap-bridge ssid=\
    MikroTik-149006 wireless-protocol=802.11
add disabled=no mac-address=<mac-address> master-interface=wlan1 mode=\
    station-pseudobridge name=wlan2
/ip neighbor discovery
set ether1 discover=no
/interface wireless security-profiles
add authentication-types=wpa-psk,wpa2-psk management-protection=allowed mode=\
    dynamic-keys name=profile1 wpa-pre-shared-key=<password> \
    wpa2-pre-shared-key=<password>
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=wlan1 name=defconf
/interface wireless connect-list
add interface=wlan2 security-profile=profile1 ssid=<network name>
/ip address
add address=192.168.88.1/24 comment=defconf interface=wlan1 network=\
    192.168.88.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=ether1
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
    interface=wlan2
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept established,related" \
    connection-state=established,related
add action=drop chain=input comment="defconf: drop all from WAN" in-interface=\
    ether1
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related" \
    connection-state=established,related
add action=drop chain=forward comment="defconf: drop invalid" connection-state=\
    invalid
add action=drop chain=forward comment=\
    "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface=ether1
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" out-interface=\
    ether1
/system clock
set time-zone-name=Europe/Oslo
/system logging
add topics=wireless,debug
/system routerboard settings
set cpu-frequency=650MHz protected-routerboot=disabled
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=wlan1
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=wlan1
By only adding the SSID to connect to and the security profile, it connects immediately
/interface wireless wlan2 set ssid=<wireless network> security-profile=profile1
 
voody77
just joined
Posts: 1
Joined: Thu Aug 18, 2016 6:18 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 18, 2016 6:23 pm

6.37rc19 Do not use RB433UAH hide all interfaces wireless (winbox, web) ethernet random refresh, wireless no configuration (remembers previous settings, broadcasts), ....downgrade previous build 6.37rc15
Most likely your wireless package got disabled, this can sometimes happen if you have installed multiple wireless packages. No need to downgrade, just need to re-enable correct wireless npk.
At start hap ac wireless interfaces is work. run 2-5 minuts - result: hide all wireless interfaces in inbox menu on 6.37rc19 and networks not working!
 
raffav
Member Candidate
Member Candidate
Posts: 279
Joined: Wed Oct 24, 2012 4:40 am

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 18, 2016 6:36 pm

6.37rc19 Do not use RB433UAH hide all interfaces wireless (winbox, web) ethernet random refresh, wireless no configuration (remembers previous settings, broadcasts), ....downgrade previous build 6.37rc15
for me is ok
[raffaello@RJ-AT-MK02 - CAP1] > interface wireless print without-paging 
Flags: X - disabled, R - running 
 0 X  ;;; COMERCIAL --- wireless
      name="Wap45_comercial" mtu=1500 l2mtu=1600 mac-address=02:15:6D:68:40:71 arp=enabled interface-type=virtual master-interface=wlan1 mode=ap-bridge ssid="comercial_answer" vlan-mode=no-tag vlan-id=1 
      wds-mode=disabled wds-default-bridge=none wds-ignore-ssid=no bridge-mode=enabled default-authentication=no default-forwarding=no default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=no 
      security-profile=comercial_answer 

 1 X  ;;; DIRETORIA --- wireless
      name="Wap75_diretoria" mtu=1500 l2mtu=1600 mac-address=02:15:6D:68:40:74 arp=enabled interface-type=virtual master-interface=wlan1 mode=ap-bridge ssid="diretoria_answer" vlan-mode=no-tag vlan-id=1 
      wds-mode=disabled wds-default-bridge=none wds-ignore-ssid=no bridge-mode=enabled default-authentication=yes default-forwarding=yes default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=no 
      security-profile=diretoria_answer 

 2 X  ;;; LOGISTICA --- wireless
      name="Wap85_logistica" mtu=1500 l2mtu=1600 mac-address=02:15:6D:68:40:70 arp=enabled interface-type=virtual master-interface=wlan1 mode=ap-bridge ssid="logistica_answer" vlan-mode=no-tag vlan-id=1 
      wds-mode=disabled wds-default-bridge=none wds-ignore-ssid=no bridge-mode=enabled default-authentication=yes default-forwarding=yes default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=no 
      security-profile=logistica_answer 

 3 X  ;;; VISITANTE --- wireless
      name="Wap145_visitante" mtu=1500 l2mtu=1600 mac-address=02:15:6D:68:40:6F arp=enabled interface-type=virtual master-interface=wlan1 mode=ap-bridge ssid="visitante_answer" vlan-mode=no-tag vlan-id=1 
      wds-mode=disabled wds-default-bridge=none wds-ignore-ssid=no bridge-mode=enabled default-authentication=yes default-forwarding=yes default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=no 
      security-profile=visitante_answer 

 4 X  ;;; MOBILE-RJ --- wireless
      name="Wap146_mobile-rj" mtu=1500 l2mtu=1600 mac-address=02:15:6D:69:38:B0 arp=enabled interface-type=virtual master-interface=wlan1 mode=ap-bridge ssid="answer_mobile" vlan-mode=no-tag vlan-id=146 
      wds-mode=disabled wds-default-bridge=none wds-ignore-ssid=no bridge-mode=enabled default-authentication=yes default-forwarding=yes default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=no 
      security-profile=mobile_answer 

 5 X  ;;; TI --- Wireless
      name="Wap155_TI" mtu=1500 l2mtu=1600 mac-address=02:15:6D:68:40:75 arp=enabled interface-type=virtual master-interface=wlan1 mode=ap-bridge ssid="TI_answer" vlan-mode=no-tag vlan-id=155 wds-mode=disabled 
      wds-default-bridge=none wds-ignore-ssid=no bridge-mode=enabled default-authentication=yes default-forwarding=yes default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=no security-profile=TI_answer 

 6 X  ;;; TI --- Wireless Mobile
      name="Wap156_MOBILE" mtu=1500 l2mtu=1600 mac-address=02:15:6D:69:38:AF arp=enabled interface-type=virtual master-interface=wlan1 mode=ap-bridge ssid="W_TI" vlan-mode=no-tag vlan-id=1 wds-mode=disabled 
      wds-default-bridge=none wds-ignore-ssid=no bridge-mode=enabled default-authentication=no default-forwarding=no default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=yes security-profile=TI_Mobile 

 7 X  ;;; managed by CAPsMAN
      ;;; channel: 2412/20/g(21dBm), SSID: diretoria_answer, CAPsMAN forwarding
      name="wlan1" mtu=1500 l2mtu=1600 mac-address=D4:CA:6D:14:01:F3 arp=enabled interface-type=Atheros AR5413 mode=ap-bridge ssid="answer_wireless" frequency=auto band=2ghz-b/g channel-width=20mhz 
      scan-list=default wireless-protocol=802.11 antenna-mode=ant-a vlan-mode=no-tag vlan-id=97 wds-mode=disabled wds-default-bridge=none wds-ignore-ssid=no bridge-mode=disabled default-authentication=no 
      default-forwarding=no default-ap-tx-limit=0 default-client-tx-limit=0 hide-ssid=yes security-profile=TI_answer compression=no 
[raffaello@RJ-AT-MK02 - CAP1] > system package print 
Flags: X - disabled 
 #   NAME                                                                                         VERSION                                                                                        SCHEDULED              
 0   routeros-mipsbe                                                                              6.37rc19                                                                                                              
 1   system                                                                                       6.37rc19                                                                                                              
 2   ipv6                                                                                         6.37rc19                                                                                                              
 3   wireless                                                                                     6.37rc19                                                                                                              
 4   hotspot                                                                                      6.37rc19                                                                                                              
 5   dhcp                                                                                         6.37rc19                                                                                                              
 6   mpls                                                                                         6.37rc19                                                                                                              
 7   routing                                                                                      6.37rc19                                                                                                              
 8   ppp                                                                                          6.37rc19                                                                                                              
 9   security                                                                                     6.37rc19                                                                                                              
10   advanced-tools                                                                               6.37rc19  
raffaello@RJ-AT-MK02 - CAP1] > system resource print 
                   uptime: 6m35s
                  version: 6.37rc19 (testing)
               build-time: Aug/18/2016 06:45:52
              free-memory: 104.7MiB
             total-memory: 128.0MiB
                      cpu: MIPS 24Kc V7.4
                cpu-count: 1
            cpu-frequency: 680MHz
                 cpu-load: 4%
           free-hdd-space: 492.1MiB
          total-hdd-space: 512.0MiB
  write-sect-since-reboot: 237
         write-sect-total: 45367767
               bad-blocks: 0.2%
        architecture-name: mipsbe
               board-name: RB433UAH
                 platform: MikroTik
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 18, 2016 6:53 pm

raffav I use „Extra packages” (all_packages...) the terminal I was not looking, important WinBox
 
raffav
Member Candidate
Member Candidate
Posts: 279
Joined: Wed Oct 24, 2012 4:40 am

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 18, 2016 7:03 pm

raffav I use „Extra packages” (all_packages...) the terminal I was not looking, important WinBox
ok
so maybe the problem is on the extra packages, my winbox is ok too
I don't lost any wifi configuration or interfaces
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1717
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.37rc [release candidate] is released, only one wireless package!

Fri Aug 19, 2016 10:26 am


You most definately need to send supout.rif file from rc19 to support@mikrotik.com
macgaiver: why he wrote it? post+1? your is spamer
Cause only ones that can help you are reachable via that mail, to make sure that RC20 doesn't have this problem.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.37rc [release candidate] is released, only one wireless package!

Fri Aug 19, 2016 11:18 am

What's new in 6.37rc20 (2016-Aug-19 06:35):

--- IMPORTANT! WIRELESS PACKAGE CHANGES:

If you are not using "routeros" bundle package and have two wireless packages installed,
uninstall one wireless package before upgrade to 6.37. For other cases simply upgrade to
6.37 version.

There will be only one "wireless" package in RouterOS v6.37. If using bundle package to
upgrade, click "Check for updates" in your RouterOS configuration interface, or head to
our download page: http://www.mikrotik.com/download.

--- IMPORTANT! DFS MODE CHANGES:

DFS mode setting is removed, and by default becomes forced to "dfs=radar-detect" for all
devices that use radar frequencies. If your client devices use a scan list with a few
specific frequencies that could conflict with radar frequencies, you could lose the
connection. It is recommended to widen the scan list range, use default scan list, or
change the AP frequency

Changes since 6.37rc19:

*) address-list - fixed crash (introduced in 6.37rc17);
*) dude - (changes discussed here: http://forum.mikrotik.com/viewtopic.php?f=8&t=110424);
*) export - updated default values in /system routerboard settings menu;
*) sfp - enabled eeprom printout in /interface ethernet monitor;
*) sfp - removed "sfp-rate-select" as command was not relevant to currently supported hardware;
*) trafficgen - fixed crash (introduced in 6.37rc17);
 
pe1chl
Forum Guru
Forum Guru
Posts: 5565
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Fri Aug 19, 2016 10:22 pm

*) snmp - added script table which executes script and returns it's output on get request;

Please explain how to use this feature, because I cannot find it in the user interface...
 
raffav
Member Candidate
Member Candidate
Posts: 279
Joined: Wed Oct 24, 2012 4:40 am

Re: v6.37rc [release candidate] is released, only one wireless package!

Fri Aug 19, 2016 11:06 pm

Very strange thing on a RB450G when I do a port knock using tcp the RB reset all interface and lost connection
using rc19 version

port knock is 2 top sequencie 2468 and 55027

can any one using rc19 tray to se if the rb crash
 
Zorro
Long time Member
Long time Member
Posts: 676
Joined: Wed Apr 16, 2014 2:43 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Sun Aug 21, 2016 11:23 pm

there was presumed some changes in 3.34 bootloader ?
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 25, 2016 10:18 am

What's new in 6.37rc21 (2016-Aug-25 06:15):

--- IMPORTANT! WIRELESS PACKAGE CHANGES:

If you are not using "routeros" bundle package and have two wireless packages installed,
uninstall one wireless package before upgrade to 6.37. For other cases simply upgrade to
6.37 version.

There will be only one "wireless" package in RouterOS v6.37. If using bundle package to
upgrade, click "Check for updates" in your RouterOS configuration interface, or head to
our download page: http://www.mikrotik.com/download.

--- IMPORTANT! DFS CHANGES:

DFS configuration in RouterOS has been redesigned, now device looks at specified country
settings (/interface wireless info country-info <country> ), and apply corresponding
DFS mode for each frequency range automatically, making dfs-mode setting unnecessary.

Please, check that your frequencies work with correcponding DFS settings before upgrade.

Changes since 6.37rc20:

*) dude - (changes discussed here: http://forum.mikrotik.com/viewtopic.php?f=8&t=110424);
*) hotspot - show comments from user menu also in active menu;
*) tunnel - ipv6 link-local address is now generated from tunnel local-address;
*) vlan - do not allow to add new vlan interface with mtu higher than l2mtu;
*) wireless - updated brazil country settings;
 
heaven
just joined
Posts: 13
Joined: Mon Aug 15, 2016 12:14 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 25, 2016 12:17 pm

Hi Guys, I have 2 Mikrotik in my network (RB2011 & hAP AC Lite). All my routers have release candidate firmware. The RB2011 is a capsman controller and hap ac is a cap with 2 more virtual cap.
When RB2011 was restart after upgrade or another cause the cap in hap ac has registered new/dynamic wlan number in cap. It's very uncomfortably because I have some bridges and all each networks (wlans) uses different bridges.
For example.
on the hAP AC
Bridge -> Ports:
br1 - wlan0
br2 - wlan2
br3 - wlan3
Wireless by controller capsman:
wlan0 - general cap
wlan2 - 1st virtual cap
wlan3 - 2nd virtual cap

after restart of capsman controller (RB2011), cap (hAP AC) registered new wlans:
Wireless capsmann controlled:
wlan0 - general cap
wlan25 - 1st virtual cap
wlan26 - 2nd virtual cap.

in Bridge -> Ports
br1 - wlan0
br2 - unknown
br3 - unknown

how to solve this problem or maybe developer have a liitle time to do a static virtual caps wlans number?) Thanks.
 
raffav
Member Candidate
Member Candidate
Posts: 279
Joined: Wed Oct 24, 2012 4:40 am

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 25, 2016 12:52 pm

Don't use dynamic enable
Use enable only

Enviado de meu XT1580 usando Tapatalk
 
heaven
just joined
Posts: 13
Joined: Mon Aug 15, 2016 12:14 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 25, 2016 12:59 pm

Don't use dynamic enable
Use enable only

Enviado de meu XT1580 usando Tapatalk
wrong(. every time cap have a new number of virtual cap wlan on reconnect. if it's was be so easy i'm not write here. but thank you for your answer).
 
raffav
Member Candidate
Member Candidate
Posts: 279
Joined: Wed Oct 24, 2012 4:40 am

v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 25, 2016 1:22 pm

Don't use dynamic enable
Use enable only

Enviado de meu XT1580 usando Tapatalk
wrong(. every time cap have a new number of virtual cap wlan on reconnect. if it's was be so easy i'm not write here. but thank you for your answer).
Sorry, but sometimes is wrong there,
My cap number don't change when devices is rebooted

Edit:
Now I got it
I understand another Dynamic number Image

The caps number on the cap device it Is normal to increase ( Why need to be like that I don't know)

The trick is to use data path settings so the caps interface go to the correct bridge


Enviado de meu XT1580 usando Tapatalk
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 25, 2016 1:52 pm

info: RB433UAH this works build 6.37rc21 (all_packages...)
upgrade 6.37rc15 :>>> 6.37rc21

6.37rc19 no works
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 25, 2016 1:56 pm

What's new in 6.37rc22 (2016-Aug-25 09:01):

--- IMPORTANT! WIRELESS PACKAGE CHANGES:

If you are not using "routeros" bundle package and have two wireless packages installed,
uninstall one wireless package before upgrade to 6.37. For other cases simply upgrade to
6.37 version.

There will be only one "wireless" package in RouterOS v6.37. If using bundle package to
upgrade, click "Check for updates" in your RouterOS configuration interface, or head to
our download page: http://www.mikrotik.com/download.

--- IMPORTANT! DFS CHANGES:

DFS configuration in RouterOS has been redesigned, now device looks at specified country
settings (/interface wireless info country-info), and applies corresponding
DFS mode for each frequency range automatically, making dfs-mode setting unnecessary.

Please, check that your frequencies work with corresponding DFS settings before upgrade.

Changes since 6.37rc21:

*) ethernet - fixed rare kernel failure on non-switch ethernet reset;
*) simple queues - fixed issue which caused additional/unnecessary CPU load;
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1717
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 25, 2016 2:03 pm

*) simple queues - fixed issue which caused additional/unnecessary CPU load;
Can you be more specific? What simple queue configurations are affected? how much?
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
heaven
just joined
Posts: 13
Joined: Mon Aug 15, 2016 12:14 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 25, 2016 2:06 pm

Don't use dynamic enable
Use enable only

Enviado de meu XT1580 usando Tapatalk
wrong(. every time cap have a new number of virtual cap wlan on reconnect. if it's was be so easy i'm not write here. but thank you for your answer).
Sorry, but sometimes is wrong there,
My cap number don't change when devices is rebooted

Edit:
Now I got it
I understand another Dynamic number Image

The caps number on the cap device it Is normal to increase ( Why need to be like that I don't know)

The trick is to use data path settings so the caps interface go to the correct bridge


Enviado de meu XT1580 usando Tapatalk
I try fistly write br number in datapath but nothing(.
 
patrick7
Member Candidate
Member Candidate
Posts: 298
Joined: Sat Jul 20, 2013 2:40 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 25, 2016 2:12 pm

Feature request:
Allow unset at every place where it's possible to set an empty value (example: bgp update source, unset update-source does not work, set update-source=none is needed. firewall log prefix, set log-prefix="" works, but unset log-prefix does not work.).
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 25, 2016 2:13 pm

macgaiver - Simple Queue hashing algorithm had an issue which caused hash rebuilds. This caused additional CPU load. This fix affects all Simple Queue configurations but improvement depends on queue count and complexity.

This issue was found on Intel based x86 installation with ~6500 Simple Queues. Load after upgrade went down from 70-80% to 20-30%.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5565
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 25, 2016 2:36 pm

Feature request:
Allow unset at every place where it's possible to set an empty value (example: bgp update source, unset update-source does not work, set update-source=none is needed. firewall log prefix, set log-prefix="" works, but unset log-prefix does not work.).
unset something is not the same as setting an empty value for it. it may work out the same in some cases, but be different in others.
maybe you would want a "reset" function that sets it to its default value, which may be unset, empty or none.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5913
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 25, 2016 2:44 pm

unset is available only for parameters that can be unset, log-prefix is not one of them.

Type in the terminal "unset 0 <tab>" and see all acceptable parameters that can be unset.
 
patrick7
Member Candidate
Member Candidate
Posts: 298
Joined: Sat Jul 20, 2013 2:40 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 25, 2016 2:45 pm

Don't agree.
[admin@cr1.zrh1] /routing bgp peer> :put [get 6 update-source ] 
As you can see, update-source is nothing (=empty). In WebFig, it's possible to click an arrow to make this field disappearing (like unset).
[admin@cr1.zrh1] /routing bgp peer> set 6 update-source=1.2.3.4
[admin@cr1.zrh1] /routing bgp peer> :put [get 6 update-source ]
1.2.3.4
Now we have the update source "1.2.3.4". I want to do the same as in the GUI, unset this value:
[admin@cr1.zrh1] /routing bgp peer> unset 6 update-source
input does not match any value of value-name
So why should I use
[admin@cr1.zrh1] /routing bgp peer> set 6 update-source=none
[admin@cr1.zrh1] /routing bgp peer> :put [get 6 update-source ] 
? In my oppinion, "none" is not correct. Every BGP update message NEEDS a source address. None means "no source address". Unset would just be right for that (= tell the router to not use a specific address, like "unspecified").

If I say that a configuration value should be "none", I expect this "none" to be in the configuration, which is not. It's also not possible to clear this value with set update-source="".
Last edited by patrick7 on Thu Aug 25, 2016 4:27 pm, edited 1 time in total.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5913
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 25, 2016 2:54 pm

Parameter is for custom update-source. What custom update-source to use? None. So perfectly valid option. And as I mentioned in previous post, unset works on specific parameters which can be seen by typing unset 0 <tab>, update-source is also not one of them.
 
patrick7
Member Candidate
Member Candidate
Posts: 298
Joined: Sat Jul 20, 2013 2:40 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Thu Aug 25, 2016 2:59 pm

Don't really see the sense behind that, but ok......
In my opinion, it should also be possible to unset (make empty) "custom" values. Because in the configuration you don't see the "none" so it's like "empty" or "not set".
 
alexjhart
Member Candidate
Member Candidate
Posts: 191
Joined: Thu Jan 20, 2011 8:03 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Fri Aug 26, 2016 1:27 am

*) snmp - added script table which executes script and returns it's output on get request;

Please explain how to use this feature, because I cannot find it in the user interface...
I too am looking for more information. Don't see anything in the wiki yet?
-----
Alex Hart

The Brothers WISP
 
Motorbreath
just joined
Posts: 13
Joined: Fri Aug 26, 2016 1:22 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Fri Aug 26, 2016 1:27 pm

I get a pretty different signal strenght between 6.36.2 and 6.37rc22, all the settings are the same...can someone please explain?

Image
Image

Edit: It's a pretty significant drop in Signal Strenght on 6.37rc22, was the same with previous 6.37rc's. As soon as I get back to 6.36.2 everything is back to normal.
 
User avatar
pukkita
Trainer
Trainer
Posts: 2981
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: v6.37rc [release candidate] is released, only one wireless package!

Fri Aug 26, 2016 2:21 pm

Have you tried resetting the wireless config and redoing it? Is your RB firmware up to date?
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
Motorbreath
just joined
Posts: 13
Joined: Fri Aug 26, 2016 1:22 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Fri Aug 26, 2016 3:24 pm

Have you tried resetting the wireless config and redoing it? Is your RB firmware up to date?
Yes, tried resetting config, and the RB fw is up to date. Mikrotik responded that it could be a new way signal strenght is calculated...
 
User avatar
pukkita
Trainer
Trainer
Posts: 2981
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: v6.37rc [release candidate] is released, only one wireless package!

Fri Aug 26, 2016 11:59 pm

I think I noticed that, but related to chain numbers... maybe the case as you have only one chain. Have you tested the link to see if there are actual performance differences?
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
Motorbreath
just joined
Posts: 13
Joined: Fri Aug 26, 2016 1:22 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Sat Aug 27, 2016 12:27 am

I think I noticed that, but related to chain numbers... maybe the case as you have only one chain. Have you tested the link to see if there are actual performance differences?
performance seems to be the same, all signal led lights are still on my Groove...

Noise floor goes to -92 dBm, signal to noise 37 dB on 6.37rc22 and on the current 6.36.2 it's -97 dBm and 48 dB signal noise... I am back on stable version for now
 
Kevo
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Wed Oct 12, 2011 1:38 am

Re: v6.37rc [release candidate] is released, only one wireless package!

Sat Aug 27, 2016 6:19 am

48db signal to noise sounds just about impossible in the real world on unlicensed freq. We have licensed links running under -50 that don't see 48db SNR. I would guess the first set of numbers are more accurate.
 
Motorbreath
just joined
Posts: 13
Joined: Fri Aug 26, 2016 1:22 pm

Re: v6.37rc [release candidate] is released, only one wireless package!

Sat Aug 27, 2016 9:51 am

48db signal to noise sounds just about impossible in the real world on unlicensed freq. We have licensed links running under -50 that don't see 48db SNR. I would guess the first set of numbers are more accurate.
So we (using Groove) had false info for wireless signal strenght this whole time? MikroTik, what did you change for the RC versions so it shows different signal quality? A bug, or?

Who is online

Users browsing this forum: No registered users and 4 guests